Logic Pro X: Get started with the Audio Track Editor

Get started with the Audio Track Editor

The Audio Track Editor shows a close-up view of part of an audio track in the Tracks area, displaying the audio waveforms of the regions on the track.

In the Audio Track Editor, you can move, trim, split, and join audio regions, play a region in isolation, and edit regions in other ways. Edits you make in the Audio Track Editor are non-destructive, so you can always return to your original recordings.

You can also quantize and edit the pitch of audio material in the Audio Track Editor using Flex Pitch. When you choose a Flex Pitch algorithm, the contents of the audio track are analyzed for pitch, and the results are displayed as a pitch curve overlaid on the waveform.

Figure. Editing an audio region in the Audio Track Editor.

Open the Audio Track Editor

Do one of the following:

  • Select an audio track, then click the Editors button .

  • Double-click an audio region to open it in the Audio Track Editor.

    Figure. The Audio Track Editor with an audio region.

The Audio Track Editor opens below the Tracks area. Along the top of the Audio Track Editor is a ruler showing time divisions, based on the time format chosen in the LCD, and a menu bar with local menus. The main area of the Audio Track Editor shows the audio waveform of the regions in the selected audio track.

Trim an audio region

  1. Place the pointer over the lower-left or lower-right edge of the region.

    The pointer changes to a trim pointer.

    Figure. The trim pointer over the lower-right edge of an audio region in the Audio Track Editor.
  2. Drag the pointer to trim the beginning or end of the region.

    Figure. Trimming an audio region in the Audio Track Editor. The Help tag shows the region length.

Split an audio region

Do one of the following:

  • Select the Scissors tool, then click the point where you want to split the region.

    Figure. Splitting an audio region in the Audio Track Editor using the Scissors tool.

    You can scrub regions to find the point where you want to cut by dragging across the regions with the Scissors tool.

  • Select the region, move the playhead over the time position where you want to split the region, then choose Edit > Split.

Before moving or deleting a segment of a split audio region, click to select it.

Join regions

  1. Select the split regions.

  2. Do one of the following:

    • Choose Edit > Join > Regions.

    • Select the Glue tool, then click the selected regions.

Turn on flex in the Audio Track Editor

  1. Open the Audio Track Editor by doing one of the following:

    • Select an audio track in the Tracks area, then choose View > Show Editors.

    • Select an audio track in the Tracks area, then click the Editors button in the control bar.

    • Double-click an audio region.

  2. Click the Flex button in the Audio Track Editor menu bar.

    Note: Click the Audio Track Editor’s workspace before using the key command, to make sure that the Audio Track Editor has key focus.

    A Flex pop-up menu appears to the right of the Flex button in the Audio Track Editor menu bar.

  3. Choose Flex Pitch or one of the Flex Time algorithms from the Flex pop-up menu.

    Figure. The Flex pop-up menu, with Flex Pitch mode selected.

Change the pitch of a note

  1. Turn on Flex in the Audio Track Editor, then choose Flex Pitch from the Flex pop-up menu.

  2. Drag a note vertically to a new pitch.

For more information about working in the Audio Track Editor, see Audio Track Editor overview.

When Show Advanced Tools is selected in the Advanced preferences pane, you can also edit the timing of individual notes, chords, or sounds in the Audio Track Editor using Flex Time. For more information about Flex Time and Flex Pitch, see Flex Time and Pitch overview. You can also open the Audio File Editor to make permanent (destructive) edits to the source audio file for a region.

Published Date: Aug 9, 2019
Helpful?