About Pro Video Formats and MXF

To import, edit, and export Material eXchange Format (MXF) files in Final Cut Pro X, Motion, and Compressor, install Pro Video Formats.

About MXF files

MXF is an industry standard file format for video and audio. Similar to QuickTime files, MXF files contain information about the media in the MXF file. This information, called metadata, can include frame rate, frame size, creation date, and custom data created by a camera operator, assistant, or archivist.

MXF files come from a wide range of sources. They can be created by cameras like Sony (OP1a) and Panasonic (OP-Atom, OP1b), editing systems like Avid Media Composer, or other video recording devices.

With Pro Video Formats, Final Cut Pro can read MXF metadata and preserve it during editing. You can also include MXF metadata when exporting a video file in the OP1a format. In addition, Compressor can take an existing video or audio file and transform it into an MXF file for digital delivery.


Install Pro Video Formats

If you've installed Final Cut Pro X, Motion or Compressor on your Mac, install Pro Video Formats using Software Update in System Preferences. Pro Video Formats installs these items:

  • MXF Reader for importing
  • MXF Export including AVC-Intra
  • Compressor settings for exporting MXF files 
  • AES3 Audio Codec

After installing, you can create more custom share settings for MXF export using Compressor.


Export XML files with custom MXF metadata

Exporting an XML file from Final Cut Pro is the best way to exchange metadata from your clips and projects with third-party applications for finishing, broadcasting, or archiving into a media database. To export custom MXF metadata in an XML file, you'll need to first create a custom metadata view.

  1. Select a clip in the Browser.
  2. Choose Window > Show in Workspace > Inspector (or press Command-4), then click the Info Inspector button Info inspector button.
  3. Select the Metadata Views pop-up menu at the bottom of the Info Inspector, then choose Edit Metadata View.
  4. Select the properties that you'd like to add to your custom MXF metadata view, including MXF metadata properties. Click OK.
  5. Click the gear icon , choose Save Metadata View As, enter a name, then click OK. This custom metadata is added to the Metadata View menu in the Inspector, and to the the Metadata View pop-up menu in the Export XML window.
  6. Select the item you're exporting in the Browser, then choose File > Export XML. 
  7. Select your custom MXF metadata view from the Metadata View pop-up menu, choose the XML version you want to save, choose a location and a name for the file, then click Save.

Information about products not manufactured by Apple, or independent websites not controlled or tested by Apple, is provided without recommendation or endorsement. Apple assumes no responsibility with regard to the selection, performance, or use of third-party websites or products. Apple makes no representations regarding third-party website accuracy or reliability. Risks are inherent in the use of the Internet. Contact the vendor for additional information. Other company and product names may be trademarks of their respective owners.

Published Date: