Final Cut Pro X: Apply color lookup tables (LUTs)

A lookup table (LUT) is a set of data that enables a numeric transformation of pixel values to change the way an image looks.

A common use of LUTs in video post-production is log conversion. Many modern cameras have a log or wide-dynamic-range recording option that provides more f-stops of exposure latitude in the image. Video footage recorded with this option initially looks “flat.” You can apply LUTs to change the appearance of log footage to a standard broadcast specification, such as Rec. 709.

Another common use of LUTs is to stylize video clips with a particular “look.” Beyond just matching some objective model of exposure, you can subtly mix color to enhance the story you’re telling with your project. Color adjustments can alter the audience’s perception of the scene being played, changing a program’s mood.

Final Cut Pro supports two categories of LUTs:

  • Camera LUTs (also known as camera log conversion LUTs) provide log processing for media from modern video cameras that have a log recording option. When applied to log media from a supported camera, camera LUTs built into Final Cut Pro convert the media to the working space of the current library. If the library is set to Wide Gamut HDR, camera LUTs preserve the full dynamic range of the log media. Depending on the source camera, these built-in camera LUTs also take into account metadata such as camera exposure index, ISO setting, and white balance.

    When you import media, Final Cut Pro detects metadata in the media identifying the log format and automatically applies the appropriate built-in camera LUT. Camera LUTs are applied at the media level (across the library) and are applied before any clip effects. In contrast, Custom LUT effects (described below) are clip effects that can be applied at any position in the effect order.

    You can also import additional camera LUTs (known as custom camera LUTs). Custom camera LUTs can be provided by camera manufacturers or can be created by your director of photography, digital imaging technician (DIT), or colorist using a third-party color grading app. You can use custom camera LUTs to correct color in your program or to apply stylized looks. For more information, see Example: Use custom camera LUTs in your workflow.

  • Custom LUT effects allow you to easily create, import, or share custom looks for video clips and projects according to your creative needs. Custom LUT effects are clip effects that you apply to timeline clips from the Effects browser. You can also use Custom LUT effects to apply tone mapping, allowing for a custom conversion to the project’s output color space.

Apply a camera LUT

Some cameras embed metadata in the media file, enabling Final Cut Pro to turn on the appropriate log processing setting automatically. Many cameras do not embed this metadata, and sometimes the metadata may simply be lost if the material is transcoded. You can apply a camera LUT to one or more video clips, or switch to a different camera LUT, using the Info inspector.

Note: Final Cut Pro preserves the full dynamic range of the log media as long as color processing for the library is set to Wide Gamut HDR. If the library is set to either Standard or Wide Gamut (Deprecated) when you apply a camera LUT, the media is tone mapped (downgraded) to the narrower standard dynamic range (SDR). For more information, see Wide color gamut and HDR overview.

  1. Select one or more video clips recorded with the log option.

  2. If the inspector isn’t already shown, do one of the following:

    • Choose Window > Show in Workspace > Inspector (or press Command-4).

    • Click the Inspector button on the right side of the toolbar.

      The Inspector button in the toolbar
  3. Click the Info button at the top of the inspector.

    The Info button
  4. Click the Metadata View pop-up menu in the bottom-left corner of the Info inspector and choose General, Extended, or Settings.

    The Metadata View pop-up menu
  5. Click the Camera LUT pop-up menu and choose an option for converting the appearance of your footage:

    • None: Turns off log processing.

    • ARRI Log C: Applies ARRI Log C linearization with a default tone mapping.

    • ARRI Log C (3D LUT): Uses the 3D LUTs embedded in the media to apply a custom look.

    • Blackmagic Design Film: Applies the appropriate linearization and a tone mapping for the Blackmagic Cinema Camera and the Blackmagic Pocket Cinema Camera.

    • Blackmagic Design Film 4K: Applies the appropriate linearization and a tone mapping for the Blackmagic Production Camera 4K.

    • Canon Log: Applies the appropriate linearization for Canon Log.

    • Canon Log2/Cinema Gamut: Uses Canon’s EOS C300 Mark II 3D LUTs that convert Canon Log 2 with Cinema Gamut to Wide DR gamma.

    • Canon Log3/Cinema Gamut: Uses Canon’s EOS C300 Mark II 3D LUTs that convert Canon Log 3 with Cinema Gamut to Wide DR gamma.

    • Panasonic V-Log: Uses Panasonic’s Varicam 35 3D LUTs that convert V-Log to V-709/V-2020.

    • Sony S-Log2/S-Gamut: Applies the appropriate linearization and 709(800%) MLUT tone mapping for footage shot with the S-Log2/S-Gamut setting on Sony cameras such as the F5 and F55.

    • Sony S-Log3/S-Gamut3: Applies the appropriate linearization and 709(800%) MLUT tone mapping for footage shot with the S-Log3/S-Gamut3 setting on Sony cameras such as the F5 and F55.

    • Sony S-Log3/S-Gamut3.Cine: Applies the appropriate linearization and 709(800%) MLUT tone mapping for footage shot with the S-Log3/S-Gamut3.Cine setting on Sony cameras such as the F5 and F55.

    If you’ve imported custom camera LUTs, you can choose one from the Custom Camera section of the pop-up menu.

    Final Cut Pro applies the camera LUT you chose, and alters the look of the video clip accordingly. The change is applied to all instances of the clip, in all projects and events in the current library.

Note: Final Cut Pro properly displays Apple ProRes media captured with the ARRI ALEXA camera Log C recording option and imported with Final Cut Pro 10.0.8 or later. If Log C media was imported into an earlier version of Final Cut Pro X, Log C processing is disabled by default for that media.

Import a custom camera LUT

  1. Select a video clip in the browser or the timeline.

  2. In the Info inspector, click the Metadata View pop-up menu in the bottom-left corner and choose General, Extended, or Settings.

    The Metadata View pop-up menu
  3. Click the Camera LUT pop-up menu and choose Add Custom Camera LUT.

  4. In the window that appears, navigate to the LUT file you want to import, and select it.

    You can import 3D LUT files with the filename extensions .cube and .mga. You can select single files, multiple files, or a folder of files.

  5. Click the Output Color Space pop-up menu and choose the target color space that the custom camera LUT converts to.

    The target color space is usually indicated in the custom camera LUT name.

  6. Click Open.

    The custom camera LUT you imported appears in the Custom Camera section of the Camera LUT pop-up menu. If you imported a folder of LUT files, it appears as a submenu in that section of the pop-up menu.

    The Camera LUT pop-up menu

To remove imported custom camera LUTs from the Camera LUT pop-up menu, choose Reveal in Finder to open the Camera LUTs folder, drag the LUT files to the Trash, and reopen Final Cut Pro.

Note: If you imported a custom camera LUT and applied it to a clip, but the LUT file is missing from the Camera LUTs folder, a yellow warning button appears next to the Camera LUT pop-up menu. Click the warning button to reimport the custom camera LUT or to replace it with a different one.

Share a custom camera LUT

You can easily copy imported custom camera LUTs to another computer or share them with friends and colleagues.

  1. Select a video clip in the browser or the timeline.

  2. In the Info inspector, click the Metadata View pop-up menu in the bottom-left corner and choose General, Extended, or Settings.

    The Metadata View pop-up menu
  3. To open the Camera LUTs folder in the Finder, click the Camera LUT pop-up menu and choose Reveal in Finder.

    The Camera LUTs folder is in the following location:

    /Users/username/Library/Application Support/ProApps/Camera LUTs/

  4. In the Finder, select the LUT files you want to share, then choose File > Compress.

    Compressing the files prevents any change to custom layouts during transit.

  5. Transfer the resulting ZIP file (with the filename extension .zip) to your friend or colleague using email or another convenient method.

  6. On the receiving Mac, double-click the ZIP file to decompress it.

  7. To import the LUT file, see Import a custom camera LUT.

Note: If you copy a library that uses an imported custom camera LUT, you must copy the custom camera LUT as a separate file. If the LUT file is missing from the Camera LUTs folder, a yellow warning button appears next to the Camera LUT pop-up menu. Click the warning button to reimport the custom camera LUT.

Example: Use custom camera LUTs in your workflow

If implemented correctly, custom camera LUTs offer multiple benefits to productions shooting log footage.

You can:

  • Access the full dynamic range of log media.

  • Stylize footage with custom looks to suit your filmmaking needs.

  • Play back without rendering. This is essential for directors and DPs to review takes immediately, on the set.

  • Apply custom camera LUTs directly in the browser. This makes viewing dailies quick and easy. (In contrast, Custom LUT effects must be applied to clips in the timeline.)

Below is an outline of how you might use LUTs in your production and post-production workflows.

  1. Before shooting begins, the director of photography (DP) creates a custom camera LUT on the set of a production that is using cameras with a log recording option.

  2. The digital imaging technician (DIT) imports the DP’s custom camera LUT.

  3. As the footage is downloaded from the camera, the DIT selects the relevant shots in the browser and applies the DP’s custom camera LUT.

  4. The director and DP conduct the on-set review with the custom camera LUT applied. Clips are played back directly from the browser.

    The organizational capabilities of Final Cut Pro (such as Keyword Collections) make it easy to quickly find the best parts of each “circle take” (a take the director considers noteworthy).

    Because camera LUTs are applied nondestructively, the DP can replace the custom camera LUT with an adjusted one at any time.

  5. The DIT sends out dailies with the custom camera LUT applied.

  6. During the editing and finishing phases, editors and colorists may replace the DP’s custom camera LUT—for example, they might augment the LUT by adding one or more color correction effects. See Color correction effects overview and Manual color correction workflow.

If a more stylized look is required (such as Summer, Old Timey, Sci-Fi, and so on), editors or colorists can add Custom LUT effects to the same footage. See Import and apply a Custom LUT effect.

Stylized Custom LUT effects are available from a variety of third-party sources.

Import and apply a Custom LUT effect

In contrast to camera LUTs, Custom LUT effects are applied by adding a clip effect to timeline clips.

  1. Select a clip in the timeline.

  2. Open the Effects browser, select the Color category on the left, then double-click Custom LUT to apply the effect to the selected clip.

    For more information, see Add video effects to your project.

  3. If the Video inspector isn’t already shown, do one of the following:

    • Choose Window > Show in Workspace > Inspector (or press Command-4).

    • Click the Inspector button on the right side of the toolbar.

      The Inspector button in the toolbar
  4. Click the Video button at the top of the inspector.

    The Video button
  5. In the Custom LUT section of the Video inspector, click the LUT pop-up menu and choose “Choose Custom LUT.”

    “Choose Custom LUT” being chosen from the LUT pop-up menu in the Custom LUT section of the Video inspector

    Note: If you previously imported a custom LUT, you can choose Recent and then choose from a list of recently used Custom LUT effects.

  6. In the window that appears, navigate to the LUT file you want to import, and select it.

    You can import 3D LUT files with the filename extensions .cube and .mga. You can select single files, multiple files, or a folder of files.

  7. Click Open.

    The LUT you imported appears as the selected LUT at the top of the Custom LUT section.

    If you imported a folder of LUT files, it appears as a submenu in the LUT pop-up menu. (In this case, choose a LUT from the submenu so that it appears as the selected LUT at the top of the Custom LUT section.)

  8. Click the Input pop-up menu and choose the color space the LUT converts from.

    This color space was determined when the custom LUT was created.

    Note: Camera LUTs and custom LUTs typically include the names of the input (source) color space and intended output (target) color space in the LUT filename. If you’re not sure which color space to choose, see the LUT creator for more information.

  9. Click the Output pop-up menu and choose the color space the LUT converts to.

    This color space was determined when the custom LUT was created.

  10. To optionally set the amount of the original image to be blended with the adjusted image, drag the Mix slider.

Final Cut Pro applies the custom LUT and the settings you chose, and alters the look of the video clip accordingly.

Share a Custom LUT effect

You can share custom LUTs by copying the LUT files to another Mac.

  1. In the timeline, select a clip that has the Custom LUT effect applied.

    To apply the Custom LUT effect, see Import and apply a Custom LUT effect.

  2. If the Video inspector isn’t already shown, do one of the following:

    • Choose Window > Show in Workspace > Inspector (or press Command-4).

    • Click the Inspector button on the right side of the toolbar.

      The Inspector button in the toolbar
  3. Click the Video button at the top of the inspector.

    The Video button
  4. To open the Custom LUTs folder in the Finder, click the LUT pop-up menu in the Custom LUT section of the inspector and choose Reveal in Finder.

    The Custom LUTs folder is in the following location:

    /Users/username/Library/Application Support/ProApps/Custom LUTs/

  5. In the Finder, select the LUT files you want to share, then choose File > Compress.

    Compressing the files prevents any change to custom layouts during transit.

  6. Transfer the resulting ZIP file (with the filename extension .zip) to your friend or colleague using email or another convenient method.

  7. On the receiving Mac, double-click the ZIP file to decompress it.

  8. To import the Custom LUT effect, see Import and apply a Custom LUT effect.

To remove imported custom LUTs from the LUT pop-up menu, follow the steps above to open the Custom LUTs folder, drag the LUT files to the Trash, then reopen Final Cut Pro.

Note: If you copy a library that uses a Custom LUT effect, you must copy the LUT as a separate file. If the LUT file is missing from the Custom LUTs folder, a yellow warning button appears next to the LUT pop-up menu. Click the warning button to reimport the LUT or replace it with a different LUT.

Published Date: May 2, 2018
Helpful?