3D-fájlok szerkesztése a Mac Megtekintő appjában
A Mac Megtekintő appjában mozgathatja, elforgathatja és átméretezheti a 3D-jelenetekben lévő primeket, szerkesztheti a tulajdonságaikat, és annotációkat adhat hozzájuk.
Megjegyzés: A Megtekintő közvetlenül szerkeszti az egyrétegű USD-, USDA-, USDC- és USDZ-fájlokat. Más formátumok – például több rétegből álló USD-fájlok – esetén a Megtekintő a fájl első szerkesztésekor egy másolatba menti el a módosításait, és az eredeti fájlt érintetlenül hagyja.
Primek mozgatása, elforgatása és méretezése
Nyissa meg a Megtekintő appot
a Macjén.
Kattintson egy primre a nézetben (vagy válassza a Nézet > Objektumhierarchia menüpontot, majd jelöljön ki egy primet). Ha a nézetablakban a csoportosított objektum egy részét szeretné kijelölni a teljes csoport helyett, kattintson rá, miközben az Option billentyűt lenyomva tartja.
Tegye a következők egyikét a Mozgatás, Elforgatás vagy Méretezés kiválasztásához:
Kattintson a
gombra, és válasszon egy lehetőséget.
Válassza az Eszközök > 3D manipulátor menüpontot, majd válasszon ki egyet.
Nyomja le az Option-W, az Option-E vagy az Option-R billentyűkombinációt.
A forgáspont módosításához vagy alaphelyzetbe állításához válassza az Eszközök > 3D manipulátor > Forgáspont beállítása menüpontot, majd válasszon egy opciót.
Húzza el a színkódolt átalakítási fogantyúkat a nézetben.
Az x tengely fogantyúja piros, az y tengely fogantyúja zöld, a z tengely fogantyúja kék, a képernyőterület fogantyúja pedig szürke.
Tipp: Egy prim megkettőzéséhez tartsa lenyomva az Option billentyűt, és húzza el az egyik átalakítási fogantyúját. Ha mozgatás közben egy másik objektum felületére szeretné ráigazítani az objektumot, húzza el a szürke képernyőterület-fogantyút a Shift billentyű lenyomva tartása közben.
Primek tulajdonságainak szerkesztése
Megtekintheti és szerkesztheti a kijelölt prim tulajdonságait az Objektumtulajdonságok panelen, ide értve az átalakítási értékeit, a láthatóságát, az anyagát és a megjelenését is. Egyes tulajdonságok (pl. az anyag és a megjelenés tulajdonságai) nem működnek minden renderelési stílussal.
Nyissa meg a Megtekintő appot
a Macjén.
Nyisson meg egy 3D-fájlt, válassza a Nézet > Objektumhierarchia menüpontot, majd válassza ki azt a primet, amelynek tulajdonságait szerkeszteni szeretné. Egy másik lehetőségként a nézetben is rákattinthat a primre a kijelöléséhez.
Megjegyzés: Ha egyszerre több primet szeretne szerkeszteni, tartsa lenyomva a Command billentyűt, és kattintson a kívánt primekre az Objektumhierarchia panelen (vagy a Shift billentyűt lenyomva tartva kattintson rájuk, ha tartományt szeretne kijelölni).
Válassza az Eszközök > Objektumtulajdonságok megjelenítése menüpontot.
Tegye a következők valamelyikét:
Átalakítási érték szerkesztése: A Fordítás, Elforgatás vagy Méretezés sorban jelöljön ki egy mezőt, majd adja meg az X, az Y vagy a Z értékét a jelenet Fordítás és Méretezés mértékegységéhez, vagy a fokot a Forgatás lehetőséghez. Egy másik lehetőséként azt is megteheti, hogy egy mezőre kattint, majd felfelé vagy lefelé húzva növelheti vagy csökkentheti az értékét. Egy mező kijelölése automatikusan kijelöli a megfelelő átalakító eszközt.
Az „Oldalarányok megtartása” funkció be- vagy kikapcsolása: Kattintson a
gombra. A gomb mindig látható, és bekapcsolt állapotban kitöltött ábrázolással jelenik meg. Ez megőrzi az X, Y és Z értékek közötti arányt ahelyett, hogy egyenlővé tenné őket.
Prim megjelenítése vagy elrejtése: Jelölje be a Látható elem jelölőnégyzetét, vagy törölje annak jelölését. (Előfordulhat, hogy rá kell koppintania az Alakzat mellett található
gombra az opció megjelenítéséhez.)
Anyag módosítása: Kattintson az Anyag felugró menüre, majd válasszon ki egy anyagot.
A szín beállítása: Kattintson az aktuális színre vagy a színkerékre, majd válasszon ki egy színt. Ez az opció csak akkor érhető el, ha az Anyag opciót Nincs értékre állította.
Anyag színeinek szerkesztése: Egy anyag prim kijelölését követően (az Option és a Shift billentyűt lenyomva tartva kattintson rá a nézetben, vagy kattintson az
ikonnal megjelölt primre az Objektumhierarchia panelen), kattintson az aktuális színre vagy a színkerékre a Tulajdonságok alatt található Diffúz szín, Emisszív szín vagy Csillogó szín mellett, majd válasszon ki egy színt. Ha egy színmező halványan jelenik meg, textúra van alkalmazva rajta. A Control billentyűt lenyomva tartva kattintson rá, majd válassza az Érték alaphelyzetbe állítása lehetőséget a textúra eltávolításához és a szín közvetlen szerkesztéséhez.
Átlátszatlanság beállítása: Húzza el az Átlátszatlanság csúszkát balra vagy jobbra, vagy adjon meg egy százalékos értéket. Az átlátszatlanság renderelése a renderelési stílustól függően eltérő lehet. A Raytracer adja a legjobb eredményeket.
Kamera fókusztávolságának vagy fényrekeszének szerkesztése: Egy kamera prim kiválasztását követően jelölje ki a mezőt a Fókusztávolság vagy a Függőleges fényrekesz sorban, majd adjon meg egy értéket. A fókusztávolság milliméterben van megadva.
Kamera felbontásának szerkesztése: Egy kamera prim kiválasztását követően jelöljön ki egy mezőt a Felbontás sorban, majd adjon meg egy értéket képpontban a szélességhez vagy a magassághoz.
Kamera pupillák közötti vagy konvergenciatávolságának szerkesztése: Egy kamera prim kiválasztását követően jelölje ki a mezőt a Pupillák közötti távolság vagy a Konvergenciatávolság sorban, majd adjon meg egy értéket a jelenet mértékegységéhez.
Fény méretének szerkesztése: Egy fény prim kiválasztását követően jelölje ki a Szélesség vagy a Magasság mezőt a Méret sorban, majd adjon meg egy értéket a jelenet mértékegységéhez. Alapértelmezés szerint az egyik érték módosítása frissíti a másik mező értékét, az oldalarány megtartása érdekében. Kattintson a
gombra, ha az egyes értékeket különállóan szeretné módosítani.
Fénykúp szerkesztése: Egy fény prim kiválasztását követően adjon meg egy értéket fokban a Kúp szöge mezőben, vagy húzza el a Kúp lágysága csúszkát.
Fény színének beállítása: Egy fény prim kijelölését követően kattintson az aktuális színre vagy a színrekeszre a Szín elem mellett, majd válasszon ki egy színt. Ha a Színhőmérséklet jelenik meg helyette, jelölje ki a mezőt, majd adjon meg egy értéket kelvinben (K). A kettő közül csak az egyik jeleni meg attól függően, hogyan lett létrehozva a fájl, és nem is lehet váltani közöttük.
Fény textúrájának módosítása: Egy fény prim kiválasztását követően kattintson a Textúra mezőre, majd válasszon ki egy képfájlt.
Fény intenzitásának beállítása: Egy fény prim kiválasztását követően jelölje ki az Intenzitás mezőt, majd adjon meg egy értéket.
Váltás változatok között: Ha a kijelölt primnek vannak változatkészletei, a Változatok alatt válasszon ki egy lehetőséget egy felugró menüből (pl. Anyag vagy Animáció).
Primek hozzáadása
3D-jelenetekhez alakzatokat, kamerákat és fényeket adhat hozzá.
Nyissa meg a Megtekintő appot
a Macjén.
Nyisson meg egy 3D-fájlt, majd válassza az Eszközök > Hozzáadás a jelenethez menüpontot.
Prim típusának kiválasztása:
Az új prim helye attól függ, hogy mi lett kijelölve: egy átalakítás vagy hatókör kiválasztása esetén az új prim a gyermekeként, míg a gemoetria kiválasztása esetén a prim a testvéreként kerül hozzáadásra a kijelölés felett található legközelebbi átalakításon vagy hatókörön belül. Ha semmi nincs kiválasztva, az új prim a jelenet gyökeréhez lesz hozzáadva. Mivel az átalakítások és hatókörök nem tartalmaznak olyan látható elemet, amire rá lehetne kattintani a nézetben, jelöljön ki egyet az Objektumhierarchia panelen, hogy szabályozni tudja, hogy az új prim hova kerüljön elhelyezésre.
A prim környezetfüggő menü használata
A Control billentyűt lenyomva tartva kattintson egy primre az Objektumhierarchia panelen az átnevezéséhez, megkettőzéséhez, törléséhez vagy számos egyéb művelet kiválasztásához.
Nyissa meg a Megtekintő appot
a Macjén.
Nyisson meg egy 3D-fájlt, majd válassza a Nézet > Objektumhierarchia menüpontot.
Az Objektumhierarchia panelen jelölje ki a módosítani kívánt primet.
Tegye a következők valamelyikét:
Prim átnevezése: Nyomja le a Return billentyűt, majd adjon meg egy új nevet. Egy másik lehetőségként kattintson a névre még egyszer, a Finderben végzett művelethez hasonlóan.
Prim megkettőzése: A Control billentyűt lenyomva tartva kattintson a primre, majd válassza a Megkettőzés lehetőséget.
Törlés: Nyomja le a Delete billentyűt, vagy a Control billentyűt lenyomva tartva kattintson a primre, majd válassza a Törlés lehetőséget.
Prim csoportosítása további kijelölt primekkel: A Control billentyűt lenyomva tartva kattintson az egyik primre, majd válassza az Új csoport kijelöléssel parancsot.
Annak beállítása, hogy a primcsoport egy egységként viselkedjen, amikor rákattintanak a nézetben: A Control billentyűt lenyomva tartva kattintson a kijelölt primek egyikére, majd válassza a Kijelölés csoportként lehetőséget.
Prim vágása: Nyomja le a Command-X billentyűkombinációt, vagy a Control billentyűt lenyomva tartva kattintson a primre, majd válassza a Kivágás lehetőséget.
Prim másolása: Nyomja le a Command-C billentyűkombinációt, vagy a Control billentyűt lenyomva tartva kattintson a primre, majd válassza ki a Másolás lehetőséget.
Prim beillesztése: Nyomja le a Command-V billentyűkombinációt, vagy a Control billentyűt lenyomva tartva kattintson a primre, majd válassza a Beillesztés lehetőséget. A beillesztett prim a mutatónál jelenik meg.
Megjegyzés: A különböző Megtekintő-ablakok között kivághat, másolhat és be is illeszthet, így könnyedén áthelyezheti a primeket egyik jelenetből a másikba.
Prim inaktiválása: A Control billentyűt lenyomva tartva kattintson a primre, majd válassza az Inaktiválás lehetőséget.
Megjegyzés: Egy prim elrejtésekor (Látható az Objektumtulajdonságokban) a prim a jelenetben megmarad, de nem lesz lerajzolva. Egy prim inaktiválásakor a rendszer teljes mértékben eltávolítja a primet és a tartalmát a jelenetből anélkül, hogy kitörölné a fájlból, később bármikor visszakapcsolhatja. Mivel az inaktivált primerek elhagyják a jelenetet, minden olyan elem, ami rájuk mutat (pl. anyagi kötés) referencia nélkül fog a jelenetben maradni.
Tipp: Egy nagy csoport inaktiválása megkönnyítheti a nagyobb fájlokkal történő munkavégzést, mivel a Megtekintő nem tölti be az inaktivált csoportok tartalmát.
Prim megjelölése szerkeszthetőként Apple Vision Prón: A Control billentyűt lenyomva tartva kattintson a primre, majd válassza a Szerkeszthető az Apple Vision Prón lehetőséget. Ez a primet olyan primként jelöli meg, amellyel interkacióba léphet az Apple Vision Prón – a Megtekintőben azonban semmi sem változik.
Prim megjelölése fájlhivatkozás-gyökérként: A Control billentyűt lenyomva tartva kattintson a primre, majd válassza a Fájlhivatkozás-gyökér lehetőséget. Egy csillag jelenik meg a neve mellett. A további fájlok alapértelmezetten ezt a primet fogják használni, amikor hivatkoznak erre a fájlra, valamint az új primek is ehhez a fájlhoz lesznek hozzáadva, ha nincs kijelölt elem.
A jelenethierarchia átrendezése
A primek Objektumhierarchia panelen történő elhúzásával módosíthatja azok szüleit, illetve átrendezheti őket.
Nyissa meg a Megtekintő appot
a Macjén.
Nyisson meg egy 3D-fájlt, majd válassza a Nézet > Objektumhierarchia menüpontot.
Tegye a következők valamelyikét:
Prim szülőjének módosítása: Húzza rá arra az átalakításra vagy hatókörre, amelyet az új szülőként szeretné kijelölni.
Prim átrendezése: Húzza át egy új helyre ugyanazon szülőelemben.
Megjegyzés: Az anyagok továbbá be is ágyazhatók a geometria alá, míg az árnyékolók kizárólag csak anyagok alá ágyazhatók be.
A fázis beállítása
Teljes jeleneteket is átméretezhet, elforgathat és újratájolhat, nem csak a nézetüket. A fázis beállítása megváltoztatja a fájlt, ellentétben a nézet körüli keringéssel, amellyel a jelenetet más szögből tekintheti meg.
Nyissa meg a Megtekintő appot
a Macjén.
Nyisson meg egy 3D-fájlt, majd tegye a következők egyikét:
Elforgatás 90 fokkal: Kattintson a
gombra a balra forgatáshoz, vagy az Option billentyűt lenyomva tartva kattintson rá a jobbra forgatáshoz.
Elforgatás adott mértékkel: Válassza az Eszközök > Méret beállítása menüpontot, adja meg az értékeket az X elforgatása, Y elforgatása vagy Z elforgatása mezőben a Tartalom tájolása alatt, majd kattintson az OK gombra.
Modell tájolásának módosítása: Válassza az Eszközök > Méret módosítása menüpontot, válassza ki az Y felfelé vagy a Z felfelé lehetőséget a Tájolás felugró menüben a Jelenetbeállítások részen, majd kattintson az OK gombra. Egy másik lehetőségként egy mértékegységet is kiválaszthat a Mértékegységek felugró menüből a Jelenetbeállítások részen.
Modell átméretezése: Válassza az Eszközök > Méret beállítása menüpontot, adja meg az értékeket a Magasság, Szélesség, Mélység vagy Méretezés mezőbe a Tartalom mérete részen, majd kattintson az OK gombra. Egy másik lehetőségként egy mértékegységet is kiválaszthat a felugró menüből a Tartalom mérete részen.
Megjegyzés: Alapértelmezés szerint a Tartalom méretének és tájolásának megőrzése opció van kiválasztva, így a Magasság, Szélesség, Mélység vagy Méretezés mezők egyikének módosításakor a rendszer a többi mezőt is frissíti az azonos arányok megtartása érdekében. Ha az egyes mezőket különállóan szeretné módosítani, törölje a jelölőnégyzet jelölését.
3D-fájlok annotálása
3D-jelenetekhez szöveges annotációkat is hozzáadhat.
Nyissa meg a Megtekintő appot
a Macjén.
Nyisson meg egy 3D-fájlt, kattintson a
gombra, majd kattintson az
gombra.
A nézetben egy annotációs ikon jelenik meg.
Kattintson az annotáció ikonra, majd írja be a megjegyzést.
Kattintson az annotáción kívülre a mentéséhez. Az annotációt továbbá át is húzhatja egy másik helyre.
Tegye a következők valamelyikét:
A szín módosítása: A Control billentyűt nyomva tartva kattintson az annotációra, majd válasszon ki egy színt.
Törlés: A Control billentyűt nyomva tartva kattintson az annotációra, majd válassza a Törlés lehetőséget.
Ráillesztés egy objektum felületére: Húzza az annotációt az objektumra.
Tipp: Ha módosítani szeretné a szerző nevét az új annotációkban, válassza a Megtekintő > Beállítások menüpontot, kattintson az Általános elemre, majd adjon meg egy nevet a Név mezőben.
Az összes annotáció és a tartalmuk megtekintéséhez válassza a Nézet > Jegyzetek menüpontot. Ha több annotációval is rendelkezik, kattintson a vagy a
nyílra az annotáción belül az előző vagy a következő annotációra lépéshez. A kamera automatikusan az annotációra fókuszál a jelenetben.