Úpravy 3D souborů v Náhledu na Macu
V Náhledu na Macu můžete přesouvat, otáčet primy v 3D scéně, měnit jejich měřítko, upravovat vlastnosti nebo přidávat anotace.
Poznámka: Soubory USD, USDA, USDC a USDZ s jednou vrstvou se v Náhledu upravují přímo. U jiných formátů, včetně souborů USD tvořených více vrstvami, Náhled vaše změny při první úpravě souboru uloží do kopie a původní soubor ponechá beze změny.
Přesunutí, otočení nebo změna měřítka primu
Na Macu přejděte do aplikace Náhled
.
Klikněte na některý prim v zobrazovací oblasti (nebo vyberte Zobrazení > Hierarchie objektů a potom objekt prim vyberte). Chcete-li v zobrazené oblasti namísto celé skupiny vybrat jen konkrétní část seskupeného objektu, klikněte na ni se stisknutou klávesou Option.
Chcete‑li vybrat volbu Přesunout, Otočit nebo Změnit měřítko, proveďte některou z následujících akcí:
Klikněte na
a pak některou položku vyberte.
Vyberte Nástroje > 3D manipulátor a potom některý vyberte.
Stiskněte Option-W, Option-E nebo Option-R.
Chcete‑li změnit nebo resetovat bod otáčení, vyberte Nástroje > 3D manipulátor > Upravit osu otáčení a potom vyberte požadovanou volbu.
Přetáhněte barevně odlišené transformační úchyty v zobrazovací oblasti.
Úchyt osy x je červený, úchyt osy y je zelený, úchyt osy z je modrý a úchyt plochy obrazovky je šedý.
Tip: Chcete‑li objekt prim duplikovat, podržte Option a přetáhněte některý z jeho transformačních úchytů. Chcete‑li, aby se objekt při přesouvání přichytil k povrchu jiného objektu, podržte klávesu Shift a přetáhněte šedý úchyt plochy obrazovky.
Úprava vlastností primů
Na panelu Vlastnosti objektu můžete zobrazit a upravit vlastnosti vybraného primu, včetně jeho transformačních hodnot, viditelnosti, materiálu a vzhledu. Ne všechny vlastnosti, například vlastnosti materiálu a vzhledu, lze použít s každým stylem vykreslování.
Na Macu přejděte do aplikace Náhled
.
Otevřete 3D soubor, vyberte Zobrazení > Hierarchie objektů a pak vyberte prim, jehož vlastnosti chcete upravit. Můžete také kliknutím vybrat některý prim v zobrazovací oblasti.
Poznámka: Chcete‑li upravit více primů najednou, přidržte klávesu Command a postupně na každý z nich klikněte na panelu Hierarchie objektů (nebo přidržte klávesu Shift a vyberte rozsah).
Vyberte Nástroje > Zobrazit vlastnosti objektu.
Proveďte některou z následujících akcí:
Úprava hodnoty transformace: V řádku Přesunout, Otočit nebo Měřítko vyberte požadované pole a zadejte hodnotu pro X, Y nebo Z – v jednotkách scény (pro Přesunout a Měřítko) nebo ve stupních (pro Otočit). Na pole můžete také kliknout a tažením nahoru nebo dolů zvýšit nebo snížit jeho hodnotu. Výběrem pole se automaticky vybere odpovídající nástroj pro transformaci.
Zapnutí nebo vypnutí volby „Zachovat poměr stran“: Klikněte na
; zobrazuje se vždy a po zapnutí se vyplní. Zachová se poměr mezi hodnotami X, Y a Z, místo aby se tyto hodnoty vyrovnaly.
Zobrazení nebo skrytí primu: Označte nebo odznačte zaškrtávací políčko Viditelné. (Aby se volba zobrazila, budete možná muset u položky Tvar kliknout na
.)
Změna materiálu: Klikněte na místní nabídku Materiál a vyberte požadovaný materiál.
Úprava barvy: Klikněte na aktuální barvu nebo na barevný kruh a vyberte barvu. Tato volba je k dispozici jen v případě, že je pro Materiál nastavena položka Žádný.
Úpravy barev materiálu: Pokud je vybraný materiálový prim (podržte Option a Shift a klikněte na prim v zobrazovací oblasti nebo klikněte na prim označený ikonou
na panelu Hierarchie objektů), klikněte na aktuální barvu nebo na kolo barev u položky Rozptýlené barvy, Barva záře nebo Zrcadlová barva v oddílu Vlastnosti a pak vyberte barvu. Pokud je barevné pole ztlumené, je na něj aplikována textura – klikněte na něj se stisknutou klávesou Control a potom vyberte Resetovat hodnotu. Tím texturu odstraníte a budete moct barvu upravit přímo.
Úprava neprůhlednosti: Přetáhněte jezdec Neprůhlednost doleva nebo doprava nebo zadejte hodnotu v procentech. Vykreslování neprůhlednosti se liší v závislosti na stylu vykreslování; nejlepších výsledků dosahuje Raytracer.
Úpravy ohniskové vzdálenosti nebo clony fotoaparátu: Pokud je vybrán prim kamery, v řádku Ohnisková vzdálenost nebo Vertikální clona vyberte pole a zadejte hodnotu. Ohnisková vzdálenost se udává v milimetrech.
Úprava rozlišení kamery: Pokud je vybrán prim kamery, v řádku Rozlišení vyberte pole a zadejte hodnotu šířky nebo výšky v pixelech.
Úprava vzdálenosti zornic nebo konvergenční vzdálenosti kamery: Pokud je vybrán prim kamery, v řádku Vzdálenost zornic nebo Konvergenční vzdálenost vyberte pole a potom zadejte hodnotu v měrných jednotkách scény.
Úprava rozměrů světla: Pokud je vybrán prim světla, v řádku Velikost vyberte pole Šířka nebo Výška a potom zadejte hodnotu v měrných jednotkách scény. Ve výchozím nastavení se při úpravě jedné hodnoty aktualizuje druhé pole tak, aby poměr stran zůstal konstantní. Chcete‑li hodnoty upravit nezávisle na sobě, klikněte na
.
Úprava světelného kuželu: Pokud je vybrán prim světla, zadejte do pole Úhel kužele hodnotu ve stupních nebo přetáhněte jezdec Měkkost kužele.
Úprava barvy světla: Pokud je vybrán prim světla, klikněte na aktuální barvu nebo na barevný kruh u položky Barva a pak vyberte barvu. Pokud se místo toho zobrazí položka Teplota barev, vyberte toto pole a zadejte hodnotu v kelvinech. Zobrazí se jen jedna z oboupoložek, v závislosti na tom, jak byl soubor vytvořen, a mezi nimi nelze přepínat.
Změna textury světla: Pokud je vybrán prim světla, klikněte na pole Textura a vyberte obrázkový soubor.
Úprava intenzity světla: Pokud je vybrán prim světla, vyberte pole Intenzita a zadejte hodnotu.
Přepnutí varianty: Pokud vybraný prim obsahuje sady variant, vyberte v místní nabídce v oddílu Varianty některou volbu, například Materiál nebo Animace.
Přidání primu (objektu scény)
Do 3D scény můžete přidávat tvary, kamery a světla.
Na Macu přejděte do aplikace Náhled
.
Otevřete 3D soubor a pak vyberte Nástroje > Přidat do scény.
Výběr typu primu:
Místo, kam se umístí nový prim, závisí na tom, co je vybráno: pokud vyberete transformaci nebo rozsah, nový prim se přidá jako podřízený prvek, a pokud vyberete geometrii, přidá se jako prvek stejné úrovně do nejbližší transformace nebo rozsahu nad výběrem. Pokud není nic vybráno, nový prim se přidá do kořene scény. Protože transformace a rozsahy nemají v zobrazovací oblasti žádný viditelný prvek, na který by bylo možné kliknout, vyberte některý v podokně Hierarchie objektů a určete, kam se má nový prim umístit.
Použití kontextové nabídky primu
S přidržením klávesy Control klikněte na některý prim v podokně Hierarchie objektů a pak ho můžete přejmenovat, duplikovat, smazat nebo vybrat další akce.
Na Macu přejděte do aplikace Náhled
.
Otevřete 3D soubor a pak vyberte Zobrazení > Hierarchie objektů.
Na panelu Hierarchie objektů vyberte prim, který chcete změnit.
Proveďte některou z následujících akcí:
Přejmenování: Stiskněte Return a zadejte nový název. Můžete také kliknout na název ještě jednou, stejně jako ve Finderu.
Duplikování: S přidržením klávesy Control klikněte na prim a vyberte Duplikovat.
Smazání: Stiskněte Delete nebo s přidržením klávesy Control klikněte na prim a potom vyberte Smazat.
Seskupení s dalšími vybranými primy: Podržte klávesu Control, klikněte na některý z vybraných primů a pak vyberte volbu Nová složka s výběrem.
Nastavení sady primů, aby se po kliknutí v zobrazovací oblasti chovaly jako jeden celek: Podržte klávesu Control, klikněte na některý z vybraných primů a pak vyberte volbu Vybrat jako skupinu.
Vyjmutí: Stiskněte Command-X nebo klikněte na prim s přidržením klávesy Control a vyberte Vyjmout.
Zkopírování: Stiskněte Command-C nebo klikněte na prim s přidržením klávesy Control a vyberte Kopírovat.
Vložení: Stiskněte Command-V nebo klikněte na prim s přidržením klávesy Control a vyberte Vložit. Vložený prim se objeví v místě ukazatele.
Poznámka: Akce vyjmutí, kopírování a vložení můžete použít mezi samostatnými okny Náhledu – jde o šikovný způsob přesunu primu z jedné scény do jiné.
Deaktivace: S přidržením klávesy Control klikněte na prim a pak vyberte Duplikovat.
Poznámka: Pokud prim skryjete (viditelný prvek ve vlastnostech objektu), bude ponechán ve scéně, ale nedojde k jeho vykreslení. Při deaktivaci se prim a jeho obsah ze scény zcela odstraní, ale nebude odstraněn ze souboru, takže ho můžete později znovu aktivovat. Deaktivované primy budou ze scény odstraněny, takže všechny položky, které na ně odkazovaly – například vazba materiálu – zůstanou neukotvené a nebudou mít na co odkazovat.
Tip: Deaktivací velké skupiny si lze usnadnit práci s velkým souborem, protože Náhled nemusí načítat obsah deaktivované skupiny.
Označení obsahu jako upravitelného na Apple Vision Pro: Se stisknutou klávesou Control klikněte na prim a pak vyberte Lze upravit na Apple Vision Pro. Tím se prim označí jako objekt, se kterým můžete pracovat na Apple Vision Pro – v samotném Náhledu k žádné změně nedojde.
Označení jako kořenu odkazu na soubor: Se stisknutou klávesou Control klikněte na prim a potom vyberte Kořen odkazu na soubor. U jeho názvu se zobrazí hvězdička. Když jiné soubory odkazují na tento soubor, použije se standardně tento prim, a jde také o místo, kam se přidávají nové primy, když není nic vybráno.
Přeskupení hierarchie scény
Nadřazený objekt primu můžete změnit a stejně tak i pořadí primů můžete změnit přetažením na panelu Hierarchie objektů.
Na Macu přejděte do aplikace Náhled
.
Otevřete 3D soubor a pak vyberte Zobrazení > Hierarchie objektů.
Proveďte některou z následujících akcí:
Změna nadřazeného objektu primu: Přetáhněte prim na transformaci nebo rozsah, který má být jeho novým nadřazeným objektem.
Změna pořadí primu: Prim přetáhněte na novou pozici v rámci téhož nadřazeného objektu.
Poznámka: Materiály lze vnořit také pod geometrii, ale shadery jen pod materiály.
Úprava nastavení scény
Můžete změnit velikost, natočení nebo orientaci celé scény, nejen vašeho pohledu na ni. Na rozdíl od otáčení zobrazovací oblasti, které slouží k zobrazení scény z jiného úhlu, se při úpravě nastavení scény změní příslušný soubor.
Na Macu přejděte do aplikace Náhled
.
Otevřete 3D soubor a potom proveďte některou z následujících akcí:
Otočení o 90 stupňů: Kliknutím na
otočíte scénu doleva. Pokud na tlačítko kliknete s přidržením klávesy Option, scéna se otočí doprava.
Otočení o určitou hodnotu: Vyberte Nástroje > Upravit velikost, v oddílu Orientace obsahu zadejte hodnoty do polí Otočit X, Otočit Y nebo Otočit Z a potom klikněte na OK.
Změna orientace modelu: Vyberte Nástroje > Upravit velikost, v místní nabídce Orientace v oddílu Nastavení scény vyberte Svislá osa Y nebo Svislá osa Z a potom klikněte na OK. V oddílu Nastavení scény můžete v místní nabídce Jednotky vybrat také měrné jednotky.
Změna velikost modelu: Vyberte Nástroje > Upravit velikost, v oddílu Velikost obsahu zadejte hodnoty do polí Výška, Šířka, Hloubka nebo Měřítko a klikněte na OK. V oddílu Velikost obsahu můžete v místní nabídce vybrat také měrné jednotky.
Poznámka: Standardně je vybrána volba Zachovat velikost a orientaci obsahu, takže při změně v jednom z polí Výška, Šířka, Hloubka nebo Měřítko se aktualizují i ostatní hodnoty, aby se zachovaly stejné proporce. Chcete‑li upravit jednotlivé hodnoty nezávisle, odznačte tuto volbu.
Anotace 3D souboru
Do 3D scény můžete přidat textové poznámky.
Na Macu přejděte do aplikace Náhled
.
Otevřete 3D soubor, klikněte na
a potom klikněte na
.
V zobrazovací oblasti se objeví ikona anotace.
Klikněte na ni a zadejte poznámku.
Anotaci uložíte tak, že kliknete kamkoli mimo ni. Anotaci můžete také přetáhnout na jiné místo.
Proveďte některou z následujících akcí:
Změna barvy anotace: S přidržením klávesy Control klikněte na anotaci a potom vyberte barvu.
Smazání anotace: S přidržením klávesy Control klikněte na anotaci a potom vyberte Smazat.
Přichycení k povrchu objektu: Přetáhněte anotaci na objekt.
Tip: Chcete‑li změnit jméno autora, které se zobrazuje u nových poznámek, vyberte Náhled > Nastavení, klikněte na Obecné a potom do pole Jméno zadejte požadované jméno.
Chcete‑li zobrazit všechny poznámky včetně jejich obsahu, vyberte volbu Zobrazit > Poznámky. Pokud je anotací víc, můžete z aktuální anotace přejít na předchozí nebo následující anotaci kliknutím na nebo
. Kamera se automaticky přesune tak, aby se anotace dostala do záběru.