Zobrazení 3D souborů v Náhledu na Macu
V Náhledu můžete zobrazovat 3D soubory a měnit jejich vzhled v zobrazovací oblasti, což je prostor, kde je můžete zobrazovat, procházet a pracovat s nimi. 3D soubor může obsahovat scénu nebo objekt. Když si prohlížíte scénu, je to, jako byste stáli uprostřed ní a mohli se rozhlížet. Při prohlížení objektů můžete objekt libovolně otáčet.
Poznámka: Pro soubory SceneKit (.scn) a Collada (.dae) nejsou některé funkce pro prohlížení a úpravy 3D objektů k dispozici.
Otevření 3D souboru
Na Macu přejděte do aplikace Náhled
.
Použijte příkaz Soubor > Otevřít.
Přejděte do složky obsahující soubor a dvakrát na něj klikněte.
Poznámka: USD soubory mohou existovat samostatně, ale často odkazují na další soubory, které jsou pro zobrazení scén nebo prostředků potřeba. USD soubory z původní složky nepřesouvejte, scéna by se nemusela zobrazit. Složka může obsahovat i více USD souborů.
Prohlížení 3D scény
Scénu můžete procházet otáčením, posouváním nebo přibližováním či oddalováním.
Na Macu přejděte do aplikace Náhled
.
Otevřete 3D soubor a potom proveďte některou z následujících akcí:
Otáčení: Po scéně se můžete pohybovat tažením kdekoli v zobrazovací oblasti.
Panoramatický pohled: Použijte tažení dvěma prsty na trackpadu nebo tažení se stisknutým prostředním tlačítkem myši.
Přiblížení: Stažení dvěma prsty na trackpadu, posouvání myší nebo tažení se stisknutým pravým tlačítkem myši.
Přiblížení výběru: Vyberte Zobrazení > Přiblížit výběr nebo stiskněte Shift-Command-8. Pokud není vybráno nic, Náhled místo toho přizpůsobí celou scénu v zobrazovací oblasti.
Chcete‑li trvale změnit orientaci nebo velikost scény, a nejen její zobrazení, přečtěte si téma „Úprava scény“ v oddílu Úpravy 3D souborů v Náhledu na Macu.
Prohlížení objektů ve scéně
3D scény se skládají z primů (objektů scény), které představují tvary, světla, kamery a materiály a jsou uspořádané v určité hierarchii. Primy v 3D scéně můžete procházet na panelu Hierarchie objektů.
Na Macu přejděte do aplikace Náhled
.
Otevřete 3D soubor a pak vyberte Zobrazení > Hierarchie objektů.
Proveďte některou z následujících akcí:
Výběr skupiny nebo primu: Klikněte na příslušný název nebo stiskněte klávesu se šipkou nahoru nebo dolů.
Rozbalení nebo sbalení skupiny: Klikněte na
nebo
nebo stiskněte klávesu se šipkou doprava nebo doleva.
Skrytí nebo zobrazení skupiny nebo primu: U příslušného názvu klikněte na
.
Označení primu jako kořenu odkazu na soubor: Se stisknutou klávesou Control klikněte na prim a potom vyberte Kořen odkazu na soubor. U jména se zobrazí hvězdička. Kořen odkazu na soubor je prim standardně používaný ostatními soubory, když na tento soubor odkazují, a také místo, kam Náhled přidává nové primy, když není vybrané žádné jiné.
Pohled prostřednictvím kamery
Scénu můžete zobrazit z perspektivy kterékoli kamery definované v 3D souboru nebo z výchozího zobrazení Perspektiva, které je na panelu Kamery vždy uvedeno jako první.
Na Macu přejděte do aplikace Náhled
.
Otevřete 3D soubor a pak vyberte Zobrazení > Kamery.
Na panelu Kamery klikněte na miniaturu požadované kamery – scéna se zobrazí z její perspektivy.
Miniatury jsou živé náhledy, které ukazují nasměrování jednotlivých kamer, a kamera, kterou právě sledujete, je zvýrazněná. Chcete‑li se vrátit k výchozímu zobrazení, klikněte na volbu Perspektiva.
Chcete‑li vybranou kameru uzamknout nebo odemknout, klikněte na
.
Uzamknutí znemožňuje otáčení, posouvání a přiblížení při pohledu přes danou kameru, ale stále můžete přesouvat primy pomocí transformačních úchytů nebo upravovat vlastnosti kamery v oddílu Vlastnosti objektu. Stav uzamčení se neukládá spolu se souborem. Kameru s animovaným pohybem nelze odemknout. Uzamčení kamery není k dispozici pro zobrazení Perspektiva, ve kterém se můžete vždy volně pohybovat.
Vyberte styl vykreslování
Na Macu přejděte do aplikace Náhled
.
Otevřete 3D soubor, potom vyberte Zobrazení > 3D vykreslování.
Proveďte některou z následujících akcí:
Zobrazení způsobu, jakým se na platformách Apple zobrazuje obsah: Vyberte RealityKit (standardní výběr).
Použití obecného vykreslovacího modulu pro širokou kompatibilitu s USD: Vyberte volbu OpenUSD Storm.
Kvalitní fyzikálně založené vykreslování: Vyberte Raytracer.
Vykreslení scény s realistickým osvětlením a materiály tak, aby vypadala jako fotografie: Vyberte Fotorealistické renderování. Můžete také kliknout na
a pak na
. Pokud je zapnuté fotorealistické vykreslování, ovládací prvky Vykreslovací modul a Prostředí nebudou dostupné. Pokud scéna neobsahuje žádná světla, zobrazí se dialogové okno. Kliknutím na Přesto povolit můžete pokračovat, nebo klikněte na Zrušit. Chcete‑li přidat světlo, viz Přidání primu.
Výběr osvětlení okolního prostředí: V oddílu Prostředí vyberte volbu Studio, Zataženo, Slunečno, Soumrak, Noc, Noční město nebo Interiér kanceláře. Můžete také kliknout na
, pak na
a potom vybrat požadovanou volbu. Ovládací prvky prostředí nejsou k dispozici, když je zapnuté Fotorealistické vykreslování.
Chcete‑li změnit výchozí vykreslovací modul, vyberte Náhled > Nastavení, klikněte na 3D a potom v místní nabídce Výchozí vykreslovací modul vyberte nový vykreslovač.
Úprava vzhledu zobrazovací oblasti
Chcete‑li v zobrazovací oblasti změnit vzhled scény, můžete upravit vzdálenost stínů, expozici nebo gamu.
Na Macu přejděte do aplikace Náhled
.
Otevřete 3D soubor a potom klikněte na
.
Na panelu nástrojů klikněte na
.
Proveďte některou z následujících akcí:
Nastavení délky vržených stínů ve scéně: Pokud je jako styl vykreslování vybrán Raytracer a fotorealistické vykreslování je vypnuté, přetáhněte jezdec Vzdálenost stínu nebo zadejte hodnotu.
Zesvětlení nebo ztmavení scény: Přetáhněte jezdec Expozice nebo zadejte hodnotu.
Úprava tónového rozsahu scény: Přetáhněte jezdec Gama nebo zadejte hodnotu.
Resetování vzdálenosti stínů, expozice a gamy na výchozí hodnoty: Klikněte na Resetovat vše.
Přehrávání animací
Pokud 3D soubor obsahuje animaci, můžete ji pustit pomocí ovládacích prvků pro přehrávání. Animace se standardně přehrávají ve smyčce.
Na Macu přejděte do aplikace Náhled
.
Otevřete 3D soubor, potom přesunutím ukazatele dolů zobrazte ovládací prvky přehrávání, případně stiskněte mezerník.
Proveďte některou z následujících akcí:
Spuštění nebo pozastavení přehrávání: V ovládacích prvcích přehrávání klikněte na
nebo
nebo stiskněte mezerník.
Jednorázové přehrání animace místo ve smyčce: Přidržte klávesu Option a klikněte na
.
Přeskočení o pět jednotek dopředu nebo dozadu: Klikněte na
nebo
.
Přepnutí měrných jednotek: Kliknutím na aktuální údaj můžete přepínat mezi snímky (standardní) a hodnotou minuty:sekundy.
Přeskočení na konkrétní snímek: Přetáhněte posuvník v pruhu přehrávání.
Poznámka: Během přehrávání nelze vybírat ani přesouvat objekty, přidávat ani upravovat poznámky ani používat nástroje na panelu nástrojů. Nadále však můžete měnit vlastnosti, přidávat nebo mazat primy a odvolávat provedené akce.
Zobrazení informací o souboru
Na bočním panelu inspektoru můžete zobrazit informace o 3D souboru, například název souboru, velikost souboru, datum vytvoření, datum úpravy, objekty, materiály a světla.
Na Macu přejděte do aplikace Náhled
.
Otevřete 3D soubor a na panelu nástrojů klikněte na
.
K prohlížení USD souborů, obrázků a PDF souborů uložených na Macu můžete použít i Apple Vision Pro. Viz Zobrazení obsahu z Macu na Apple Vision Pro.