Просмотр 3D-файлов в приложении «Просмотр» на Mac
Вы можете открывать 3D-файлы в приложении «Просмотр» и менять настройки отображения в окне просмотра — пространстве, где можно просматривать документ, перемещаться по нему и взаимодействовать с ним. 3D‑файл может содержать сцену или объект. При просмотре сцены создается впечатление, что Вы находитесь внутри нее и можете оглядываться вокруг. При просмотре объекта его можно поворачивать в любом направлении.
Примечание. Некоторые функции просмотра и редактирования 3D-объектов недоступны для файлов формата SceneKit (.scn) и Collada (.dae).
Открытие 3D‑файла
Откройте приложение «Просмотр»
на Mac.
Выберите «Файл» > «Открыть».
Перейдите к папке, содержащей файл, затем дважды нажмите файл.
Примечание. Иногда вся информация содержится непосредственно в файле USD, но чаще он указывает на другие файлы, необходимые для отображения сцены или объектов. Не перемещайте файл USD за пределы исходной папки: это может привести к невозможности отображения сцены. В папке может быть несколько файлов USD.
Просмотр 3D-сцены
Для просмотра сцены можно использовать вращение, панарамирование и изменение масштаба.
Откройте приложение «Просмотр»
на Mac.
Откройте 3D-файл, затем выполните любое из указанных ниже действий.
Вращение. Перемещайтесь по сцене по кругу, перетягивая окно просмотра в любую точку.
Смещение обзора. Перетягивайте двумя пальцами на трекпаде или с помощью средней кнопки мыши.
Изменение масштаба. Сведите или разведите два пальца на трекпаде, выполните прокрутку с помощью мыши или перетягивание с удерживанием правой кнопки мыши.
Изменение масштаба до выбранного. Выберите меню «Вид» > «Изменить масштаб до выбранного» или нажмите Shift-Command-8. Если ничего не выбрано, в окне просмотра в приложении «Просмотр» отобразится вся сцена целиком.
Информацию о том, как изменить ориентацию или размер сцены, а не просто сменить ракурс для ее просмотра, см. в разделе Редактирование 3D-файла в приложении «Просмотр» на Mac (статья «Корректировка сцены»).
Просмотр объектов сцены
3D-сцены состоят из примитивов — упорядоченных по иерархии объектов, таких как формы, источники света, камеры и материалы. В панели «Иерархия объектов» можно просматривать примитивы в 3D-сцене.
Откройте приложение «Просмотр»
на Mac.
Откройте 3D-файл, затем выберите меню «Вид» > «Иерархия объектов».
Выполните любое из указанных ниже действий.
Выбор группы или примитива. Нажмите имя или нажмите клавишу со стрелкой вверх или вниз.
Развертывание или свертывание группы. Нажмите
или
либо нажмите клавишу со стрелкой вправо или влево.
Скрытие или отображение группы или примитива. Нажмите
рядом с именем.
Отметка примитива в качестве корневого элемента ссылки на файл. Нажмите примитив, удерживая клавишу Control, затем выберите «Корневой элемент ссылки на файл». Рядом с именем примитива появится значок звезды. Корневой элемент ссылки файла является первичным элементом, который используется другими файлами по умолчанию при связывании с этим файлом. Сюда приложением «Просмотр» будут добавляться новые примитивы, если не сделан никакой выбор.
Просмотр через камеру
Просматривать сцену можно с ракурса любой камеры, определенной в 3D-файле, или в режиме «Перспектива», используемом по умолчанию. Этот режим всегда отображается первым в панели «Камеры».
Откройте приложение «Просмотр»
на Mac.
Откройте 3D-файл, затем выберите меню «Вид» > «Камеры».
В панели «Камеры» нажмите миниатюру камеры, чтобы просмотреть сцену с ее ракурса.
Миниатюры — это интерактивные изображения, показывающие, куда направлена каждая камера. Камера, через которую Вы смотрите, выделена. Чтобы вернуться к настройкам по умолчанию, нажмите «Перспектива».
Чтобы установить или снять блокировку с выбранной камеры, нажмите
.
Блокировка запрещает вращение, перемещение и изменение масштаба, пока Вы смотрите через эту камеру. Однако Вы все еще можете перемещать объект с помощью его меток-манипуляторов или редактировать свойства камеры в панели «Свойства объекта». Статус блокировки не сохраняется с файлом, а разблокировать камеру с анимированным движением невозможно. Блокировка камеры недоступна в режиме «Перспектива», в котором всегда можно передвигаться свободно.
Выбор стиля рендеринга
Откройте приложение «Просмотр»
на Mac.
Откройте 3D-файл, затем выберите меню «Вид» > «3D‑рендеринг».
Выполните любое из указанных ниже действий.
Просмотр того, как контент отображается на платформах Apple. Выберите «RealityKit» (параметр выбран по умолчанию).
Использование универсального рендеринга для обеспечения большей совместимости с USD. Выберите «OpenUSD Storm».
Получение высококачественного физически корректного рендеринга. Выберите «Raytracer».
Рендеринг сцены с реалистичным освещением и материалами для отображения результата, схожего с фото. Выберите «Фотореалистичный рендеринг». Либо нажмите
, затем нажмите
. Когда режим «Фотореалистичный рендеринг» включен, элементы управления «Обработчик» и «Окружение» недоступны. Если в сцене отсутствуют источники освещения, появится диалоговое окно. Нажмите в нем «Все равно включить», чтобы продолжить рендеринг, или нажмите «Отменить», чтобы отменить его. Информацию о добавлении источника освещения см. в разделе Добавление примитива.
Выбор среды освещения. Для параметра «Окружение» выберите «Студийный», «Тусклый», «Солнечно», «Сумрачно», «Ночь», «Ночной город» или «Офисный интерьер». Либо нажмите
, затем нажмите
и выберите параметр. Когда режим «Фотореалистичный рендеринг» включен, элементы управления «Окружение» недоступны.
Чтобы изменить обработчик по умолчанию, выберите меню «Просмотр» > «Настройки», нажмите «3D», затем во всплывающем меню «Обработчик по умолчанию» выберите новый обработчик.
Настройка оформления окна просмотра
Можно настроить длину тени, экспозицию и гамму, чтобы изменить оформление окна просмотра.
Откройте приложение «Просмотр»
на Mac.
Откройте 3D-файл, затем нажмите
.
В панели инструментов нажмите
.
Выполните любое из указанных ниже действий.
Управление длиной тени, отбрасываемой в сцене. Если выбран стиль рендеринга «Трассировщик лучей» и отключена функция «Фотореалистичный рендеринг», перетягивайте слайдер «Длина тени» или введите значение.
Увеличение или уменьшение яркости сцены. Перетяните слайдер «Экспозиция» или введите значение.
Настройка тонального диапазона сцены. Переместить слайдер «Гамма» или введите значение.
Сброс параметров «Длина тени», «Экспозиция» и «Гамма» к значениям по умолчанию. Нажмите «Сбросить все».
Воспроизведение анимации
Если 3D‑файл содержит анимацию, ее можно воспроизводить с помощью элементов управления воспроизведением. По умолчанию анимация воспроизводится циклически.
Откройте приложение «Просмотр»
на Mac.
Откройте 3D-файл, затем переместите указатель в нижнюю часть отображения, чтобы отобразить элементы управления воспроизведением, или нажмите пробел.
Выполните любое из указанных ниже действий.
Воспроизведение или приостановка. Нажмите
или
в элементах управления воспроизведением или нажмите клавишу пробела.
Однократное воспроизведение анимации без зацикливания. Нажмите
, удерживая нажатой клавишу Option.
Перемотка вперед или назад на пять единиц. Нажмите
или
.
Смена единиц измерения. Нажмите текущую единицу измерения, чтобы переключиться между кадрами (единица измерения по умолчанию) и минутами с секундами.
Переход к определенному кадру. Перетяните индикатор воспроизведения по шкале воспроизведения.
Примечание. Во время воспроизведения невозможно выбирать или перемещать объекты, добавлять или редактировать аннотации, а также использовать инструменты в панели инструментов. Однако Вы можете добавлять или удалять примитивы, изменять их свойства, а также отменять действия.
Просмотр информации о файле
В боковом меню «Инспектор» можно просмотреть информацию о 3D-файле, например, имя файла, его размер, дату создания и изменения, объекты, материалы и источники освещения.
Откройте приложение «Просмотр»
на Mac.
Откройте 3D-файл, затем нажмите
в панели инструментов.
На Apple Vision Pro также можно просматривать файлы USD, PDF и изображения, сохраненные на Mac. См. раздел Просмотр контента с Mac на Apple Vision Pro.