Редактирование 3D‑файла в приложении «Просмотр» на Mac
В приложении «Просмотр» на Mac можно перемещать, поворачивать и изменять масштаб примитивов в 3D-сцене, редактировать их свойства и добавлять примечания.
Примечание. Однослойные файлы USD, USDA, USDC и USDZ можно редактировать непосредственно в приложении «Просмотр». Если Вы впервые редактируете файлы других форматов (включая файлы USD, состоящие из нескольких слоев) в приложении «Просмотр», изменения сохраняются в копии, а оригинал остается нетронутым.
Перемещение, поворот или изменение масштаба примитива
Откройте приложение «Просмотр»
на Mac.
Нажмите примитив в окне просмотра (или выберите меню «Вид» > «Иерархия объектов», затем выберите примитив). Чтобы выделить в окне просмотра часть сгруппированного объекта вместо всей группы, нажмите группу, удерживая клавишу Option.
Чтобы выбрать команду «Переместить», «Повернуть» или «Изменить масштаб», выполните одно из указанных ниже действий.
Нажмите
, затем выберите один из вариантов.
Выберите меню «Инструменты» > «3D‑манипулятор», затем выберите один из вариантов.
Нажмите сочетание клавиш Option-W, Option-E или Option-R.
Чтобы изменить или сбросить ось поворота, выберите меню «Инструменты» > «3D‑манипулятор» > «Настроить ось», затем выберите вариант.
Перетяните цветные манипуляторы в окне просмотра.
Манипулятор оси X — красный, оси Y — зеленый, оси Z — синий, манипулятор пространства экрана — серый.
Совет. Чтобы дублировать примитив, перетяните один из его манипуляторов преобразования, удерживая клавишу Option. Чтобы прикрепить объект к поверхности другого объекта во время его перемещения, удерживайте клавишу Shift во время перетягивания серого манипулятора пространства экрана.
Редактирование свойств примитива
Свойства выбранного примитива можно просматривать и редактировать в панели «Свойства объекта», включая значения трансформации, видимость, материал и оформление. Некоторые свойства, например свойства материала и образца, работают не со всеми стилями рендеринга.
Откройте приложение «Просмотр»
на Mac.
Откройте 3D‑файл, выберите меню «Вид» > «Иерархия объектов», затем выберите примитив, свойства которого Вы хотите изменить. Примитив также можно выбрать, нажав его в окне просмотра.
Примечание. Чтобы редактировать несколько примитивов одновременно, в панели «Иерархия объектов» нажмите каждый из них, удерживая клавишу Command (или выберите диапазон, удерживая клавишу Shift).
Выберите меню «Инструменты» > «Показать свойства объектов».
Выполните любое из указанных ниже действий.
Редактирование значений преобразования. В строке «Перевести», «Повернуть» или «Масштабировать» выберите поле, затем введите значение для осей X, Y или Z в единицах измерения сцены для соответствующих параметров. Также можно нажать поле при его перетягивании вверх или вниз, чтобы увеличить или уменьшить его значение. При выборе поля автоматически выбирается соответствующий инструмент преобразования.
Включение или выключение параметра «Сохранять пропорции». Нажмите
. Этот значок всегда виден и отображается заполненным, когда параметр включен. Таким образом, сохраняется соотношение между значениями X, Y и Z, не делая их равными.
Отображение или скрытие примитива. Выберите или отмените выбор для параметра «Видимый». (Для отображения этого параметра, возможно, потребуется нажать
рядом с параметром «Фигура».)
Изменение материала. Нажмите всплывающее меню «Материал», затем выберите материал.
Настройка цвета. Нажмите текущий цвет или цветовую область, затем выберите цвет. Эта настройка доступна, только если для параметра «Материал» выбран вариант «Нет».
Редактирование цветов материала. Если выбран примитив, для которого указан материал (нажмите его в окне просмотра, удерживая клавиши Option и Shift, или нажмите примитив со значком кисти
в панели «Иерархия объектов»), нажмите текущий цвет или цветовую область рядом с параметрами «Цвет рассеивания», «Цвет свечения» или «Цвет блика», затем выберите цвет. Если цветовое поле выглядит затемненным, это значит к нему применена текстура. Нажмите ее, удерживая клавишу Control, и выберите «Сбросить значение», чтобы удалить текстуру и редактировать цвет напрямую.
Настройка прозрачности. Перетяните слайдер «Прозрачность» влево или вправо или введите значение в процентах. Отображение прозрачности зависит от стиля отображения. Наилучший результат можно получить при использовании стиля «Трассировщик лучей».
Редактирование фокусного расстояния и диафрагмы камеры. Если выбран примитив камеры, в строке «Фокусное расстояние» или «Вертикальная диафрагма» выберите поле, затем введите значение. Фокусное расстояние указывается в миллиметрах.
Редактирование разрешения камеры. Если выбран примитив камеры, в строке «Разрешение» выберите поле, затем введите значение в пикселях для параметров «Ш» или «В».
Редактирование межзрачкового или фокусного расстояния камеры. Если выбран примитив камеры, в строке «Межзрачковое расстояние» или «Фокусное расстояние» выберите поле, затем введите значение в единицах измерения сцены.
Редактирование размера для света. Если выбран примитив освещения, в строке «Размер» выберите поле «Ширина» или «Высота», затем введите значение в единицах измерения сцены. По умолчанию изменение одного значения меняет значение в другом поле, чтобы соотношение сторон всегда сохранялось. Нажмите
, чтобы отрегулировать каждое значение по отдельности.
Редактирование светового конуса. Если выбран примитив освещения, в поле «Угол конуса» введите значение в градусах или перетяните слайдер «Мягкость конуса».
Настройка цвета для света. Если выбран примитив освещения, нажмите текущий цвет или цветовую область рядом с параметром «Цвет», затем выберите цвет. Если вместо этого параметра отображается вариант «Цветовая температура», выберите поле, затем введите значение в Кельвинах. Отображается только один из двух вариантов в зависимости от способа создания файла, и переключаться между ними невозможно.
Изменение текстуры света. Если выбран примитив освещения, нажмите поле «Текстура», затем выберите файл изображения.
Настройка интенсивности света. Если выбран примитив освещения, выберите поле «Интенсивность», затем введите значение.
Выбор между вариантами. Если для выбранного примитива представлены несколько вариантов, во всплывающем меню в разделе «Варианты» выберите параметр, например «Материал» или «Анимация».
Добавление примитива
В 3D‑сцену можно добавлять фигуры, камеры и источники освещения.
Откройте приложение «Просмотр»
на Mac.
Откройте 3D-файл, затем выберите «Инструменты» > «Добавить в сцену».
Выберите тип примитива.
Где будет размещен новый примитив, зависит от выбора. Если выбрано преобразование или область видимости, новый примитив будет добавлен в качестве дочернего элемента. Если выбрана геометрия, примитив будет добавлен в качестве элемента той же родственной ветви внутри ближайшего преобразования или области видимости, расположенных в иерархии выше выбранного объекта. Если ничего не выбрано, новый примитив добавляется в корень сцены. Поскольку преобразования и области видимости не содержат видимых элементов, которые можно выбрать нажатием, выберите один из элементов в панели «Иерархия объектов», чтобы управлять местоположением нового примитива.
Использование контекстного меню для примитива
В панели «Иерархия объектов» нажмите объект, удерживая клавишу Control, чтобы переименовать его, дублировать, удалить или выбрать другое действие.
Откройте приложение «Просмотр»
на Mac.
Откройте 3D-файл, затем выберите меню «Вид» > «Иерархия объектов».
В панели «Иерархия объектов» выберите примитив, который хотите изменить.
Выполните любое из указанных ниже действий.
Переименование примитива. Нажмите клавишу Return, затем введите новое имя. Также можно дважды нажать имя, как в Finder.
Дублирование примитива. Нажмите примитив, удерживая клавишу Control, затем выберите «Дублировать».
Удаление примитива. Нажмите клавишу Delete или нажмите примитив, удерживая клавишу Control, затем выберите «Удалить».
Группирование с другими выбранными примитивами. Нажмите один из выбранных примитивов, удерживая клавишу Control, затем выберите «Новая группа из выбранного».
Объединение нескольких примитивов в одну группу объектов в окне просмотра. Нажмите один из выбранных примитивов, удерживая клавишу Control, затем выберите «Выбрать как группу».
Вырезание примитива. Нажмите клавиши Command + X или нажмите примитив, удерживая клавишу Control, затем выберите «Вырезать».
Копирование примитива. Нажмите клавиши Command + X или нажмите примитив, удерживая клавишу Control, затем выберите «Копировать».
Вставка примитива. Нажмите клавиши Command + X или нажмите примитив, удерживая клавишу Control, затем выберите «Вставить». Вставленный примитив появится там, где находится указатель.
Примечание. Вы можете вырезать, копировать и вставлять объекты между отдельными окнами приложения «Просмотр» — это удобный способ перемещать объект из одной сцены в другую.
Деактивирование примитива. Нажмите примитив, удерживая клавишу Control, затем выберите «Деактивировать».
Примечание. Скрытие примитива (видимого в панели «Свойства объекта») оставляет его в сцене, но прекращает его отрисовку. Деактивация полностью удаляет объект и его содержимое из сцены, но не удаляет из файла, поэтому его можно включить позже. Поскольку деактивированный примитив удаляется из сцены, все связанные с ним элементы (например, связанные материалы), оказываются без связи.
Совет. Деактивация большой группы может уменьшить размер файла, поскольку содержимое деактивированной группы не загружается в приложении «Просмотр».
Отметка примитива в качестве объекта, редактируемого на Apple Vision Pro. Нажмите примитив, удерживая клавишу Control, затем выберите «Можно редактировать на Apple Vision Pro». Объект будет отмечен как интерактивный на Apple Vision Pro. В приложении «Просмотр» ничего не изменится.
Отметка примитива в качестве корневого элемента ссылки на файл. Нажмите примитив, удерживая клавишу Control, затем выберите «Корневой элемент ссылки на файл». Рядом с именем примитива появится значок звезды. Другие файлы по умолчанию используют этот примитив при ссылке на этот файл. Сюда будут добавляться новые примитивы, если не сделан никакой выбор.
Переупорядочивание иерархии сцен
Родительский объект для примитива можно изменить. Также можно изменить порядок примитивов, перетягивая их в панели «Иерархия объектов».
Откройте приложение «Просмотр»
на Mac.
Откройте 3D-файл, затем выберите меню «Вид» > «Иерархия объектов».
Выполните любое из указанных ниже действий.
Смена родительского объекта. Перетяните объект, который должен стать родительским, в преобразование или область видимости.
Изменение порядка отображения примитива. Перетяните примитив на новое место в той же родительской иерархии.
Примечание. Материалы также могут быть вложены в геометрию, а шейдер может быть вложен только в материал.
Корректировка сцены
Можно изменить размер сцены, повернуть ее или изменить ориентацию всей сцены, а не только точку обзора. В отличие от вращения окна просмотра для осмотра сцены с другого ракурса корректировка сцены изменяет файл.
Откройте приложение «Просмотр»
на Mac.
Откройте 3D-файл, затем выполните одно из указанных ниже действий.
Поворот на 90 градусов. Нажмите
, чтобы повернуть влево, или нажмите, удерживая клавишу Option, чтобы повернуть вправо.
Поворот на определенный угол. Выберите «Инструменты» > «Настроить размер», введите значения в полях «Повернуть по оси X», «Повернуть по оси Y» или Повернуть по оси Z» ниже поля «Ориентация контента», затем нажмите «OK».
Изменение ориентации модели. Выберите «Инструменты» > «Настроить размер», во всплывающем меню «Ориентация» под разделом «Настройки сцены» выберите «Вверх по оси Y» или «Вверх по оси Z», затем нажмите «OK». Также можно выбрать единицу измерения во всплывающем меню «Единицы» под разделом «Настройки сцены».
Изменение размера модели. Выберите меню «Инструменты» > «Настроить размер», введите значения в полях «Высота», «Ширина», «Глубина» или «Масштаб» под разделом «Размер контента», затем нажмите «ОК». Также можно выбрать единицу измерения во всплывающем меню под разделом «Размер контента».
Примечание. По умолчанию выбрано значение «Сохранить размер и ориентацию контента», поэтому при изменении одного из полей «Высота», «Ширина», «Глубина» или «Масштаб» другие поля обновляются с сохранением пропорций. Чтобы отрегулировать каждое значение по отдельности, снимите флажок для этого параметра.
Добавление пометок в 3D-файл
В 3D‑сцену можно добавлять текстовые аннотации.
Откройте приложение «Просмотр»
на Mac.
Откройте 3D‑файл, нажмите
, затем нажмите
.
В окне просмотра отображается значок аннотации.
Нажмите значок аннотации, затем введите заметку.
Чтобы сохранить аннотацию, нажмите в любом месте за ее пределами. Вы также можете перетянуть аннотацию туда, куда Вам нужно.
Выполните любое из указанных ниже действий.
Изменение цвета. Нажмите аннотацию, удерживая клавишу Control, затем выберите цвет.
Удаление аннотации. Нажмите аннотацию, удерживая клавишу Control, затем выберите «Удалить».
Привязка объекта к поверхности другого. Перетяните аннотацию к объекту.
Совет. Чтобы изменить имя автора, которое будет отображаться в новых аннотациях, выберите меню «Просмотр» > «Настройки», нажмите «Основные», затем введите имя в поле «Имя».
Чтобы просмотреть все аннотации и их содержимое, выберите меню «Вид» > «Заметки». Если есть несколько аннотаций, можно нажать или
внутри аннотации, чтобы перейти к предыдущей или следующей. Камера автоматически перемещается, чтобы кадрировать аннотацию в сцене.