Edytowanie pliku 3D w Podglądzie na Macu
Aplikacja Podgląd na Macu pozwala przesuwać, obracać i skalować prymitywy w scenie 3D, edytować ich właściwości oraz dodawać adnotacje.
Uwaga: Aplikacja Podgląd umożliwia bezpośrednią edycję jednowarstwowych plików USD, USDA, USDC i USDZ. W przypadku innych formatów, w tym plików USD składających się z wielu warstw, pierwsza edycja w Podglądzie powoduje zachowanie zmian w kopii, a oryginał pozostaje niezmieniony.
Przesuwanie, obracanie i skalowanie prymitywu
Przejdź do aplikacji Podgląd
na Macu.
Kliknij w prymityw w obszarze widocznym (lub wybierz polecenie menu Widok > Hierarchia obiektów, a następnie zaznacz prymityw). Aby zaznaczyć określoną część zgrupowanego obiektu w obszarze widocznym (zamiast całej grupy), kliknij z klawiszem Option w tę część.
Wykonaj jedną z następujących czynności, aby wybrać opcję Przesuń, Obróć lub Skaluj:
Kliknij w
, a następnie wybierz jedną z opcji.
Wybierz polecenie menu Narzędzia > Manipulator 3D, a następnie wybierz jedną z opcji.
Naciśnij klawisze Option‑W, Option‑E lub Option‑R.
Aby zmienić lub wyzerować punkt obrotu, wybierz polecenie menu Narzędzia > Manipulator 3D > Dostosuj punkt obrotu, a następnie wybierz żądaną opcję.
Przeciągaj oznaczone kolorem uchwyty transformacji w obszarze widocznym.
Uchwyt osi x jest czerwony, uchwyt osi y jest zielony, uchwyt osi z jest niebieski, a uchwyt w przestrzeni ekranu jest szary.
Porada: Aby powielić prymityw, przeciągnij z klawiszem Option dowolny z jego uchwytów transformacji. Aby przyciągnąć obiekt do powierzchni innego podczas jego przesuwania, przytrzymaj klawisz Shift podczas przeciągania szarego uchwytu w przestrzeni ekranu.
Edytowanie właściwości prymitywu
W panelu Właściwości obiektu możesz przeglądać i edytować właściwości zaznaczonego prymitywu, w tym wartości transformacji, widoczność, materiał oraz wygląd. Nie wszystkie właściwości, takie jak właściwości materiału i wyglądu, działają z każdym stylem renderowania.
Przejdź do aplikacji Podgląd
na Macu.
Otwórz plik 3D, wybierz polecenie menu Widok > Hierarchia obiektów, a następnie zaznacz prymityw, którego właściwości chcesz edytować. Możesz także zaznaczyć prymityw, klikając w niego w obszarze widocznym.
Uwaga: Aby edytować jednocześnie wiele prymitywów, kliknij w każdy z nich z klawiszem Command w panelu Hierarchia obiektów (lub kliknij z klawiszem Shift, aby zaznaczyć zakres).
Wybierz polecenie menu Narzędzia > Pokaż właściwości obiektu.
Wykonaj dowolną z następujących czynności:
Edytowanie wartości transformacji: Wybierz odpowiednie pole w wierszu Przesuń, Obróć lub Skaluj, a następnie wprowadź wartość X, Y lub Z (w jednostkach pomiaru sceny w przypadku pól Przesuń i Skaluj lub w stopniach w przypadku pola Obróć). Możesz również kliknąć w pole podczas przeciągania w górę lub w dół, aby zwiększyć lub zmniejszyć jego wartość. Wybranie pola automatycznie powoduje wybranie odpowiedniego narzędzia transformacji.
Włączanie lub wyłączanie utrzymywania proporcji: Kliknij w ikonę
. Jest ona zawsze widoczna; gdy opcja jest włączona, ikona jest wypełniona. Powoduje to zachowanie proporcji między wartościami X, Y i Z, zamiast ich wyrównywania.
Pokazywanie lub ukrywanie prymitywu: Zaznacz lub usuń zaznaczenie pola wyboru Widoczne. Wyświetlenie tej opcji może wymagać kliknięcia w
obok etykiety Kształt.
Zmienianie materiału: Kliknij w menu podręczne Materiał, a następnie wybierz materiał.
Dostosowywanie koloru: Kliknij w bieżący kolor lub w koło kolorów, a następnie wybierz kolor. Dostępne tylko wtedy, gdy materiał jest ustawiony na Brak.
Edytowanie kolorów materiału: Jeśli zaznaczony jest prymityw materiału (kliknij w niego z klawiszami Option‑Shift w obszarze widocznym lub kliknij w prymityw oznaczony
w panelu Hierarchia obiektów), kliknij w bieżący kolor lub w koło kolorów obok etykiety Diffuse Color (Kolor rozproszenia), Emissive Color (Kolor emisji) lub Specular Color (Kolor odbicia) w sekcji Properties (Właściwości), a następnie wybierz kolor. Jeśli pole koloru jest wyszarzone, oznacza to, że zastosowana jest tekstura. Aby usunąć teksturę i edytować kolor bezpośrednio, kliknij z klawiszem Control w menu podręczne tekstury, a następnie wybierz Wyzeruj wartość.
Korygowanie krycia: Przeciągnij suwak Krycie w lewo lub w prawo albo wpisz wartość w procentach. Sposób wizualizacji krycia różni się w zależności od wybranego silnika renderującego. Najlepsze wyniki daje Raytracer.
Edytowanie długości ogniskowej lub przysłony kamery: Jeśli zaznaczony jest prymityw kamery, wybierz pole w wierszu Ogniskowa lub Wysokość matrycy, a następnie wprowadź wartość. Długość ogniskowej jest podawana w milimetrach.
Edytowanie rozdzielczości kamery: Jeśli zaznaczony jest prymityw kamery, wprowadź wartości w pikselach w polach W i H, znajdujących się w wierszu Rozdzielczość.
Edytowanie rozstawu źrenic lub odległości zbieżności: Jeśli zaznaczony jest prymityw kamery, wybierz pole Rozstaw źrenic lub Odległość zbieżności, a następnie wprowadź wartość w jednostkach miary sceny.
Edytowanie rozmiaru światła: Jeśli zaznaczony jest prymityw światła, wybierz pole Szerokość lub Wysokość, a następnie wprowadź wartość w jednostkach miary sceny. Domyślnie zmiana jednej wartości powoduje automatyczne uaktualnienie drugiego pola, aby zachować stały współczynnik proporcji. Aby zmienić wartości niezależnie od siebie, kliknij w
.
Edytowanie kąta stożka światła: Jeśli zaznaczony jest prymityw światła, wprowadź wartość w stopniach w polu Kąt stożka lub przeciągnij suwak Rozmycie stożkowe.
Korygowanie koloru światła: Jeśli zaznaczony jest prymityw światła, kliknij w bieżący kolor lub w koło kolorów obok etykiety Kolor, a następnie wybierz kolor. Jeśli zamiast tego widoczne jest pole Color Temperature (Temperatura koloru), wybierz je, a następnie wprowadź wartość w Kelwinach. Wyświetlany jest tylko jeden z tych elementów. Zależy to od sposobu utworzenia pliku. Nie ma możliwości przełączania między nimi.
Zmienianie tekstury światła: Jeśli zaznaczony jest prymityw kamery, kliknij w pole Tekstura, a następnie wybierz plik obrazka.
Korygowanie intensywności światła: Jeśli zaznaczony jest prymityw światła, wybierz pole Intensywność, a następnie wprowadź wartość.
Przełączanie wariantu: Jeśli zaznaczony prymityw ma zestawy wariantów, wybierz żądaną opcję (np. Materiał lub Animacja) w menu podręcznym pod etykietą Warianty.
Dodawanie prymitywu
Możesz dodawać kształty, kamery i oświetlenie do scen 3D.
Przejdź do aplikacji Podgląd
na Macu.
Otwórz plik 3D, a następnie wybierz polecenie menu Narzędzia > Dodaj do sceny.
Wybierz typ prymitywu:
Miejsce dodania nowego prymitywu zależy od tego, co jest zaznaczone: zaznaczenie transformacji lub kontenera dodaje nowy prymityw jako jego obiekt podrzędny, a zaznaczenie geometrii dodaje go jako obiekt równorzędny w transformacji lub zakresie najbliższym zaznaczeniu. Jeśli nic nie jest zaznaczone, nowy prymityw jest dodawany do podstawowego elementu sceny. Transformacje i kontenery nie mają obiektów reprezentujących je wizualnie w obszarze widocznym. Aby określić miejsce dodania nowego prymitywu, zaznacz transformację lub kontener w panelu Hierarchia obiektów.
Używanie menu kontekstowego prymitywu
Kliknij z klawiszem Control w prymityw w panelu Hierarchia obiektów, aby zmienić jego nazwę, skopiować go, usunąć lub wybrać inną czynność.
Przejdź do aplikacji Podgląd
na Macu.
Otwórz plik 3D, a następnie wybierz polecenie menu Widok > Hierarchia obiektów.
W panelu Hierarchia obiektów zaznacz prymityw, który chcesz zmodyfikować.
Wykonaj dowolną z następujących czynności:
Zmienianie nazwy: Naciśnij Return, a następnie wprowadź nową nazwę. Możesz również kliknąć w nazwę po raz drugi, jak w Finderze.
Powielanie: Kliknij z klawiszem Control w prymityw, a następnie wybierz Powiel.
Usuwanie: Naciśnij klawisz Delete lub kliknij z klawiszem Control w prymityw, a następnie wybierz Usuń.
Grupowanie z innymi zaznaczonymi prymitywami: Kliknij z klawiszem Control w jeden z zaznaczonych prymitywów, a następnie wybierz Nowa grupa z zaznaczenia.
Traktowanie zestawu prymitywów jako jednego obiektu po kliknięciu w obszarze widocznym: Kliknij z klawiszem Control w jeden z zaznaczonych prymitywów, a następnie wybierz Zaznacz jako grupę.
Wycinanie: Naciśnij Command‑X lub kliknij z klawiszem Control w prymityw, a następnie wybierz Wytnij.
Kopiowanie: Naciśnij Command‑C lub kliknij z klawiszem Control w prymityw, a następnie wybierz Kopiuj.
Wklejanie: Naciśnij Command‑V lub kliknij z klawiszem Control w prymityw, a następnie wybierz Wklej. Wklejony prymityw pojawi się w miejscu, w którym znajduje się wskaźnik.
Uwaga: Możesz wycinać, kopiować i wklejać rzeczy między osobnymi oknami Podglądu, co pozwala wygodnie przenosić prymitywy z jednej sceny do innej.
Dezaktywowanie: Kliknij z klawiszem Control w prymityw, a następnie wybierz Dezaktywuj.
Uwaga: Ukrycie prymitywu (przy użyciu opcji Widoczne w panelu Właściwości obiektu) sprawia, że obiekt nadal znajduje się w scenie, ale nie jest rysowany. Dezaktywowanie prymitywu całkowicie usuwa go ze sceny wraz z zawartością, ale nie powoduje usunięcia go z pliku, dzięki czemu można go później ponownie aktywować. Ponieważ zdezaktywowane prymitywy znikają ze sceny, wszelkie odniesienia do nich — na przykład przypisanie materiału — pozostają bez celu, nie mając obiektu, do którego mogłyby się odnosić.
Porada: Dezaktywowanie dużej grupy może ułatwić pracę z dużym plikiem, ponieważ aplikacja Podgląd nie wczytuje zawartości dezaktywowanej grupy.
Oznaczanie jako edytowalnego na Apple Vision Pro: Kliknij z klawiszem Control w prymityw, a następnie wybierz Do edycji na Apple Vision Pro. Spowoduje to oznaczenie prymitywu jako obiektu, z którym można wejść w interakcję na Apple Vision Pro. W samej aplikacji Podgląd nic się nie zmieni.
Oznaczanie jako odwołania głównego pliku: Kliknij z klawiszem Control w prymityw, a następnie wybierz Odwołanie główne pliku. Obok nazwy pojawi się gwiazdka. Inne pliki domyślnie wykorzystują ten prymityw, gdy odwołują się do tego pliku; jest to również miejsce, do którego trafiają nowe prymitywy, gdy nic nie jest zaznaczone.
Reorganizowanie hierarchii sceny
Możesz zmieniać obiekty nadrzędne prymitywów, a także zmieniać kolejność prymitywów, przeciągając je w panelu Hierarchia obiektów.
Przejdź do aplikacji Podgląd
na Macu.
Otwórz plik 3D, a następnie wybierz polecenie menu Widok > Hierarchia obiektów.
Wykonaj dowolną z następujących czynności:
Zmienianie obiektu nadrzędnego prymitywu: Przeciągnij go na transformację lub kontener, który ma stać się jego nowym obiektem nadrzędnym.
Zmienianie kolejności prymitywów: Przeciągnij prymityw do nowej pozycji w ramach tego samego obiektu nadrzędnego.
Uwaga: Materiały można również zagnieżdżać pod geometrią, ale shadery mogą być zagnieżdżane tylko pod materiałami.
Korygowanie sceny
Możesz zmieniać rozmiar, obracać oraz zmieniać orientację całej sceny, nie tylko jej widoku. Korygowanie sceny powoduje modyfikowanie pliku, w przeciwieństwie do obracania obszaru widocznego (orbitowania) w celu spojrzenia na scenę pod innym kątem.
Przejdź do aplikacji Podgląd
na Macu.
Otwórz plik 3D, a następnie wykonaj jedną z następujących czynności:
Obracanie o 90 stopni: Kliknij w
, aby obrócić w lewo. Kliknij z klawiszem Option, aby obrócić w prawo.
Obracanie o określoną wartość: Wybierz polecenie menu Narzędzia > Dostosuj wymiary, wprowadź wartości w polach Obróć X, Obróć Y lub Obróć Z poniżej etykiety Orientacja zawartości, a następnie kliknij w OK.
Zmienianie orientacji modelu: Wybierz polecenie menu Narzędzia > Dostosuj wymiary, wybierz Y w górę lub Z w górę w menu podręcznym Orientacja pod etykietą Ustawienia scen, a następnie kliknij w OK. Możesz również wybrać jednostkę miary w menu podręcznym Jednostki pod etykietą Ustawienia scen.
Zmienianie rozmiaru modelu: Wybierz polecenie menu Narzędzia > Dostosuj wymiary, wprowadź wartości w polach Wys., Szer., Głębia oraz Skala poniżej etykiety Wielkość zawartości, a następnie kliknij w OK. Możesz również wybrać jednostkę miary w menu podręcznym Jednostki pod etykietą Wielkość zawartości.
Uwaga: Domyślnie pole wyboru Zachowaj wielkość i orientację zawartości jest zaznaczone, więc zmiana wartości w polu Wys., Szer., Głębia lub Skala powoduje zmianę wartości w pozostałych polach, aby zachować proporcje. Aby zmieniać wartości niezależnie od siebie, usuń zaznaczenie tego pola.
Dodawanie adnotacji do pliku 3D
Możesz dodawać adnotacje tekstowe do scen 3D.
Przejdź do aplikacji Podgląd
na Macu.
Otwórz plik 3D, kliknij w
, a następnie kliknij w
.
Ikona adnotacji jest wyświetlana w obszarze widocznym.
Kliknij w ikonę adnotacji, a następnie wpisz notatkę.
Aby zachować adnotację, kliknij w dowolnym miejscu poza nią. Możesz również przeciągnąć adnotację w inne miejsce.
Wykonaj dowolną z następujących czynności:
Zmienianie koloru: Kliknij z klawiszem Control w adnotację, a następnie wybierz kolor.
Usuwanie: Kliknij z klawiszem Control w adnotację, a następnie wybierz Usuń.
Przyciągnięcie do powierzchni obiektu: Przeciągnij adnotację do obiektu.
Porada: Aby zmienić nazwę autora, która jest wyświetlana w nowych adnotacjach, wybierz polecenie menu Podgląd > Ustawienia, kliknij w Ogólne, a następnie wpisz nazwę w polu Użytkownik.
Aby wyświetlić wszystkie adnotacje i ich zawartość, wybierz polecenie menu Widok > Notatki. Jeśli masz wiele adnotacji, możesz kliknąć w lub
w adnotacji, aby przejść do poprzedniej lub następnej. Aparat przemieszcza się automatycznie w celu wykadrowania adnotacji w scenie.