Mac용 미리보기에서 3D 파일 편집하기
Mac의 미리보기에서 3D 장면의 프림을 이동, 회전하거나 크기를 조절하고, 속성을 편집하고, 주석을 추가할 수 있습니다.
참고: 미리보기에서는 단일 레이어의 USD, USDA, USDC 및 USDZ 파일을 직접 편집할 수 있습니다. 여러 레이어로 구성된 USD 파일을 비롯한 다른 포맷을 편집할 경우, 미리보기는 파일을 처음 편집할 때 원본은 그대로 두고 복사본에 변경사항을 저장합니다.
프림 이동, 회전 또는 크기 조절하기
Mac의 미리보기 앱
으로 이동하십시오.
뷰포트에서 프림을 클릭하거나, 보기 > 오브젝트 계층을 선택한 후 프림을 선택하십시오. 전체 그룹 대신 뷰포트에서 그룹화된 오브젝트의 특정 부분을 선택하려면 Option-클릭하십시오.
다음 중 하나를 수행하여 이동, 회전 또는 크기 조절을 선택하십시오.
를 클릭한 다음, 하나를 선택하십시오.
도구 > 3D 조작기를 선택한 다음, 하나를 선택하십시오.
Option-W, Option-E 또는 Option-R을 누르십시오.
피벗 지점을 변경하거나 재설정하려면 도구 > 3D 조작기 > 피벗 조절을 선택한 다음, 옵션을 선택하십시오.
뷰포트에서 색상으로 구분된 변환 핸들을 드래그하십시오.
x축 핸들은 빨간색, y축 핸들은 초록색, z축 핸들은 파란색, 화면 공간 핸들은 회색입니다.
팁: 프림을 복제하려면 프림의 변환 핸들 중 하나를 Option-드래그하십시오. 이동하면서 오브젝트를 다른 오브젝트의 표면에 스냅하려면 Shift 키를 누른 채로 회색 화면 공간 핸들을 드래그하십시오.
프림 속성 편집하기
선택한 프림의 속성을 변환 값, 가시성, 재질 및 표현 등 오브젝트 속성 패널에서 보고 편집할 수 있습니다. 재질 및 표현 속성처럼 모든 속성이 모든 렌더링 스타일에서 지원되는 것은 아닙니다.
Mac의 미리보기 앱
으로 이동하십시오.
3D 파일을 열고, 보기 > 오브젝트 계층을 선택한 다음, 편집하려는 속성이 있는 프림을 선택하십시오. 뷰포트에서 프림을 클릭하여 선택할 수도 있습니다.
참고: 여러 프림을 동시에 편집하려면 오브젝트 계층 패널에서 Command-클릭하십시오(또는 범위를 선택하려면 Shift-클릭).
도구 > 오브젝트 속성 보기를 선택하십시오.
다음 중 하나를 수행하십시오.
변환 값 편집하기: 이동, 회전 또는 크기 조절 행에서 필드를 선택한 다음, X, Y 또는 Z 값을 입력하십시오. 이동과 크기 조절에는 장면의 측정 단위로, 회전에는 도 단위로 값을 입력합니다. 위 또는 아래로 드래그하면서 필드를 클릭하여 값을 늘리거나 줄일 수도 있습니다. 필드를 선택하면 해당 변환 도구가 자동으로 선택됩니다.
‘비율 고정’ 켜기 또는 끄기:
을 클릭하십시오. 이 버튼은 항상 표시되며 켜져 있을 때는 채워진 상태로 나타납니다. 이렇게 하면 X, Y 및 Z 값을 동일하게 만드는 대신 각 값의 비율을 유지할 수 있습니다.
프림 보기 또는 가리기: ‘표시’를 선택 또는 선택 해제하십시오. (이 옵션을 보려면 ‘도형’ 옆의
을 클릭해야 할 수 있습니다.)
재질 변경하기: 재질 팝업 메뉴를 클릭한 다음, 재질을 선택하십시오.
색상 조절하기: 현재 색상 또는 색상 휠을 클릭한 다음, 색상을 선택하십시오. 이 옵션은 재질이 ‘없음’으로 설정된 경우에만 사용할 수 있습니다.
재질의 색상 편집하기: 재질 프림이 선택되어 있는 경우(뷰포트에서 Option-Shift-클릭하거나 오브젝트 계층 패널에서
으로 표시된 프림을 클릭) 속성에서 확산 색상, 발광 색상 또는 반사 색상 옆에 있는 현재 색상 또는 색상 휠을 클릭한 다음, 색상을 선택하십시오. 색상 필드가 흐리게 표시되면 텍스처가 적용되어 있는 것입니다. 해당 필드를 Control-클릭한 다음, 값 재설정을 선택하여 텍스처를 제거하고 색상을 직접 편집하십시오.
불투명도 조절하기: 불투명도 슬라이더를 왼쪽 또는 오른쪽으로 드래그하거나 백분율로 값을 입력하십시오. 불투명도 렌더링은 렌더링 스타일에 따라 달라집니다. 레이트레이서가 최상의 결과를 생성합니다.
카메라의 초점 거리 또는 조리개 편집하기: 카메라 프림이 선택된 경우 초점 거리 또는 수직 조리개 행에서 필드를 선택한 다음, 값을 입력하십시오. 초점 거리는 밀리미터 단위입니다.
카메라의 해상도 편집하기: 카메라 프림이 선택된 경우 해상도 행에서 필드를 선택한 다음, W 또는 H에 픽셀 단위로 값을 입력하십시오.
카메라의 동공 간 거리 또는 수렴 거리 편집하기: 카메라 프림이 선택된 경우 동공 간 거리 또는 수렴 거리 행에서 필드를 선택한 다음, 장면의 측정 단위로 값을 입력하십시오.
조명의 크기 편집하기: 조명 프림이 선택된 경우 크기 행에서 너비 또는 높이 필드를 선택한 다음, 장면의 측정 단위로 값을 입력하십시오. 기본적으로 하나의 값을 조절하면 다른 필드가 업데이트되어 종횡비가 일정하게 유지됩니다. 각 값을 독립적으로 조절하려면
을 클릭하십시오.
조명의 원뿔 편집하기: 조명 프림이 선택된 경우 원뿔 각도 필드에 도 단위로 값을 입력하거나 ‘원뿔 부드러운 정도’ 슬라이더를 드래그하십시오.
조명의 색상 조절하기: 조명 프림이 선택된 경우 색상 옆에 있는 현재 색상 또는 색상 휠을 클릭한 다음, 색상을 선택하십시오. 색상 온도가 대신 표시되면 해당 필드를 선택하고 K 단위로 값을 입력하십시오. 파일을 작성한 방식에 따라 둘 중 하나만 표시되며 서로 전환할 수는 없습니다.
조명의 텍스처 변경하기: 조명 프림이 선택된 경우 텍스처 필드를 클릭한 다음, 이미지 파일을 선택하십시오.
조명의 강도 조절하기: 조명 프림이 선택된 경우 강도 필드를 선택한 다음, 값을 입력하십시오.
변형 전환하기: 선택한 프림에 변형 집합이 있는 경우 변형의 ‘재질’ 또는 ‘애니메이션’ 등 팝업 메뉴에서 옵션을 선택하십시오.
프림 추가하기
3D 장면에 도형, 카메라 및 조명을 추가할 수 있습니다.
Mac의 미리보기 앱
으로 이동하십시오.
3D 파일을 연 다음, 도구 > 장면에 추가를 선택하십시오.
프림 유형을 선택하십시오.
새로운 프림이 배치되는 위치는 선택한 항목에 따라 달라집니다. 변환 또는 스코프를 선택하면 새로운 프림이 하위 항목으로 추가되고, 형상을 선택하면 선택 부분에서 가장 가까운 상위 변환 또는 범위 내에서 형제 요소로 대신 추가됩니다. 선택된 항목이 없으면 새로운 프림이 장면의 루트에 추가됩니다. 변환과 스코프는 뷰포트에서 클릭할 수 있는 표시 요소가 없으므로, 새로운 프림이 배치될 위치를 지정하려면 오브젝트 계층 패널에서 하나를 선택하십시오.
프림의 빠른 메뉴 사용하기
오브젝트 계층 패널의 프림을 Control-클릭하여 이름을 변경하거나, 복제하거나, 삭제하거나, 다른 여러 가지 동작 중 하나를 선택하십시오.
Mac의 미리보기 앱
으로 이동하십시오.
3D 파일을 연 다음, 보기 > 오브젝트 계층을 선택하십시오.
오브젝트 계층 패널에서 변경하려는 프림을 선택하십시오.
다음 중 하나를 수행하십시오.
이름 변경하기: Return 키를 누른 다음, 새로운 이름을 입력하십시오. Finder에서와 마찬가지로 이름을 한 번 더 클릭할 수도 있습니다.
복제하기: 프림을 Control-클릭한 다음, 복제를 선택하십시오.
삭제하기: Delete 키를 누르거나 프림을 Control-클릭한 다음, 삭제를 선택하십시오.
선택한 다른 프림과 그룹화하기: 선택한 프림 중 하나를 Control-클릭한 다음, ‘선택 항목을 포함하는 새로운 그룹’을 선택하십시오.
뷰포트에서 클릭 시 프림 집합이 하나의 항목처럼 동작하도록 설정하기: 선택한 프림 중 하나를 Control-클릭한 다음, ‘그룹으로 선택하기’를 선택하십시오.
오려두기: Command-X를 누르거나 프림을 Control-클릭한 다음, 오려두기를 선택하십시오.
복사하기: Command-C를 누르거나 프림을 Control-클릭한 다음, 복사를 선택하십시오.
붙여넣기: Command-V를 누르거나 프림을 Control-클릭한 다음, 붙여넣기를 선택하십시오. 붙여넣은 프림은 포인터가 있는 위치에 나타납니다.
참고: 서로 다른 미리보기 윈도우 간에 오려두기, 복사 및 붙여넣기를 할 수 있습니다. 이는 하나의 장면에서 다른 장면으로 프림을 옮길 때 유용한 방법입니다.
비활성화하기: 프림을 Control-클릭한 다음, 비활성화를 선택하십시오.
참고: 프림을 가리면(오브젝트 속성에는 표시됨) 장면에는 그대로 남아 있지만 화면에 렌더링되지 않습니다. 프림을 비활성화하면 파일에서 삭제하지 않고도 해당 프림과 내용을 장면에서 완전히 제거할 수 있으며 나중에 다시 활성화할 수 있습니다. 비활성화된 프림은 장면에서 사라지므로, 재질 바인딩처럼 해당 프림을 참조하는 항목은 참조할 대상이 없어져 끊어진 참조가 됩니다.
팁: 미리보기는 비활성화된 그룹의 내용을 로드하지 않으므로, 큰 그룹을 비활성화하면 용량이 큰 파일도 더 가볍게 작업할 수 있습니다.
Apple Vision Pro에서 편집 가능으로 표시하기: 프림을 Control-클릭한 다음, ‘Apple Vision Pro에서 편집 가능’을 선택하십시오. 이 작업은 해당 프림을 Apple Vision Pro에서 상호 작용할 수 있는 대상으로 표시하지만, 미리보기 자체에서는 아무런 변화도 일어나지 않습니다.
파일 참조 루트로 표시하기: 프림을 Control-클릭한 다음, 파일 참조 루트를 선택하십시오. 이름 옆에 별이 나타납니다. 다른 파일은 이 파일을 참조할 때 기본적으로 해당 프림을 사용하며, 아무것도 선택되지 않은 경우 새로운 프림이 추가되는 위치이기도 합니다.
장면 계층 재구성하기
오브젝트 계층 패널에서 프림을 드래그하여 프림의 상위 항목을 변경하거나 프림의 순서를 재정렬할 수 있습니다.
Mac의 미리보기 앱
으로 이동하십시오.
3D 파일을 연 다음, 보기 > 오브젝트 계층을 선택하십시오.
다음 중 하나를 수행하십시오.
프림의 상위 항목 변경하기: 새로운 상위 항목으로 지정할 변환 또는 스코프로 드래그하십시오.
프림 재정렬하기: 동일한 상위 항목 내에서 새로운 위치로 드래그하십시오.
참고: 재질은 형상 아래에 중첩할 수도 있지만 쉐이더는 재질 아래에만 중첩할 수 있습니다.
스테이지 조정하기
단순히 장면을 보는 시점만 바꾸는 것이 아니라, 전체 장면의 크기를 조절하거나 회전하거나 방향을 변경할 수 있습니다. 스테이지를 조절하면 파일이 변경되지만, 다른 각도에서 장면을 보기 위해 뷰포트를 회전하는 것은 파일을 변경하지 않습니다.
Mac의 미리보기 앱
으로 이동하십시오.
3D 파일을 열고 다음 중 하나를 수행하십시오.
90도 회전하기:
을 클릭 또는 Option-클릭하여 왼쪽 또는 오른쪽으로 회전하십시오.
특정 각도로 회전하기: 도구 > 크기 조절을 선택하고 ‘콘텐츠 방향’ 아래의 X축 회전, Y축 회전 또는 Z축 회전 필드에 값을 입력한 다음, 확인을 클릭하십시오.
모델의 방향 변경하기: 도구 > 크기 조절을 선택하고 ‘장면 설정’ 아래의 ‘방향’ 팝업 메뉴에서 ‘Y축 위로’ 또는 ‘Z축 위로’를 선택한 다음, 확인을 클릭하십시오. ‘장면 설정’ 아래의 ‘단위’ 팝업 메뉴에서 측정 단위를 선택할 수도 있습니다.
모델 크기 조절하기: 도구 > 크기 조절을 선택하고 ‘콘텐츠 크기’ 아래의 높이, 너비, 깊이 또는 크기 조절 필드에 값을 입력한 다음, 확인을 클릭하십시오. ‘콘텐츠 크기’ 아래의 팝업 메뉴에서 측정 단위를 선택할 수도 있습니다.
참고: 기본적으로 ‘콘텐츠 크기 및 방향 유지’가 선택되어 있으므로 높이, 너비, 깊이 또는 크기 조절 필드 중 하나를 변경하면 다른 필드도 업데이트되어 동일한 비율이 유지됩니다. 각 필드를 독립적으로 조절하려면 선택 해제하십시오.
3D 파일에 주석 달기
3D 장면에 텍스트 주석을 추가할 수 있습니다.
Mac의 미리보기 앱
으로 이동하십시오.
3D 파일을 열고
을 클릭한 다음,
을 클릭하십시오.
뷰포트에 주석 아이콘이 나타납니다.
주석 아이콘을 클릭한 다음, 메모를 입력하십시오.
주석 바깥쪽에서 임의의 지점을 클릭하여 주석을 저장하십시오. 주석을 다른 위치로 드래그할 수도 있습니다.
다음 중 하나를 수행하십시오.
색상 변경하기: 주석을 Control-클릭한 다음, 색상을 선택하십시오.
삭제하기: 주석을 Control-클릭한 다음, 삭제를 선택하십시오.
오브젝트의 표면에 스냅하기: 주석을 오브젝트로 드래그하십시오.
팁: 새로운 주석에 표시되는 저자 이름을 변경하려면 미리보기 > 설정을 선택하고 일반을 클릭한 다음, 이름 필드에 이름을 입력하십시오.
모든 주석 및 해당 내용을 보려면 보기 > 메모를 선택하십시오. 여러 개의 주석이 있는 경우, 주석에서 또는
를 클릭하여 이전 또는 다음 주석으로 이동할 수 있습니다. 카메라가 자동으로 움직여 장면에서 주석이 프레임에 들어오도록 조정합니다.