Logic Pro X 10.3 リリースノート

Logic Pro X 10.3 の最新および過去のアップデートについて説明します。 

Logic Pro X をアップデートする前に、現在インストールされているバージョンの Logic Pro アプリケーションと Logic Pro プロジェクトをバックアップしておいてください。

Logic Pro X 10.3.1 の新機能

新機能/改善点

  • 仮想 MIDI ポートで Audio Unit v3 仕様に対応するようになりました。

安定性と信頼性

  • 以下の場合に Logic Pro が予期せず終了することがなくなりました。
    • イベントリストでフィールドがハイライトされている間にイベントの複製コマンドを使ったとき。
    • Flex が有効なトラックで Apple Loop の左隅を調整したとき。
    • 大きなプロジェクトでダイナミクスの記号をスコアにドラッグしたとき。
    • 「トランスポート」フローティングウインドウからツールバーをカスタマイズしたとき。
    • Touch Bar で東アジアのスケールから別のスケールに変更したとき。
    • グルーブトラックが有効なプロジェクトで I/O バッファのサイズを変更したとき。
    • Alchemy のプラグインウインドウで「デフォルトとして保存」が選択されているとき。
    • テイクフォルダの中で Flex を操作中に「高速セクションを作成してもよろしいですか?」ダイアログを閉じたとき。
  • Retina ディスプレイでピアノロールが確実に表示されるようになりました。
  • ソロを使用した後でミキサーを閉じてから再び開いたときに、フォルダスタックからトラックが予期せず削除されることがありましたが、この症状が解消しました。

パフォーマンス

  • 「option」キーを押しながらオーディオリージョンの左隅をドラッグしてそのリージョンをタイムストレッチしたときの、インターフェイスの反応がよくなりました。
  • 「プロジェクトオーディオ」ウインドウが開いているときにキーコマンドを使ってリージョンのソロを無効にすると数秒かかることがありましたが、この症状が解消しました。
  • 大きなプロジェクトでプロジェクト・ファイル・ブラウザのパフォーマンスが向上しました。
  • オーディオリージョンの長さをトリミングする際に、再生のタイミングと再生ヘッドの位置が常に維持されるようになりました。
  • Varispeed が有効な間に Apple Loops をタイムストレッチしたときに、Logic Pro が安定して反応し続けます。
  • 再生中に実行した 1 回目の取り消し操作で、再生に若干の不具合が生じることがなくなりました。

Alchemy

  • Alchemy の Magnet Effect の音が確実に調子を合わせて聴こえるようになりました。

プラグイン

  • プロジェクトでサイクルが有効な場合に、「NeedsTimingInfo = True」コマンドで始まるコマンドを含む Scripter インスタンスが原因でノートがハングすることがなくなりました。
  • 「エンバイロメント」ウインドウのミキサーオブジェクトからプラグインを再び開けるようになりました。
  • Audio Unit v3 プラグインのプリセット名が正しく表示されるようになりました。

オートメーション

  • テイクフォルダでリージョンベースのオートメーションを再び編集できるようになりました。

フェード

  • 選択されている複数のオーディオリージョンにフェードアウトが確実に適用されるようになりました。
  • クリックゾーンのフェードツールでフェードをクリックしたときに、その長さが意図せず変更されることがなくなりました。

Flex

  • オーディオ Apple Loops をクオンタイズしても、その長さが変更されることがなくなりました。
  • 既存のテンポ情報があるオーディオファイルが、テンポが違うプロジェクトに追加した場合でも、適切に Flex に従うようになりました。
  • オーディオリージョンをタイムストレッチすると予期せずフェードアウトが作成される場合がありましたが、この症状が解消しました。
  • 「ファイルにオーディオテールを含める」オプションを有効にして所定の場所にバウンスしたオーディオファイルに、「すべての Flex 編集をリセット」コマンドを使った後で再び Flex を適用できます。

テイクとコンピング

  • 選択されている MIDI テイクフォルダを再びフラット化できるようになりました。
  • テイクフォルダのリージョンの開始位置と長さが、オーディオファイルを別のサンプルレートに変換すると併せて変更される場合がありましたが、この症状が解消しました。
  • フォルダスタックの中のテイクフォルダが、「パックを解除して新規代替トラックに」コマンドを使った後で「取り消す」を実行した場合に削除されることがなくなりました。

Touch Bar

  • Touch Bar がオーバービューモードのときに再生ヘッドを移動すると、小節や拍にスナップするようになりました。
  • Touch Bar のオーバービューモードが縦方向にスクロールするようになり、選択されているトラックが表示範囲から外れても、現在表示可能になっているリージョンが表示されるようになりました。
  • Touch Bar で表示される位置が、1 1 1 1 よりも後の位置から始まるプロジェクトでも正確になりました。

代替トラック

  • 「代替トラックを複製」コマンドで作成されたアクティブではない代替トラックのリージョンが、意図せず削除されないように選択解除されるようになりました。
  • アクティブではない代替トラックをアクティブにしたときに、同じグループのメンバーであるほかのトラックの試聴ボタンが予期した通りにクリアされるようになりました。
  • アクティブではない代替トラックを削除しても、選択されているトラックがトラック 1 にシフトしなくなりました。
  • ギター/ベーストラックの代替トラックを作成できるようになりました。
  • 時間をカット/挿入するグローバル編集が、アクティブではない代替トラックにも適用されるようになりました。

スコア

  • スタンドアロンのスコアウインドウに、現在選択中のリージョンが確実に表示されるようになりました。
  • スコアオブジェクトのドラッグ中にスナップのオン/オフを切り替えるスイッチが追加されました。
  • 現在のスコアセットの一部になっている音源トラックを選択しても、「同じレベル」リンクモードが有効なときにスコアセットが変更されなくなりました。

Drummer

  • 代替トラックの Drummer リージョンが、Drummer の特性を変更したときに MIDI リージョンに変換されることがなくなりました。

編集

  • イベントリストで値を簡単にドラッグできるようになりました。
  • ピアノロールのノートをミュートツールでクリックすると、以前と同様に、すぐにノートが消音されるようになりました。
  • ステップエディタでレーンのノート長の値を再び編集できるようになりました。
  • 「イベントフロート」ウインドウで選択されている複数のイベントを再び編集できるようになりました。
  • イベントリストにプログラムチェンジの GM 音源名が再び表示されるようになりました。
  • ピアノロールでハサミツールを使って簡単にノートを分割できるようになりました。
  • MIDI トランスフォームエディタの「選択したイベントに対する操作」マップに、第 2 データバイトに対する操作の結果が再び表示されるようになりました。
  • イベントリストで MIDI コントローラ番号を再び編集できるようになりました。
  • 「追加情報」が有効なときに、以前と同様に、歌詞がイベントリストに直接表示されるようになりました。
  • ピアノロールで、ループした MIDI リージョンに対して、再生ヘッドに従う機能が働くようになりました。

共有

  • iOS 用 GarageBand に送信する機能を使って追加したトラックが、Logic プロジェクトのサンプルレートが 44.1 kHz 以外でも正しく再生されるようになりました。

読み込み

  • アクティブではない代替トラックのテイクフォルダが、トラックをプロジェクトに読み込む際に対象に含まれるようになりました。
  • Track Stack の中にあるトラックを読み込み/置き換えできるようになりました。

App の相互運用性

  • 既存のプロジェクトの ReWire バス番号が 60 に変更されることがなくなりました。
  • Logic Pro の再生ヘッドとロケータが、接続先の ReWire スレーブアプリケーションの位置に再び従うようになりました。

ビデオ

  • プロジェクトのフレームレートを変更しても、SMPTE 開始時刻が予期せずずれることがなくなりました。
  • 「ムービー」フローティングウインドウが開いているときにキーコマンドが確実に機能するようになりました。

コントロールサーフェス/MIDI コントローラ

  • Logic Pro を再起動したときに、Logic Remote でスライダ、パンのノブ、トラック名が確実に更新されるようになりました。
  • Logic のコントロールを使って、サイクル位置を再びシフトできるようになりました。

全般

  • マーキーで範囲を選択しているときに「カット」(command + X) を実行すると、予期した通りに取り消しステップが作成されるようになりました。
  • ウインドウを開き直しても、「移動」ウインドウの新規の位置のフィールドに、最後に入力した位置が再び表示されるようになりました。
  • マーキーツールを使って、以前と同様に、複数のリージョンを分割できます。
  • Varispeed の「速度のみ」が有効で、「低レイテンシーモードを切り替える」がオフのときに、ソフトウェア音源が再び、予期した通りにオーディオを出力するようになりました。
  • ベロシティのオフセットが負の MIDI リージョンでパラメータをノーマライズすると、ベロシティがそのオフセットよりも小さいノートが 1 ではなく 127 に設定されることがなくなりました。
  • ドラッグしたリージョンが、まれに macOS Sierra で間違った位置に移動することがなくなりました。
  • 逆方向にしたオーディオリージョンを短くした後で、その末尾を再び拡張できます。 
  • Varispeed が有効なときに、入力モニタリングが再び機能するようになりました。
  • エイリアスの名前が再び斜体フォントで表示されるようになりました。(英数字のみ)
  • 「プロジェクトオーディオ」ウインドウで「使用されていない項目を選択」コマンドが再び機能するようになりました。
  • リージョンインスペクタのスコアパラメータに、リージョンの表示/隠すのステータスが再び表示されるようになりました。
  • 閉じるボタンを使って、アクティブではない代替トラックを隠すと、取り消しステップが作成されるようになりました。
  • ループした MIDI リージョンでサスティン・ペダル・イベントが適切に実行されるようになりました。
  • Flex リージョンの右下の端をグラブしたときに、ポインタが再び、一貫してループツールに変化するようになりました。 
  • Retina 以外のディスプレイでフォントの見た目が改善されました。
  • Track Stack にパッチの一部として保存された Aux が、そのパッチを読み込んだときに、カスタムで割り当てられた色を再び維持するようになりました。
  • 選択されている複数のオーディオトラックを正常に録音可能/録音不能にできるようになりました。

 

Logic Pro X 10.3

新機能と機能拡張

  • MacBook Pro の Touch Bar に対応しました。
  • 「代替トラック」を使って、トラックのリージョンや編集内容を変えたさまざまなプレイリストを作成し、それらを切り替えることができます。
  • 「選択ベース処理」を使って、エフェクトプラグインを任意に組み合わせてレンダリングし、選択したオーディオに適用できます。
  • 「GarageBand に送信」オプションを使えば、iPhone または iPad から iCloud を利用して、Logic Pro プロジェクトに新しいトラックを追加できます。
  • リージョン編集画面が刷新され、トリミング中にオーディオファイル全体、または未使用の MIDI データの波形が表示されるようになりました。
  • 本格的なステレオパン機能を備え、ステレオ信号をさらに細かく制御し、個別に操作可能になりました。
  • プロジェクトで最大 256 のバスを使えるようになりました。
  • Logic Pro に 64 ビットの集約エンジンが搭載されました。
  • MusicXML ファイルを読み込めます。
  • ステレオトラックにプラグインをステレオまたはデュアルモノとして挿入できます。
  • カラーパレットが新たに 24 色を追加して拡充され、リージョン、トラック、ノートにラベルを付けることができます。
  • 「設定およびコンテンツの複製を使った新規トラック」キーコマンドが追加されました。トラックヘッダで「command」キーを押しながら「設定の複製を使った新規トラック」ボタンをクリックした場合も、同じ操作を実行できます。
  • I/O プラグインに「Mix」コントロールが追加されました。
  • 環境設定ウインドウに新たに「録音」ページが追加されました。このページで、録音が重複する場合や、録音ファイルのタイプ、録音のビット数などの設定ができるようになりました。
  • ロケータを 1 小節分前後に移動するキーコマンドが追加されました。
  • 横方向に自動的に拡大/縮小するためのコントロールが、メインウインドウ、ピアノロール、オーディオ・トラック・エディタ、ステップエディタに新たに追加されました。
  • アレンジメントマーカーを新規作成するキーコマンドが追加されました。
  • 現在選択されている Track Stack、またはすべての Track Stack の開閉用三角ボタンの開閉を切り替えるキーコマンドが追加されました。
  • 新規代替プロジェクトを作成するキーコマンドと、現在の代替バージョンを編集するキーコマンドが追加されました。
  • トラック領域の背景の明るさを調整する環境設定項目が追加されました。
  • 現在選択されているトラックの Track Stack フォルダを閉じるキーコマンドが新たに追加されました。
  • 選択されているリージョンに、最後のフェード編集を適用するキーコマンドとメニューコマンドが新たに追加されました。
  • 最大 30 個のトランスフォーム・ユーザ・プリセットの中から 1 つをキーコマンドを使って適用できるようになりました。
  • 「ムービーリージョンを再生ヘッド位置に移動」コマンドを、コンテクストメニュー項目およびキーコマンドとして使えるようになりました。
  • インパルスレスポンスユーティリティで IR を作成する際にサンプルレートを設定できるようになりました。
  • 「エイリアスとして繰り返す」キーコマンドが追加されました。
  • ディスク容量管理が、macOS Sierra で完全にサポートされるようになりました。
  • 「ムービーを Finder に表示」キーコマンドが追加されました。
  • スコアウインドウに「全音階でイベント入力」キーコマンドが追加されました。
  • 「デフォルトのクロスフェードを適用」キーコマンドが追加されました。
  • MIDI トラックで置き換えモードで録音する際に、MIDI リージョンを置き換えるのか、既存のリージョン内のコンテンツだけを置き換えるのかを選択するオプションが、環境設定の「録音が重複する場合」に追加されました。

安定性と信頼性

  • 以下の場合に Logic Pro が予期せず終了することがなくなりました。
    • 開いている 2 つのプロジェクトを切り替えたとき。
    • プラグインマネージャからカテゴリをすべて削除したとき。
    • MIDI テイクフォルダ内で同じループファミリから違う Apple Loop を選択し、そのテイクフォルダをフラット化したとき。
    • 圧縮されたオーディオファイルをトラックに追加したとき。
    • フルスクリーンモードの間にプロジェクトを閉じたとき。
  • 30 分以上の曲に対して「Drummer リージョンから作成」コマンドを実行しても、Logic Pro が停止しなくなりました。
  • Alchemy の「SOURCES」>「オーディオを読み込む」ポップアップメニューから、マウントされたドライブを選択したときに、Logic Pro が反応しなくなることがありましたが、この症状が解消されました。

パフォーマンス

  • ミキサーでトラックを録音可能にしたときに若干の遅延が生じる場合がありましたが、この症状が解消されました。
  • 圧縮したオーディオファイルを使った EXS インストゥルメントの読み込みが格段と速くなりました。
  • Logic Pro を終了する際に時間がかからなくなりました。
  • Logic Pro で、MacBook Pro (Late 2016) に搭載されている最大コア数に「処理スレッド数」を適切に設定できるようになりました。
  • 再生中にマーカーを移動しても、オーディオ出力でクリック音が生じることがなくなりました。
  • 大量のリージョンが使われた大規模プロジェクトで、スクロールの性能が向上しました。
  • 上向きまたは下向きの矢印キーを使って前または次のトラックを選択した際に、オートメーション表示が有効になっていても低速化しなくなりました。

Alchemy

  • Alchemy の LFO 波形表示が、LFO プリセットを読み込んだ後で適切に更新されるようになりました。
  • Alchemy の Mod Map を「Y Snap」を有効にして 1/12 に設定した場合に、ノードが 1/12 単位で正確にスナップするようになりました。
  • Alchemy で、サンプルを Sample モードでソース A に読み込んでから、同じサンプルをソース B、C、または D に Granular モードで読み込んだ場合に、ソース A を無効にしても、ほかのソースの位置が 0 から動かなくなることがなくなりました。
  • パフォーマンスコントロールの下のテキストを編集する際は、ダブルクリックが必要になりました。
  • Alchemy ソースにオーディオを読み込むために最後に使われたフォルダが、「ファイル」>「消去」コマンドが使われた後も記憶されるようになりました。
  • Alchemy のパフォーマンスコントロールの「Auto-assign」を右クリックして、確実にそのコントロールだけを割り当てられるようになりました。
  • 複数の Alchemy プリセットのチューニングが改善されました。
  • Alchemy でカーブした ADSHR セグメントを「option」キーを押しながらクリックすると、コントロールセグメントに即座に反映され、リニアの Decay ステージの音が聞こえるようになります。
  • Alchemy の Arpeggiator パターンノブの周りにあるポストモジュレーションのフィードバックリングが、手動で調整された後も更新され続けるようになりました。
  • モジュレーションホイールを割り当てて Alchemy でパラメータを制御する場合に、パフォーマンスセクションでそのモジュレーションホイールの割り当てが解除されることがなくなりました。
  • Alchemy のスペクトルエディタで、ソースごとに別々の取り消しステップが保存されるようになり、取り消しステップがない場合は、「取り消す」ボタンがグレイ表示されるようになりました。
  • VA オシレータの波形を切り替え中に Alchemy でノートをホールドした場合に、引き続き想定した通りのサウンドが鳴るようになりました。
  • Alchemy で Source、Master、Multimode フィルタのオプションとして「Downsample」を使えるようになりました。
  • Alchemy のエンベロープエディタでポイントを変更すると、「Partials」表示が適切に更新されるようになりました。
  • Alchemy Arpeggiator に「Input Snap」設定が追加され、Logic Pro の実行中に、受信した MIDI ノートを所定のレートにクオンタイズしてくれます。
  • 外部コントローラを使って Alchemy の AHDSR を調整している場合、カーブの見た目がプラグインですぐに更新されるようになりました。
  • MIDI ファイルの Alchemy Arpeggiator への読み込みが改善されました。
  • プラグインのファイルの読み込みメニューから、Alchemy の .acp ファイルを再び読み込めるようになりました。
  • Alchemy で 1 回クリックするだけで、ADSR のパフォーマンスコントロールをすべて同じエンベロープに自動割り当てできるようになりました。
  • グレインサイズを 1 ms 未満の単位で調整する際に、値が表示されるようになりました。
  • Alchemy が、チャンネルプレッシャーやポリフォニックプレッシャーに常に反応するようになりました。
  • パッチを読み込んだ後で「取り消す」を実行しても、プロジェクトを前回保存したときから変更されている Alchemy のインスタンスが、保存時の状態や、プロジェクトが一度も保存されたことのないデフォルトの状態に予期せずリセットされることがなくなりました。
  • Alchemy に読み込んだ Apple Loops の音質が改善されました。
  • Alchemy の LFO 選択メニューに、LFO 番号と、現在構成されている波形が表示されるようになりました。
  • Alchemy のインスタンスで最初のノートを演奏する際に CPU の使用量が急増することがなくなりました。
  • 自動保存が Alchemy で正常に働くようになりました。
  • Alchemy のブラウザプリセットリストに、スクロールバーが常にシンプルモードで表示されるようになりました。
  • AAZ ファイルを使うプリセットが Alchemy にすばやく読み込まれるようになりました。
  • 半音値で動作するコントロールに割り当てた Alchemy の Mod Map が、デフォルトで、調整時に半音 1 個分ずつスナップしていくようになりました。
  • Additive Magnetic エフェクトを適用した Alchemy サウンドを「Key Follow」でモジュレートした場合に、再生したときに確実にチューニングが合うようになりました。
  • ソースメニューから VA 波形を変更したときに、ソースに複数のグループが含まれている場合に、グループが適切にリセットされるようになりました。
  • フォルマント解析で、44.1 kHz 以外のサンプルレートのサンプルで良好な結果が得られるようになりました。
  • Logic Pro のクイックヘルプシステムが Alchemy で機能するようになりました。
  • Alchemy で「Add FX」または「Spec FX」というラベルの付いたコントロールが、「Learn」ページで MIDI 演奏に反応するようになりました。

アクセシビリティ

  • Voiceover が有効な場合、プラグインがデフォルトでコントロール表示で開きます。
  • タイムラインが「時間:分:秒.サンプル」と「SMPTE/EBU (サンプル付き)」を表示する設定になっているときに、VoiceOver が再生ヘッドの位置を正確に読み上げてくれるようになりました。
  • オーディオ・トラック・エディタのピッチ補正スライダが、VoiceOver で読み上げられるようになりました。
  • オーディオ・トラック・エディタのクオンタイズの強さスライダが、VoiceOver で読み上げられるようになりました。
  • オーディオ・トラック・エディタのトランスポーズスライダが、VoiceOver で読み上げられるようになりました。
  • コントロール表示で Alchemy パラメータへのアクセシビリティが改善されました。

オートメーション

  • リージョンベースのオートメーションを Apple Loops に書き込めるようになりました。
  • SMPTE ロックが、リージョンベースのオートメーションイベントに適用されるようになりました。
  • 「無音を挿入」コマンドを使用したときに、挿入した領域の右側のオートメーションが、環境設定で「オートメーションを移動」が「しない」に設定されていても、適切に移動するようになりました。
  • 2 つのリージョンを結合したときに、最初のリージョンの MIDI ドローノードが、そのリージョンの最初のノードがリージョンの開始位置より前になっていても除去されなくなりました。
  • ピッチ・ベンド・イベントを削除すると、関連付けられている補間済みのピッチ・ベンド・イベントがすべて確実に削除されるようになりました。
  • MIDI ドロー CC ノードがあるリージョンを分割または結合すると、余計な CC イベントが予期せず作成されることがありましたが、作成されなくなりました。
  • オートメーション表示が有効になっていて、MIDI の録音中にフェーダーを移動した場合に、不要な一時リージョンが作成されることがなくなりました。
  • センドのオンとオフを自動化できるようになりました。
  • オートメーションノードをリージョン境界に作成するコマンドが、アクティブなトラックグループのすべてのリージョンに適用されるようになりました。
  • 複数のトラックにわたるオートメーションをゴムバンドで選択できるようになりました。
  • プラグインをバイパスするトラックオートメーションが、そのプラグインが別のスロットに移動した後も正常に機能し続けるようになりました
  • スコアの MIDI ドローで、別の MIDI チャンネルのイベントを使ったリージョンが適切に処理されるようになりました。

Drummer

  • Track Stack に Drummer トラックが入っているときに、「従う」機能を設定し、Drummer トラックが Stack 内のほかのトラックに従うようにすることができます。
  • MIDI リージョンを Drummer トラックにドラッグしてから「取り消す」を実行すると、削除された Drummer リージョンが復元され、MIDI リージョンが元の位置に移動するようになりました。
  • MIDI リージョンが従っている Drummer リージョンが、Drummer の特性を切り替えたときに正確に再生成されるようになりました。
  • ドラムまたはパーカッション以外のループを Drummer トラックにドラッグすることはできなくなりました。
  • Drummer リージョンで境界ツールを使えるようになりました。
  • Drum Machine Designer パッドのアイコン表示を無効にできるようになりました。
  • Drummer リージョンのキックとスネアのパターンを調整したときに、編集されているリージョンのコピーであるリージョンに影響しなくなりました。 
  • ハーフタイムのキックとスネアパターンが選択されているときに、エレクトロニックな Drummer に対してスウィングが正しく計算されるようになりました。
  • アコースティックな Drummer トラック用に Producer Kit を読み込んである場合に、Drummer の特性を変更すると、その特性に対応する Producer Kit が読み込まれます。

Flex

  • Flex Pitch が改善され、ノートをパーフェクトピッチに設定したときに問題が起こりにくくなりました。
  • サンプルレートが 44.1 kHz より高いプロジェクトの Apple Loops が、該当するトラックで Flex が有効になっているときに、正しい速度で再生されるようになりました。
  • Flex Pitch が有効になっている場合にオーディオエディタで「フォルマントシフト」コントロールを「option」キーを押しながらクリックすると、その値が適切に 0 に設定されるようになりました。
  • Flex Pitch の「パーフェクトピッチに設定」コマンドが、選択されているすべてのリージョンに対して作用するようになりました。
  • Apple Loops のトランジェントがオーディオ・ファイル・エディタで正しく計算され、表示されるようになりました。 
  • Apple Loops でトランジェントを編集した後で、「取り消す」が正常に機能するようになりました。

テイクとコンピング

  • テイクフォルダを接着できるようになりました。
  • 開いているテイクフォルダのリージョンに対し、フェードツールが機能するようになりました。
  • コンプが含まれていないテイクフォルダを右クリックしたときに、フォルダ内のテイクごとに 1 つだけリストが表示されるようになりました。
  • フェーズロックされた編集グループのすべてのトラックが、連続していない複数のコンプセグメントに編集が及ぶ場合に、コンプの編集に正しく従うようになりました。
  • テイクフォルダのパックを解除してできたリージョンに、正しい名前が付くようになりました。
  • テイクリージョンをコピーアンドペーストできるようになりました。
  • 「録音結果を取り込む」でテイクフォルダが適切に作成されるようになりました (「録音」環境設定で MIDI についてそのように設定されていた場合)。
  • リージョンインスペクタで、テイクリージョンが選択されているときに、機能しない「ミュート」チェックボックスが表示されることがなくなりました。
  • テイクリージョンを「option」キーを押しながらマーキーツールでクリックしたときに、適切に選択されるようになりました。
  • 再生中に「新規コンプを作成」キーコマンドを適用しても、トラックの出力が消音にならなくなりました。
  • テイクフォルダに対して、メニュー項目から「フラット化」を選択した場合に、選択されているほかのすべてのテイクフォルダに対しても同様の処理が実行されるようになりました。
  • 環境設定の「録音」>「テイクフォルダを作成」が有効になっていて、オーディオの録音中に MIDI が送信された場合に、新しいトラックが作成されることがありましたが、作成されなくなりました。

Track Stack

  • デフォルトの名前のオーディオ・チャンネル・ストリップを含む Track Stack を複製したときに、複製元と同じデフォルトの名前で Track Stack チャンネルストリップが作成されることがなくなりました。
  • 選択されている Track Stack を「command」キーを押しながらクリックすると、その Stack 内のすべてのトラックの選択が解除されるようになりました。
  • 閉じている Track Stack を「shift」キーを押しながらクリックすると、その中のサブトラックがすべて確実に選択されるようになりました。

プラグイン

  • プラグインのサイドチェーンメニューに、チャンネルセンドの場合と同様に、バスのルーティング情報がすべて表示されるようになりました。
  • Stereo Delay の「Feedback」値が、「Routing」が「Straight」から別のプリセットに変更され、「Straight」に戻された場合に、適切に維持されるようになりました。
  • Smart Control に割り当てられた MIDI ハードウェアコントローラでパラメータが変更されたときに、プラグインの「比較」ボタンが有効になるようになりました。
  • 再生中に Exciter プラグインでパラメータを変更したときに、オーディオに問題が起きることがなくなりました。
  • SUM に設定された Compressor のサイドチェーンを通る信号のレベルが正しくなりました。
  • Audio Unit プラグインウインドウが、画面の特定の位置で固定される場合がありましたが、この症状が解消されました。
  • プラグインがレイテンシを生む場合に、そのプラグインスロットの上にポインタを置いたときに表示されるヘルプタグに、プラグインが生じるレイテンシの量が表示されます。
  • 外部のモジュレーションホイールイベントが原因で、Vintage Organ インストゥルメントでモーフィングモードのときに予期せずパーカッションの再トリガが起きる場合がありましたが、この症状が解消されました。
  • Scripter プラグインで ProcessMIDI() 関数のタイミングが改善されました。
  • マルチ出力の Audio Unit インストゥルメントが複数のモノラル Aux に出力される設定になっている場合に、出力 2 がスキップされなくなりました。
  • Ultrabeat の読み込みシートからインストゥルメントスロットにボイスをドラッグすると、読み込んだボイスの名前がスロットに表示されるようになりました。
  • Multimeter および Level Meter のピーク値が、「True Peak」から「RMS」モードに切り替えた後も適切に表示されるようになりました。
  • Phaser プラグインのモノラルインスタンスで、フェーズノブが適切にグレイ表示されるようになりました。
  • モノラルとサラウンドの両方に対応した Audio Unit ソフトウェアインストゥルメントが、マルチモノインストゥルメントとして読み込まれるようになりました。
  • マルチチャンネルの Gain プラグインと BPM Counter プラグインのユーザインターフェイスが刷新されました。
  • Modifier MIDI プラグインでプログラム・チェンジ・メッセージが処理されるようになりました。
  • macOS Sierra で Vintage Clav プラグインのエフェクトを並べ替えると、エフェクトのタイルが重なる場合がありましたが、この症状が解消されました。
  • EXS インストゥルメントエディタでグループの「Dcy」チェックボックスの選択を解除すると、「トリガ」=「キーリリース」の場合に、そのグループのディケイが無効になります。
  • MIDI プラグインで、同じチャンネルストリップのオートメーション可能なプラグインパラメータをリモートコントロールできるようになりました。
  • Arpeggiator スクリプトを使う Scripter インスタンスが、適切に、所定の場所にバウンスされるようになりました。
  • 最近使ったプラグインが最大 5 個まで、プラグインメニューの上部のリストに表示されるようになりました。
  • Arpeggiator プラグインで「Add Temporarily」モードの間に「Latch」ボタンを制御するときに、サスティンペダルが一貫して機能するようになりました。
  • Arpeggiator で、アルペジオで演奏したものではなく、ソース素材からリージョンを作成するオプションが追加されました。
  • Bass Amp Designer プラグインのインスタンスを含むパッチを読み込むと、ポップ音がすることがありましたが、この症状が解消されました。
  • プラグインマネージャでプラグインの名前を変更した場合、そのプラグインの上にポインタを置くと、ヘルプタグに編集後のプラグイン名が表示されるようになりました。
  • I/O プラグインのステレオバージョンに、中央/サイドシグナルを送受信するオプションが追加されました。
  • EFM1 インストゥルメントプラグインでピッチベンドの範囲を調整可能になりました。
  • Modulator MIDI プラグインで 1/128 LFO レートを扱えるようになりました。
  • パッチの読み込みを取り消しても、ほかの Kontakt インストゥルメントのサンプルが予期せず再読み込みされることがなくなりました。
  • サンプルレートを変更すると、Flanger、Chorus、Vintage Clavinet、Retrosynth、Pedalboard Chorus、Flanger プラグインのサウンドが予期せず変更される場合がありましたが、この症状が解消されました。
  • プラグインマネージャで、ほかと重複するカスタムのプラグイン名を付けることができなくなりました。
  • トラックに割り当てられているソフトウェア音源プラグインを変更しても、そのトラックのコントローラデータが削除されることがなくなりました。
  • Space Designer で、Logic 9 でカスタムの場所に保存したプラグインプリセットファイルを再び読み込めるようになりました。
  • Logic Pro で録音中に挿入したプラグインが、録音が停止しても機能するようになりました。
  • Scripter プラグインのフェーダーイベントで制御されているプラグインパラメータが、チャンネルストリップ内でのプラグインの順序が変更されたり、新しいプラグインが挿入されたりしても、機能し続けるようになりました。
  • プラグインマネージャでカテゴリの名前を変更しても、そのカテゴリがリストの一番下に予期せず移動することがなくなりました。
  • Vintage B3 Organ の「Split」表示で「Multi」に設定されている鍵盤が、表示が「Presets」や「Controls」に切り替わってから「Split」に戻っても、設定を維持するようになりました。
  • Delay Designer のグリッドが、同じプラグインのインスタンスが 2 度目に開いたときも表示されたままになります。
  • 他社製の Audio Unit プラグインで、コントロール表示にメーターが適切に表示されるようになりました。
  • 他社製の Audio Unit プラグインで、コントロール表示でのパラメータ値の入力が確実に処理されるようになりました。
  • Amp Designer の「Mic Position」を、位置の表示が間違って閉じたりすることなく、簡単に調整できるようになりました。
  • Vintage Clav で、Plectratone、Dulcitone、Belltone モードのときにサスティンペダルが適切に機能するようになりました。
  • RetroSynth または MIDI Modulator の ENV 表示でスクラバーを使って「Attack」「Hold」「Release」タイムを調整すると、ディスプレイのエンベロープポイントが確実に更新されるようになりました。
  • Modulation Delay で「Constant Mod」を有効にしても、「Delay」と「Modulation」の設定が上がることがなくなりました。
  • Logic Pro X が Audio Unit v3 プラグインに対応しました。

ミキサー

  • 「次のチャンネルを使った新規トラック」コマンドが、現在選択されているトラックの入力設定を維持するようになりました。 
  • ミキサーとトラックヘッダのサラウンド・チャンネル・ストリップのレベルメーターが、ステレオリージョンの再生時に動かなくなることがなくなりました。
  • Aux にルーティングされている複数のトラックから Track Stack を作成し、その Aux がすでに 1 つのトラックに割り当てられている場合に、既存の Aux へのルーティングが適切に維持されるようになりました。
  • 集約スタックのサブトラックの出力がスタックの外部にルーティングされている場合、その集約スタックをコピーしたときに、サブスタックのルーティングが適切に複製されます。
  • 以前のように、ミキサーで 1 つのフォルダチャンネルを選択できるようになりました。
  • トラックヘッダで「+」ボタンをクリックして集約スタックの内側に作成したトラックが、集約バスに正しくルーティングされるようになりました。
  • チャンネルストリップのプラグインだけ、またはセンドだけをコピー/ペーストできるようになりました。
  • ミキサー・チャンネル・ストリップを「control」キーを押しながらクリックしても、選択されている複数のチャンネルストリップの選択が予期せず解除されることがなくなりました。
  • 「センド」スロットや「出力」スロットをクリックしたときに、バスの番号ではなく名前がリストに表示されるようになりました。
  • 「センド」メニューや「出力」メニューのバスのラベルに、割り当てられたルーティングが表示されるようになりました。
  • Track Stack のルーティングに使われているバスがグループ化され、Stack の名前のラベルが付いたサブメニューに表示されるようになりました。
  • 複数のチャンネルストリップが選択されているときに、1 つのチャンネルのフェーダーやコントロールを「option」キーを押しながらクリックすると、選択されているすべてのチャンネルでそのコントロールがデフォルトの状態に設定されます。
  • すべてのトラックがすでに既存の VCA に割り当てられているときに、新しい VCA を作成できるようになりました。
  • 複数のチャンネルストリップがミキサーで選択されていて、トラックリストでは 1 つしか選択されていない場合に、トラックヘッダまたはチャンネルストリップのインスペクタでコントロールを調整すると、選択されているトラックにだけ作用します。ミキサーでコントロールを調整すると、そこで選択されているすべてのチャンネルストリップに作用します。
  • パッチライブラリが開いている間にサラウンド・オーディオ・トラックを作成したときに、モノラルシグナルパスが作成されなくなりました。
  • ミキサーでチャンネルストリップの下部をゴムバンド選択しやすくなり、フェーダーが誤って動くことがなくなりました。
  • ソフトウェア音源を「サイドチェーン」の入力として直接使えるようになりました。
  • サラウンド・チャンネル・ストリップから作成された Aux がサラウンドとして構成されるようになりました。
  • チャンネルストリップの入力をバスに割り当てるときに、すでに割り当てられているバスのラベルが一貫して表示されるようになりました。

グローバルトラック

  • 「スニップされたセクションを再生ヘッド位置に挿入」コマンドで、挿入されたセクションの後のキーが、そのセクションに別のキーが含まれている場合でも適切に維持されるようになりました。
  • ビート・マッピング・トラックのトランジェントが、オーディオファイル内のアンカー位置が変更された後も、正しい位置に表示されるようになりました。
  • テンポトラックで「平均で置き換える」コマンドをキーコマンドに割り当てることができます。
  • 整数以外の値が指定されたテンポイベントが、別の時間位置に移動されたときに整数値に丸められることがなくなりました。
  • 接着ツールがアレンジメントマーカーで機能するようになりました。
  • LCD で拍子を編集すると、現在の再生ヘッドの位置に新しい拍子が追加される代わりに、現在の拍子が変更されるようになりました。
  • ビート・マッピング・トラックが、オーディオリージョンのアンカー位置が変更された時点ですぐに更新されるようになりました。
  • グルーブにマッチしたトラックが、アレンジメントマーカーが移動したときに、それぞれのクオンタイズを確実に維持するようになりました。
  • 「後続のものすべてを選択」コマンドが、現在の選択範囲に続くテンポイベントだけを確実に選択するようになりました。
  • 拍子の変更が、ピアノロールやオーディオ・トラック・エディタで適切に表示されるようになりました。
  • マーカーセットをグローバルトラックの「マーカーセット」メニューから以前と同様に削除できるようになりました。
  • マーカーが誤って作成されることが極力ないように、アクティブなサイクルを下方向にバールーラの下半分までドラッグしてマーカーを作成する機能を使う際は、サイクル範囲の中から操作を始めることが必須になりました。 
  • 縦方向に拡大/縮小の倍率が低い場合に、グローバルトラックからキー/拍子エディタを開けるようになりました。
  • 以前と同様に、テンポトラックで複数のポイントをゴムバンドで選択して、新しい位置までドラッグまたはコピーできるようになりました。
  • 「すべてを選択」で、開いているグローバルトラックのすべてのイベントが対象になりました。
  • LCD で拍子を変更すると、以前と同様に、現在の再生ヘッドの位置を含む小節に新しい拍子が挿入されるようになりました。

編集

  • 「後続のものすべてを選択」コマンドをエディタで使ったときに、マーカーが予期せず選択されることがなくなりました。
  • 「MIDI」>「アーティキュレーション ID で分離」コマンドで、分離後のトラックにアーティキュレーション ID に基づいて名前が付けられるようになりました (名前を利用できる場合)。
  • 「録音として取り込む」コマンドを使って既存のリージョンに MIDI 録音を結合した場合に、結合後のリージョンの選択が解除されなくなりました。
  • ピアノロールで SMPTE ロックされたイベントのロックを再び解除できるようになりました。
  • ピアノロールで MIDI ドローデータを追加すると、クリックした位置ではなく、再生ヘッドの位置に新しいポイントが配置されることがありましたが、この症状が解消されました。
  • 「繰り返す」機能が、マーキーの選択範囲と、ピアノロールのタイムハンドルに対して使えるようになりました。
  • 選択されているリージョンの境界内に再生ヘッドがある場合、コンテンツのリンクモードが有効になっているピアノロール領域またはウインドウで、再生ヘッドの周りの領域が常に表示されます。
  • 再生ヘッドから離れたリージョンが選択されているため、ピアノロールで「再生ヘッドの位置をキャッチ」がオフになっている場合、再生ヘッドの範囲内のリージョンが選択されたら自動的にオンに戻るようになりました。
  • ピアノロールでクオンタイズの「強さ」または「スウィング」のスライダをクリックしただけで動かしていない場合に、MIDI データが、クオンタイズ後の位置にジャンプすることがなくなりました。
  • ピアノロールで鉛筆ツールを使って作成したノートが、以前に作成したノートの MIDI チャンネルに一致するようになりました。
  • ドラム名を表示した状態でサイクルモードでの録音を切り替えるときに、ピアノロールが予期せず縦にスクロールすることがなくなりました。
  • ロックされたトラックとロック解除されたトラックの両方のリージョンがピアノロールで表示されている場合に、ロック解除されたトラックのノートを調整しても、「このトラックは保護されているため、変更できません」というエラーが表示されなくなりました。
  • 「リンク」ボタンが無効になっている場合、ピアノロール表示が録音中に正常に動作するようになりました。
  • 録音後にピアノロールが開いている場合、表示の位置と倍率が自動的に調整され、録音後のコンテンツが表示されるようになりました。
  • 「時間の表示形式」が「SMPTE/EBU (サンプル付き)」に設定されていて、イベントリストが位置と長さを時間で表示するように設定されている場合に、イベントリストで位置と長さをサンプル単位で調整できるようになりました。
  • イベントリストで SMPTE ロックされたノートにクオンタイズを適用した場合に、そのノートの位置や長さが予期せずずれることがなくなりました。
  • イベントリストで選択されている複数のリージョンの開始時間を設定したときに、その開始時間が正しく設定されるようになりました。
  • 「shift + option」キーを使って、選択されている複数のイベントをイベントリストで同じ値に設定できるようになりました。
  • 「+」キーまたは「-」キーを使って編集し、イベントリストで最後にクリックした値を調整したときに、正しいフィールドに確実に作用するようになりました。
  • イベントリストにイベントの位置と長さを時間で表示するように設定されている場合に、「イベントフロート」ウインドウに、SMPTE タイムが表示されるようになりました。
  • 「イベントフロート」ウインドウが開いている場合に、ほかの領域を対象としたキーコマンドが正常に機能するようになりました。
  • テキストツールが、オーディオ・ファイル・エディタの「Flex Pitch」表示で機能するようになりました。
  • 「プロジェクトオーディオ」ウインドウで開閉用三角ボタンを使ってグループを閉じたときに、そのグループ内のすべてのオーディオファイルの開閉用三角ボタンが閉じることがなくなりました。
  • ステップエディタの一番下のレーンの下を始点として、ゴムバンド選択ができるようになりました。
  • ステップエディタで選択されているイベントの数を表示するカウンタが、選択対象が変更された時点ですぐに更新されるようになりました。
  • ステップエディタの自動レーンセットがすべてのテンプレートで使えるようになりました。
  • オーディオ・トラック・エディタのリージョンヘッダに、選択されているトラックのリージョンだけが確実に表示されるようになりました。
  • マルチインストゥルメントでパッチを選択したときに、現在選択されているバンクのパッチ名が適切に表示されるようになりました。
  • 「全オブジェクト」エンバイロメントレイヤーにオブジェクトを作成できなくなりました。この方法で作成したオブジェクトは機能しない場合がありました。

書き出し/レンダリング

  • プラグインのサイドチェーン設定の効果が、トラックを所定の場所にバウンスしたときに、結果に正しく作用するようになりました。
  • マルチチャンネルのソフトウェア音源をバウンスすると、バウンスのソースリージョンがすべて適切に消音になります。
  • プロジェクトを MIDI ファイルとして書き出す際に、エイリアスリージョンとループも対象になります。
  • 「選択範囲を MIDI ファイルとして書き出す」が、現在のセッションで最後に使われた書き出し先を記憶するようになりました。
  • Logic Pro で Final Cut Pro XML バージョン 1.5 ファイルを書き出せるようになりました。
  • Logic Pro で、PCM バウンスオプションが 16 ビットに設定されている場合、16 ビットの Apple ロスレスファイルが作成されます。
  • 1 1 1 1 以外の位置から始まるプロジェクトのセクションを書き出す場合に、正しいセクションが書き出されるようになりました。
  • リージョンから Apple Loop を作成した際に、プロジェクトの「バウンス」ダイアログの「ノーマライズ」設定が予期せず無効になることがなくなりました。
  • MusicXML ファイルの書き出しに関していくつか機能強化が施されています。
  • ステレオ・オーディオ・デバイスが有効なときにサラウンドミックスをバウンスすると、サラウンドバウンスが実現します。
  • 「所定の場所にバウンス」で新しいトラックにバウンスすると、新たに作成されたトラックに、オリジナルと同じ VCA の割り当てが含まれるようになりました。
  • 選択範囲をオーディオファイルとして書き出すオプションが追加されました。
  • 無音部分を含むバウンスに、無音部の開始位置に大きなクリック音が入ることがありましたが、この症状が解消されました。
  • Apple Loops を CAF ファイルに変換できるようになりました。
  • Aux を使うマルチ出力音源を書き出した場合に、Aux からの信号が音源のメイントラックに予期せず追加されることがなくなりました。
  • バウンスしたリージョンが、ユーザが作成した名前を確実に維持するようになり、トラックに追加された場合は、そのトラックにリージョンにちなんだ名前が適切に付けられるようになりました。
  • トラック、リージョン、または選択範囲をオーディオファイルとして書き出す場合に、新しい各種オプションを使ってカスタムファイル名を設定できるようになりました。

読み込み

  • Logic Pro で直接開いた MIDI ファイルの拍子が LCD に正しく表示されるようになりました。
  • MIDI ファイルを新しい Logic Pro プロジェクトとして開いた場合に、MIDI ファイルの拍子の情報が含まれるようになりました。
  • B フォーマットのサラウンドファイルをインパルスレスポンスユーティリティにドラッグアンドドロップできます。
  • Logic Pro に Final Cut Pro XML バージョン 1.6 ファイルを読み込むことができます。
  • PCM に自動変換される圧縮オーディオファイルは、録音ファイルのタイプに変換されます。
  • Logic Pro で、名前に特殊文字が使われたトラックを含む AAF ファイルや OMF ファイルを適切に処理できます。
  • 44.1 kHz 超のサンプルレートでプロジェクトに読み込まれた Music Memos ファイルを、プロジェクトのサンプルレートに変換できるようになりました。
  • 再生中にほかのプロジェクトからトラックを読み込んだ場合に、オーディオトラックがサウンドの出力を停止することがなくなりました。
  • 大きな FCPX XML ファイルを読み込む際に、Logic Pro に進行状況バーが表示されるようになりました。
  • 複数のアセットが不足している FCPX XML ファイルを読み込んだ場合に、見つからないファイルをすべてスキップするオプションを使えるようになりました。
  • 読み込んだ FCPX XML ファイルに、多数の不要なトラックが入ることがありましたが、この症状が解消されました。
  • 以前の Logic Pro バージョンからの .LSO ファイルの変換が強化されました。
  • Pro Tools から書き出したオーディオファイルにテンポ情報を書き込んだときに、ホワイトノイズが突然発生することがなくなりました。

スコア

  • すべての五線譜のスコア記号のメタイベントが、「声部を分けて表示」で表示されるようになりました。
  • スコアでノートに色を割り当てるコンテクストメニューに、実際の色とその名前が表示されるようになりました。
  • 複数のスコアセットを同時に選択できるようになりました。
  • 以前と同様に、スコアでコードシンボルから拡張を削除できるようになりました。
  • スコアエディタで、コードシンボルの変更について「取り消す」を使えるようになりました。
  • MIDI テイクで鉛筆を使ってスコアに挿入したノートが、スコアトラック表示にすぐに表示されるようになりました。
  • 手動で取り消した改段が、拡大/縮小の倍率を変更しても維持されるようになりました。
  • トラックの最終リージョンの末尾に「改行なし」オブジェクトが配置されている場合に、そのリージョンのページ表示で、リージョンの末尾からプロジェクトの末尾まで、譜表なしの予期しない余分な括弧が表示されることがなくなりました。
  • 選択されている複数のリージョンに「shift」キーを押しながらスコア記号をドラッグして挿入できるようになりました。
  • インディペンデント音符と装飾音符を、音部記号の変更後の最初の非インディペンデント音符と同じ位置に挿入した場合、インディペンデント音符が音部記号の影響を受けるようになります。
  • 矢印キーを使って選択範囲を変更した場合に、スコアにすぐに反映されるようになりました。
  • リニア表示に設定されたスコアウインドウで再生ヘッドをドラッグしたときに、適切にルーラにスナップするようになりました。
  • スコアに記号をドラッグする際に、既存の記号と縦位置が揃ったときにガイドラインが表示されるようになりました。
  • コードグリッドをスコアにドラッグする際に、正しいサイズで表示されるようになりました。
  • 「スコア」プロジェクト設定の「拍子:すべてを隠す」が適切に機能し、ユーザが作成した拍子が非表示になるようになりました。
  • スコアでテキストや歌詞を右クリックすると、コンテクストメニューが開き、テキストの整列、フォントの調整、テキストスタイルの設定といったオプションが表示されます。 
  • スコア・セット・ウインドウでインストゥルメントを新しい位置にドラッグできるようになりました。
  • ページ表示で倍率が 150 % 以上のときに、拍子の表示サイズが大きくなりすぎることがなくなりました。
  • スコアウインドウに、まれに予期しない重複キーが表示される場合がありましたが、この症状が解消されました。
  • 譜線の末尾の右側に、慣例のキー変更が表示されることがありましたが、表示されなくなりました。
  • 手動で挿入した音部記号が、譜線の末尾の右側に表示されることがありましたが、表示されなくなりました。

コントロールサーフェス/MIDI ハードウェア

  • EuCon コントロールサーフェスのフェーダーやボタンが、Logic Pro の終了時に適切に更新されるようになりました。
  • コントロールサーフェスのインストールウインドウに、サポートされている MIDI ハードウェアコントローラが表示されるようになりました。
  • Arturia KeyLab 25 がサポート対象の MIDI ハードウェアデバイスとなりました。
  • Logic Remote で、MIDI Arpeggiator、EFM1、ES1、ES2、EXS24 プラグインの以前は欠損していたパラメータにアクセスできるようになりました。
  • Logic Remote に、EFM1 の「MIDI Mono Mode」と「Pitch Bend Range」用のコントロールが表示されるようになりました。
  • Logic Remote に、ES1 の「MIDI Mode」と「Filter Boost」用のコントロールが表示されるようになりました。
  • Logic Remote に、ES2 の「MIDI Mono Mode」と「Pitch Range」用のコントロールが表示されるようになりました。
  • Logic Remote に、「MIDI Mono Mode」「Pitch Range」「LFO Triangle Shape」「Prev/Next Instrument」用のコントロールが表示されるようになりました。
  • Logic Remote のトラック選択の矢印が、Logic Pro でトラックが新しい位置にドラッグされたときに適切に更新されるようになりました。
  • Logic Pro で保存ダイアログがすでに開いているときに Logic Remote で「別名で保存」を押しても、不要な保存ダイアログがいくつも開くことがなくなりました。
  • Logic Remote でステレオ出力のチャンネルストリップを選択した場合に、Logic Pro で予期しないトラックが選択されることがなくなりました。

ビデオ

  • ビデオウインドウのサイズをヘッダをダブルクリックして自動変更できるようになりました。
  • ムービーサムネールをクリックしたまま長押しすると、ムービーの位置が表示されるようになりました。
  • AAC フォーマットを選択した場合の「オーディオをムービーに書き出す」が、初回の書き出し後も確実に機能するようになりました。
  • MPEG2 または AC3 でエンコードされたオーディオトラックを使ったムービーを Logic Pro プロジェクトに再び読み込めるようになりました。
  • サイクルが有効な場合に置き換えモードで手動でパンチイン/アウトすると、既存のリージョンが適切に消去されるようになりました。

同期

  • Logic Pro が低レイテンシモードの場合に、MIDI クロックが正確な時刻で送信されるようになりました。

MIDI

  • フィジカルインプットに MIDI 入力ポートが 65 個以上ある場合に、ポート 65 以上に着信する MIDI が間違ってポート 1 以上にルーティングされることがなくなりました。
  • MIDI を外部に送信する MIDI トラックのタイミングが改善されました。

サウンド/コンテンツ

  • Drum Machine Designer キットピースのサウンドを矢印キーを使って停止したときに、サウンドライブラリの選択範囲が予期せずジャンプすることがなくなりました。

全般

  • タイムルーラに時刻を表示する設定になっている場合、時刻の形式には、環境設定の「表示」>「一般」>「時間の表示形式」が反映されます。
  • 「ソースのみ」モードでフリーズしたトラックのプラグインパラメータを、再び自動化できるようになりました。
  • マーキーの選択範囲を右クリックしたときに、選択範囲が予期せず分割されることがなくなりました。
  • 「代替バージョンを編集」ウインドウで複数の代替バージョンを選択できるようになりました。
  • プロジェクトオーディオの「オーディオファイルを追加」ダイアログの「終了」ボタンが、一部のファイルが選択され、追加対象のファイルのリストから削除された場合に「追加」に変化することがなくなりました。
  • インスペクタの個々の開閉用三角ボタンの状態が、インスペクタを非表示にしてから再表示した場合も維持されるようになりました。
  • LCD ディスプレイに表示される SMPTE タイムが、テンポエディタや「テンポオペレーション」ウインドウに表示される SMPTE タイムと適切に一致するようになりました。
  • トラック領域の「録音可能」ボタンが、ミキサーの対応するボタンと同期して確実に点滅するようになりました。
  • ツールバーの「書き出す」ボタンを押すと表示されるオプションが、メインメニューから「ファイル」>「書き出す」を選択した場合に表示されるものと一致するようになりました。
  • 同じ種類の複数のウインドウが開いている場合に、各ウインドウに個別のズームメモリが維持されるようになりました。
  • トラックを 1 つ含むフォルダがトラック領域で選択されている場合に、コンテンツリンクが有効なエディタに、そのトラックのコンテンツが表示されるようになりました。
  • トラックを集約スタックの横にドラッグしたときに、集約スタックの中に間違って配置されることがなくなりました。
  • スタック内のトラックをフォルダにパックした場合に、そのフォルダの中にスタックのメイントラックの不要なコピーが作成されることがなくなりました。
  • メインウインドウが閉じているときに新しいメインウインドウを開いた場合、「リージョンを相対値にスナップ」と「リージョンを絶対値にスナップ」の設定が維持されるようになりました。
  • 「分割点にノートがあります」ダイアログ、「複数のトラックにペースト」ダイアログ、「すべてのトラックを Write モードに設定」ダイアログで選択されている設定が、Logic Pro の再起動後も維持されるようになりました。
  • マーキー選択範囲が MIDI リージョンの左端から始まり、ノートを分割している場合、「分割点にノートがあります」ダイアログが適切に表示されるようになりました。
  • タイムルーラの目盛りのラベルが、「ディビジョン」フォーマット設定に従うようになりました。
  • フェーズロックされた編集グループに割り当てられたトラックに対してフェードツールを使うと、フェードがグループ内のすべてのトラックに適用されるようになりました。
  • プロジェクトの「録音」設定で「サイクル」モードが「結合」に設定されている場合に、「録音結果を取り込む」で既存のリージョンと適切に結合されるようになりました。
  • トラックを削除した場合に、そのトラックがパッチの一部となっているプロジェクトに追加されている Aux も、その Aux がそのプロジェクトのトラックに割り当てられている場合、併せて削除されるようになりました。
  • Drum Machine Designer インスタンスの作成を正常に取り消せるようになりました。
  • MIDI リージョンのトランスポーズ設定が、重複する MIDI 録音を結合モードで作成した後に予期せず 0 にリセットされることがなくなりました。
  • マーキー選択範囲による MIDI リージョンの分割をキャンセルした場合に、そのリージョンが削除されることがなくなりました。
  • メトロノームがシンプルモードの場合、オーディオの録音中にメトロノームクリックのオン/オフを切り替えられるようになりました。
  • フェードツールで、ズームの倍率に関係なく、グループ化されたトラックに対するフェードアウトを確実に作成できるようになりました。
  • 「トラックを作成」または「トラックを作成してミュート」録音オプションを使って、サイクルモードでいくつかのトラックの複数のパスを録音するときに、トラックの正しい順序が確実に維持されるようになりました。
  • 代替バージョンやバックアップを「代替バージョンおよびバックアップを選択」ダイアログでダブルクリックして読み込めるようになりました。
  • メインウインドウで「繰り返す」を使った後で「取り消す」を実行したときに、リージョンの選択が維持されるようになりました。
  • リージョンインスペクタの値を、ハイライトして削除してから「return」キーを押して、再びデフォルト値に設定できるようになりました。
  • ハサミツールを使って切り取る、マーキーの選択範囲をクリックする、マーキーの選択範囲をダブルクリックする、またはリージョンをトリムするなどしてオーディオリージョンを分割した場合に、「ゼロクロッシングにスナップ」が適用されるようになりました。
  • サイクルモードで録音を置き換えた場合に、録音の停止時に、サイクル領域の右側のリージョンが選択されることがなくなりました。
  • プラグインを別のチャンネルストリップにドラッグした後で取り消しを実行した場合に、プラグインに適用された最後のパラメータ変更が併せて取り消されることがなくなりました。
  • 置き換えモードで既存のリージョンの上に手動でパンチインして作成した MIDI リージョンが、適切に再生されるようになりました。
  • Apple Loop のバリエーションのドロップダウンメニューに、名前が似た関連のないループが表示されることがなくなりました。
  • 「元の録音位置に移動」コマンドを使って移動したリージョンが、「オーバーラップなし」モードが有効な場合に、ほかのリージョンと重なってしまうことがなくなりました。
  • コントロールバーから「置き換える」ボタンを削除した場合に、置き換えモードが自動的に無効になるようになりました。
  • 「環境設定」ウインドウがすでに開いているときに、プロジェクト設定ウインドウを開けるようになりました。
  • 個々のトラックをズームするキーコマンドが、選択されているすべてのトラックに適用されるようになりました。
  • 1 1 1 1 以外の位置から始まるプロジェクトで「オリジナルの位置にペースト」コマンドを使ったときに、データが正しい位置に配置されるようになりました。
  • グループ設定をコピー/ペーストできるようになりました。
  • 「リージョン名に基づいてトラック名を付ける」コマンドを実行した後で、「取り消す」を実行できるようになりました。
  • マーキーの選択範囲をプロジェクトの開始位置より前にドラッグすることはできなくなりました。
  • 1 1 1 1 より前の位置からコピーしたリージョンが、選択されている位置に正常に配置されるようになりました。
  • 「重なったオブジェクトを削除」コマンドがまれに機能しない場合がありましたが、この症状が解消されました。
  • 「オーバーラップなし」モードが有効な場合に、テイクフォルダの左側にリージョンをコピーすると、そのテイクフォルダが予期せず削除される場合がありましたが、この症状が解消されました。
  • 閉じた Track Stack の中のリージョンの長さが間違って変更されることがなくなりました。
  • 「プロジェクト管理」>「整理」コマンドで、ほかの代替プロジェクトに属するオーディオファイルが削除されることがなくなりました。
  • トラックとその内容を複製したときに、新しいトラックに、エイリアスではなく元のリージョンのコピーが含まれるようになりました。
  • 「選択した項目から再生」キーコマンドが、オーディオリージョンで選択されている Flex Pitch ノートに反応するようになりました。
  • 拡大縮小してサイズを合わせるキーコマンドが、マーキーで選択された領域で使ったときに適切に機能するようになりました。
  • 「クリップの長さ」がオンになっているリージョンに MIDI CC データが入っていて、そのリージョンを分割したときに、MIDI CC データがすべて分割位置の左側に入っている場合、分割位置の右側の新しいリージョンには、正しい値の MIDI CC メッセージが追加され、分割前と同様に再生されるようになります。
  • 選択されている複数のリージョンに、右から左にスワイプしてクロスフェードを適用できるようになりました。 
  • 同じトラック上で選択されている複数のリージョンに、フェードツールを使ってフェードインとフェードアウトを適用できるようになりました。
  • オーディオトラックの作成を取り消した場合に、閉じたスタックの中のトラックが予期せず選択されることがありましたが、この症状が解消されました。
  • 「繰り返し録音」キーコマンドを使う際に、録音中にトラックの音量を調整した場合、最近録音したリージョンが削除されることがなくなりました。
  • リージョンアンカーが開始位置に配置されていないオーディオリージョンを分割した場合に、分割後の 2 つのリージョンの間に予期しない隙間ができることがなくなりました。
  • 以前と同様に、オーディオ入力デバイスを「なし」に設定できるようになりました。
  • インターリーブ・サラウンド・リージョンを接着したときに、モノラルファイルが作成されることがなくなりました。
  • 「起動時の状態」ダイアログで、上下の矢印キーを使ってオプションを操作できるようになりました。
  • トラックヘッダのデフォルト構成を設定できるようになりました。
  • オーディオ・ファイル・ブラウザで「不使用の項目を選択」が選択されている場合、ファイルを削除すると、ほかの代替プロジェクトで使われていないファイルだけが削除されます。代替バージョンで使われているファイルは、現在の代替バージョンのオーディオ・ファイル・ブラウザから削除されますが、ハードドライブには残ります。
  • トラックオートメーションが表示されている場合に、「option」キーを使ってループツールにアクセスできるようになりました。
  • ファイル選択画面の最近使ったプロジェクトのリストに、iCloud に保存されているプロジェクトが表示されるようになりました。
  • 拡大縮小してサイズを合わせるコマンドが、トラックオートメーションが表示されている場合に適切に機能するようになりました。
  • クイックパンチインが有効な場合に、再生中にプラグインを挿入できるようになりました。
  • 自動生成されたクロスフェードが、左側のリージョン境界を調整するときに消えることがなくなりました。
  • リージョンの左隅が変更された後で、「クロックをピックアップ」でノートイベントを適切な位置に移動できるようになりました。
  • 別のウインドウにキーフォーカスがある状態で「command + W」キーが押されたときに、「ミュージックタイピング」ウインドウが閉じることがなくなりました。
  • マーキー選択を行うときは、「キャッチ」が無効になります。
  • トラック領域でリージョンをグラブすると、選択されているリージョンの数がヘルプタグに表示されるようになりました。
  • リージョンの境界をクリックしたまま長押しした場合に、予期しない取り消しステップが作成されることがなくなりました。
  • ループブラウザで再生されるループが、トラック領域にリージョンがなく、シーケンサーが停止しているときに、オリジナルのテンポで再生されるようになりました。
  • ミュージックタイピングのキーボードが、オーディオ・トラック・エディタで Flex Pitch が有効になっているときに正常に機能するようになりました。
  • 「option」キーを押しながらすばやくスクロールした際に、表示倍率が変わることがなくなりました。
  • コントロールボタンの上にポインタを置いたときに、割り当てられているキーコマンドがヘルプタグに表示されるようになりました。
  • トラックヘッダで「control」キーを押しながらソロボタンをクリックすると、ソロセーフが適切に有効になるようになりました。
  • 1 つのウインドウのツールセットのカーソルが、フォーカスが別のウインドウに切り替わったときも残ってしまうことがなくなりました。
  • ドラッグモードが「クロスフェード」に設定されている場合、プロジェクト・オーディオ・ブラウザや「すべてのファイル」ブラウザからリージョンをドラッグしたときに、クロスフェードが適切に設定されるようになりました。
  • フレームレートが変更された場合に、SMPTE ロックされたマーカーがその位置を確実に維持するようになりました。
  • ループした MIDI リージョンを結合したときに、ループしたリージョンの終了位置が、次の小節の開始位置より少なくとも 1 クロックティック分前になっていない場合、追加の MIDI ノートが作成されることがありましたが、この症状が解消されました。
  • メインウインドウのミキサーの高さがスクリーンセットに確実に保存されるようになりました。
  • ツールのキーコマンドが「command」修飾キーを含む場合、該当するキーコマンドの組み合わせを放したときに、以前のツールに正しく切り替わるようになりました。
  • コンテクストメニュー項目の「フェードを削除」で、選択されているすべてのリージョンから、同じ種類のフェードが正確に削除されるようになりました。
  • 「拡大/縮小して選択部分またはすべてのコンテンツのどちらにサイズを合わせるかを切り替える」キーコマンドが、選択されている Track Stack コンテナで正常に機能するようになりました。
  • 自動的に拡大/縮小されたトラックが、オートメーション表示が有効になってから無効になったときに、拡大することがなくなりました。
  • ソロツールが感圧タッチトラックパッドで適切に機能するようになりました。
  • 再生中にリージョンのゲインを変更した場合、再生を開始および停止しなくても、音の変化を確認できます。
  • ループしたリージョンを、そのリージョン自体またはループの方をクリックしたままドラッグすることができます。

 

関連情報

Apple 製以外の製品に関する情報や、Apple が管理または検証していない個々の Web サイトは、推奨や承認なしで提供されています。Apple は他社の Web サイトや製品の選定、性能、使用については一切責任を負いません。Apple は他社の Web サイトの正確性や信頼性については一切明言いたしません。インターネットの使用にはリスクがつきものです。詳しくは各社にお問い合わせください。その他の会社名や製品名は、それぞれの所有者の商標である場合があります。

公開日: