Resolver un problema en MainStage 3

Aprende a aislar, diagnosticar y solucionar problemas en MainStage 3.

Sigue las recomendaciones que se ofrecen a continuación por orden hasta que consigas aislar o solucionar el problema. Antes de comenzar, asegúrate de hacer una copia de seguridad de la aplicación MainStage.

1. Asegúrate de que MainStage está actualizado

Asegúrate de estar utilizando la versión más reciente de MainStage 3. Selecciona el menú Apple () > App Store y, a continuación, haz clic en Actualizaciones en la barra de herramientas. Si hay una actualización disponible, haz clic en el botón Actualizar para descargarla e instalarla.

2. Comprueba la compatibilidad con tu dispositivo o software

Si usas una interfaz de audio externa, una interfaz MIDI, un sistema de almacenamiento o un plug-in que no es de Apple, comprueba que sea compatible con la versión más reciente de MainStage 3. Para obtener soporte técnico, ponte en contacto con el fabricante. Si hay disponible una actualización, sigue las instrucciones del fabricante para actualizar el dispositivo o el software. 

3. Comprueba la documentación

Consulta la Ayuda de MainStage 3 para asegurarte de que funciona como debería. En la Ayuda puedes buscar términos clave que aparezcan en las alertas o los mensajes de error.

4. Prueba con el audio integrado

A veces, una interfaz de audio externa incompatible o que no funciona correctamente puede provocar problemas en MainStage. Si estás usando una interfaz de audio externa, prueba a utilizar el audio integrado en tu Mac en lugar de la interfaz.

Para usar el audio integrado con MainStage:

  1. Desconecta la interfaz de audio externa de tu Mac.
  2. Abre MainStage y, a continuación, selecciona MainStage > Preferencias > Audio.
  3. Selecciona Salida integrada en el menú emergente Salida de audio.
  4. Selecciona Micrófono integrado (o bien Entrada integrada, según el ordenador que tengas) en el menú emergente Entrada de audio.
  5. Haz una prueba con un concierto, set o patch con los que hayas tenido problemas.

Si al usar el audio integrado se ha resuelto el problema, es posible que tengas que actualizar o reparar tu interfaz de audio. Para obtener soporte técnico, ponte en contacto con el fabricante.

5. Crea un nuevo concierto

En ocasiones, los archivos de concierto pueden volverse inservibles y provocar un comportamiento inesperado en MainStage.

Para crear y probar un proyecto nuevo:

  1. Abre MainStage y selecciona Archivo > Nuevo.
  2. Selecciona los dispositivos que quieres usar para la entrada y salida de audio en los menús emergentes “Entrada de audio” y “Salida de audio” del diálogo.
  3. Haz clic en una categoría de instrumentos de la izquierda y, a continuación, selecciona la plantilla que quieres usar.
  4. Haz clic en Seleccionar.
  5. Prueba a ver si el problema se produce también en el nuevo concierto. Si no se produce el problema en el nuevo concierto, puede que el concierto con el que tienes problemas esté dañado. Puedes probar a reconstruir el archivo del concierto.

Reconstruir un archivo de concierto dañado

Al reconstruir un concierto, exportas el layout, los sets y los patches del concierto y los importas a un nuevo concierto.

  1. Abre el concierto con el que tienes problemas.
  2. Para exportar el layout, haz clic en Layout, haz clic en el icono de engranaje que hay en la parte superior de la sección Layout y, a continuación, selecciona Exportar layout en el menú. Selecciona una ubicación para guardar el layout y haz clic en Exportar.
  3. Para exportar tus sets y patches, haz clic en Editar, luego en la lista de patches y, a continuación, pulsa Comando + A (o selecciona Editar > Seleccionar todo) para seleccionar todos los sets y patches de la lista de patches. Arrástralos al escritorio o a una carpeta.
  4. Cierra el concierto.
  5. Crea un nuevo concierto desde cualquier plantilla.
  6. Haz clic en Layout, pulsa Comando + A (o selecciona Editar > Seleccionar todo) para seleccionar todos los elementos de la sección Layout y, a continuación, pulsa Eliminar para eliminarlos.
  7. Para importar el layout desde el concierto original, haz clic en el icono de engranaje que hay en la parte superior de la sección Layout y, a continuación, selecciona Importar layout en el menú. Selecciona el layout y haz clic en Importar.
  8. Haz clic en Editar, selecciona todos los sets y patches de la lista de patches y pulsa Eliminar para suprimir todos los patches existentes.
  9. Arrastra los patches del concierto original a la lista de patches. Puede que necesites reordenar los sets y patches después de arrastrarlos a la lista de patches.
  10. Prueba un nuevo concierto para ver si el problema persiste.

7. Restablece las preferencias

El hecho de restablecer las preferencias de MainStage no afecta a los archivos, a los preajustes ni a los patches de tu proyecto. Sin embargo, se pierden todos los ajustes de preferencias personalizados que has hecho.

Antes de restablecer las preferencias, selecciona MainStage > Preferencias y revisa los ajustes que has hecho. Así, si restableces las preferencias, podrás volver atrás y aplicar tus ajustes personalizados. Para obtener información sobre las distintas preferencias, consulta Introducción a las preferencias en Ayuda de MainStage.

Para restablecer las preferencias de MainStage:

  1. Cierra MainStage si está abierta.
  2. En el Finder, mantén pulsada la tecla Opción y elige Ir > Librería.
  3. Elimina el archivo com.apple.mainstage3.plist de la carpeta Preferences.
  4. Reinicia el Mac.

Cuando el Mac se haya reiniciado, abre MainStage e intenta reproducir el problema que tenías. Si el problema no vuelve a producirse, abre las preferencias de MainStage y vuelve a aplicar tus ajustes personalizados.

8. Reinstalar MainStage

Si el problema continúa, elimina y reinstala MainStage. Los conciertos existentes de MainStage no se eliminarán y podrás abrirlos después de volver a instalarlo.

  1. En el Finder, selecciona Ir > Aplicaciones.
  2. Busca MainStage 3 y arrástralo a la Papelera.
  3. Vuelve a instalar MainStage desde el App Store o restáuralo desde una copia de seguridad. Al restaurar una copia de la aplicación MainStage desde una copia de seguridad, puedes arrastrarla desde la ubicación de almacenamiento original a la carpeta Aplicaciones o bien restaurarlo a partir de copias de seguridad de Time Machine.

La información sobre productos no fabricados por Apple, o sobre sitios web independientes no controlados ni comprobados por Apple, se proporciona sin ningún tipo de recomendación ni respaldo. Apple no se responsabiliza de la selección, rendimiento o uso de sitios web o productos de terceros. Apple no emite ninguna declaración sobre la exactitud o fiabilidad de sitios web de terceros. El uso de Internet conlleva riesgos inherentes. Ponte en contacto con el proveedor para obtener información adicional. Otros nombres de empresas o productos pueden ser marcas registradas de sus respectivos propietarios.

Fecha de publicación: