关于适用于 Ubuntu 的 Swift 5.1.1 的安全性内容

这篇文稿介绍了适用于 Ubuntu 的 Swift 5.1.1 的安全性内容。

关于 Apple 安全性更新

为保护我们的客户,在没有进行调查并推出修补程序或发行版本之前,Apple 不会透露、讨论或确认安全性问题。“Apple 安全性更新”页面上列出了近期发布的版本。

如果可能,Apple 安全性文稿会引用 CVE-ID 中列出的安全漏洞。

如果需要了解有关安全性的更多信息,请参阅“Apple 产品安全性”页面。

适用于 Ubuntu 的 Swift 5.1.1

发布于 2019 年 10 月 11 日

Foundation

适用于:Ubuntu 14.04、16.04 和 18.04

影响:URLSession 中文件描述符的错误管理可能导致意外的数据泄露

描述:通过更新错误的 URLSession 文件描述符管理逻辑以与 Swift 5.0 相匹配,从而解决了这个问题。

CVE-2019-8790: Apple

有关非 Apple 制造的产品或非 Apple 控制或测试的独立网站的信息仅供参考,不代表 Apple 的任何建议或保证。Apple 对于第三方网站或产品的选择、性能或使用不承担任何责任。Apple 对于第三方网站的准确性和可靠性不作任何担保。互联网的使用具有一定风险。请联系供应商以了解其他信息。其他公司和产品名称可能是其各自所有公司的商标。

发布日期: