关于 SwiftNIO 1.8.0 的安全性内容

本文介绍了 SwiftNIO 1.8.0 的安全性内容。

关于 Apple 安全性更新

为保护我们的客户,在没有进行调查并推出修补程序或发行版本之前,Apple 不会透露、讨论或确认安全性问题。“Apple 安全性更新”页面上列出了近期发布的版本。

如果需要了解有关安全性的更多信息,请参阅“Apple 产品安全性”页面。您可以使用 Apple 产品安全性 PGP 密钥对与 Apple 的通信进行加密。

如果可能,Apple 安全性文稿会引用 CVE-ID 中列出的安全漏洞。

SwiftNIO 1.8.0

发布于 2018 年 6 月 27 日

SwiftNIO

适用于:macOS Sierra 10.12 及更高版本、Ubuntu 14.04 及更高版本

影响:远程攻击者或许能够覆盖任意内存

描述:已通过改进大小验证解决缓冲区溢出问题。

CVE-2018-4281: Apple

以下版本也包含 SwiftNIO 1.8.0 的安全性内容:1.0.1、1.1.1、1.2.2、1.3.2、1.4.3、1.5.2、1.6.2、1.7.3。

有关非 Apple 制造的产品或非 Apple 控制或测试的独立网站的信息仅供参考,不代表 Apple 的任何建议或保证。Apple 对于第三方网站或产品的选择、性能或使用不承担任何责任。Apple 对于第三方网站的准确性和可靠性不作任何担保。互联网的使用具有一定风险。请联系供应商以了解其他信息。其他公司和产品名称可能是其各自所有公司的商标。

发布日期: