关于 Xcode 9 的安全性内容

本文介绍了 Xcode 9 的安全性内容。

关于 Apple 安全性更新

为保护我们的客户,在没有进行调查并推出修补程序或发行版本之前,Apple 不会透露、讨论或确认安全性问题。“Apple 安全性更新”页面上列出了近期发布的版本。

如果需要了解有关安全性的更多信息,请参阅“Apple 产品安全性”页面。您可以使用 Apple 产品安全性 PGP 密钥对与 Apple 的通信进行加密。

如果可能,Apple 安全性文稿会引用 CVE-ID 中列出的安全漏洞。

Xcode 9

发布于 2017 年 9 月 19 日

Git

适用于:macOS Sierra 10.12.6 或更高版本

影响:签出恶意制作的储存库可能会导致任意代码执行

描述:已通过改进输入验证解决 ssh:// URL 方案处理问题。

CVE-2017-1000117

ld64

适用于:macOS Sierra 10.12.6 或更高版本

影响:解析恶意制作的 Mach-O 文件可能会导致任意代码执行

描述:已通过改进内存处理解决多个内存损坏问题。

CVE-2017-7076、CVE-2017-7134、CVE-2017-7135、CVE-2017-7136、CVE-2017-7137:腾讯安全平台部的 riusksk(泉哥)

Subversion

适用于:macOS Sierra 10.12.6 或更高版本

影响:签出恶意制作的储存库可能会导致任意代码执行

描述:已通过改进输入验证解决输入验证问题。

CVE-2017-9800

其他表彰

Swift Package Manager

由衷感谢 Vincent Esche 为我们提供的帮助。

有关非 Apple 制造的产品或非 Apple 控制或测试的独立网站的信息仅供参考,不代表 Apple 的任何建议或保证。Apple 对于第三方网站或产品的选择、性能或使用不承担任何责任。Apple 对于第三方网站的准确性和可靠性不作任何担保。互联网的使用具有一定风险。请联系供应商以了解其他信息。其他公司和产品名称可能是其各自所有公司的商标。

发布日期: