Logic Pro X 10.2 – 10.2.4 发布说明

了解有关所有 Logic Pro X 10.2 更新的信息。

更新 Logic Pro X 之前,请确保备份当前安装的 Logic Pro 版本

Logic Pro X 10.2.4

Logic Pro X 10.2.4 包含以下更改。

稳定性/可靠性

在以下情况下,Logic Pro X 不再意外退出:

  • 有时打开或创建项目时。
  • 有时为 Drum Machine Designer 单元格挑选图标时。
  • 在更改屏幕设置后立即在钢琴卷帘中使用橡皮圈选择一组音符时。
  • 当初始化连接的 Mackie HUI 控制表面时。
  • 在将当前活跃的音频设备断开并重新连接时。
  • 当从 Alchemy 源弹出式菜单选择“导入音频”时。
  • 当使用 Alchemy 源弹出式菜单在包含名称以 Unicode 双字节字符开头的已装载宗卷的系统上导入音频时。
  • 当将名称包含双字节字符的文件拖移到 Match EQ 插件的“当前”或“引用”按钮上时。

性能

  • 在 OS X Yosemite 中打开 Retro Synth 的扩展参数时不再有时触发内部错误警告。
  • 当启用循环预处理时,跳过循环区域的开头不再出现问题。
  • 在回放期间量化软件乐器轨道上的音符不再有时导致音频中断。
  • 逐步执行 Alchemy 预置不再导致 Logic Pro 的内存使用率意外升高。
  • 当使用源左/右按钮浏览样本时,Alchemy 不再导致 Logic Pro 内存使用率意外升高。

编辑

  • 可以再次在钢琴卷帘编辑器中通过按住 Shift 键并点按来选择非连续音符。
  • 在调整钢琴卷帘力度滑块的同时按住 Option-Shift 键会再次正常地将所有音符设为同一力度。
  • 可以再次使用指针来通过橡皮圈选择使用 MIDI 通道的“全部”设置创建的 MIDI 画笔点。
  • 不会再在事件编辑器或逐步编辑器中意外将音符的长度设为 0 音位。

混音器

  • 解决了可导致静音的通道条上已旁通的“发送”保持活跃的与自动化有关的罕见问题。
  • 现在,复制轨道可以可靠地复制所有插件参数值。
  • 当在已分配至轨道的混音器中删除辅助时点按所显示对话框中的“取消”不再删除该辅助。
  • 独奏现在可以在发送至高于输出 1 或 2 的单声道输出的通道上正常工作。
  • 独奏发送至单声道输出的通道条不再意外使右输出通道静音。
  • 独奏 1—2 以上的输出现在会正常使输出 1—2 静音。
  • 复制轨道现在也会复制其轨道音符。

辅助功能

  • VoiceOver 可以再次正确地播报选定的片段。

插件

  • 现在,音频可以正确地在用旧版 Logic Pro X 存储的项目中从基于音频设备的多输出乐器传送。
  • 当将架子鼓导入 Ultrabeat 时,导入架子鼓名称会再次正确显示。
  • 载入项目时,速率设为 Hz 值的 Tremolo 插件的实例不再重置为 32 小节。

常规信息

  • 低延迟模式启用时,接合音频片段不再有时导致新片段移至错误位置。
  • 现在,如果工具栏“替换”按钮在“项目设置”>“录音”窗口打开时激活,所有重叠录音设置会从“切换”切换为“替换”。
  • 现在,当“录音”>“重叠 MIDI 录音”>“替换”启用时,MIDI 轨道上的自动插入录音表现正常。
  • 现在,在替换模式下手动设定入点和出点可以正常适用于 MIDI 片段。
  • 启用循环后,在替换模式下录制 MIDI 时,只要是在循环开始前播放 MIDI,将不再导致循环开始之前的小节被替换。
  • 将 Apple Loop 文件拖移至带自定名称的轨道中不再重命名轨道。
  • 可以再次将自定键盘命令分配给“放弃上次录音并返回上次播放位置”命令。
  • 编辑混音器记事本中的音符不再有时导致自定字体重置或导致文本被意外复制。
  • 现在,粘贴到现有记事本中的文本可以正确采用现有文本的颜色,并且不会导致现有文本更改为默认颜色。
  • 可以再次使用键盘命令在项目文件浏览器中重命名文件和片段。现在,键盘命令可分配并称为“重新命名”。
  • 可以再次在“环境”窗口将文本输入多乐器对象内的 Patch 名称单元格中。
  • 可以再次在脉冲响应实用工具中将选定的音频文件扩展到当前可见区域以外。

Logic Pro X 10.2.3

Logic Pro X 10.2.3 包含以下更改。

新增功能/增强功能

  • 现在,汇整折叠夹中伴奏部分之间的交叉渐变可以图形方式进行编辑。
  • 以下插件已经过重新设计,现可提供适应 Retina 显示屏的界面:Exciter、Echo、Modulation Delay、Noise Gate、Pitch Shifter、Match EQ、Match EQ Surround、Surround Multimeter。
  • 新的 Loudness Meter 插件提供对 LUFS 指示的支持。
  • 现在,Modulation Delay 插件包含“Feedback Filter”(反馈滤波器)。
  • 现在,Chorus 和 Modulation Delay 插件各提供一个 D 模式按钮。
  • 现在,Noise Gate 包含闪避器。
  • 现在,Noise Gate 插件可提供滤波器特性菜单,可设置为“Band Pass”(带通)或“Band Reject”(带阻)。
  • 现在,Multimeter 插件的“Analyzer”(分析器)、“Goniometer”(测向器)和“Level Meter”(电平指示器)部分有单独的保持按钮。
  • 当 Multimeter 处于显示视图中时,按住 Ctrl 并点按或右键点按显示区域可使显示在“Analyzer”(分析器)和“Goniometer”(测向器)之间切换。当 Multimeter 处于指示视图中时,按住 Ctrl 并点按或右键点按指示区域可使指示在“Peak”(峰值)、“RMS”、“Peak & RMS”(峰值与 RMS)、“True Peak”(真峰值)和“True Peak & RMS“(真峰值与 RMS)之间切换。
  • 现在,汇整折叠夹中有一个“编辑”偏好设置,可启用垂直点按区以在“快速扫动伴奏”和“汇整编辑”模式之间切换。
  • 现在,量化 MIDI 事件始终参考绝对网格而非包含事件的片段的起始位置。旧行为可通过在选取量化值的同时按住 Option 进行访问。
  • 现在,“乐谱项目”设置中有针对罗马文和弦的和弦语言设置。
  • 现在,用户可分配 Drum Machine Designer 单元格的图标,方法是按住 Control 键并点按单元格上的图标。
  • 现在,用户可定义键盘命令来从打开的“工具”菜单中临时选择工具。
  • 现在有“先前选择的工具”键盘命令。
  • 现在,用于挪动选定的对象/事件的键盘命令适用于自动化。
  • 现在,受“片段长度”片段参数影响的 MIDI 控制器数据类型可在“项目设置”>“MIDI”>“片段长度”中进行设置。
  • 现在有“循环显示窗口视图(逆时针方向)”键盘命令。
  • 现在有可用于挪动自动化值的键盘命令。
  • 新增了两个片段正常化键盘命令,使片段增益能够用于完好无损地正常化选定的音频片段。“非破坏性正常化(全部)”可正常化相互关联的所有选定的片段。“非破坏性正常化(各自)”可分别正常化各个选定的片段。
  • 现在,Logic 中有一个偏好设置,用于从可用的本地化内容中进行选择。

稳定性/可靠性

  • 在以下情况下,Logic 不再意外退出:
    • 通过新项目覆盖已打开的现有项目。
    • 按住 Option 键并拖移以拷贝环绕声音频文件。
    • 将采样速率不同于项目的多个音频文件拖移到轨道区域中。
    • 有时电脑从睡眠唤醒时。
    • Alchemy 打开包含 60 个样本或以下大小的音频文件的 EXS 乐器。
    • 从同一项目的其他备选导入。
    • 有时在循环浏览器中预览循环时。
    • 有时在两个打开的项目之间切换时。
    • 展平 Track Stack 后点按主窗口中的“乐谱编辑器”标签后。
    • 当调整“乐谱 Set”窗口的大小时。
  • 当从 Logic Remote 录制两个或更长小节的音符时,Logic 不再挂起。

性能

  • 现在,载入新的 Alchemy 实例的用时更短。
  • 在 Alchemy 中播放的第一个音符不再有时导致意外 CPU 峰值。
  • 点按 Drum Machine Designer 中的单元格会更快得到响应,并且不再有时导致音频爆裂。
  • 如果关闭插件管理器时未作任何更改,Logic 不再重新初始化 Core Audio。
  • 当插件窗口关闭时,“通道均衡器”分析器不再使用 CPU。
  • 当“Playback + Live Tracks”(回放轨道与实时轨道)多线程偏好设置启用时,包含 Alchemy 实例的项目不太可能意外显示系统过载信息。
  • 现在,在 Logic Pro 9 或较低版本中创建的包含 EXS 乐器轨道的项目打开得更快。
  • Logic 不再有时花费异常长的时间来载入某些大型项目。
  • Logic 不再有时在某些显示全局轨道的项目中运行缓慢。

编辑

  • 现在,关闭再重新打开 MIDI 画笔视图后,它将保持在钢琴卷帘中调整过的尺寸。
  • 现在,在“钢琴卷帘”或“乐谱”中的音符上使用“在取整的播放头位置拆分”命令后,将取消选中右手边的音符或和弦。
  • 现在,钢琴卷帘中的“折叠”视图模式会考虑到“片段移调”设置。
  • “钢琴卷帘编辑器”>“删除 MIDI”>“重复的事件”命令不再有时错误地删除非重复的控制器事件。
  • 当 MIDI 画笔可见时,可以继续使用 Shift 键限制在钢琴卷帘中单向拖移。
  • 在钢琴卷帘中通过橡皮圈来选择音符不会再出现这些音符显示为已选中但却无法编辑的个别少数情况。
  • 可以继续使用 Command + Shift 将钢琴卷帘中的铅笔工具转换为笔刷工具。
  • 现在,在已选择轨道的片段的情况下,当在回放期间从一个轨道切换到另一个轨道时,钢琴卷帘中的“跟随播放头位置”按钮将可靠地显示其已关闭。
  • 在钢琴卷帘中连按两次音符以打开事件浮动窗口时,不会再意外激活钢琴卷帘中的“跟随播放头位置”。
  • 现在,当“显示”>“片段移调”设置启用时,钢琴卷帘中的工具提示会考虑到片段移调设置。
  • 当快速调整窗口大小时,钢琴卷帘力度滑块不再有时消失。
  • 现在,可通过点按钢琴卷帘的背景来取消选中已选中的标记。
  • 当在片段开始位置的左侧开始选择时,可以继续在钢琴卷帘中通过橡皮圈来选择 MIDI 画笔事件。
  • 在事件编辑器中的片段结束位置键入的调整不再解读为片段长度。
  • 现在,在事件列表中点按事件的“附加信息”行可正常触发该事件。
  • 现在,可在音频文件编辑器中使用“缩放至窗口大小”键盘命令。
  • 现在,当在音频文件编辑器打开并且聚焦于文件的情况下回放片段的选取框部分时,播放头在到达该部分的结尾后仍在该编辑器中保持可见。
  • 现在,在音频文件编辑器中,调整片段开始点、结束点或锚点会创建撤销步骤。
  • 现在,在打开再按住 Option 并连按两次关闭后,音频文件编辑器可以可靠地打开。
  • 现在,在切换到音频文件编辑器再切换回来后,音轨编辑器将保留其“跟随播放头位置”设置。
  • 可以继续使用控制器键盘将音符逐个输入小节 1 之前的片段中。
  • 现在,MIDI 画笔视图可正确显示被拆分的片段中的 MIDI 数据。
  • 现在,“环境”窗口中的线缆可通过 Delete 或 Backspace 键进行删除。
  • 现在,当在“环境”中创建新的推子对象时,“垂直 6”和“旋钮 6”风格可用。
  • 现在,置于环境宏中的对象名称稳定可见并且位置正确。
  • 现在,当移动或拷贝环境对象时,其名称保持可见。
  • 现在,在列表编辑器中以数字形式输入拍号的分母可产生正确的值。
  • 在连按两次参数以进行编辑前,无需点按浮动窗口以将其带入焦点内。
  • 现在,当项目重新打开时,逐个输入键盘可记住上次使用的音符长度。

汇整/伴奏

  • 现在,延长 SMPTE 锁定汇整折叠夹长度的新录音可见,并可正常进行编辑。
  • 现在,展平已缩短的汇整折叠夹可保持该汇整折叠夹的长度。
  • 现在,右键点按关闭的 MIDI 汇整折叠夹将显示关联菜单,用于选择汇整。
  • 现在,当在汇整折叠夹上执行展平或展平和合并时,其静音状态将保留。
  • 现在,在汇整折叠夹包含 Apple Loop 的情况下,用于点按汇整折叠夹上的控件的热点将保留其正确位置。
  • 在用“进行中插入”录制其他轨道的同时用剪刀编辑汇整折叠夹时,不会再导致所编辑轨道上的汇整文件夹发生意外位移。
  • 当在一组成组的音轨上的一个汇整折叠夹中选择某个伴奏片段时,用户命名的其他伴奏不会再重命名为其默认名称。
  • 如果在拖移模式设为重叠时将片段移至重叠的位置,现有汇整折叠夹不再缩短。
  • 现在,“将片段结尾修剪到下一个片段”和“将片段开头修剪到上一个片段”命令适用于已停用“快速扫动伴奏”的汇整文件夹。
  • 在音轨编辑器中点按选定汇整中的 Flex Pitch 音符时,不会再导致轨道区域中的焦点丢失。

Flex

  • 现在,Flex Time 和 Flex Pitch 可更有效地处理超大型项目。
  • 片区模式不再导致可见波形在不伸缩的音频上发生变化。
  • 现在,在切换到 MIDI 片段再切换回来后,已启用 Flex Pitch 的片段的显示范围可正确保持。
  • 在音符的中央拆分已启用 Flex Pitch 的片段时,不会再导致 Flex Pitch 针对在拆分右侧创建的片段进行重置。 
  • 当回放已启用 Flex Time 并包含一系列各自属于不同音频文件的极短片段的轨道时,Logic 不再显示错误信息。
  • 现在,已启用 Flex Pitch 的音轨的回放质量一致,无论回放从时间线上的哪个位置开始。
  • 轨道参数检查器中新增了一个 Flex Pitch 选项,用于在编辑共振峰后选择如何处理音频的清音部分。 

Drummer

  • 现在,Drummer 编辑器可即时显示 Drummer 片段颜色的变化。
  • 现在,当播放头从 MIDI 片段跨至 Drummer 轨道中的 Drummer 片段时,Drummer 编辑器的自动选择功能能够正常发挥作用。
  • 更改“时钟格式”偏好设置不再有时将 Drummer 片段延长一个时钟音位。
  • 更改轨道的 Drummer 特性不再从已从 Drummer 片段转换为 MIDI 片段的片段中移除数据。

Track Stack

  • 现在,在 Track Stack 内的最后一个轨道上使用“使用同一个通道条/乐器新建轨道”命令可正常在该 Track Stack 内放置新的轨道。
  • 现在,将 Track Stack 替换为声音资源库中的单一通道 Patch 能够正常工作。
  • 重复的 Track Stack 不再发送到主输出,而是发送到正确复制的辅助。
  • 现在,在关闭的 Track Stack 上使用“使用同一个乐器新建轨道”可正确创建使用相同乐器作为原始乐器的 Track Stack。
  • 在输出已更改的“总和 Track Stack”中的轨道上使用“复制使用相同设置的轨道”命令时,不会再将原始轨道和复制的轨道的输出更改为 Track Stack 的默认总线输出。
  • 现在,复制 Track Stack 时,也会复制轨道颜色。

全局轨道

  • 当拍号设置为 ¾ 拍时,长按标记不再将所选的所有标记向左移动一个节拍。
  • 现在,标记 Set 可以可靠删除。
  • 现在,编辑所选的多个标记的边界可正确调整所有这些标记。
  • 在回放期间移动标记不再导致在音频输出过程中出现喀哒声。
  • 现在,在标记轨道中更改标记颜色后,标记列表编辑器中的标记颜色会即时更新。
  • 现在,从标记轨道右键点按菜单选取“创建标记”将在点按鼠标的位置而非播放头位置放置新的标记。
  • 时间标尺中的标记不再在某些缩放比例中出现相互重叠。
  • 现在,在执行“全选”再拖移后使用“撤销”时,标记可以正确移回其原始位置。
  • 现在,在速度列表中执行多项编辑后执行“撤销”时,可正常一次撤销一项编辑。
  • 现在,在节拍映射轨道中应用“来自片段的节拍”时,节拍标记可以可靠地放置在小节位置。
  • 在为编配标记选择不同名称后执行“撤销”时,将不再删除该标记,而是复原至先前的名称。
  • 移动编配标记不再停用已启用“匹配音乐套路轨道”的轨道的该选项。 
  • 长按速度曲线不再导致向左移动四分音符。
  • 当切换影片轨道时,不再不必要地重新生成影片轨道缩略图。
  • 现在可以撤销移调轨道中移调点的创建。
  • 现在,当移调轨道因编配标记的位置更改而被移动时,其中的变调值可以正确保持其值。

混音器

  • 现在,混音器可以在使用“按片段名称给轨道命名”选项后可靠地显示自定轨道名称。
  • 在混音器中选中了多个通道条时,按住 Option 键并点按发送不再有时将其设置为 +6 db,而会设置为正常的 0 db。
  • 现在,通过将环绕声音频文件拖移至轨道区域中或通过从影片中提取环绕声音频而创建的通道条上的输出将正常设置为“环绕声”。
  • 现在,当通道条输出至总线为独奏时,输入分配至同一总线的所有辅助将保持活跃。
  • 现在,通过在多输出软件乐器中复制通道而创建的辅助通道将拥有正确的输入。

自动化

  • 当在轨道区域中拖移片段时,将不再意外复制自动化节点。
  • 现在可以更轻松地抓取自动化点,而不会无意中移动它们。
  • 现在,当在不包含片段的项目中执行“剪切/插入时间”操作时,自动化和全局轨道数据会得到正确处理。
  • 现在可通过键盘命令来向上或向下挪动自动化值。
  • 现在,键盘命令“为音量、声相和发送各创建 1 个自动化点”和“为音量、声相和发送各创建 2 个自动化点”适用于组中的所有轨道。
  • 现在,可在首次尝试时将新建的 MIDI 画笔点拖移至其可能的最小或最大值。
  • 在 MIDI 画笔视图中抓取一组选定的延音事件时,不会再导致它们意外更改值。
  • 现在,将“基于片段的自动化”录制到输出轨道时,Logic 会在录制时指示它正在创建片段。
  • 在回放期间编辑“基于片段的自动化”时,不会再导致自动化在播放头通过片段的结尾后跳至错误的电平。
  • “修剪自动化”不再适用于受保护的轨道。
  • 现在,使用“将所有轨道自动化移到片段”键盘命令时,片段结尾处的 MIDI 音量和声相控制器事件可以可靠地转换为自动化事件。
  • 现在,当插件移至通道条中的不同插槽时,该插件的现有基于片段的自动化可以继续正确回放。
  • 现在始终可以在汇整折叠夹上编辑“基于片段的自动化”。
  • 调整已冻结轨道的 Smart Control 不再写入自动化。
  • 现在,因使用“删除未使用的轨道”命令导致删除的轨道的自动化可通过“撤销”正确恢复。 
  • 现在,用于挪动选定的对象/事件的键盘命令适用于自动化。
  • 现在,“重复片段/事件”命令可用于自动化。
  • 现在,当“样本精确自动化”处于打开状态时,插件参数的自动化可以可靠地进行追踪。

Alchemy

  • 现在,载入用户创建的 IR 文件时,Alchemy 可以记住上次使用的文件夹位置。
  • 现在,Alchemy 完全支持文件名称、文件夹名称、Patch 名称和注释使用 Unicode/双字节字符。
  • 现在,表情符号可正确用于 Alchemy 中的名称和标签。
  • 在存储经编辑的 Alchemy 预置之前重新启用 Core Audio 不再导致其 AAZ 数据丢失。
  • 现在,当自动存储的项目打开时,导入的 Alchemy AAZ 数据可以可靠保留。
  • 当样本通过加法 + 频谱分析模式导入时,Alchemy 中的声音质量会得到改善。
  • 当起音包络设置为 0 时,Alchemy 不再生成短节拍。
  • 在频谱模式中将三个样本导入到源 A、B 和 C 再启用变形线性时,Alchemy 不再显示不必要的“激活所有源以启用变形”警告。
  • 在 Alchemy 中,取消包含多个文件的第二区导入不再将添加到该组以及其他空白区的部分文件留下。
  • 现在,Alchemy 的 FM 滤波器参数可在调制架中以及针对自动化显示正确的名称。
  • 现在,当延迟载入 Alchemy 音效架中时,该旋钮将显示 -100 – +100 的正确范围。
  • 现在,Alchemy 中的滑音旋钮始终根据针对预置选定的选项显示速率和时间值。
  • 添加使 Alchemy 的音效架重新定位或重新绘制的音效时,不会再导致一些控件被意外重命名。
  • 现在,Alchemy 的 LFO 波形显示会在 LFO 部分文件清除后可靠重置。
  • 当逐步通过以振荡器命名的源文件时,Alchemy 不再选择振荡器并将其设为 VA 模式。
  • 现在,Alchemy 的 AHDSR 包络保持和衰减阶段可始终通过短值触发。
  • 现在,Alchemy 的“Convolution Reverb IR”(褶积混响 IR)选择菜单将在向音效架添加其他音效后在正确的条目旁边显示勾号。
  • Alchemy 的加法和频谱音效参数不再在为从属的变形源选择第三方加法音效或调整频谱滤波器的频率值后意外重置。
  • 现在,为 Alchemy 的加法或频谱音效选择“无”可正常停用该音效。
  • 当存储在最后一次存储时已在其中使用加法 + 频谱 + 共振峰将音频导入源中的项目时,Alchemy 不再显示不需要的查找文件对话框。
  • 现在,当 Alchemy 导入有旋律的 Apple Loop 时,将使用循环中储存的按键标签来设置根音符。
  • “项目管理 > 整理项目”命令不再移除项目软件包或文件夹中储存的 Alchemy IR 文件。
  • 现在,Alchemy 可以在其中父文件夹包含与其名称相同的子文件夹的文件夹结构中正确浏览。
  • 在现有 Alchemy 预置上执行“存储为”操作不会再将该预置的属性错误地应用为预置列表的过滤器。
  • 现在,Alchemy 的加法 + 频谱分析将忽略信号中的噪声成分,从而更好地分离噪声和泛音成分。
  • 现在,当 Alchemy 将仅包含一个组的 EXS 乐器导入 Alchemy 中的新组或区时,生成的区将扩展以覆盖整个力度范围。
  • 当起音极短的 AHDSR 分配给 Alchemy 振幅控件时,其他音符释音相位期间播放的音符不再导致喀哒声。
  • 当合并的 Logic 项目被拷贝至其他电脑时,Alchemy 不再有时要求找到丢失的资源。
  • XFade XY 变形不再影响未设置为参加变形的源。
  • 现在,在加法模式中将其他源导入到现有声音时,新源的音效值将设置为默认值。
  • 现在,当 KeyFollow 或 KeyFollowFixed 被分配给控件时,调制源名称可在调制架中正确显示。

插件

  • 现在,Microphaser 可以在原先用 Logic 10.2 或较低版本创建的项目中以编辑器视图正常打开。
  • 现在,Modulation Delay 插件包含“Feedback Filter”(反馈滤波器)。
  • 现在,Chorus 和 Modulation Delay 插件各提供一个 D 模式按钮。
  • 当 LFO 速率和强度均设置为低值时,Ensemble 插件不再有时产生爆裂噪声。
  • Autofilter 继续提供 LFO 重新触发开关。
  • 现在,右键点按或按住 Control 键并点按 Drum Machine Designer 中的鼓垫将打开图标挑选器。
  • 现在,当 Logic Pro 不是活跃应用程序时,Drum Machine Designer 仍保持可见。
  • 现在,实例化 Drum Machine Designer 将打开插件界面。
  • 在 Drum Machine Designer 中右键点按单元格可将其图标设置为“无图标”。
  • 将资源库中的鼓件插入空白 Drum Kit Designer Patch 中将不再把整个 Patch 替换为鼓件。
  • 现在,将鼓件载入空白鼓模板的单元格将表现正常。
  • Amp Designer 不再有时在从 TREM 切换到 VIB 后意外输出噪声。
  • 现在,当选择外部乐器轨道后,Tuner 正常工作。
  • 现在,Multimeter 插件的“Analyzer”(分析器)、“Goniometer”(测向器)和“Level Meter”(电平指示器)部分有单独的保持按钮。
  • 现在,Multimeter 插件底部的控件面板可隐藏。
  • 现在,当启用“保持”后,Multimeter 插件可以继续可靠地显示峰值,直到回放重新开始或点按了图形。
  • 在启用“保持”并且峰值设置为无限的 Multimeter 插件中,当轨道或歌曲中遇到无声段时,峰值指示器在回放期间保持可见。
  • 在插件窗口打开时按下 Command 和 Option 键时,Ultrabeat 不再意外更改为“步长音序器”模式。
  • 现在,Double Dragon 踏板上的“Bright/Fat”(明亮/圆润)开关可正常操作。
  • 现在,MIDI Randomizer 插件中的“Seed”(种子)参数可正常工作。
  • 现在,Pitch Shifter 插件中的延迟补偿可以可靠地进行计算。
  • 现在,按住 Option 键并点按 Pitch Shifter 插件中的半音旋钮可将其设置为 0 半音而非 +7 半音。
  • 现在,当窗口关闭再重新打开时,Bit Crusher 插件中的图形保持可见。
  • 现在,用 Scripter 插件创建的乐器可从未知 MIDI 处理器的设置通过。
  • 现在,插件预置可通过“载入”命令从所有 Logic 插件可靠打开。
  • 现在,复制轨道时,插件侧链分配可以正确保持。
  • 现在,在 Patch 资源库中连按两次任何基于软件乐器的轨道的图标可打开软件乐器插件。
  • 解决了导致插件错误地显示为丢失的问题。
  • 解决了复制的 EXS24 乐器可能停止回放的罕见问题。
  • 现在,如果为其他插件输入已在使用中的自定名称,插件管理器将显示警告对话框。

导入/导出

  • 当在原位并轨轨道和自动化时使用“替换轨道”选项时,轨道音量设置为 0 dB,声相设置为 0,并且自动化模式设置为关闭。
  • 早于小节 1 开始的轨道位置在冻结时不再静音。
  • 现在,当将轨道原位并轨到新轨道时,新轨道将从原始轨道继承轨道名称和轨道音符。
  • 现在,当在日语系统上导出多个音频片段时,生成的文件将可靠地获得正确名称。
  • 现在,在将项目存储为新名称后将该项目并轨到磁盘时,Logic 会建议使用当前的项目名称。 
  • 现在,当“循环”处于活跃状态时,共享到“邮件”、Soundcloud 或 Airdrop 将可靠地包含循环片段。
  • 现在,当“Limit to Cycle”(循环限制)启用时,“将轨道导出为音频文件”和“将所有轨道导出为音频文件”将对生成的文件正确地设置时间戳。
  • 现在,并轨的开始和结束点将考虑到所选但已关闭的 Track Stack。 
  • 现在,当导出或并轨包含多个使用同一软件乐器通道条的子轨道的 Track Stack 时,每个子轨道将导出或并轨为单独的音频文件。
  • 现在,Logic 保留“并轨项目”对话框中“发送到 iTunes”复选框上次使用的设置。
  • 当在原位并轨片段时启用“忽略效果插件”选项时,不再忽略 MIDI 插件。
  • 现在,当在原位并轨多输出软件乐器轨道时,软件乐器的子轨道上的片段在执行并轨后将正常静音。
  • 现在,当从其他 Logic Pro 项目导入时,导入对话框默认为上次为源项目存储的备选,并将显示每个备选的最后存储日期和时间。

乐谱

  • 现在,“乐谱项目”设置中有针对罗马文和弦的和弦语言设置。
  • 现在,五线谱风格窗口的“Staves and Voices”(五线谱和声音)部分在切换视图时可以正确调整大小。
  • 在从部件箱拖移拍号的分子和分母时它们不再翻转。
  • 现在可以在线性视图中将音符和对象输入谱号五线谱风格中。
  • 乐谱中和弦和临时记号之间的间隔已减小。
  • 现在,符杠可以正确拖过乐谱中的换行符。
  • 现在,新项目和模板中的吉他和贝斯奏法记谱法显示降低一个八度音程。
  • 现在,当和弦编辑器激活时,和弦语言设置可以可靠保持。
  • 现在,在轨道区域中拷贝片段后,链接内容的乐谱窗口将即时更新。

影片

  • 现在,“文件”>“影片”子菜单会列出拷贝至项目文件夹中的所有影片文件。
  • 在“影片丢失”警告对话框中点按“取消”后,不再创建空白影片窗口。
  • 现在,当使用“将音频导出至影片”时,影片中的嵌入式音频默认为关闭。
  • 现在,影片窗口在关闭全屏模式时将正常显示相同内容和影片控件。
  • 现在,当在包含在项目软件包中的两个影片之间切换时,影片窗口和影片缩略图轨道将正确更新。

控制表面/MIDI 控制器

  • 现在,分配给 Smart Control 的 MIDI 控制器的所有旋钮在 Logic 控制以外使用时均能正常发挥作用。
  • 现在,Nektar Impact LX49 上的“走带控制”按钮能够正常发挥作用。
  • 现在,AKAI MPK25 和 MPK88 控制器上的“走带控制”按钮能够正常发挥作用。
  • 现在,首次按下 AKAI MPK49 键盘上的开关时,它们可以可靠地激活其分配到的 Smart Control。
  • AKAI LPD8 控制器上的旋钮不再在 Smart Control 中偏移一个位置。
  • 在控制器分配窗口中为已学习的分配重新分配控件时,不再有时删除错误的分配。
  • 现在,控制器分配窗口的大小可以减小。
  • 现在,当重新连接多个外部 USB 控制器时,Logic Pro 可以正确保持控制器分配。
  • Logic Remote 现在可以显示各种插件的所有控件。

辅助功能

  • 现在,当在 LCD 显示器上切换显示模式时,VoiceOver 将保持正确的聚焦。
  • 现在,可以使用 VoiceOver 调节环绕声轨道的声相值。
  • 现在,当键盘命令用于独奏、静音或让轨道准备录制时,VoiceOver 将提供语音反馈。
  • 现在,单个轨道的垂直缩放比例可以使用 VoiceOver 进行调整。
  • 现在,当使用上下箭头前往轨道头中的不同轨道时,VoiceOver 焦点可以正确更改至新轨道。

常规信息

  • 当 MTC 同步停用时,Logic Pro 不再意外响应 MTC 全帧消息。
  • 追踪现在适用于长度短于 640 音位的音符。
  • 现在,当复制轨道时,可保留自定用户名称。
  • 可以继续在 I/O 标签窗口中通过拖移鼠标来启用/停用连续的单选按钮。
  • 现在,时钟符号可以始终在 SMPTE 锁定片段上显示。
  • 循环工具现在适用于已经过弹性调整的音频片段。
  • 现在,当多个片段被拖到其他轨道中的片段上时,“无重叠”设置可以可靠地工作。
  • 当片段的锚点移至右侧时,可以继续通过点按选中片段,并且选中的片段将与轨道中后续片段的起点重叠。
  • 现在,在紧随资源库的新 Patch 的部分之后执行“撤销”后,Smart Control 对象将正确保持原位。
  • 现在,“量化选定事件”键盘命令可以在使用“撤销量化”键盘命令后继续正常工作。
  • 现在,当“添加到轨道”命令用于从项目媒体夹中添加音频文件时,Logic 将在当前选定的轨道下方创建轨道。 
  • 现在,当在检查器中重命名片段时,按 Escape 键可正确中止重命名操作,而不会打开自动完成菜单。
  • “将编辑吸附到过零点”可以继续在轨道区域中正常工作。
  • 当解锁的 MIDI 片段接合到其右侧的 SMPTE 锁定片段中时,右侧片段中的事件不再意外移到后面的位置。现在,生成的片段处于解锁状态,但原先锁定片段中的 MIDI 事件仍保持锁定。
  • 现在,粘贴到注释板中的文本默认匹配注释板文本样式。
  • 现在,在使用“将播放头设置到下一个/上一个瞬变”键盘命令后,使用“跳到上次定位位置”键盘命令会将播放头移到正确的位置。
  • 现在,当在编辑器或轨道检查器中的“音色库”下拉菜单中选择新的音色库后,多乐器编辑器中的 Patch 名称将即时更新。
  • 不管在录制音频时是否已启用“循环”,“自动着色汇整”现在都可以正常工作。 
  • 现在可以在撤销删除仪器后继续删除多输出软件乐器中的子通道。
  • 当调整片段的左边缘时,音频片段波形不再抖动。
  • 在调整片段的左角后执行撤销,不会再导致片段取消选中。
  • 调整其中锚点已移动的片段的左边界时,不会再导致左边界吸附到锚点位置。
  • 在“新建轨道”表单中选择“MIDI 控制的效果”时,不会再意外通过 Electric Piano 插件创建轨道。
  • “切换缩放以适合所选内容或所有内容”键盘命令可以继续正常发挥作用。
  • 现在,拖移采样速率不匹配项目的拆分立体声文件的左通道时,可正确导入配对的两个文件,并将显示提示转换文件采样速率的对话框。
  • 连接工具现在可以正常适用于那些锚点位置经过调整的片段。
  • Logic 不再持续向连接的 Roland A500 键盘发送 CC 消息。
  • 现在,在项目音频窗口中在多个音频文件上使用“拷贝/转换”时,进度条会更新以显示正确的名称。
  • 现在,用户可定义键盘命令来从打开的“工具”菜单中临时选择工具。
  • 现在有“先前选择的工具”键盘命令。
  • 现在,在分配到的外部 MIDI 端口不可用时存储的项目备选可以在这些端口可用时正确地重新连接到这些端口。
  • 当有其他端口变得可用时,外部 MIDI 轨道的 MIDI 端口分配不再有时意外更改。
  • 当使用箭头键浏览声音资源库时,所选内容不再有时意外跳至上一个 Patch。
  • 通过按住 Option 键并拖移音频片段的左角来对音频片段进行有损时间压缩时,不会再意外移动后续片段的左边界。
  • 在 MIDI 片段上用剪刀工具向前进或向后退时,不再有时导致“项目设置”>“MIDI”>“追踪”中的音符的“追踪”停用。
  • 更改为不同屏幕设置时,不会再重置循环浏览器中的视图过滤器设置。
  • 在“选取框标尺”处于活跃状态下开始录音时,不会再意外显示并轨对话框。
  • 将输出设置为折叠夹 Track Stack 的总线的轨道进行拖移时,不会再错误地将其输出更改为立体声输出。
  • 现在,在包含速度更改的项目中,音频波形可以以高水平缩放比例正确显示。
  • 现在,粘贴到 Logic 的记事本中的文本可以自动转换为默认文本样式以保证可读性。
  • 在音轨编辑器中编辑 Flex 标记后执行“撤销”时,不会再取消选中汇整。
  • 在至少包含一个汇整折叠夹的项目中按住 Shift 键和 Option 键并拖移片段仍可创建替身而非副本。
  • 拖移至轨道区域中的音频片段或文件现在可以始终采用轨道的通道条颜色。
  • 现在可以在轨道列表的“独奏”按钮上切换“Solo Safe”(独奏(安全))模式。
  • 在将片段转换成采样器轨道后执行“撤销”时,不会再删除环境对象。
  • 轨道列表不再显示离线控制表面的控制条。
  • 现在,当“给轨道重新命名”键盘命令用于在使用高垂直缩放比率的轨道上时,“给轨道重新命名”栏位可见。
  • “将延音踏板转换成音符长度”不再有时在片段中意外留下延音事件。
  • 现在可以撤销创建新组。
  • 现在,时间标尺上的位置音位标记可以可靠地在所有水平缩放状态下在其正确位置绘制。
  • 在循环浏览器中搜索特殊 ASCII 字符不再区分大小写,与使用其他字符进行搜索的行为一致。
  • 现在可以在超出项目结尾的区域用“缩放”工具启动使用橡皮圈选择。
  • 删除 SMPTE 锁定片段上的单点选取框选择时,不会再删除所选内容右侧的片段部分。
  • 在脉冲响应实用工具中激活录音时,不会再同时激活独奏按钮,否则有时会导致意外反馈。
  • 交叉渐变现在可正常应用于组中所有音轨。
  • 音色变化消息现在可正常从外部乐器轨道中发出。
  • 无法再使用“向左挪动”命令将事件移到片段开始之前的位置。
  • 通过接合多个较短片段生成的片段不再有时是长度短于组合的源片段的几个样本。
  • 现在,当浮动窗口是项目中最后打开的窗口时,Logic 会在关闭浮动片段检查器窗口时提示存储项目。
  • 在替换模式处于活跃状态时,使用“采集为录音”创建的 MIDI 片段不再在回放期间静音。 
  • 正确安装的声音资源库内容的 Patch 不再在某些个别情况下衰减。
  • 现在可以在组设置窗口打开时给组命名。
  • 当在包含冻结的轨道的折叠夹上执行“剪切部分”命令时,现在会正常显示必须先解冻轨道的警告。
  • 现在,当通过连按两次时间线启动回放时 Logic 停止时,Logic 会清除播放的 MIDI 音符的缓冲。
  • 更改电脑上的可用 MIDI 端口数量时,不会再导致节拍器的 MIDI 输出端口分配更改。
  • 现在,在选中多个轨道的同时按住 Option 键并点按轨道独奏按钮,可以可靠地激活所有选中轨道的独奏,并取消激活所有其他轨道的独奏。
  • 在多次连续快速进出音频录制时,Logic 的播放头不再有时在个别情况下卡住。
  • 在独奏其他轨道时将新的 Patch 载入轨道中不会再导致轨道意外静音。
  • 无法再从 Patch 资源库浏览器中删除出厂 Patch。
  • 现在,可通过激活“替换”按钮来替换 MIDI 轨道上的现有录音。
  • 在回放期间调整循环的位置或边界不会再导致播放头意外跳至光标位置。
  • 现在,当将 Logic 项目从 Finder 拖移至“所有文件”面板时,拖移的项目将在“所有文件”中保持选中状态。
  • 现在,使用关联菜单移除片段中的渐变后,可进行撤销。
  • 现在,低延迟模式可以正确忽略多输出软件乐器的子轨道上导致延迟的插件。
  • 解锁受保护的轨道不会再导致主窗口中的滚动功能停止工作。

Logic Pro X 10.2.2

Logic Pro X 10.2.2 包含以下更改。

新增功能/增强功能

  • Logic 现在提供了一个新的偏好设置面板(“控制表面”>“MIDI 控制器”),用于为要启用和停用的受支持 USB MIDI 控制设备自动分配控制。

稳定性/可靠性

  • 在以下情况下,Logic 不再有时意外退出:
    • 启动时 Alchemy 数据库或预置的路径中存在替身,或者 Alchemy 数据库已设置为“只读”
    • 显示内容下载进度条
    • 从 Logic Remote 打开“通道均衡器”插件窗口
    • 包含打开的“乐谱”文本框的项目已关闭
    • 在日语环境下运行时,用键盘命令打开音频文件编辑器
    • 打开插件管理器(如果某个插件的自定显示名称包含 2 个以上的空格)
    • 在音频媒体夹中对文件进行分组
    • 按住 Option 键并拖移文件夹堆栈
  • 在以下情况下,Logic 不再有时停止响应:
    • 在循环浏览器中预览 Apple Loop 时取消某个下载
    • 使用 VoiceOver 与混音器进行交互
    • 在选中某个软件乐器轨道并在某个音轨上插入 Melodyne 4 实例后点按“资源库”标签

编辑

  • 现在,在钢琴卷帘中使用橡皮圈选择 MIDI 画笔数据时,如果在片段边界外部开始进行选择,则可以正常操作。
  • 现在,如果在 Flex Pitch 编辑器中拖移某个音符时按下 Control + Shift 键以使其移动范围超过一个半音,则只能在垂直方向进行拖移。

自动化

  • 现在,在 Logic Pro X 10.2 或更早版本中创建的Stereo Delay 和 Tape Delay 自动化将可以在 Logic Pro X 10.2.2 及后续版本中正常回放了。

混音器

  • 从混音器中创建轨道不会再意外更改这些轨道的输出设置。

插件

  • 现在,在载入预置或倒转脉冲响应时,会立即更新 Space Designer 中显示的脉冲响应波形。
  • 现在,在将用户添加的 Space Designer 脉冲响应从一台电脑拷贝到另一台电脑后,可以在目标电脑上可靠地找到这些响应。
  • Logic 能够继续打开 Altiverb 7.1 或更低版本的实例。

乐谱

  • 现在,可以继续在乐谱编辑器中使用带删除线的文本。

影片

  • 触碰到播放头时,已打开的影片中的音频不再意外静音。
  • 右键点按或按住 Control 键并点按影片窗口可以继续正常打开关联菜单。

常规信息

  • 现在,MIDI 输入将支持 Roland A49 和 A88 USB 键盘。
  • 现在,在使用导致延迟的插件时,循环模式下的回放将始终保持同步。
  • 停止后播放 Logic 中的 MIDI 数据时,不会再清除“Capture Last Recording”(采集上次录音)缓冲区中的数据。
  • 安装管弦乐内容后,管弦乐和画面音乐项目模板将继续可用。
  • 现在,在针对重叠录音设定“创建轨道”偏好设置后,通过在循环模式下设定入点和出点制作的音频录音能够可靠地保持同步。
  • 现在,在 Logic 下载附加内容时,所有键盘命令均可以正常发挥作用。
  • 移动一个或多个片段后执行撤销操作不再导致相关片段被取消选中。
  • 检测到片段的速度后,片段检查器中将继续提供“跟随速度”复选框。
  • 现在,可以继续将音频文件中存储的速度信息载入到 Logic 项目中。
  • 缩小大型项目时,播放头将继续流畅地滚动。
  • 重新应用相同的设置后,“剥离无声”将继续提供一致的结果。
  • 现在,所有菜单均能够在运行 OS X 10.9.5 的电脑上可靠打开。
  • 现在,可以继续将 Track Stack 相邻软件乐器轨道上的某个片段移动到时间线上的另一个位置,而不会导致该片段意外移动到 Track Stack 中。
  • 拖移启用了“将编辑吸附到过零点”的音频片段的左边缘,不再有时导致波形显示看起来像是片段内容已经移动。
  • 现在,在片段独奏模式下选择不同轨道上的片段时,所有发送均可以正常发声。
  • 现在,在启用“跳过循环”后,点按时间线可以正确定位播放头。
  • 现在,可以继续在“片段增益”参数中键入一个大于 +6db 的值。
  • 如果已在工具栏中停用“跟随播放头位置”,则使用走带控制停止回放将不再意外地重新启用“跟随播放头位置”。
  • 在录制到一组音频通道的过程中,删除某个汇整后,Logic 之前有时会取消除选定轨道以外的其他轨道的录音,并显示错误信息“此录音组的多个通道具有完全相同的输入设置”,现在则不会出现这种情况。
  • 现在,在激活多线程偏好设置“Playback & Live Tracks”(回放与实时轨道)后,音频输入监视可与活跃的变速配合使用。
  • 用一个空的音轨打开时,音轨编辑器不会再以近乎其最大的缩放比例打开。
  • 现在,在将“音频”>“设备”>“多线程”偏好设置设定为“回放轨道”后,播放头可以正常循环。
  • 回放过程中,“滚动到选定部分”键盘命令将继续正常发挥作用。
  • 现在,“检测速度”的“2/3”选项将继续正常发挥作用。

Logic Pro X 10.2.1

Logic Pro X 10.2.1 包含以下更改。

新增功能和增强功能

  • Logic Pro X 10.2.1 在各种舞曲和流行音乐风格中加入了 650 多种全新的 Apple Loops。
  • 添加了一个音频偏好设置,用于对实时轨道进行多线程处理,以便在处理多个实时轨道时提高 CPU 性能。
  • 现在,Alchemy 中的频谱引擎提供了 11 个频谱效果,可在频域中实现富有创意的音效处理。
  • 现在,Logic 针对播放头、混音器上的指示以及插件内部应用插件延迟补偿。
  • 可以将音乐备忘录灵感中嵌入的速度映射导出到项目速度。
  • 您可以将 Apple Loops 拖入 Alchemy,它们会自动与当前速度保持协调。
  • 音乐备忘录灵感的强拍在导入后会自动吸附到距离播放头最近的小节。
  • “检测速度”选项的准确度已得到显著提高,尤其是对于播放时间较长的音频文件
  • 启用“相同级别”链接模式后,乐谱编辑窗口的内容能够可靠地正常更新
  • 现在,Alchemy 支持 MIDI 单声道模式。这使您可以使用第三方 Expressive MIDI Controller,包括由 Roli 和 Roger Linn Design 推出的产品。
  • 现在提供了一个空鼓件 Patch,供 Drum Machine Designer 在基于拖入空单元格中的样本生成自定鼓件时使用。
  • 现在,播放头将一直显示在音频文件编辑器中,您可以在回放停止后使用它在音频文件编辑器中进行浏览。
  • 现在,您可以在插件管理器中手动(不借助字母表)对“类别”文件夹进行排序,方法是将文件夹抓取并拖移到列表中的新位置。
  • 插件管理器中新增了两个栏,可用于为每个插件分配长和/或短名称。较长的名称将显示在菜单中,而较短的名称将显示在插件插入选项中。 
  • 现在,声音资源库和 Apple Loops 浏览器可以显示已发布但尚未下载的内容。此外,单个文件或目录可直接从浏览器中下载。
  • 现在,如果在点按空通道条均衡器图形时按住 Shift 键,便可以插入线性相位均衡器。
  • 现在,Logic 中的架子鼓和软件乐器可以通过受支持的设备响应 Force Touch 和 3D Touch。
  • 现在,Drum Machine Designer 支持同时拖放多个音频文件。
  • 现在新增了一个选项,用于将 MIDI 文件导入现有项目时包含速度信息。 
  • 现在,对于大小超过 4 GB 的 WAV 文件,Logic 支持 WAV RF64 音频文件格式。
  • 现在,您可以针对多个选定片段使用“将片段导出为音频文件”命令。
  • 现在,“将轨道导出为音频文件”适用于多个选定轨道,并且每个轨道均作为单独的文件导出。
  • “原位并轨轨道”现在适用于多个选定轨道。
  • 现在新增了一个节拍器选项,用于根据当前拍号的节拍编组生成重音。
  • 现在,如果当前选定的音频设备不可用,Logic 将按照上次使用的顺序使用其他三个最近使用的音频设备之一(而不是默认使用内建的音频硬件)。
  • 现在,“Create Tracks when recording in Cycle mode”(在‘循环’模式中录音时创建轨道)中新增了一个项目设置录音选项。
  • 现在,您可以按窗口单独定义“跟随”行为,方法是右键点按或在按住 Control 时点按每个窗口中的“跟随”按钮。
  • 现在,逐步编辑器包括一个主道 Set,可用于自动创建能够显示片段中的所有内容的主道。
  • 现在,您可以抓取插件窗口的标题或窗口的下边缘,以调整插件窗口的位置。
  • 现在,在对共振峰进行变形处理时,Alchemy 会自动调整增益。
  • 现在,通过“根据 Flex Pitch 数据创建 MIDI 轨道”生成的 MIDI 可基于源音频的音量包含力度数据。
  • 现在,“删除未使用的轨道”功能提供了一个选项,用于包括那些没有片段但包含自动化的轨道。
  • 现在,当主窗口的水平大小减小到足以隐藏“波形缩放”和“垂直自动缩放”按钮时,这些控件将添加到操作菜单中。
  • 现在,当并轨到新轨道时,源轨道中的轨道音符将传输到目标轨道。
  • 现在,当您将某个钢琴卷帘时间帧控制柄拖过另一个钢琴卷帘时间帧控制柄时,前者将旋转音符的起始位置(而不是调换音符的起止位置)。您仍可以通过在拖移控制柄时按住 Shift 键来触发较旧的行为。
  • 现在,事件列表中 Option 键的行为现在取决于您将指针放到的位置:
    • 当您在一组选定事件的事件值或位置栏中使用 Option 键向前进或向后退时,如果选定部分达到最大或最小限制,则允许继续进行编辑。
    • 当您在事件类型栏上使用 Option 键向前进或向后退时,会暂时独奏事件。
  • 现在提供了一个“隐藏所有空轨道”键盘命令,用于隐藏所有不包含片段或自动化的轨道。
  • 现在,如果 Logic Remote 发出了自定键盘命令来执行当前高级工具设置中尚未启用的功能,系统将提示您激活所需的设置。
  • 现在,点按检查器区域通道条中的 VCA 插槽,可以将检查器中的第二个通道条切换到相应的 VCA 通道中。
  • 现在,您可以在混音器的轨道视图中创建和展平 Track Stack。
  • 现在,您可以在插件管理器中创建新的类别,方法是将一组选定的插件拖移到“类别”栏中最后一个类别的下面。
  • 现在,节拍映射适用于汇整片段。
  • 现在,在某个轨道中选择一组非连续片段后,将在回放期间根据需要自动停用和重新启用钢琴卷帘中的“跟随播放头”。
  • 现在,乐谱提供了一个按钮,用于缩放五线谱以填充单个轨道视图中的所有可用垂直空间。
  • 现在,轨道导出对话框提供了一个选项,用于将导出限制到循环范围中。
  • 现在,在针对汇整折叠夹停用“快速扫动伴奏”后,您可以水平拖移多个选定的汇整片段。
  • 现在,Drummer 编辑器包含一个自动片段选择按钮,用于在播放头到达轨道中的 Drummer 片段时选择这些片段。
  • 全新的工具选择闩锁模式让您可以按住某个工具的键盘命令来暂时选择该工具。
  • 您现在可以使用 Smart Control 来自动配置 Logic 与各种 MIDI 控制器和键盘进行交互的方式。
  • 在一组选定事件的事件值或位置栏中使用 Option 键向前进或向后退时,如果选定部分达到最大或最小限制,则允许继续进行编辑。 
  • 在事件类型栏上使用 Option 键向前进或向后退时,会暂时独奏事件。
  • “钢琴卷帘视图”菜单现在提供了“片段移调”选项,用于使“钢琴卷帘”中音符的显示方式与片段检查器中的移调设置相匹配。
  • 现在,将指针放在插件插槽上会显示带有插件名称以及插件预置(如果载入了一个预置)名称的“帮助”标记。

下列插件已经过更新,现提供“具备 Retina 功能”的全新界面:

  • Stereo Delay、Tape Delay、Sample Delay、Bitcrusher、Clip Distortion、Distortion、Phase Distortion,Adaptive Limiter、Limiter、Single Band EQ、AutoFilter、Levelmeter、Multimeter、Chorus、Ensemble、Flanger、Microphaser、Phaser、EnVerb、SilverVerb、Gain、Klopfgeist、Test Oscillator、Correlation Meter、Surround Level Meter、Surround Limiter、Binaural Post-Processing

这些插件包含以下新功能:

延迟 > Stereo Delay

  • 立体声链接 – 同时更改左右声道的参数,并保留值之间的任何差异。Command 键可用于临时解除立体声链接,以便分别更改左声道和右声道。
  • 现在,左声道和右声道具有单独的滤波器设置。
  • 延时菜单中新增了附点音符和三连音符。
  • 拖移延时旋钮可用于通过“中间”值偏差来设定时间。点按旋钮周围的音符值可吸附到偏差设定为 0% 的时间。
  • 路由预置可以简化“前后交替”、“移动”、“旋转”等常用延迟模式的设置。

延迟 > Tape Delay

  • Tape Delay 现在包含“磁带头”模式和“展开”控制。
  • “失真电平”已重命名为“片段阈值”。
  • 延时菜单中新增了附点音符和三连音符。
  • 拖移延时旋钮可用于通过“中间”值偏差来设定时间。点按旋钮周围的音符值可吸附到偏差设定为 0% 的时间。

延迟 > Sample Delay

  • 您现在可以在毫秒和样本之间切换延迟量。

失真 > Bitcrusher

  • “混音”参数现在位于主界面上。

失真 > Distortion

  • “电平补偿”现在位于主界面上

失真 > Overdrive

  • 现在包含电平补偿

力度变化 > Adaptive Limiter

  • 指示器延迟补偿
  • 最佳预测按钮

力度变化 > Limiter

  • 指示器延迟补偿
  • 可选择“旧有”模式和“精度”模式

力度变化 > Surround Limiter

  • 指示器延迟补偿
  • 可选择“旧有”模式和“精度”模式

滤波器 > AutoFilter

  • AutoFilter 现在包含“添加峰值”滤波器模式。
  • “失真模式”菜单现在包含“Classic”(古典)、“Tube”(电子管)和“Scream”(尖叫声)
  • 可针对输入和输出失真单独选择“失真模式”。
  • 滤波器前和滤波器后现在有单独的“失真模式”菜单。
  • “失真”、“LFO”、“包络”和“滤波器”部分现在都有一个单独的旁通按钮。

指示 > Correlation Meter

  • 指示器延迟补偿

指示 > Levelmeter

  • 指示器延迟补偿
  • 最大 RMS 值的数字读数
  • 垂直和水平 UI 版本
  • 在黄色范围的开始位置可调节“目标电平”

指示 > Surround Level Meter

  • 指示器延迟补偿
  • 适用于中置通道、超低音通道以及其他通道的可调节“目标电平”

指示 > Multimeter

  • 指示器延迟补偿
  • 最大 RMS 值的数字读数
  • 全新的 63 波段模式
  • 在黄色范围的开始位置可调节“目标电平”
  • 响度指示器
  • LU-I 和 LU-S 的离散读数

调制 > Ensemble

  • LFO 1、LFO 2 和随机调制源的开/关

调制 > Flanger

  • LFO 同步

调制 > Microphaser

  • LFO 同步

调制 >Phaser

  • LFO 同步
  • 指数扫掠模式
  • 反馈滤波器开/关装置

混响 > SilverVerb

  • 调制开/关装置

稳定性和性能

  • 当您转换新项目的采样率以与拖入“轨道”区域的音频文件采样率相匹配时,Logic 不会再在播放时意外退出。
  • 在拖移某个显示了多个自动化主道的垂直缩放轨道时,Logic 不再停止响应。 
  • 现在,在从具有多个速度改变事件的项目进行输出时,MIDI 时间码变得更加稳定。
  • Alchemy 进行了多处改进,可减少播放期间在切换 Patch 时可能出现的喀哒声和砰砰声。
  • 通过“控制”视图中包含大量参数的插件窗口,改进了滚动和重绘性能。
  • 您不必再下载“基本声音”资源库,即可打开 Logic。
  • 现在,无需关闭当前项目,即可弹出已从中导入轨道的外置驱动器。
  • 长按通道条上的“音频 DSP”插槽时,不再出现响应延迟问题。
  • 现在,通道条插入上的插件的旁通按钮能够更迅速地响应快速、连续的鼠标点按操作。
  • 软件乐器总和堆栈上演奏的第一个音符不再意外延迟。
  • 预览 Apple Loops 并执行片段编辑时,回放响应速度更快。
  • 现在,Alchemy 针对每个实例使用更少的 CPU 处理资源。
  • 当主窗口中显示大量经过弹性调整的轨道时,Logic 性能得到改进。 
  • 启用 Flex 后,Logic 可在更短的时间内分析具有大量片段的轨道。
  • 现在,在执行以下操作时,Logic 的响应更灵敏:
    • 在钢琴卷帘中使用橡皮圈选择大量音符
    • 使用铅笔在逐步编辑器中绘制一系列音符
    • 放大包含大量自动化的项目
    • 以较高的缩放比例拖移并拷贝或移动自动化
    • 在包含大量自动化的项目的轨道头中重新排列轨道的顺序
    • 针对包含大量轨道的项目使用 EuCon 控制表面
    • 在包含大量自动化的项目中水平拖移自动化点
    • 在包含大量轨道、片段或自动化的主窗口中进行滚动
    • 在停用了“使用音乐网格”选项的乐曲的“片段参数”框中键入延迟值
    • 撤销伴奏选择操作后重做该操作
    • 启动时使用替身来访问 Alchemy 样本内容
    • 使用 Enter 键激活“跳到位置”命令
    • 在 Logic 演奏时对通道条进行重命名
    • 在 Space Designer 中载入文件名中包含某些特殊字符的脉冲响应文件
    • 使用 Logic Remote 连接多部 iPad
    • 从 Vintage B3 Organ 预置菜单中选取预置

编辑

  • 现在,当您连按某个音频片段时,音频文件编辑器将进行缩放以利用屏幕的整个水平宽度。
  • 现在,在音频文件编辑器中对某个立体声文件进行垂直缩放时,如果不再有垂直空间来完全显示两个通道,则会使一个通道居中显示。
  • 现在,对于速度与项目速度不匹配的 Apple Loops,音频文件编辑器中的小节标尺能够可靠地显示正确位置。
  • 当您连按两次某个音频片段时,音频编辑器将再次打开(而不是打开单独的音频文件编辑器)。
  • 现在,在启用“跟随播放头”后,如果您在轨道之间进行切换,音轨编辑器能够正确地将焦点保持在播放头上。
  • 现在,在恢复屏幕设置后,音频文件编辑器能够正确显示当前片段位置。
  • 当备选标尺可见时,“Play Region Solo”(独奏片段)按钮可继续在音轨编辑器中正常发挥作用。
  • 现在,在配备 Retina 显示屏的 Mac 上录制 MIDI 事件时,钢琴卷帘能够正确显示这些事件。
  • 现在,“撤销”操作适用于使用钢琴卷帘中的“量化强度”和“摇摆”滑块进行的调整。
  • 现在,钢琴卷帘能够可靠地显示所选 MIDI 汇整折叠夹的内容。
  • 不小心使用钢琴卷帘中的笔刷或铅笔工具向折叠夹中添加音符的情况再也不会出现了。
  • 现在,当您使用选取框工具连按两次已成组的轨道时,该工具可以正常分开组中的所有片段。
  • 现在,当您将某个选定轨道拖移到轨道头中的新位置时,钢琴卷帘能够可靠地显示该轨道各片段的内容。
  • 您可以使用 Control 和 Shift 修饰键在钢琴卷帘中当前等份值的外部插入音符。
  • 现在,当您首次选择一个片段时,钢琴卷帘中将立即显示折叠夹内部某个片段的内容。
  • 当您点按“轨道”区域的背景,然后重新选中某个片段时,系统将不再停用钢琴卷帘中的“折叠”按钮。
  • 现在可以更轻松地对钢琴卷帘中音符的长度进行小幅调整。
  • 现在,当您关闭并重新打开钢琴卷帘时,钢琴卷帘中的 MIDI 画笔主道将能够正确地保持其大小。
  • 当您停止回放并输入音符时,钢琴卷帘不会再停用“跟随”模式。
  • 当您使用量化工具点按并按住钢琴卷帘中的音符时,“量化”快捷菜单将正常显示。
  • 当您使用钢琴卷帘独奏循环按钮演奏某个片段时,即使该片段已在主窗口中取消选中,它也会继续演奏。
  • 现在,您可以在钢琴卷帘中使用任意工具抓取音符的右边缘,来可靠地调整音符大小。
  • 现在,钢琴卷帘中新插入音符的力度与上次通过在检查器中调整力度滑块设定的值相匹配。
  • 钢琴卷帘中的“全选”不会再选择位于当前片段边界之外的音符。
  • 现在,在启用“明亮背景”偏好设置后,钢琴卷帘中的位置参考线将变得更清晰。
  • 现在,当您从“鼓名称”视图切换时,钢琴卷帘的背景颜色将与键盘上的黑/白按键正确匹配。
  • 如果您对名称栏的大小进行了调整,使其宽度足以显示整个名称,则钢琴卷帘中的鼓名称将不再被截断。
  • 现在,当您将指针悬停在钢琴卷帘上,而另一个窗口具有键焦点时,钢琴卷帘区域中分配给 Command 键的工具将正确显示。
  • 现在,当您点按钢琴卷帘中的键盘来选中同一音高的音符时,这些音符将在事件列表中显示为已选中。
  • 钢琴卷帘齿轮菜单中继续提供“吸附 MIDI 画笔和自动化”。
  • 现在,Logic 在新建项目中使用上次设定的钢琴卷帘音符颜色设置。
  • 您可以继续像以往那样将 MIDI 画笔点垂直拖移到大小为 127 的值。
  • 当您在钢琴卷帘中选择多个片段时,铅笔工具不再只限于在最左侧的片段中创建 MIDI 画笔点。
  • 录制 MIDI 时,显示编配级别的事件列表不再同时显示编配中新录制的 MIDI 事件和片段。
  • 现在,您可以使用事件列表中的“添加”(+) 按钮来插入推子事件。
  • 现在,对于粘贴到事件编辑器中的多个选定事件,如果您调整其中一个事件的位置,则所有事件都将随之移动。
  • 现在,事件浮动窗口能够可靠地显示当前选定的 MIDI 事件,而不显示包含这些事件的片段。
  • 现在,您能够可靠地在逐步编辑器中选择未量化的事件。
  • 现在,如果在打开某个项目后点按主窗口中的“逐步编辑器”标签,将立即显示选定的片段内容。
  • 现在,当您选择某个片段时,逐步编辑器将垂直滚动以显示包含数据的步长主道。
  • 现在,环境中的对象标签可显示为多个行。
  • 当您断开环境中某个变换器对象的电缆时,将正常创建一个额外的电缆端口。
  • 环境对象现在可以使用调板中 72 种可用颜色的任何一种颜色。
  • 映射乐器编辑器会继续显示一个垂直键盘。
  • 当您通过控制器演奏 MIDI 时,如果已对某个编辑器启用了“MIDI 输入”且声音资源库具有焦点,则不再向该编辑器中触发逐个输入

自动化

  • 显示自动化主道不会再导致当前选定的轨道缩小当前视图。
  • 现在,当您使用“剪开:剪切定位符之间的部分”命令时,不包含片段的项目部分中的轨道自动化将正常移动。
  • 现在,复制的轨道将设置为与其原始轨道相同的自动化模式和活跃状态。
  • 现在,轨道头中的自动化模式按钮与混音器中该按钮的颜色相匹配。
  • 现在,Alchemy 滤波器 3 自动化参数在自动化主道中(而非滤波器 2 子菜单中)拥有自身的子菜单。
  • 现在,在您粘贴自动化时,该自动化能够可靠地置于在小节 1 之前或之后开始的项目中的正确位置。
  • 使用键盘命令“为可视参数创建 2 个自动化点”时,不会再导致自动化显示切换至之前选择的参数。
  • 现在,当您为 Drum Machine Designer Track Stack 的主轨道设置自动化模式时,将针对所有子轨道设置该模式。
  • 当您在非选定轨道上显示附加的自动化主道时,可见区域不会再移动以显示当前选定的轨道。
  • 现在,当“显示自动化”处于活跃状态时,已折叠的 Track Stack 将显示堆栈中子轨道的自动化。 

汇整/伴奏

  • 现在,汇整折叠夹控制自动与片段名称一起移动,因此它们在所有缩放比例下均可见。
  • 现在,在轨道独奏时,汇整折叠夹中的活跃伴奏将正确地显示为活跃状态。
  • 现在,当您在已拷贝到某个轨道的汇整折叠夹中进行伴奏,然后保护并取消保护该轨道时,此过程将正常工作。
  • 现在,如果您选择铅笔工具,则在汇整折叠夹中使用 Flex Pitch 时,光标将显示正确的工具。

乐谱

  • 您无需再针对一组音符两次应用“连音”窗口中的“允许二分音符时值”设置以使该设置生效。
  • 现在,如果您在和弦网格编辑器中使用不可演奏的指法创建和弦,Logic 将显示一条警告。
  • 现在,“选择同等着色的音符”键盘命令适用于乐谱编辑器。
  • 现在,当您在乐谱中较高的小节编号位置处进行工作时,指针能够可靠地选择正确事件。
  • 现在,您可以在五线谱风格编辑器中按数字顺序来编辑“大小”、“变调”和“拆分”点的值。
  • 在乐谱窗口中使用滚轮鼠标和 Option 键执行缩小操作的过程变得更加顺畅。
  • 缩放工具继续在乐谱的绕排视图中正常发挥作用。
  • 乐谱中的和弦现在跟随移调轨道。您还可以通过键盘命令使这些和弦移调。
  • 现在,在使用 Sigler Jazz 字体时,插入的尾音符号可以正确显示。
  • 现在,在和弦网格中,和弦扩展与和弦根音显示在同一行上。
  • 现在,选中轨道中的所有片段时,将选中内容关联的乐谱窗口中的所有片段。
  • 现在,当您选中乐谱中的多个部件箱时,当前处于活跃状态的部件箱将显示一个蓝色框。
  • 纳什维尔和罗马文和弦的对齐和间距已得到改进。
  • 停用“填充间隙”后,乐谱不会再在某些片段的结尾处显示意外的垂直线。
  • 现在,连按空白乐谱 Set 中的乐器区域将创建一个乐器条目。
  • 现在,重复符号和双线可以根据乐谱 Set 缩放值进行正确缩放。
  • 现在,当您在乐谱中的轨道或整页视图中抓取音符时,工具提示将显示其在项目中的正确绝对位置(而不是其在片段中的相对位置)。
  • 现在,您可以在乐谱中的多个页面之间拖移和拷贝乐谱符号。
  • 您可以继续使用 Backspace 键和箭头来编辑并选择和弦网格库中的栏。
  • 您可以继续使用 Return 键关闭和弦网格库中已激活的文本编辑栏。
  • 滚动可见区域时,乐谱显示不再受损。
  • 从和弦网格编辑器中添加和弦网格时不会再插入空和弦网格。
  • 现在,“隐藏所有拍号”项目设置将正常隐藏所有拍号。此外,还新增了一个用于只隐藏第一个拍号的设置。
  • 现在,乐谱中的“显示相同级别”链接模式会应用乐器滤波器参数。
  • 现在,“五线谱风格”窗口中的“颜色”菜单会显示颜色条和颜色标签。
  • 现在,在使用布局工具移动某个小节时按下 Option 键,会保留后续手动插入的换行符。
  • 现在,您可以在乐谱中对已转换为 MIDI 片段的 Drummer 片段进行编辑。

Flex

  • 启用了 Flex Time 的片段的显示方式现已更新,使您可以更轻松地识别已经过弹性调整的区域:
    • 当您在片区模式下向已成组的轨道添加 Flex 标记时,该操作将不会再意外移动瞬变标记。
    • 可以使用钢琴卷帘界面直接在轨道区域中执行 Flex Pitch 编辑
  • 现在,在放大已量化的音频片段时,量化功能会正确地应用于该片段新显示的部分。
  • 现在,您可以执行连按操作来可靠地删除汇整折叠夹中的 Flex 标记。
  • 在已启用 Flex 的音频通道上载入 Patch 或通道条设置时,不会再停用 Flex。
  • 现在,“分析音频以进行 Flex 编辑”命令可以恢复之前从汇整中删除的音符音高。
  • 现在,当您通过抓取某个热点来选中另一个片段中的音符时,Flex Pitch 音符将被正确取消选中。
  • 现在,在使用“Flex 片区”模式剪切片段时,在剪切左侧生成的片段的波形会正常显示。
  • 压缩区域以白色显示。
  • 拉伸区域以灰色显示。 
  • 保留片段颜色的区域将以其原生速度演奏。

Drummer

  • 编辑循环的 Drummer 片段的结束点时,可见区域不再跳转至原始片段。
  • 使用剪刀工具分开 Drummer 片段时,Logic 不再显示“发现重叠音符”信息。
  • 现在,当您在事件编辑器中延长 Drummer 片段时,会更新该片段的内容。

混音器

  • 从视图中过滤乐器后,Drum Machine Designer 轨道不再显示在混音器中。
  • 现在,针对混音器或检查器通道条中的相应通道启用“Solo Safe”(独奏(安全))后,轨道头中的独奏按钮会显示此功能。
  • 大小为 0 db 的值不会再显示在前跟减号 (-) 的混音器电平指示上。
  • 现在,将 Apogee 音频通道从单声道切换为立体声时,将会正确更新其音频设备控制。
  • 现在,在之前未选中通道的情况下,如果您在混音器中选中一个通道,则还会在主窗口中选中相应的轨道。
  • 现在,当您从 Logic Remote 中激活“衰减”后,Logic 主推子上的衰减按钮将正常点亮。
  • 点按混音器中的“设置”菜单时,不会再针对已修改的插件停用比较按钮。
  • 现在,复制的折叠夹 Track Stack 将正确设置为一个新的 VCA 控制推子。

影片

  • 现在,您可以将影片设置为在负的 SMPTE 时间开始。
  • 现在,影片片段边界将始终以 23.97、23.976 和 59.94 的帧速率进行正确计算。

控制表面

  • 您可以继续使用 Apple Remote 来控制 Logic。
  • 现在,您可以使用 Logic Remote 来调整 Alchemy 中的格式控制。
  • 现在,即使您的电脑在同一网络上具有两个 IP 地址(例如,当电脑同时连接至 Wi-Fi 和以太网时),Logic 也能够可靠地连接至 Logic Remote。
  • 现在可以从控制表面访问 MIDI 插件。
  • 外部 MIDI 轨道的自动化模式开关继续适用于控制表面。
  • 针对连接的 SSL Nucleus 和 Mackie Control MCU Pro 控制表面进行的检测更加可靠。
  • 现在,当您在混音器中当前音色库的外部选中一个通道时,Mackie Control 控制表面将正常更新。
  • 现在,Logic 可以顺畅地响应来自 Mackie Control 控制表面的转轮输入。
  • 现在,您可以在 Logic 中针对 Mackie C4 控制表面使用修饰键。
  • 现在,已连接的 SSL Nucleus 控制表面上显示的电平指示与 Logic 混音器中显示的指示相匹配。

辅助功能

  • 现在,在 OS X 10.10 或更高版本中关闭“快速导航”后,VoiceOver 可以正常工作。
  • 现在,VoiceOver 可以识别用于在主窗口列表区域中的“项目”、“媒体”和“所有文件”视图之间进行切换的按钮。
  • 现在,在与 LCD 中的采样速率设置进行交互时,VoiceOver 可以报告设置的名称及其值。
  • 使用 VoiceOver 在控制视图中访问 Alchemy 时,Logic 不会再表现出响应迟缓。
  • 与一组总线发送进行交互时,Voiceover 不会再错误地用语音提示一个不存在的设定按钮。
  • 可以更轻松地使用 VoiceOver 对循环控制进行大幅调整。
  • 现在,您可以使用 VoiceOver 访问以下项目:
    • 主窗口中的按钮
    • 通道条上的按钮和插入插槽
    • 循环浏览器中的试听音量滑块
    • 输出通道上的输入格式选择器
    • 钢琴卷帘中的钢琴键盘
    • 混音器中的通道条名称
    • “添加”(+) 按钮,用于在插件管理器中添加新类别折叠夹
    • 此外,还对钢琴卷帘中的 VoiceOver 辅助功能进行了多处改进。

全局轨道

  • 现在,您可以取消使用编配标记轨道,以便在编辑编配标记时不会对轨道区域内容产生影响。
  • 现在,点按一下全局速度轨道会创建一个新的速度点。
  • 现在,您可以按住 Command 键并点按标记轨道以将标记修剪到当前光标位置。
  • 现在,粘贴到 LCD 的速度值将正常发挥作用。
  • 现在,LCD 能够可靠地针对所有主调显示全局调拍号。
  • 现在,当您右键点按或按住 Control 键并点按某个标记,然后选取“给标记重新命名”时,Logic 将对该标记进行重命名。
  • 现在,当您选择其他类型的对象时,“通过播放头拆分”命令将作用于编配标记。
  • 现在,当您调整全局轨道的高度时,光标将在您抓取全局轨道头底部的拆分器时出现变化。这表示,拖动操作将调整所有全局轨道的大小。
  • 现在,当您创建一个标记,然后使用“撤销”将其移除时,标记列表将立即进行更新。
  • 现在,可以继续拷贝短于 16 个小节的乐曲中的编配标记。
  • 当您调整全局速度轨道中的速度曲线时,SMPTE 锁定片段的位置不再轻微移动。
  • 现在,当标记高度大到足以显示多行文本时,文本将在标记上正常绕排。

导入和导出

  • 现在,包含复合片段的 Final Cut Pro X XML 项目中的音频能够可靠地同步播放。 
  • 现在,Final Cut Pro X XML 项目中已同步片段的音频能够可靠地同步播放。
  • Final Cut Pro X XML 项目中的音频不会再在 Logic Pro X 中被截断。
  • 在 Logic Pro X 中打开从 Logic 7 转换的项目后,这类项目不会再显示太长时间。
  • 现在,当您从另一个项目导入轨道时,将导入正确的 Smart Control 布局。

同步

  • 现在,MIDI 时钟传输延迟设置的值以毫秒而非音位为单位显示。 

一般改进

  • 打击乐发音 Apple Loops 不会再在回放时出现移相失真现象。
  • 当您将 MIDI(绿色)Apple Loops 拖入项目时,这些循环可以继续可靠地载入。
  • 现在,对于停用了“跟随速度”并且具有 1x 以外速度设置的 Apple Loops,波形显示将正确无误。
  • 现在,当您拖移项目轨道区域中某个起始位置并非 1 1 1 1 的片段或 Apple Loop 时,如果备选标尺可见,“帮助”标记将显示正确的时间位置。
  • 在您将 Apple Loops 设为“个人收藏”后,选定部分将不再跳转至列表的顶部。
  • 现在,将指针悬停在“通道条发送”上将显示一个工具提示,其中显示了发送目的位置的名称。
  • 现在,您可以使用剪刀工具同时分开选定的音频片段、汇整折叠夹、MIDI 片段和折叠夹。
  • 现在,您可以在音频媒体夹中重命名某个片段后使用“撤销”。
  • 现在,即使在点按鼠标之前按下了 Option 键,您仍可以在按住 Option 键的同时从小节标尺向下拖移来进行缩放。
  • 现在,对于停用了音乐网格的项目,“并轨”对话框将显示要按时间而非小节和节拍并轨的部分。
  • 现在,录制到总和堆栈的主轨道时,将会录制到其中所有设定为离散输入的音轨。
  • 现在,如果您从工具框中连续两次选择同一工具,则光标将继续显示正确的工具。
  • 当您使用 Magic Mouse 鼠标拷贝片段时,Logic 将不再意外进行缩放。
  • 当 MIDI 片段彼此重叠且“无重叠”模式处于活跃状态时,MIDI 事件不会再显示在错误片段中。
  • 现在,您可以按住 Option 键并拖移 MIDI 片段的左边缘来拉伸或压缩内容,这与按住 Option 键并拖移右边缘的操作方式完全相同。
  • 在计算要显示的区域时,键盘命令“切换缩放以适合所选内容或所有内容”不再适用于隐藏轨道上的内容。
  • 现在,用于编辑轨道自动化的菜单命令将影响所有选定轨道。
  • 键盘命令“设定最适宜的片段大小(按小节取整)”将继续正常发挥作用。
  • 进行了多处修复,用于解决导致显示错误光标的问题。
  • 现在,当您将选取框工具拖移到组中的某个轨道上时,选取框能够在已成组的轨道上进行正确绘制。
  • 当您将某个备选与包含影片的项目一起存储时,如果“将影片文件拷贝到项目中”设置未启用,则不会再意外拷贝该影片。
  • 现在,对于已冻结轨道上的片段,片段参数将被正确锁定。
  • 在对 Smart Control 设置进行任何更改之前,您无法再激活 Smart Control 窗口中的比较按钮。
  • 现在,在其锚点并不位于片段开头的片段中,“替换或叠加鼓乐器轨道”功能可将 MIDI 音符放在其正确的位置。
  • 现在,当您在钢琴卷帘中选择一组音符,而未选中包含这些音符的片段时,“切换缩放以适合所选内容或所有内容”键盘命令也能继续正常发挥作用。
  • 现在,“打开/关闭 Track Stack”命令适用于轨道头中的多个选定轨道。
  • 现在,Smart Control 映射将在切换布局时得到更可靠的保持。
  • 现在,当您在 Logic 与其他应用程序之间进行切换,并且“自动设定定位符”处于启用状态时,定位符将被正常保持。
  • “将所有都轨道设定为自动化 Touch”命令不会再创建意外的古典 MIDI 轨道。
  • 现在,“采集录音”键盘命令可为 Kontakt 乐器正常创建一个轨道。
  • 现在,您可以更改具有以下特征的片段的长度:右边缘与某个循环片段重叠的范围超过循环长度。
  • 当您轻扫其他轨道的“轨道保护”按钮时,轨道头中的 VCA 轨道将不再意外受到保护。
  • 现在,“自定 LCD”设置中提供了“调号显示”。
  • 现在,您可以在 OS X El Capitan 上关闭“事件浮动”窗口后再重新打开它。
  • 现在,在连按 LCD 中的 MIDI 输出显示时,会将音符关发送至所有软件乐器轨道。
  • 现在,Smart Control 管弦乐布局中的清晰度状态将作为 Patch 的一部分存储。
  • 分开 SMPTE 锁定的片段时,不会再导致某个生成片段的位置出现轻微移动。
  • 如果播放头当前在某个片段的覆盖范围内,则打开此片段的钢琴卷帘时,将启用“跟踪播放头位置”。
  • 现在,您可以将包含加号 (+) 的电子邮件地址与 Gobbler 共享配合使用。
  • 现在,在您恢复屏幕设置时,片段中显示了 MIDI 画笔的垂直自动缩放轨道将保持其原有高度。
  • 对源自已被展平的汇整折叠夹并且包含在锁相组中的片段进行编辑时,将不再导致显示“开始位置不一致”信息。
  • 现在,在从外部控制器调整参数时,Smart Control 参数值标签将随之更新。
  • 删除设定为“不带 MIDI 直通功能的乐器”的 MIDI 环境对象时,将不会再导致新建的对象被分配为“不带 MIDI 直通功能的乐器”。
  • 在小节 1 之前开始的项目中,循环区域的开头不会再意外提前出现。
  • 现在,缩放工具可以正常放大所选区域。
  • 现在,“缩放至窗口大小”键盘命令会在屏幕上垂直居中显示内容(而不是将内容顶部对齐)。
  • 点按一下已冻结轨道上的某个片段时,不会再触发不必要的提醒信息(包含用于解冻该轨道的选项)。
  • 编辑另一个未冻结的轨道并选取“撤销”时,Logic 不会再重新冻结已冻结的轨道。
  • 现在,当您右键点按通道条检查器,并从菜单中选取“分配通道条颜色”时,它将正常调出颜色调板。
  • 如果在较大的循环区域内部设置了自动插入区域,则当播放头移出自动插入边界时,Logic 不再直观地显示其仍处于录制状态。
  • 现在,对于根据先前项目存储的模板,如果已从音频媒体夹中移除了之前的所有音频录制,则在基于该模板派生的项目中,音频片段将从 1 开始进行编号。
  • “跳到位置”窗口中的“新建”栏将继续正确地拥有之前定义的位置(而不是当前位置)。
  • 抓取某个片段时,工具提示将继续显示片段长度。
  • 现在,当您从检查器设置菜单中替换某个通道,然后执行“撤销”操作时,将保留 Smart Control 映射。
  • 现在,在将逗号用作小数分隔符的片段中,向“片段增益”栏中输入大小为 0 或更小的值将正常发挥作用。
  • 现在,当您将片段拖移到当前不在可见区域中的轨道时,Logic 能够更轻松地滚动。
  • 合并轨道中的重叠 MIDI 片段时,不再导致生成的片段中出现意外的多余事件。
  • 现在,在触发“为选定的通道条创建轨道”命令后,将可靠地创建“撤销”步骤。
  • 现在,在所有显示标尺的编辑器中,都可以按住 Command-Option 并点按标尺来切换“自动插入”。
  • 现在,与音符事件位于同一位置的音色变化事件将先可靠发送至项目开始位置并非 1 1 1 1 的项目中的外部 MIDI 乐器。
  • 现在,记事本的字体选择窗口中的纸张颜色选项可以正常发挥作用。
  • 接合两个分别包含 MIDI CC 数据的非连续性 MIDI 片段不会再意外创建附加的 MIDI CC 事件。
  • 当您点按小节标尺中的循环区域以启用或停用循环时,将不再改变项目的结束点。
  • 现在,锁定片段的字形在任何缩放比例下均始终可见。
  • 现在,节拍器 (Klopfgeist) 声音设置会与项目一同存储。 
  • 当您将指针悬停在汇整折叠夹的控制上时,不会再意外显示渐变工具。
  • 现在,使用键盘命令“采集为录音”后,将选中使用该命令创建的 MIDI 片段。
  • 以较高的缩放比例分开音频片段时,不会再在生成的片段之间创建意外的间隙。
  • 现在,在替换模式下进行录制后,组中的所有片段都将被选中。
  • 现在,音频片段的替身能够可靠地置于正确的位置。
  • 现在,如果“显示隐藏轨道”按钮处于活跃状态,则对于 H 按钮处于活跃状态的轨道,所有编辑功能均能够正常发挥作用。
  • 现在,当您从浮动部件箱中选择项目,并且已分配另一个工具时,光标将能够正确显示指针。

已更新的插件

  • 现在,Alchemy 预置的默认星级评分显示为三颗浅灰色的星号。
  • 现在,在 Alchemy 中选择滤波器类型会自动启用该滤波器。
  • 现在,如果载入的预置包含 Logic 无法定位的样本,Alchemy 将显示一条警告信息。
  • 现在,在开始回放前,Alchemy 波形成形器会影响输出。
  • 现在,在项目中的预置已更改但未存储为预置的情况下,Alchemy 可以可靠地载入样本。
  • 现在,EXS 乐器的各区域中的循环渐变在导入 Alchemy 后会得到可靠的维护。
  • 在 Alchemy 中的加法合成模式下,Num-Osc 控制已重命名为 Partials,以便更准确地表示它的功能。
  • 现在,当循环的开始或结束标记位于样本开始或样本结束标记处时,Alchemy 循环渐变将正常工作。
  • 现在,Alchemy 中滤波器 2 的旋钮 3 上的标签可以可靠地显示当前所选源滤波器的标题。
  • Alchemy 中 Retina 显示屏上的文本渲染效果得到改善。
  • 现在,在控制视图中,插件窗口中的立体声链接控制在调整后会以可视方式正确更新。
  • 现在,在插件窗口中,为控制视图和 Smart Control 中的 Alchemy 参数键入一个值时,系统会将此参数正确地设置为您键入的值。
  • 将 Apple Loop 导入 Alchemy 源后,系统将自动对设置进行配置,这样便可以通过任意按键触发循环,并且该循环会以当前的项目速度播放。
  • 现在,您可以移动 Alchemy 插件窗口,即使是在它关闭并重新打开之后。
  • Alchemy“优先级 = 最旧”声部模式现在可以正常工作。
  • 在项目采样速率设置为 96 kHz 的情况下,进行再次回放后,Alchemy 导入浏览器中的采样预览不再改变音高。
  • 现在,在您打开已存项目时,Alchemy 的浏览器将在上次存储项目时所在的同一区域打开。
  • 现在,在您启用“Morph”(变形)模式和“Additive Complex”(加法复合)模式后,如果样本已导入第二个源,Alchemy 将显示“Additive Complex”(加法复合)的正确设置。
  • 如果未启用“已分析”,Alchemy 中的“已分析的共振峰”控制将不再显示为活动状态。
  • 向 Alchemy 中添加新标记时,在文本栏中键入文本不再激活分配给已键入字符的键盘命令。
  • 现在,Alchemy 中的复音调制器可以正常工作。
  • 现在,从一个组切换至另一个组时,在 Alchemy 的键映射编辑器中选择“MIDI”可以正常发挥作用。
  • 现在,点按 Alchemy 源选择器中的“上一个”或“下一个”箭头将启用相应的源(如果该源已停用)。
  • 导入样本时,Alchemy 不再显示不包含受支持音频文件类型的文件夹。
  • 现在,在主显示器小于辅助显示器的双显示器系统上,已关闭的 Alchemy 窗口在重新打开时会调整为合适的大小。
  • 现在,在将软件乐器音高项目设置设定为一个 0.0 音分 (440 Hz) 以外的值后,Vintage B3 Organ 在从立体声切换为单声道时可以协调地演奏。
  • 将 IR 文件拖移到 Space Designer 中以载入文件这一功能现已恢复。
  • Space Designer 中已恢复对倒转功能的支持。
  • 将 Output Mix 推子从放大器移动到 Direct Box 时,Bass Amp Designer 不再输出咔嗒声。
  • 在 Ultrabeat 中,从振荡器样本选择菜单中选择“在 Finder 中显示”选项时,Logic 不再初始化振荡器的参数。
  • 在 Autofilter 中自动将截止滤波器设置为 100% 不再导致间歇性的音频中断。
  • 将指针移动到 Surround Multimeter 插件窗口的左侧,不再导致该窗口意外地在 Analyzer(分析器)模式与 Goniometer(测向器)模式之间进行切换。
  • 现在,“上一个”和“下一个”设置的键盘命令支持 MIDI 插件。
  • 现在,在 Transposer MIDI 插件中定义“用户音阶”这项功能已经恢复。
  • 现在,在 Logic Pro 中创建的使用外部乐器插件的 Patch 可以在 MainStage 中正常打开。
  • 现在,Alchemy 窗口关闭并重新打开后将保持大小不变。

Logic Pro 10.2

Alchemy 简介

Alchemy 是一款包含以下功能的全新样本操作合成器:

  • 具有多个声音发生器(包括相加、频谱、共振峰、粒子、采样器和虚拟模拟)的新一代合成器插件
  • 3,000 多种预置,适用于所有类型的电子音乐,包括电子舞曲、嘻哈舞曲、摇滚乐和图片声音
  • 集成的关键字预置浏览器,用于快速查找正确的声音
  • 性能控件(如“转换板”)可以轻松发现和重塑声音
  • 组合多达四种合成器模块来创建复杂的多层次声音
  • 虚拟模拟振荡器可真实重现标志性的合成器声音
  • 各种模型化模拟和特殊音效过滤器选择可产生具有复古特点和音调复杂性的声音
  • 利用 100 多种调制源(包括灵活的 LFO、AHDSR 和 MSEG 包络以及步进音序器)创建动画形式的动态乐器
  • 利用变形和重新合成工具的独特组合以各种新的方式操作和组合样本
  • 导入 EXS24 乐器,或使用一组强大的采样器功能创建自己的乐器
  • 对四种声音源中的每个声音源应用独立的自动琶音器,将简单和弦变换成精心设计的效果
  • 集成的音效架,包括混响、调制、延迟、压缩和一系列失真效果

更多新功能

  • 直接共享到 Apple Music Connect(需要拥有 Apple Music Connect 帐户)
  • 将文件共享和备份到 Gobbler(需要 Gobbler 第三方订阅)
  • 增加了对 Force Touch 触控板的支持
  • 使用您自己的图像文件创建自定轨道图标
  • 1000 种全新的 Apple Loops,涵盖各种流行乐器和风格,包括 EDM、嘻哈、独立、迪斯科、放克和蓝调
  • 现在,可根据“循环”处于打开还是关闭状态对重叠 MIDI 录音的处理进行独立设置
  • 现在,可以根据“循环”处于打开还是关闭状态来为音频录制独立地设置替换模式
  • 现在,在循环模式下录制音频时,可以使用同一通道条创建新轨道,而不必创建汇整折叠夹
  • 扩展的 MIDI 时钟选项改善了与外部 MIDI 设备的同步兼容性
  • 钢琴卷帘吸附菜单中新增的“按时间量化”选项可设置吸附值,以跟随检查器量化设置
  • 现在,可以使用片段检查器中的复选框或键盘命令对音频片段进行无损倒转
  • 现在提供了用于将挪动值设置为各种音符值的全局键盘命令
  • 现在提供了一个用于切换“清除/恢复独奏”按钮的键盘命令
  • 现在,音频编辑器可以显示应用于已经过弹性调整的片段的渐变
  • 全新的偏好设置“钢琴卷帘:片段边界修剪”(位于“通用”>“编辑”下)可控制能否在钢琴卷帘编辑器中编辑片段边界
  • 现在,“全局轨道标记 Set”菜单中提供了相应的命令,用于将当前选定的标记 Set 转换为编配标记,或将编配标记转换为传统标记
  • 现在新增了一个键盘命令“按片段/事件/选取框来设定定位符并启用循环模式”
  • 右键点按或按住 Control 键并点按 Drum Machine Designer 中的单元格后,可从显示的快捷菜单中打开声音资源库

性能改进

  • 量化大型音频文件的速度更快
  • Logic 执行撤销操作时的性能得到改进
  • 在以下情况下,Logic 不再有时意外退出:
    • 将内容共享到 iTunes 12.2
    • 重新索引循环浏览器中的所有循环
    • 调整片段检查器中的值
    • 导入包含未知的文本编码的 MIDI 文件
    • 在配置面板处于打开状态时退出
    • 在“自定控制条和显示”对话框处于打开状态时关闭项目
    • 创建 64 个以上的辅助通道条
    • 在已安装 V-Control 控制表面的情况下退出
    • 播放期间删除轨道上的所有自动化
    • 在乐谱编辑器中拖移长文本字符串
  • 在以下情况下,Logic 不再停止响应:
    • 在模态对话框窗口已打开的情况下打开乐曲
    • 使用修剪栏调整 Smart Control 自动化
    • Logic 处于隐藏状态,且已连接的控制表面断开连接
    • 停用某个组的锁相音频(以前有时会导致 Logic 停止响应)
    • Logic 处于打开状态,且可供使用的 MIDI 端口增多(以前有时会导致 Logic 停止响应)
    • 退出(以前有时会导致 Logic 停止响应)

主窗口

  • 现在,在同时剪切多个片段时,编辑窗口的位置对所有受影响的片段始终保持相同。
  • 现在,在将 Flex 量化音频片段的左角落向左拖移时,此片段的新显示部分将立即正常量化。
  • 现在,在开始位置早于 1 1 1 1 的项目中,按住 Option 键并拖移以拷贝片段时可将副本放置到正确位置。
  • 现在,可以通过垂直轻扫来影响轨道头中“录音”、“输入”、“静音”和“独奏”按钮的多个实例。
  • 现在,锁定标记可以正确显示锁定符号。
  • 更改从属于音乐套路主轨道的片段的开始位置时,不会再导致意外的时序变化。
  • “重复部分”命令不再截断位于左定位符处的音频循环。
  • 现在,“重复部分”功能在应用于循环片段的循环部分时可以正常发挥作用。
  • 现在,在 Flex 模式下使用选取框工具定义要及时移动的区域后,用户界面将正确更新。
  • 在屏幕较小的电脑上,如果创建了新项目或在现有项目中打开了新的主窗口,轨道检查器不再与通道条检查器重叠。
  • 现在,锁定轨道可防止进行 Flex 编辑。
  • 现在,将片段打包到汇整折叠夹中以后,片段增益值将被保留。
  • 现在,片段增益可以正常应用于锁相音轨上已折叠汇整折叠夹内的汇整片段。
  • 现在,按住 Option 键并点按片段检查器中的参数时,可继续可靠地将其设置为它们的中间值。
  • 现在,在创建空的 MIDI 片段时,MIDI 直通检查器中的所有片段参数都将被正确应用。
  • 当新的 MIDI 录音与现有片段合并后,合并后的片段中包含的音符在录音后不再处于选中状态。
  • 现在,可以从汇整折叠夹中删除单个 MIDI 汇整。
  • 现在,在将 MIDI 录制到已启用“无重叠”模式的现有片段时,新的 MIDI 录音将与现有片段合并。
  • 现在,您可以通过在窗口边框外部点按或使用“配置轨道头”键盘命令进行切换,来关闭轨道头配置面板。
  • 连按轨道头中的声相控制并键入一个值时,不会再导致错误的随机设置。
  • 现在,将轨道头的高度减小为一行时,将显示轨道名称而非轨道/片段自动化按钮。
  • 现在,在轨道列表中停用“附加名称栏”后,轨道命名功能将可靠地发挥作用。
  • 现在,“重复部分”功能可在必要时延伸项目结束点,以容纳更多片段。
  • 现在,在使用“将活跃伴奏导出到新轨道”后执行撤销操作可以正常发挥作用。
  • 使用选取框工具分开循环的片段时,不会再在编辑位置的左侧创建一个额外的片段。
  • 将某个 MIDI 片段拖移到启用了“无重叠”模式的另一个 MIDI 片段上时,不会再导致重叠区域外部的 MIDI 音符被删除。
  • 现在,在锚点已调整到片段开头的右侧的片段中,选取框工具瞬变检测功能可将选取框边框放在正确的位置。
  • 现在,可以同时为所有选定轨道设置图标。

编辑器

  • 现在可以更轻松地在钢琴卷帘编辑器中抓取播放头。
  • 现在,钢琴卷帘量化值将与项目一同存储。
  • 在钢琴卷帘中移动时,在片段开头之前的 ¼ 音符内开始的音符不会再意外吸附到片段开头。
  • 现在,播放头能够可靠地置于钢琴卷帘时间线中已点按的位置。
  • 在将笔刷选作备选工具的情况下,定义笔刷模式不会将主要工具也设置为笔刷。
  • 如果已启用“跟随”并且 MIDI 画笔正在显示 MIDI 延音事件,则在点按某个音符时,钢琴卷帘中的可见位置不会再跳转至播放头。 
  • 如果在钢琴卷帘中拖移某个音符后执行撤销操作,不会再导致项目设置中的“调音”复原至默认值。
  • 更改或刷新屏幕 Set 时,不会再导致钢琴卷帘检查器控制复原至其默认值。
  • 当播放头出离屏幕并且钢琴卷帘处于打开状态时,点按某个片段不再有时导致该片段异常移异常移动。
  • 将“Q-范围”设置为非零值后,钢琴卷帘编辑器中的量化按钮不会再量化未选定的音符。
  • 现在,钢琴卷帘量化模式与在片段检查器中选择的模式相匹配。
  • 现在,“映射的乐器”的按键标签显示在钢琴卷帘编辑器中的键盘上。
  • 选中不同轨道上的多个片段后,使用铅笔工具在钢琴卷帘编辑器中添加的音符将置于当前选定轨道(而非第一个轨道)上的片段中。
  • 现在,在钢琴卷帘中启用折叠模式后,可以使用铅笔或笔刷工具将音符插入到空的片段中。
  • 现在,在启用折叠模式后,关联菜单命令“创建音符”会在钢琴卷帘中点按的位置创建音符。
  • 点按并拖移窗口右边缘时,力度工具会再次导致钢琴卷帘编辑器滚动。
  • 现在,可以继续将 Control + Command 用作修饰键来访问钢琴卷帘中的力度工具。
  • 现在,在钢琴卷帘编辑器与另一个编辑器之间来回切换时,钢琴卷帘编辑器中的时间伸展控制柄将保持可见状态。
  • 现在,在钢琴卷帘中取消选中音符后,时间控制柄将立即关闭。
  • 如果已启用“时间控制柄”选项,则在钢琴卷帘中应用的挪动命令会移动时间控制柄选定部分以及选定的音符。
  • 在钢琴卷帘中,使用缩放工具通过橡皮圈来选择一系列音符时,不会再影响时间控制柄选定部分。
  • 现在,用于在钢琴卷帘中执行压缩或拉伸操作时,时间控制柄选定部分将包含非音符 MIDI 事件。
  • 现在,当播放头位于片段内部时,按住 Option 键并拖移播放头能够在钢琴卷帘中正常进行水平缩放。
  • 垂直定位线继续显示在钢琴卷帘中被拖移的音符开头。
  • 现在,将光标悬停在钢琴卷帘编辑器中某个音符的左边缘或右边缘时,光标能够可靠地切换至“长度改变”工具。
  • 现在,使用笔刷工具来重复现有部分时,将包含源中的非音符 MIDI 事件。
  • 停用锁定模式后,在笔刷工具处于音高锁定模式的情况下输入的音符不会再意外地移调。
  • 使用笔刷工具时,如果通过 Shift 键切换力度模式或锁定音高模式,则 Logic 不会再插入非预期的音符。 
  • 现在,钢琴卷帘检查器中的力度滑块会为笔刷工具添加的音符设置力度。
  • 现在,使用箭头键在音符间进行导航时,钢琴卷帘中的“包括非音符 MIDI 事件”功能将正常工作。
  • 针对分配至 MIDI 通道 1 的事件使用钢琴卷帘中的键盘命令“选定相同通道”时,该命令不会再同时选中同一轨道的所有片段。
  • 在启用“钢琴卷帘和乐谱”偏好设置中的“在以下窗口中限制单向拖移”后,可以继续使用 Shift 键在钢琴卷帘中的水平拖移和垂直拖移之间进行切换。
  • 当备选标尺可见时,“Play Region Solo”(独奏片段)按钮可继续在钢琴卷帘编辑器中正常发挥作用。
  • “选择下一个片段/事件,或者将选取框末端(或框点)移动到下一个瞬变”和“选择上一个片段/事件,或者将选取框末端(或框点)移动到上一个瞬变”键盘命令可以继续在钢琴卷帘编辑器中正常发挥作用。
  • 在钢琴卷帘中选择大量音符不再有时导致意外的噪声。
  • 更改屏幕设置不再导致钢琴卷帘中的量化值设置为 16 分音符。
  • 在“显示”>“用时间表示的事件位置和长度”选项启用后,可以再次编辑事件列表中事件的位置。
  • 现在,可以继续通过在事件列表中按下 Option 和 Shift 键时拖移某个选定事件的值,以将多个事件的通道值设置为 MIDI 通道 1。
  • 如果只选择一种事件类型以开始操作,则事件列表中的“选择相似事件”命令不会再同时选中相对和绝对自动化事件。
  • 现在,在拖移某个事件的值时,即使按下 Option 键使一个或多个事件达到其可能的最小或最大值,也可以继续编辑事件列表中的多个选定事件。
  • Logic 不会再在两个手动插入事件列表编辑器中的控制器事件之间创建插入事件。
  • 现在,音频文件编辑器时间线会针对处于“小节/节拍”视图模式的节拍显示标签。
  • 现在,音轨编辑器中 Flex Pitch 音符周围热点的行为更加可靠。
  • 从一个片段切换至另一个片段后,音轨编辑器中的音高滑块不再有时停止工作。
  • 启用 Flex Pitch 后,如果轨道编辑器中显示多个片段,则选取“全选”将不再高亮显示当前选定片段之外的音符。 
  • 不必再在音轨编辑器中进行滚动,即可针对已调整音高的片段显示音符小节显示视图。
  • 现在,在片段之间切换时,音轨编辑器检查器能够准确显示当前片段的 Flex Pitch 设置。
  • 现在,在乐谱编辑器中的线性视图和页面视图之间切换时,将可靠地继续显示最近所录制片段的内容。
  • 现在,在将相应的 CC64 信息移到片段结尾后,延音踏板关闭符号能够可靠地显示在乐谱中。
  • 现在,上下扫弦符号能够被正确地插入采用 Bravura 字体的奏法记谱法中。
  • 奏法记谱法中静音的符干和菱形头符干不再有时用跨越整页的符干绘制。
  • 现在,整个小节休止符能够在跟随拍号变化的片段中的正确位置可靠显示。
  • 现在,在将踏板事件插入乐谱后,乐谱部件箱中高亮显示的延音踏板符号将在“打开”和“关闭”之间交替切换。
  • 现在,乐谱编辑器中的 MIDI 画笔能够可靠地显示所有可用参数的名称。
  • 现在,重复“部件箱:4 分音符”、“部件箱:8 分音符”等的键盘命令时,可在相关的附点音符值和三连音符值之间循环切换。
  • 现在,音符名称可以在使用非 serif 字体的音符头内部正确地居中显示。
  • 现在,如果将 MIDI 片段转换为 Drummer 片段后使用了“撤销”命令,编辑器可以正确地切换回 Drummer 编辑器。
  • 现在,在将某个 Drummer 片段从一个 Drummer 轨道移动到另一个 Drummer 轨道后,Drummer 编辑器能够正常更新。
  • 现在,可以使用实时 MIDI 输入为变换窗口中相应的输入栏定义 MIDI 音高。
  • 现在,在关闭逐个输入窗口后,键盘命令“延音插入的音符”可以正常发挥作用。
  • 现在,无法再使用“八度音程 - 1”键盘命令将逐个输入键盘设置为允许的 MIDI 最小范围 C-2 以下的八度音程范围。
  • 现在,环境对象可以自由放置在窗口中。

混音器

  • “还原通道条”命令现在适用于混音器中所有选定的通道条。
  • 现在,混音器可显示选定音轨的录音就绪状态。
  • 按住 Option 键并点按通道条 VCA 插槽时,可将通道条添加到新创建的 VCA。
  • 现在,将“显示”>“混音器”>“峰值保持时间”偏好设置设定为“无穷大”后,点按通道条指示将清除所有通道上的峰值保持显示。
  • 现在,连按 Logic 混音器中的外部 MIDI 音量推子时,可正常地将其值设置为 90。
  • 现在,按住 Option 键并点按混音器中的数字音量显示时,可将其设置为 0dB。
  • 现在,在混音器中连按已分配至单声道输出的通道条的输出插槽时,会正确地选中相应的单声道输出通道条。

自动化

  • 现在,可以更轻松地抓取和向上拖移由自动化主道底部的两个点定义的自动化线。
  • 如果轨道的音量自动化已可见,则新的自动化主道不再设置为“音量”。
  • 调整片段的左角落后,基于片段的自动化不会再被意外移动或删除。
  • 现在,在接合最初从一个连续片段分开的片段时,将针对所有片段正确地保留基于片段的自动化。
  • 此更新改善了在片段开头移到第一个自动化点右侧的情况下,对基于片段的自动化进行处理的效果。
  • 在片段中间开始回放后,采用基于片段的自动化的“自动化 Write”模式不再创建意外的自动化斜坡。
  • 现在,在同一通道中写入不同的参数后,采用基于片段的自动化的“自动化 Write”模式能够可靠地使上次使用的参数位于前端。
  • 对于添加到已关闭的自动化主道的自动化节点,除非该主道重新开启,否则这些节点不再回放。
  • 如果不存在包含整个轨道的片段,则在将基于轨道的自动化转换为基于片段的自动化时,不会再创建意外的轨道自动化斜坡。
  • 现在,在 Latch 和 Write 模式下写入后,音量自动化能够正确地保持上次写入的值。
  • 现在,使用“导出活跃伴奏”或“移动活跃伴奏”命令时,基于片段的自动化能够正常导出或移动。
  • 现在,在选取框所选内容右侧创建的自动化节点能够可靠地放在正确位置。
  • 现在,当锚点已在左侧片段中偏移后,用于在重叠片段边界设置自动化点的命令可以正确地放置最右侧片段开头的各点。
  • 将基于轨道的自动化转换为基于片段的自动化后,不再有时创建带有“显示关闭”标记的自动化主道;反之亦然。
  • 现在,外部乐器轨道上的自动化可以在基于片段的自动化与基于轨道的自动化之间进行转换。
  • 现在,在使用开始位置位于小节 0 之前的项目中的轨道头控制进行修剪时,基于片段的自动化能够直观地进行更新。
  • 将基于轨道的自动化与片段一同移动时,不再有时导致开始位置位于小节 1 之前的项目中出现意外的自动化斜坡。
  • 在接合两个均包含基于片段的自动化的重叠片段后,Logic 不再有时创建额外的意外自动化点。
  • 在使用铅笔工具添加基于轨道的自动化时,更改方向不会再在自动化中产生意外的峰值。
  • 现在,即使导入的轨道不包含自动化,这些轨道仍包含音量和声相电平。
  • 现在,在启用了“MIDI”>“通用”>“控制更改 7/10 控制通道条对象的音量/声相”项目设置的乐曲中,相对自动化可以正常发挥作用。
  • 在 Touch 模式下添加第二个自动化点时,自动化视图不会再错误地切换以显示 Read 模式。
  • 写入新自动化时,不会再将现有自动化设置为外部 MIDI 乐器。
  • 如果轨道设置为基于片段的自动化模式,则在关闭自动化视图后,Logic 不会再切换到写入基于轨道的自动化。 
  • 现在,如果较长的片段与较短的片段完全重叠,则在播放头通过短片段的右边缘后,Logic 会继续将基于片段的自动化写入较长的片段。
  • 现在,无论“MIDI”>“通用”>“控制更改 7/10 控制通道条对象的音量/声相”项目设置是否已启用,均会始终显示静音自动化开关点的位置。
  • 在 Touch 模式下释放推子后,自动化不会再意外地在斜坡时间的开头短暂跳跃。
  • 现在,Midi 画笔能够在乐谱和钢琴卷帘编辑器中显示弯音和声相的正确音阶。
  • 现在,在 Touch 模式下写入其相应参数的自动化后,Smart Control 能够可靠地更新。 

插件

  • 无需再点按两下另一个应用程序,即可使其位于 Logic 插件窗口的前端。
  • 现在,在调整 Drum Machine Designer 插件窗口的大小时,窗口右上角会以百分比形式显示当前大小。
  • 存储并重新打开项目后,已在 Drum Machine Designer 插件中重新排列的鼓件单元格的新位置将被保留。
  • 现在,BPM Counter 能够在控制视图中正确显示速度。
  • 无需再按下 Return 或 Enter 键,即可确认在插件管理器中创建的新文件夹的名称。
  • 点按通道条插件插入插槽时,名称中包含“/”的插件管理器类别不会再多次显示。
  • 现在,Logic 轨道名称和编号会在 Softube Console 1 插件中正常显示。
  • 打开包含超过 256 个样本的 Omnisphere Patch 时,Logic 不再显示“打开的文件太多”错误信息。
  • 在德语环境中运行 Logic 时,可继续自动处理 Apple AUPitch 插件的“音高”参数。

共享与导出

  • 现在,从 Logic 导出到 Final Cut Pro X 的项目 XML 文件能够可靠地保持正确的采样率。
  • 现在,在导入 Final Cut Pro X 项目 XML 时,Logic 能够将缺少时间位置信息的音频片段放在音频媒体夹中。

辅助功能

  • 现在,可以使用 VoiceOver 访问事件列表中的过滤器按钮。
  • 现在,可以使用 VoiceOver 访问钢琴卷帘检查器中的力度滑块。
  • 现在,可以通过 VoiceOver 访问轨道头中的音量滑块。
  • 现在,可以通过 VoiceOver 访问混音器中的音量推子和总线发送旋钮。

同步

  • Logic 在停止后不再发送 MIDI 时钟,从而改进了与 MIDI 硬件设备的同步性能。
  • 现在,MIDI 时钟乐曲位置指针能够在循环模式下正常工作。
  • 现在,在启用“循环”并将“循环预处理”偏好设置设定为“关闭”后,MIDI 时钟传输能够正常发挥作用。
  • 如果在停止 Logic 后拖移播放头,Logic 不再发送 MIDI 时钟数据。
  • 现在,在选择 30 fps(非丢帧)后,Logic 显示的帧速率警告将提供“不再显示”选项。
  • 现在,连按走带控制中的时间显示并键入 SMPTE 位置后,会将播放头移动至设置了 SMPTE 偏移的项目中的正确位置。
  • 现在,在将“显示时间”设置设定为“SMPTE/EBU 带子帧”后,“同步”>“通用”项目设置窗口中 SMPTE 栏上的演奏将显示正确的时间。
  • 导入带有嵌入式音频的影片时,不会再导致 SMPTE 意外锁定项目中的现有音频片段。

控制表面

  • 现在,Touch OSC 可以访问未分配给轨道的辅助通道条。
  • 未分配给轨道的通道条不再用已连接的控制表面上的轨道编号进行标记。
  • 现在,“点抹掉”按钮适用于 Mackie C4 控制表面。
  • Logic 在启动后能够可靠地识别 Mackie Control 控制表面。
  • 将 Logic 控制滚轮转到右侧时,不再有时导致播放头跳转至项目结尾处。
  • 现在,可以继续使用 Emagic Logic Control 硬件上的左右光标键来逐步执行各个参数。
  • 现在,“全选”和删除操作可以在“控制表面设置”窗口中正常发挥作用。
  • 现在,控制表面“成对组”参数适用于并非由 Logic 直接支持的控制表面。

其他更新

  • 此更新包括各种针对 Patch 及内容相关问题的修复。
  • 恢复 Patch 后,存储为 Track Stack Patch 的多音色乐器不再作为单独的乐器载入。
  • 现在,无论“循环”和“循环预处理”设置如何,在项目开头之前演奏的 MIDI 音符的“宽限期”继续始终为四分音符。
  • 现在,存储到 iCloud Drive 的项目将显示在 Logic 的最近文件列表中。
  • 现在,可以使用鼠标滚轮或触控板对偏好设置窗口中的滑块进行增量式调整。
  • 现在,“正常化片段参数”键盘命令可以正确地更改软件乐器轨道片段内的事件的 MIDI 通道。
  • 现在,“使用重复设置新建轨道”菜单命令和键盘命令适用于 Drummer 轨道。 
  • 现在,始终能够正常取消 Flex 分析。
  • 现在,可以将项目模板设置为包含小数的速度。
  • 现在,在 Logic 10.1 之前的版本中创建的软件乐器循环可以正常回放。
  • 现在,拖入“项目音频”窗口中的新文件将放在列表底部。
  • 现在,当音符跨越将 MIDI 片段分开的点时,对话框中会出现“取消”按钮。 
  • 现在,活动音乐套路连接能够与量化的音频片段正常配合使用。
  • 现在,环境中的物理输入对象将显示每个端口的设备名称以及端口号。
  • 当多个全局轨道可见时,调整全局轨道的大小不再有时导致图形问题。
  • LCD 中继续显示等份值 1/192。
  • 现在,键盘命令“将上一个点按的参数减小 1”和“将上一个点按的参数增加 1”适用于钢琴卷帘的窗内检查器、乐谱编辑器、轨道头通道条以及混音器通道条。
  • 现在提供了一个关联菜单和键盘命令,用于针对所有选定片段删除所有基于片段的自动化。
  • 现在,如果存在多个速度 Set,则可以删除第一个速度 Set。
  • 现在,通过点按速度轨道背景中的任意位置,能够可靠地取消选中速度轨道中选定的速度事件。
  • 现在,可以将速度列表中的速度事件拷贝/粘贴到速度轨道中的一个新速度 Set。
  • 点按速度轨道中的某个速度事件不会再选中上一个事件,即使该事件为同一值也不例外。
  • 现在,通过点按速度列表中的“+”按钮创建的速度事件会立即显示在速度轨道中。
  • 如果项目的 SMPTE 格式并非 25 fps,则抹掉项目中的第一个节拍映射事件时,不再导致第一个速度事件的 SMPTE 位置移动。
  • 现在,如果标记轨道的高度足以容纳多行文本,则标记文本可以绕排到下一行。
  • 现在,在选取一个新的标记 Set 后,时间线中显示的标记能够正常更新。
  • 关闭标记列表编辑器后,在恢复屏幕设置或重新打开关闭后存储的乐曲时,该编辑器不会再次出现。
  • 现在,速度轨道中的第一个点将正常显示。
  • 将 MIDI 端口设置为“所有”时,可以继续了解 MIDI 命令。
  • 现在,“设定定位符”和“跳到位置”对话框允许以时间码格式以及小节和节拍格式输入位置。
  • 创建一个包含软件乐器轨道的新项目,并停用“打开资源库”选项后,“音乐键入”窗口将不再打开。
  • 将两个 SMPTE 锁定片段粘合在一起时,MIDI 事件不再有时消失。
  • 现在,“合并与获得伴奏”的“音频”>“编辑”>“交叉渐变曲线”偏好设置能够正确地影响伴奏时创建的交叉渐变。
  • “重复部分”命令不再导致播放头更改位置。
  • “按标记和启用的循环来设定定位符”可继续正常发挥作用。
  • Logic 项目能够继续可靠地显示 Quick Look 预览。
  • 当光标位于检查器中时,按下 Option 键不再错误地将光标更改为缩放工具。
  • 现在,在处理一些音频后,如果“Time & Pitch Machine”窗口具有焦点,则用于控制走带控制的键盘命令可以正常发挥作用。
  • 移动编配标记不再有时导致受保护的文本标记被删除。
  • 如果启用了“循环”,Logic 将忽略选定的片段,并只使用其范围来确定在将音频导出至影片时应包含的项目部分。 
  • 现在,“映射的乐器”上的 MIDI 输入显示会更新为显示上次弹奏的音符。
  • 选定的片段不会再因更改为另一个屏幕设置或重新载入乐曲而发生意外更改。
  • 现在,“用于合并的音频交叉渐变选项”键盘命令可以打开正确的偏好设置面板。
  • 如果在导入轨道后执行撤销步骤,不会再意外将标记颜色更改为默认颜色。

了解详情

有关非 Apple 制造的产品或非 Apple 控制或测试的独立网站的信息仅供参考,不代表 Apple 的任何建议或保证。Apple 对于第三方网站或产品的选择、性能或使用不承担任何责任。Apple 对于第三方网站的准确性和可靠性不作任何担保。互联网的使用具有一定风险。请联系供应商以了解其他信息。其他公司和产品名称可能是其各自所有公司的商标。

发布日期: