Logic Pro X 10.3 发布说明

了解当前和之前的 Logic Pro X 10.3 更新的内容。 

更新 Logic Pro X 之前,请务必备份当前安装的 Logic Pro 应用程序和您的 Logic Pro 项目。

Logic Pro X 10.3.2 中的新功能

新增功能与增强功能

  • 添加了三名新鼓手,分别以“流行”、“原创”和“拉丁”风格演奏打击乐器。   
  • 向您的项目添加新的鼓手乐段,然后使用演奏控制对这些乐段进行自定义。
  • 音频片段的 Pitch 现可以移调或微调。
  • Alchemy 包括了自动时间对齐功能以改进变形。
  • Alchemy 中新的加法音效可展开过滤和调制声音的选项。
  • 现在提供了一个键盘命令以“拷贝定位符之间的部分(全局)”,这个命令将拷贝定位符之间的所有内容,而不管是否选中。
  • 在 Flex Pitch 中,现在提供了一个关联菜单项,可以重置所有当前选定片段中的所有 Flex 变音音符。
  • 增加了对在 Scripter 中创建瞬间按钮的支持。
  • 环绕声声相器和环绕声平衡器已经使用支持 Retina 的全新界面进行了更新。
  • 在琶音器中,现在可以调整图案网格中各个音级的长度。
  • 在“环境”中按住 Option 并点按“MIDI 监视器”对象时,现在将清除项目中所有“MIDI 监视器”对象的内容。
  • 现在提供了一个键盘命令来切换“帮助”标签。
  • 显示/隐藏备选轨道时,按下 Option 现在将切换所有轨道的设置。
  • 现在可以将 L 和 R 控件链接到双单声道插件。
  • 现在提供了一个键盘命令“移除渐变”。
  • 现在提供了一个“音频”>“通用”偏好设置来保留自动分配的下降数字总线。
  • 在插件窗口中关闭时,按住 Shift 并点按,现在将关闭所有打开的插件窗口。

详细了解 Logic Pro X 中的新功能。

稳定性和可靠性

  • 在所用的选取框所选内容上使用“将所选片段拷贝到所选轨道”命令后,执行撤销时 Logic Pro 不再意外退出。
  • 进行以下操作时,Logic Pro 不会再意外退出:
    • 在链接关闭并且资料库打开的情况下,在钢琴卷帘中使用铅笔工具插入音符后,使用“重复片段/事件”命令。
    • 打开包含 Camel Audio Alchemy 1.5 和 Logic Pro X Alchemy 实例的项目。
    • 在音轨编辑器中移动包含一组 Flex 标记的选中选取框。
    • 当音乐键入窗口和鼓手编辑器打开时,选择一个新下载的鼓机 Patch。
  • 在没有其他窗口打开的情况下,将音频导入到独立的项目音频窗口时,Logic Pro 不再挂起。
  • 进行以下操作时,Logic Pro 不会再挂起:
    • 在资料库中的某些 Patch 之间切换时。
    • 将多个片段拷贝到快速继承中的“轨道”区域。
    • 在音频文件编辑器中使用更改增益功能。

性能

  • 提高了在执行以下操作时图形用户界面的响应能力,特别是使用 Retina 或其他高分辨率显示器时:
    • 调整窗口和区域的大小。
    • 拖动和修剪片段。
    • 打开和关闭钢琴卷帘编辑器。
    • 在大型项目中进行缩放和滚动,特别是那些包含大量 Flex 编辑或速度事件的项目。
    • 使用向上/向下箭头键逐步执行轨道。 
    • 当逐步编辑器也打开时,调整事件列表中多个选定事件的参数。
    • 使用 EuCon 控制表面选择包含 Flex 编辑的已编组轨道。
    • 调整片段边界。
  • 在播放时使用 Flex Pitch 在音频片段中调整片段参数,不会再导致突发的噪音。
  • 索引“Apple 乐段”资料库现在要快得多。
  • 改进了 Alchemy 的频谱编辑器和其他实时显示中的性能。
  • 使用 Force Touch 触控板拖动片段时,不会再导致触控板意外振动。
  • 在包含大量速度变化的项目中,音频量化的速度现在要快得多。

Alchemy

  • Alchemy 增加了五种新的加法效果:锯切+噪音、噪音、梳状、EQ、过滤、扫弦、声浪加上额外的脉冲/锯切控制。
  • Alchemy 添加了 12 个新的合成共振峰过滤器形状。
  • Alchemy 现在在变形处理时将自动调节来源。
  • Alchemy 现在在噪音部分提供调谐控制。
  • Alchemy 的调制器现在拥有一个新的触发模式,允许在所有新 MIDI 音符上重新触发效果参数。 
  • “Alchemy 音符属性”菜单“步进 4”、“步进 8”和“步进 16”中添加了新选项。这些选项的功能与 Flip Flop 属性相似,但会产生一个调制信号,可以在连续的音符之间循环相等的间隔值。
  • 在 Alchemy 琶音器的周期复位中,“键盘触发器”菜单中添加了一个设置,以确保样式始终从序列器的步进 1 的第一个音符开始。
  • Alchemy 中的浏览器现在包括“新于”和“旧于”列选项,以根据内容的安装日期限制预设列表。 
  • Alchemy 中琶音器的新实例的默认速率现在是 1/16。
  • Alchemy“绝佳质量”模式中的部分最大数量从 128 个提高到 256 个。
  • Alchemy 增加了 21 个新的琶音器预设。
  • Alchemy 用于脉冲/锯切 - 同步,移位 - Patch 和磁性 - Patch 的加法效果旋钮现可在编辑时显示半音。
  • Alchemy 音效架中的音效现归为多个类别。
  • 拷贝/粘贴调制现在包括分配给所有相关深度旋钮的完整路由。
  • Alchemy 的按键切换现在默认为 KEYSW1 而不是 SNAP1。
  • 当有超过 30 个标记需要显示时,Alchemy 区域编辑器现仅显示每 10 个标记,以此处理大量弯曲标记的显示。
  • Alchemy 界面现在可以在宽屏彩色 P3 显示屏上立即响应鼠标输入。
  • Alchemy 使用的存储空间比以前的版本减少 40%。
  • 导入 Alchemy 的 Apple 乐段现在可保持可靠地同步。
  • 当从琶音快照转换为非琶音快照并返回时,琶音器现会切换回开启。
  • 改善了频谱拉伸在低速下的声音质量。
  • 在 Alchemy 的“变形 XY/Lin”模式下,“自动增益”设置为“关”。
  • 现在可以用 Arp Mod 调制 Alchemy 的 Keyswitch 旋钮。
  • 当导入 MIDI 文件时,Alchemy Argeggiator/步进音序器中的最后一个步进不再意外绑定。
  • 在频谱模式下,调整云频谱效果中的简化控制不会再取消效果。
  • 分配给映射到 Alchemy 中的样本的 Keyswitch 旋钮的随机音符属性调制器现在可以正确地随机化按键开关。
  • 在 Alchemy 延迟效应中将梳状滤波器的反馈值设置为 99% 或更高不再会导致不受控制的反馈。
  • 当音色计数器设置为 1 时,如果播放了 Patch 中的两个音符,FM Keyfollow 现在可以正常缩放。
  • 当导入 EXS 乐器时,Alchemy 现在将映射到相同按键开关或清晰度的 EXS 组合并。
  • Alchemy 中的浏览器现可在从一个预设切换到另一个预设时,保留用户的列选择。
  • Alchemy 音效架中的波形成形器双极按钮再次可正常工作。

Drummer

  • 在播放过程中,切换鼓手角色不会再导致鼓手在演奏停止并再次启动之前停止演奏。
  • 在更换鼓套件时,Drum Machine Designer 轨道上的记录按钮不再意外禁用。
  • “复制轨道”命令现在适用于分配给 Drum Machine Designer 或 Drum Kit Designer 制作者套件的鼓手或软件乐器轨道。 
  • Drum Machine Designer 轨道现在总是在“轨道”区域中显示为可扩展 Track Stack,以便子轨道立即可用于自动化或其他任务。 
  • 按住 Option 并拖动使用 Drum Machine Designer 的鼓手或软件乐器轨道现在可以正确创建包含所有套件的轨道。

自动化

  • 已编组轨道的自动化现在可以在“项目设置”>“MIDI”>“通用”>“控制更改”下 10 个控件中的第 7 个控制通道条对象的音量/平移的设置处于活动状态时正常工作。
  • 当将汇整折叠夹解包到“备选轨道”时,基于片段的自动化现将保留。
  • 在项目起始位置调整后进行编辑,自动化点不会再跳转到意外的位置。
  • 当循环返回到开始点时,音量自动化将按预期重置
  • 当使用选框工具同时选择并调整多个轨道上的自动化时,相对自动化水平将再一次保留。 

Flex

  • 具有 Flex 编辑的音频片段,如果启用了“将编辑吸附到过零点”,不会再将分割片段迅速恢复原始长度。
  • 从 Flex Pitch 片段创建的 MIDI 音符的力度现在可以从 0-127 正确调整。
  • 移调片段参数现在可用于 Flex 片段。
  • 如果启用了“选定片段时同时选定轨道”偏好设置,则当 Flex Pitch 被抓取时,不再显示为 Pitch 偏移。
  • 任何音频片段的 Pitch 现可以移调或微调,而不再仅限 Apple 乐段。
  • 当 Flex Pitch 启用时,音频片段不会再稍微偏移。

渐变

  • 当调整交叉渐变的右边部分时,不再选中左边的片段,以避免对以前的交叉渐变进行意外编辑。
  • 在播放过程中创建渐变时,渐变现在可以立即生效。

Multi-Touch Bar

  • 在导航模式下,在 Multi-Touch Bar 上用两根手指滑动即可重新定位可见框架,而不会移动播放头。
  • 当没有打开的窗口时,全局调命令现在可以在 Multi-Touch Bar 中使用。
  • Multi-Touch Bar 上的键盘命令标签现在可以占据两行,以使其更容易阅读。
  • 当节拍器禁用并启用预备拍时,Multi-Touch Bar 上的节拍器按钮现在会变暗。
  • Multi-Touch Bar 鼓垫不再会通过本应触发具有 C#2 音符的长鸣铙钹的按钮触发重复 C#1 音符。
  • 当 Multi-Touch Bar 键盘设置为旋律小调计时,某些音符在演奏下行音阶时不再挂起。
  • 当“键盘命令”窗口打开时,如果在 Multi-Touch Bar 上轻按键盘命令,现在可以在窗口中选择该命令,而不是触发该命令。
  • Multi-Touch Bar 现在可以正确显示“按片段来设定定位符”键盘命令的字形。
  • 按下修饰键现在切换 Multi-Touch Bar 以显示分配给这个修饰键的键盘命令。

汇整与伴奏

  • “将片段吸附到相对值”设置现在可在汇整折叠夹内正常使用。
  • 当点按汇整折叠夹的右侧边缘时,显示的当前伴奏中未使用音频将不会再与轨道中的下一个片段重叠。
  • “展平和合并”现在的功能相同,无论是从汇整折叠夹的 Widget 触发还是使用键盘命令。

备选轨道

  • “显示/隐藏不活跃的备选轨道”现在可在所有选定的轨道上使用。
  • 现在可以通过轨道头中点按两次轨道的名称来重命名备选轨道。
  • “取消全选”命令现在将取消选中所有隐藏的不活跃备选轨道。
  • 对“将所选片段拷贝到所选轨道”命令执行撤消之后,当前活跃备选轨道中的片段不会再丢失。
  • 执行“重复部分”命令不再会导致不活跃的备选轨道被意外地重命名。
  • 当某些轨道具有备选轨道,而其他轨道不具备时,现在可按照预期选择群组中所有轨道的片段。
  • 通过按住 Option 并将轨道拖拽到新的空轨道,隐藏的备选轨道现在按照预期拷贝。
  • 当目前所选的轨道不包含备选轨道时,“隐藏所有备选轨道”键盘命令现在也可以使用。

Track Stack

  • 现在,重复 Track Stack 中的软件乐器轨道将保持正确的轨道名称。
  • 当选择 Track Stack 中的最后一个轨道时,使用“使用同一个通道新建轨道”命令现在会把新轨道放置在 Track Stack 中。
  • 当选择“移调”和“力度”时,总和堆栈的主轨道不会使 MIDI 直通的数值翻倍。
  • 当按住 Option 并拖拽软件乐器 Track Stack 以进行拷贝时,轨道名称现将被正确保留。

混音器

  • 现在可以使用鼠标、在 Magic Mouse 上使用滑动手势或在触控板上使用双指滑动来调整立体声声相器的声相或展开位置。
  • 当拷贝带记录保护的轨道时,新创建的轨道现在也会受到保护。
  • 现在添加了用于立体声轨道的音频硬件设备控件。
  • 当轨道设置为“独奏安全”时,轨道头中的独奏按钮现在将始终显示
  • 点按独奏安全轨道的轨道头中的独奏按钮将不再禁用“独奏安全”。
  • 如果项目中有拆分立体声文件,则“项目音频”窗口中的“编辑”菜单现在提供断开所选的拆分立体声文件或重新连接所有拆分立体声文件的选项。
  • 录制开始后,受保护轨道上的 R 按钮现在可以继续闪烁。
  • 当插件旁通时,具有单声道插件的立体声轨道现在将继续播放单声道音轨。
  • I/O 标签现在与“新建轨道”窗口中的正确硬件输出相关联。
  • 使用“软件乐器”轨道作为侧链输入的插件保存的 Patch 现在在重新加载时能够正确调用侧链设置。
  • 保存为辅助通道条设置一部分的双声道插件在设置重新加载时不再转换为立体声。
  • 加载 Patch 不再擦除轨道中的现有轨道音符。
  • 已经从立体声设置为单声道的轨道上的双单声道插件现在将立即切换到单声道模式。
  • 混音器中的“创建轨道”命令现在可以正常工作。
  • 当将新通道发送到辅助通道时,插入作为总和总线的辅助通道的插件干电平不再意外设置为零。
  • 包括发送的软件乐器通道条中演奏的第一个音符不再包含意外的大量混响。
  • 低延迟模式现在可以在输出 1–2 上未插入插件的输出通道中正常工作。
  • 包括传送到名称中包含斜杠 (/) 的通道的用户 Patch 现在可以正确加载。

插件

  • 将 EXS 乐器导入 Ultrabeat 时,将再次显示向上/向下箭头以浏览样本区域。
  • 通过拖动界面中的垂直辅助线进行的通道均衡中的带宽调整现在反映在通道条 EQ 缩略图中。
  • 如果琶音器在运行时接收到一组新的音符,将如预期重新开始。
  • 现在提供了一个偏好设置来控制最新使用的插件是否显示在插件列表中。
  • 当链接到外部驱动器上文件夹的默认位置上有一个替身“Sampler Instruments ”文件夹时,EXS24 现在可以按预期查找 Sampler Instruments。
  • 插入了 MIDI 插件的软件乐器通道条不会再停止播放。
  • 当未选择通道条时,自动播放的 Patch 现在将继续运行。
  • 现在可以通过在“基于采样的处理”窗口按住 Option 并拖拽以拷贝/替换插件。
  • 增加了调制器 MIDI 插件的输出清晰度。
  • 现在提供了一个专用按钮用来切换环绕声声相器插件中的分离。
  • 撤销更改通道条中插件的位置不再撤消在插件上执行的最后一个参数更改。
  • 当 EXS24 配置为在接收到某些 MIDI 音符时更改乐器,发送到 Drum Designer 实例的相同音符不再会导致预设更改。
  • Ultrabeat 的“语音自动选择”功能现在适用于静音音符。
  • EXS24 选项“从由音频片段创建的乐器中提取 MIDI 片段”现在始终可用。
  • 在 Sculpture 出厂默认设置中更改参数值现在将激活“比较”按钮。
  • 将 EXS 乐器文件从 Finder 拖到 Ultrabeat 界面上时,现在将显示可见的反馈。
  • 如果调制器 MIDI 插件的多个实例设置为输出随机波形,在项目关闭并重新打开后,现在将输出不同的波形。
  • 对调制器 MIDI 插件的多个实例的调制定时现在可保持同步。
  • Retrosynth 插件设置现在包括第四个调制滑块和目标。
  • EXS24 现在提供适用于群组的“样本选择随机偏移”设置
  • 当 Drum Machine Designer 打开时,通过点按两次轨道头中最后一个轨道下方创建新轨道,Drum Machine Designer 界面不再意外更改。
  • 在重新加载用户创建的 Patch 时,Drum Machine Designer 中单元格的自定义排列现在将保留。
  • Correlation Meter 插件中的衰减时间现在可以调整为慢、中等或快。
  • Loudness Meter 在并轨项目后现在将继续显示值。
  • EXS24 中的“样本随机选择”在使用力度值 127 演奏的情况下更好地随机抽取样本。
  • 如果在其他文件夹中有另一个具有相同文件名的乐器,EXS24 现在将显示乐器的正确路径。
  • Ringshifter 插件现在提供了延迟低切和延迟高切控件。
  • 在设置控件数值后拖动控件不会再导致设置值在某些 Logic Pro 插件中跳转到原始值。
  • Peadalboard 插件中的 Retro Chorus 踏板在较高的深度设置下不再显示过大的晃动。
  • 当光标悬停在通道 EQ 的显示区域上时,现在将显示所有频段的中心手柄。
  • 如果没有保存的“表现通道条”设置,程序更改现在将传递给“软件乐器。
  • 当选择用户音阶后,MIDI Transposer 插件现在可以播放正确的音符。
  • 现在,在改变插件时,资料库总是按预期进行更新,并将焦点放在插件预设上。 
  • 在 Scripter 中设置为只读的参数不再写入自动化。
  • 定义为只读的 Scripter 参数将不再写入自动化数据。 

基于所选部分的处理

  • 对于使用选取框选择的循环片段的部分,如果应用基于所选部分的处理,现在将仅影响所选择的区域。
  • 基于所选部分的处理现在会识别先前保存在新打开的项目中,使用选取框选择的区域。
  • 当使用 Command - 句号 (.) 取消基于所选部分的处理操作时,基于所选部分的处理通道条将不再保留在轨道区域中。

全局

  • 在“传输拍号显示”菜单中设置节拍编组现在可以正常工作。
  • 现在又可以拷贝锁定标记的时间码位置。
  • 将片段从“轨道”区域拖动到“标记全局轨道”时,现在提供一个可见的指示。
  • 按住 Command 并点按“标记”轨道中的标记以将其添加到当前选择。
  • 现在又可以按住 Option 并拖动拍号以进行拷贝,而不是简单地移动它。
  • 使用鼠标滚轮缩放不再会取消选择“全局轨道”中的项目。
  • 当“全局轨道”关闭时,按住 Command 并将标记拖动到时间尺现在将启用循环,并将定位器设置为标记所包含的范围。
  • 向右拖动标记现在将始终有效。
  • 为“标记”列表中先前已被删除的“标记”轨道中的标记命名时,Logic Pro 不再意外退出。
  • 当添加新的拍号时,分子栏位再次将被预先选择。

导出和共享

  • 导出的 Music XML 文件现在与 Dorico 更加兼容。
  • 速度事件现在将可靠地包含在导出的 MusicXML 文件中。
  • 如果在询问“是否导入对共享到 GarageBand(iOS 版)的项目进行的更改”的对话框第一次出现是选择“否”,这个对话框将不再显示。 
  • 当选择“导出循环范围”选项并且“小节范围”是“样式”所选择的元素之一时,“导出轨道”对话框中的“文件名示例”现在可以反映实际的循环范围值。
  • 包含“小节名称”元素的导出轨道的文件名现在更加可靠地格式化,有时将被缩短。
  • 当启用旁路效果选项时,现在可以使用音频尾部并轨。 
  • 在 Dorico 中打开时,从 Logic Pro 导出的 Music XML 文件包含 TAB 五线谱风格。
  • Bounce-in-place 现在适用于 Drum Machine Designer 和 Drum Kit Designer Track Stack。
  • Bounce-in-place 现在适用于分配给接收多出软件乐器输入的辅助通道的轨道上的 MIDI 片段。

导入

  • 当导入包含多通道音频文件的 Final Cut Pro XML 项目时,Logic Pro 现在可以可靠地保持通道分配。
  • 现在大型 Final Cut Pro XML 文件的加载速度更快。
  • Final Cut Pro X XML 文件现在可以可靠地使用正确的子角色名称导入。
  • 当导入 FCPX XML 文件时,Logic Pro 现在为每个父角色创建一个总和堆栈。
  • 现在可以从目前活跃备选轨道为空,但其他备选轨道具有内容的轨道导入内容。
  • 当导入具有已分配的发送和汇整折叠夹片段的轨道时,如果您选择重新发送以发送到现有的辅助轨道,用于管理发送这些发送折叠夹的对话框现在仅出现一次,而不是在每个任务中重复出现。 

Logic Remote

  • “立体声延迟”插件中缩小和加倍延迟长度的按钮的标签现在能够在 Logic Remote 中正确标记。
  • “磁带延迟”插件中的“同步时间”控件现在在 Logic Remote 中可见。
  • 在 Logic Pro 中更改轨道顺序后,Logic Remote 现在将立即更新混音器和 LCD 中的音轨显示。
  • Logic Remote 现在可以可靠地显示所有插件参数。

控制曲面和 MIDI 控制器

  • Crumar Mojo 控制器现在可用于控制复古风琴。

辅助功能

  • VoiceOver 现在可以根据 Logic Pro 是否正在演奏,准确地说明“停止/跳到开头”按钮的功能。
  • VoiceOver 现在将正确地说明列表编辑器中单元格的内容,而不是列的标题。
  • 现在有可以使用 VoiceOver 选择鼓手。

乐谱

  • 改进了在乐谱中捕捉对象的行为。
  • 乐谱中的“开关显示”键盘命令现在可以在所有三种可用的视图模式之间切换。
  • 即使“全局轨道”被隐藏,标记现在也会显示在乐谱的标尺中。 

编辑

  • 使用 MIDI 画笔调节力度现在只影响所选音符。
  • 鼓名称现在会缩小时正确显示在钢琴卷帘上。
  • 事件列表现在将更新更快以反映“轨道”区域中选择的片段。
  • 环境中的“选定电缆的起始位置”命令现在可以可靠地突出显示所连接环境对象上的电缆端口。
  • “在原来的位置粘贴”又会将音符放在钢琴卷帘中的预期位置。
  • 在环境中移动对象后执行撤消不会再导致 Smart Contro 删除。
  • 第一次在钢琴卷帘中使用时“水平自动缩放”时,现在可以可靠地设置正确的缩放级别。
  • 现在可以在钢琴卷帘中录制 past bar 2000。
  • 在选择音频片段时,如果打开逐步编辑器,Logic Pro 不再显示“非法区域编号”对话框。
  • 在钢琴卷帘关闭并重新打开之后,在钢琴卷帘中设定的音阶量化值不会再被设置为它们的并行等效值。
  • 又可以输入加号 (+) 和数字来增加事件列表中事件的音乐位置。
  • 当 Databyte 2 的操作设置为“反转”时,环境变换器编辑窗口中的映射现在可以随所有条件可靠地更新
  • 事件列表中的“长度/信息”列又能显示元事件的名称。
  • 逐步编辑器中的水平和垂直自动缩放现能正常工作。
  • 逐步编辑器中的水平缩放现被限制为项目长度。
  • 在钢琴卷帘中编辑音符时,在小节中开始的 MIDI 片段不会再意外延长。
  • 当另一个窗口当前处于焦点状态时,右键点按钢琴卷轴中的“捕捉”按钮,现在可以正确调整钢琴卷轴的“捕捉”设置,而不是焦点窗口的设置。
  • 在事件列表中选择一个音符不会再使打开钢琴卷帘中的视图滚动到播放头位置,而是将选择保持在可见区域内。 
  • 映射的乐器和 Touch Tracks 编辑器在关闭并重新打开后仍将保持正确的缩放级别。
  • 当环境中选择通道拆分器并且 MIDI 输出处于活跃状态时,环境中的通道拆分器对象不再发送意外的“音色变化 0、MIDI CC7 值 0 和 MIDI CC10 值 0”消息。
  • 在“显示”偏好设置中禁用帮助标记后,钢琴卷轴不再继续显示帮助标记。
  • 现在,在“显示”偏好设置中禁用帮助标记也会作用于钢琴卷轴中的帮助标记。
  • 使用“将上一个点按的参数增大/减小 10”命令现在可以将事件列表中的一个或多个音符向上或向下移动 12 个而不是 10 个半音。
  • 音轨编辑器现在将一直更新以显示当前选择的汇整。
  • 在更改并禁用音阶量化设置后,如果调整了力度,钢琴卷轴中的音符现在可以正确地返回到原来的 Pitch。
  • 在启用水平自动缩放功能的钢琴卷轴中,通过橡胶带选择的音符不再导致意外滚动。
  • 在速度变化时,MIDI 编辑器现在可以更新 SMPTE 锁定片段的内容。
  • 在循环录制到启用合并的 Drum Machine Designer 轨道时,钢琴卷轴不再间歇地关闭鼓名称显示模式。
  • 逐个输入窗口中的 Q 按钮现在将亮起以表示活动状态。
  • 当钢琴卷轴处于“一个轨道”视图中时,音符强制连音现在可正常工作。
  • 使用“线”工具在逐步编辑器中点按最后一个通道不会再意外更改这个片段的长度。
  • 按住 Option 并拖动多个选定的 MIDI 画笔点不会再将拷贝的点放置在错误的位置。
  • 从音轨编辑器切换后,音频文件编辑器中的时间标尺标签现在将保持正确。
  • 当移动其他对象时,环境中的物理输入对象不会再意外更改大小。
  • 在开始于 1 1 1 1 之前的项目中,钢琴卷轴中的自动缩放功能现在能够变现正常。
  • 当启用附加简介时,事件列表又将在“信息/长度”列的弹出菜单中显示正确内容。
  • 在编辑窗口中编辑“MIDI 画笔”后,现在发出的“跳到开头”命令将一直重新启用“跟随”。

常规信息

  • 现在,使用渐变工具点按并拖动音频片段将会选中这些片段。
  • 当没有打开的项目时,打开插件管理器的键盘命令现在可以正常工作。
  • 拖曳到轨道区域、名称中包含单个和多个数字编号组合的音频文件,现在可以正常排序。
  • 执行“另存为”操作时,又会显示拷贝音频文件的进度条。
  • 当不在当前视图中开始时,如果使用“跳到开头”按钮,跟随播放头现在可以正常工作。
  • 在 Logic 9 中创建的键盘命令集又可以正常工作。
  • 手动垂直轨道缩放设置现在将单独存储,以用于自动开启和关闭视图。
  • “隐藏所有空轨道”键盘命令不再隐藏当前所选轨道(如果为空)。
  • 当在项目音频窗口中调整某一个选定的片段时,视图不再意外滚动到最低的选定区域。
  • “设定最佳的片段大小”命令又可在文件夹中使用。
  • “采集为录音”命令现在包含来自 Smart Control 和 Multi-Touch Bar 的数据。
  • “水平自动缩放”命令现在可在文件夹中使用。
  • 在高垂直缩放级别下移动最上方轨道中的片段不会再遮挡小节标尺。
  • 在将“媒体”标签中预览的文件推动到“轨道”区域时,现在文件将停止播放。
  • 在启动窗口打开时,如果从“文件”>“最近的项目”菜单中选择项目,并选中“打开上一个项目”选项,不会再导致 Logic Pro 加载除“最近的项目”菜单中选择的项目之外的上一个项目。
  • 激活片段独奏不会再导致视图意外滚动到项目的开头。
  • 执行“按片段颜色给轨道着色”命令后,撤消现在可以正常工作。
  • 在所选轨道之一只包含一个片段的情况下,如果执行“按轨道接合”,撤消现在可以正常工作。
  • 执行撤消后再执行“拷贝带内容的轨道”不再意外更改轨道和通道条的名称。 
  • 调整替身的左边框现在会将其转换为真正的 MIDI 片段,以正确保留已编辑替身中事件的时间。
  • 从 Patch 资料库中的文件夹中删除 Patch 不再将焦点从文件夹移出。
  • 如果启用了“从循环播放”选项,“轨道”区域的水平自动放大现在只包括循环范围。
  • 关闭单独的音频文件编辑器窗口不再意外删除之前音频片段编辑的撤消步骤。
  • 在使用剪刀工具进退以找到所需的编辑位置后,剪刀工具现在可以正常工作。
  • 解包文件夹时不会再为每个文件夹中的第一个片段创建一个额外的不必要轨道。
  • “还原所有偏好设置(键盘命令除外)”命令现在可以正常工作。
  • 当 LCD 设置为“自定”时,输入的 3 位力度的最后一位时不会再被切断。
  • 当启用水平自动缩放功能时,播放头现在将可靠地显示在正确的位置,并且窗口宽度将更改。
  • Tab 键现在可以在“偏好设置”窗口的“我的简介”面板中将焦点从一个栏位转移到下一个栏位。
  • 又可以在轨道检查器中将轨道的冻结模式设置为“仅来源”。
  • 当在乐段浏览器中预听时,如果使用向下箭头滚动乐段,当前播放的乐段现将在向下箭头释放时显示在视图中。
  • 优化的音频文件现在包括这个片段中应用的交叉渐变所覆盖的区域。
  • “从注释板打印”现在会默认为白色背景上的黑色文字。
  • 移动或拷贝音频片段不会再意外地缩短已移动或复制片段右侧的片段。
  • “将片段开头修剪到上一个片段”命令现在可以在“编辑”菜单和关联菜单中使用。
  • 如果将音量工具分配为屏幕集中的辅助工具,切换到另一个屏幕集并返回时不会再使辅助工具重新设置为指针工具。
  • 当选择冻结的软件乐器轨道时,添加新轨道不会再导致出现轨道被冻结的无关警告。
  • 在启用“仅在预备拍期间”选项时,又可以在录制过程中切换节拍器。
  • 点按“轨道”区域中的某个片段会将焦点立即移动到“轨道”区域。
  • 当键盘命令窗口和音乐键入窗口同时打开时,键盘命令现在会传送到打开的键盘命令窗口。
  • 当“轨道”区域没有焦点时,全局键盘命令现在可以正常工作。
  • 当输入超过 999 个小节的值时,LCD 中的歌曲长度现将正确显示。
  • 当 Logic Pro 切换到全屏时,打开的插件窗口现在仍将保持可见。
  • 轨道上重叠的音频片段不会再与某些交叉渐变和片段增益设置同时播放。
  • 使用选取框工具点按两次片段,然后点按两次第二个片段将不会再意外地将第二个编辑应用于先前点按的片段。
  • 光标现将根据位置可靠地更改为正确的工具。 
  • 当外部 MIDI 轨道设置为低于 -100ms 的值时,轨道将精确地遵循“延迟(毫秒)”轨道检查器设置。 
  • Apple 乐段浏览器现在提供专门的标签来选择“乐器”、“类型”和“心情”这些键盘按钮类别。 
  • 快速帮助弹出窗口现在可以直接显示在指针所在的区域旁边。
  • 在某些特定情况下,移动或拷贝已编组轨道上的 Flex 片段将不再缩短的编辑后的片段。
  • 在轨道检查器中,如果将外部 MIDI 乐器轨道的“延迟(毫秒)”参数设置为低于 -110 的值,现在会按指定的量延迟轨道。 
  • 跟踪检查器中的没有移调复选框现在只有两个状态。 
  • 现在,“轨道”区域中波形图的显示质量在所有缩放级别和使用波形缩放功能时都更为一致。 

早期版本

Logic Pro X 10.3.1

新增功能/增强功能

  • Logic 现在支持针对虚拟 MIDI 端口的 Audio Unit v3 规范。

稳定性和可靠性

  • 进行以下操作时,Logic Pro 不会再意外退出:
    • 当事件列表中的某个栏位高亮显示时使用“复制事件”命令。
    • 在已启用 Flex 的轨道上调整 Apple 乐段的左角落。
    • 将动态符号拖入大型项目的乐谱中。
    • 通过“浮动走带控制”窗口自定义工具栏。
    • 在 Multi-Touch Bar 上,从东亚比例尺更改为另一个比例。
    • 更改已启用 Groove 音轨的项目中 I/O 缓冲区的大小。
    • 在 Alchemy 插件窗口中选择“存储为默认”。
    • 在汇整折叠夹内处理 Flex 时关闭“您确实要创建高速部分吗”对话框。
  • 钢琴卷帘现能可靠地显示在 Retina 显示屏上。
  • 采用独奏模式,然后关闭并重新打开混音器时,音轨不会再从文件夹堆栈中意外移除。

性能

  • 在按住 Option 键并拖移某个音频片段的左角落以伸展时间时,界面现在能更加灵敏地响应。
  • 在“项目音频”窗口打开时使用键盘命令停用独奏片段不再需要数秒钟时间。
  • 大型项目中项目文件浏览器的性能得到提升。
  • 在修剪音频片段的长度时,播放时间和播放头的位置现在会始终保持不变。
  • 在变速模式下对 Apple 乐段进行时间伸展时,Logic Pro 会始终保持响应。
  • 在播放过程中首次完成撤销操作不会再导致播放出现短暂停顿。

Alchemy

  • Alchemy 中的磁性效果现在会调音中可靠地播放。

插件

  • 项目启用循环模式时,如果 Scripter 实例中包含以“NeedsTimingInfo = True”命令开头的代码,则不会再导致音符挂起。
  • 可通过环境窗口的混音器对象再次打开插件。
  • Audio Unit v3 插件的预设名称现在会正确显示。

自动化

  • 现在又可以在汇整折叠夹上编辑基于片段的自动化。

渐变

  • 现在可以正常将渐弱效果应用于多个选中的音频片段。
  • 通过渐变工具点按区域点按渐变功能时,不会再意外更改它的长度。

Flex

  • 量化 Audio Apple 乐段不会再地更改音频长度。
  • 现在,将具有当前速度信息的音频文件添加到具有不同速度的项目中时,该音频文件可以正确地跟随 Flex。
  • 对某个音频片段进行时间伸展不会再意外导致渐弱。
  • 应用“还原所有 Flex 编辑”命令后,可再次对已原位并轨并已启用“在文件中包括音频结尾”选项的音频文件进行 Flex 编辑。

汇整与伴奏

  • 选定的 MIDI 汇整折叠夹可以再次展平。
  • 音频文件转换为不同的采样速率时,不会再更改汇整折叠夹中的开始位置和片段长度。
  • 在使用“解开到新备选轨道”命令后完成撤销操作时,不会再删除文件夹堆栈中的汇整折叠夹。

Multi-Touch Bar

  • 现在,在 Multi-Touch Bar 的概览模式下移动播放头时,它将吸附到小节和节拍。
  • Multi-Touch Bar 概览模式现在可垂直滚动以显示当前可见片段,即使选定的音轨不再出现在视图中也没关系。
  • 现在,在起始位置晚于 1 1 1 1 的项目中,Multi-Touch Bar 中显示的位置正确无误。

备选轨道

  • 现在,已取消选中通过“复制备选轨道”命令在不活跃备选轨道上创建的片段,以防它们被意外删除。
  • 当不活跃的备选轨道升级到活跃状态时,同一组其他轨道上的预聆听按钮现在与预期一样清晰。
  • 删除不活跃的备选轨道不会再导致所选轨道移向轨道 1。
  • 现在,可为吉他/贝司轨道创建备选轨道。
  • 现在,还可以将能剪切或插入时间的全局编辑应用到不活跃的备选轨道。

乐谱

  • 独立的乐谱窗口现在能够可靠地显示当前选定的片段。
  • 现在提供了一个开关,可在拖移时切换对乐谱对象的捕捉。
  • 启用“相同级别”链接模式时,选择属于当前乐谱 Set 的乐器轨道不会再更改乐谱 Set。

Drummer

  • 更改鼓手色调时,备选轨道中的鼓手片段不会再转换为 MIDI 片段。

编辑

  • 现在可以更轻松地拖动事件列表中的值。
  • 现在,使用静音工具在钢琴卷帘中点按某个音符时,依然会立即使该音符静音。
  • 现在又可以在逐步编辑器中编辑主道的音符长度值。
  • 现在又可以在事件浮动窗口中编辑多个选定的事件。
  • 现在,事件列表又会根据音色变化显示 GM 乐器名称。
  • 现在可以更轻松地在钢琴卷帘中使用剪刀工具分开音符
  • “MIDI 变换”编辑器中的“在选定事件上进行的操作”映射又会在第二个数据字节上显示操作的结果。
  • 现在又可以在事件列表中编辑 MIDI 控制器编号。
  • 现在,启用“附加简介”后,歌词又会直接显示在事件列表中。
  • “跟随播放头”现在可与钢琴卷帘中循环的 MIDI 片段配合使用。

共享

  • 当 Logic 项目的采样速率不是 44.1 kHz 时,使用“共享到 iOS 版 GarageBand”功能添加的音轨现在会正常播放。

导入

  • 现在,将音轨导入项目时,会包含不活跃备选轨道上的汇整折叠夹。
  • 现在,可以导入/替换驻留在 Track Stack 内的音轨。

应用间的可操作性

  • Logic Pro 不会再将现有项目中的 ReWire 总线数更改为 60。
  • Logic Pro 的播放头和定位器又会跟随所连 ReWire 从属应用程序的位置。

视频

  • 更改项目的帧速率不会再导致 SMPTE 起始时间意外转变。
  • 当浮动影片窗口处于打开状态时,键盘命令现在可以可靠运行。

控制表面/MIDI 控制器

  • 在 Logic Pro 重新启动时,滑块、声相旋钮和轨道名称目前能够可靠地在 Logic Remote 中实现更新。
  • Logic 控制又可用于转变循环位置。

常规信息

  • 现在,在有选取框所选内容时执行剪切 (Command-X) 会按照预期方式创建撤销步骤。
  • 重新打开时,“前往位置”窗口中的“新位置”栏位又会显示最后输入的位置。
  • 选取框工具又可用于分开多个片段。
  • 当“仅变速速度”处于活跃状态,而且“低延迟模式”处于关闭状态时,软件乐器又会按预期输出音频。
  • 在力度偏移为负的 MIDI 片段上对参数实施标准化时,力度小于该偏移的音符不会再被意外设置为 127,而是会设为 1。
  • 在极少数情况下,拖移的片段不会再移到 macOS Sierra 上的错误位置。
  • 又可以延长已缩短反向音频片段的末尾。 
  • 变速应用到位后,输入监视又能正常运行了。
  • 替身的名称又会以斜体显示。
  • “选定未使用的”命令又可以在项目音频窗口中正常运行。
  • 片段检查器中的乐谱参数又能显示片段的“显示”或“隐藏”状态。
  • 现在,使用关闭按钮隐藏不活跃的备选轨道会创建一个撤销步骤。
  • 延音踏板事件现在可在循环的 MIDI 片段上正确触发。
  • 抓取某个经过 Flex 编辑的片段的右下边缘时,指针又能持续变成循环工具。 
  • 改善了多个字体在非 Retina 显示屏上的显示外观。
  • 作为 Patch 一部分存储在 Track Stack 中的辅助又能在载入 Patch 时保留自定分配的颜色。
  • 现在又能正常对多个选定音轨启用再停用录音。

 

Logic Pro X 10.3

新增功能与增强功能

  • 支持 MacBook Pro 上的 Multi-Touch Bar。
  • 通过“备选轨道”,可在轨道上创建片段和编辑以及在不同的片段播放列表和编辑之间切换。
  • 使用“基于所选部分的处理”可以将任意效果插件组合渲染到所选的音频。
  • 利用“共享到 GarageBand”选项,可从 iPhone 或 iPad 通过 iCloud 远程向您的 Logic Pro 项目中添加新轨道。
  • 新的片段编辑设计可在您进行修剪操作时显示整个音频文件或未使用的 MIDI 数据的波形。
  • 真实立体声声相功能提供了对立体声信号的更多控制和离散操作
  • 项目现在可以包含多达 256 条总线。
  • Logic Pro 现在提供了一个 64 位求和引擎。
  • 导入音乐 XML 文件。
  • 在立体声轨道上插入作为立体声或双单声道的插件。
  • 颜色调板增加了 24 种颜色,以用于标记片段、轨道和音符。
  • 增加了“使用重复设置和内容新建轨道”的键盘命令。按住 Command 键并点按轨道头中的“使用重复设置新建轨道”按钮也可触发相同的操作。
  • I/O 插件现在拥有“混音”控件。
  • 偏好设置窗口中新增一个“录音”页面,其中包含重叠录音、录音文件类型及录音位长度的设置。
  • 增加了将定位符向前和向后移动一小节的键盘命令。
  • 主窗口、钢琴卷帘、音轨编辑器和逐步编辑器中增加了水平自动缩放控件。
  • 增加了新建编配标记的键盘命令。
  • 增加了切换当前选定 Track Stack 或所有 Track Stack 显示的键盘命令。
  • 增加了新建项目备选和编辑当前备选的键盘命令。
  • 增加了一项调节“轨道”区域背景亮度的偏好设置。
  • 增加了关闭当前选定轨道上的 Track Stack 文件夹的键盘命令。
  • 增加了向所选片段应用上次渐变编辑的键盘命令和菜单命令。
  • 增加了用于应用多达 30 个“变换用户”预置的键盘命令。
  • 增加了以关联菜单项和键盘命令方式使用的“将影片片段移到播放头”命令。
  • 现在,在脉冲响应实用工具中创建脉冲响应时,可设定采样速率。
  • 增加了“重复为替身”的键盘命令。
  • macOS Sierra 现在完全支持磁盘空间管理。
  • 增加了“在 Finder 中显示影片”的键盘命令。
  • 乐谱窗口中增加了“全音阶插入”键盘命令。
  • 增加了“Apply Default Crossfades”(应用默认交叉渐变)的键盘命令。
  • “重叠录音”偏好设置中增加了一个选项,允许您选择在 MIDI 轨道上以“替换”模式录音时,是替换 MIDI 片段还是只替换现有片段中的内容。

稳定性和可靠性

  • 进行以下操作时,Logic Pro 不会再意外退出:
    • 在两个打开的项目之间切换。
    • 从插件管理器中移除所有类别插件。
    • 您在 MIDI 汇整折叠夹中从同一乐段系列选取不同的 Apple 乐段,然后展平汇整折叠夹。
    • 向轨道添加压缩的音频文件。
    • 在全屏模式下关闭项目。
  • 在长度不短于 30 分钟的歌曲上执行“使用鼓手片段填充”命令时,Logic Pro 不会再挂起。
  • 从“Alchemy 源”>“导入音频”弹出式菜单选择已装载的驱动器时,Logic Pro 不会再呈现挂起状态。

性能

  • 在“混音器”中录制轨道时,不会再有微小的延迟。
  • 现在载入使用压缩音频文件的 EXS 乐器时快了很多。
  • Logic Pro 现在能够更快地退出。
  • Logic Pro 现在能够在 MacBook Pro(2016 年末)上将“处理线程数”正确设为最大内核数。
  • 在播放期间移动标记不会再导致音频输出出现咔哒声。
  • 在包含大量片段的大型项目中,滚动操作的处理速度得到改善。
  • 在启用“自动化”视图的情况下,使用向上和向下箭头键选择上一个或下一个轨道不会再有延迟。

Alchemy

  • 载入低频振荡器预置后,Alchemy 的低频振荡器波形显示现在能够正常更新。
  • 当将“Y Snap”(Y 坐标吸附)设为 1/12 时,Alchemy Modmaps 现在能够正确地将节点吸附到 1/12 增量处。
  • 在 Alchemy 中,如果使用采样模式将某个样本导入到源 A 中,然后使用颗粒感模式将同一样本导入到源 B、C 或 D 中,在停用源 A 时不会再使其他源位置卡在 0 处。
  • 现在,您需要连按两次才能编辑 Performance Control 下方的文本。
  • 现在,使用“文件”>“清除”命令后,Alchemy 仍可以记住上次将音频导入到 Alchemy 源时使用的文件夹。
  • 在 Alchemy Performance Control 上右键点按“自动分配”现在能够可靠地只分配这个控件。
  • 改善了多项 Alchemy 预置的调音。
  • 在 Alchemy 中按住 Option 键并点按弧形 ADSHR 片段又可以立即影响控制片段,并且您可以听见线性衰减阶段。
  • 现在,Alchemy 自动琶音器模式旋钮周围的后期调制反馈圆环能够在手动调整后继续更新。
  • 现在,当将调制轮分配为控制 Alchemy 中的某个参数时,不会再移除演奏部分中的调制轮分配。
  • 现在,Alchemy 的频谱编辑器单独为每个源保存撤销步骤,如果没有撤销步骤,则“撤销”按钮将显示为灰色。
  • 现在,切换 VA 振荡器波形期间保留在 Alchemy 中的音符会继续正常发声。
  • 现在,Alchemy 为“源”、“主控”和“Multimode”(多模式)滤音器提供了下采样选项。
  • 现在,在 Alchemy 的包络编辑器中更改某个点能够正确更新“分音”显示。
  • Alchemy 自动琶音器增加了一个输入吸附设置,后者能够将收到的 MIDI 音符量化为 Logic Pro 运行时的速率。
  • 现在,使用外部控制器调整 Alchemy 的 AHDSR 时,插件中的曲线会立即进行直观地更新。
  • 改进了将 MIDI 文件导入到 Alchemy 自动琶音器的过程。
  • 现在又可以从插件的“载入”文件菜单载入 Alchemy .acp 文件。
  • 现在,只需在 Alchemy 中点按一下,就可以将所有 ADSR Performance Control 自动分配到相同的包络。
  • 现在,当以不足毫秒的增量调整颗粒大小时,Alchemy 会显示相应的值。
  • Alchemy 现在会持续响应通道和复音压力。
  • 在载入 Patch 后执行撤销不会再导致自上次存储以来发生过修改的 Alchemy 实例意外地还原为存储状态或默认状态(如果项目从未存储过的话)。
  • 改善了导入到 Alchemy 中的 Apple 乐段的音频质量。
  • 现在,Alchemy 的低频振荡器选择菜单会列出低频振荡器编号及当前配置的波形。
  • 在 Alchemy 实例中播放的第一个音符不会再导致 CPU 用量意外出现峰值。
  • 现在,自动存储可用于 Alchemy。
  • 现在,在简单模式下,Alchemy 的浏览器预置列表中会持续显示滚动条。
  • Alchemy 现在能够更快地载入使用 AAZ 文件的预置。
  • 现在,分配到控件的 Alchemy 调制映射(按半音值进行操作)在调整时默认吸附 1 个半音的增量。
  • 具有通过按键跟随调制的相加磁性效果的 Alchemy 声音现在可在调音中可靠地播放。
  • 现在,当源包含多个组时,从源菜单更改 VA 波形能够正确地还原组。
  • 现在,格式分析能够在 44.1 kHz 以外的采样速率提供良好的采样结果。
  • “快速帮助”现在可配合 Alchemy 使用。
  • 现在,Alchemy 中带有“Add FX”或“Spec FX”标记的控件能够响应“学习”页面中的 MIDI 学习。

辅助功能

  • 当 Voiceover 处于启用状态时,插件默认在控制视图中打开。
  • 现在,当时间线设为显示“小时:分钟:秒钟:样本”和“SMPTE/EBU 带样本”时,VoiceOver 会正确播报播放头的位置。
  • 现在,VoiceOver 会播报音轨编辑器中的音高修正滑块。
  • 现在,VoiceOver 会播报音轨编辑器量化强度滑块。
  • 现在,VoiceOver 会播报音轨编辑器移调滑块。
  • 改善了控制视图中 Alchemy 参数的辅助功能。

自动化

  • 现在,可将基于片段的自动化写入 Apple 乐段。
  • 现在,SMPTE 锁定适用于基于片段的自动化事件。
  • 现在,使用“插入无声片段”命令时,即使“Move Automation”(移动自动化)偏好设置设为“从不”,插入区域右侧的自动化也能正常移动。
  • 在接合两个片段时,如果第一个片段中的第一个节点位于片段开始位置之前,此片段中的 MIDI 画笔节点不会再被消除。
  • 现在,删除弯音事件能够可靠地同时删除所有相关的插值弯音事件。
  • 使用 MIDI 画笔 CC 节点拆分或接合片段不会再导致意外创建多余的 CC 事件。
  • 当自动化视图处于活跃状态且推子在录制 MIDI 期间发生移动时,Logic Pro 不会再创建不需要的临时片段。
  • 现在可以自动打开和关闭发送。
  • 现在,在片段边界处创建自动化节点的命令将应用到活跃轨道组的所有片段。
  • 现在可以通过橡皮带选择跨多个轨道的自动化。
  • 旁通插件的轨道自动化现在能在将插件移到其他插槽后继续正常运行。
  • 乐谱中的 MIDI 画笔现在能够正确处理具有位于不同 MIDI 通道上的事件的片段。

Drummer

  • 现在,当 Track Stack 包含鼓手轨道时,您可以设定跟随功能,以便鼓手轨道跟随这个堆栈中的其他轨道。
  • 现在,将 MIDI 片段拖到鼓手轨道上然后执行撤销,可恢复已删除的鼓手片段,并将这个 MIDI 片段移回到原始位置。
  • 现在,在切换鼓手色调时,能够正确地重新生成后跟 MIDI 片段的鼓手片段。
  • 不能再将非鼓或打击乐器乐段拖到鼓手轨道上。
  • 连接工具现在能够配合鼓手片段使用。
  • 现在,可以禁止在 Drum Machine Designer 鼓垫上显示图标。
  • 调整鼓手片段的脚鼓和小军鼓模式不会再影响正在编辑的片段的副本片段。 
  • 现在,当选中 1/2 倍脚鼓和小军鼓模式时,可以为电子鼓手正确计算摇摆。
  • 现在,如果为原声鼓手轨道载入了 Producer Kit,则更改鼓手色调会为此色调载入相应的 Producer Kit。

Flex

  • 改善了 Flex Pitch,以降低将音符设为完美音高时出现失真的可能性。
  • 现在,当在轨道上启用了 Flex 时,采样速率高于 44.1 kHz 的项目中的 Apple 乐段会以正确的速度播放。
  • 现在,在启用了 Flex Pitch 的情况下,在音频编辑器中按住 Option 键并点按共振峰移动控件能够将它的值正确地设为 0。
  • Flex Pitch“设定为完美音高”命令现在适用于所有选定片段。
  • 现在,可以在音频文件编辑器中正确地计算和显示 Apple 乐段中的瞬变。 
  • 现在,撤销操作能够在编辑 Apple 乐段中的瞬变后正常工作。

汇整与伴奏

  • 现在,可以将汇整折叠夹粘合到一起。
  • 现在,可以对打开的汇整折叠夹中的片段使用渐变工具。
  • 现在,在不包含伴奏的汇整折叠夹上点按右键将只为这个折叠夹中的每个汇整显示一个列表。
  • 现在,当编辑操作涵盖不连续的伴奏片段时,锁相编辑组中的所有轨道能够正确地跟随伴奏编辑。
  • 现在,因解开汇整折叠夹而产生的片段会被正确命名。
  • 现在可以复制和粘贴汇整片段。
  • 现在,当对 MIDI 录音偏好设置进行相应设定时,采集录音能够正确创建汇整折叠夹。
  • 当选中汇整片段时,片段检查器不会再显示无法工作的“静音”复选框。
  • 现在,按住 Option 键并用选取框工具点按汇整片段可以正常选择它。
  • 在播放期间应用键盘命令“创建新伴奏”不会再将轨道输出静音。
  • 现在,在汇整折叠夹上选择展平汇整菜单项也会对所有其他选定汇整折叠夹完成这个操作。
  • 启用“录音”>“Create Takes”(创建汇整)偏好设置后,在录制音频期间发送 MIDI 时,Logic Pro 不会再创建新的轨道。

Track Stack

  • 如果 Track Stack 包含具有默认名称的音频通道条,复制它时不会再创建与原始 Track Stack 采用相同默认名称的 Track Stack 通道条。
  • 现在,按住 Command 键并点按选定的 Track Stack 会取消选中这个堆栈中的所有轨道。
  • 现在,按住 Shift 键并点按已关闭的 Track Stack 能够可靠地选中它包含的所有子轨道。

插件

  • 插件侧链菜单现在会显示总线的完整路径信息,与在通道上发送完全一致。
  • 现在,当“路径”从“Straight”(直线)更改为其他预置然后改回“Straight”(直线)时,“立体声延迟”中的“反馈”值能够正确地保持不变。
  • 现在,当某个参数被某个映射为智能控制的 MIDI 硬件控制器更改时,插件的比较按钮会激活。
  • 在播放期间更改“激励效果器”插件中的参数不会再导致音频失真。
  • 现在,设为“总数”且经过“压缩度”侧链的信号将处于正确的电平。
  • 音频单元插件窗口不会再卡在屏幕上的某个位置。
  • 当某个插件产生延迟时,将光标悬停在对应插件插槽上时显示的帮助标记会显示这个插件产生的延迟量。
  • 在变形模式下,外部调制旋钮事件不会再导致在复古风琴乐器中意外重新触发打击乐器。
  • 改进了 Scripter 插件中 ProcessMIDI() 函数的时序。
  • 设定为输出到多单声道辅助的多输出音频单元乐器不会再跳过输出 2。
  • 现在,将某个声部从 Ultrabeat 导入表拖到乐器插槽时,这个插槽会显示导入的声部的名称。
  • 现在,万用表和“电平指示器”中的峰值读数会在从“True Peak”(真峰值)切换到 RMS 模式后继续工作。
  • 现在,在“相位器”插件的单声道实例中,相位旋钮会正确地显示为灰色。
  • 支持单声道和环绕声的音频单元软件乐器现在能够作为多单声道乐器载入。
  • 现在,Multichannel Gain(多声道增益)和 BPM Counter(BPM 计数器)插件采用了更新后的用户界面。
  • Modifier MIDI 插件现在能够处理音色变化信息。
  • 在 macOS Sierra 上,在 Vintage Clav 插件中对效果重新排序不会再造成效果拼贴相互重叠。
  • 现在,当“触发器”为“释键”时,在 EXS 乐器编辑器中取消选中组的“衰减”复选框会为这个组停用衰减。
  • MIDI 插件现在能够远程控制同一通道条上的任意可自动化插件参数。
  • 现在,使用自动琶音器脚本的 Scripter 实例能够正常地原位并轨。
  • 现在,插件菜单顶部会显示包含最多五个最近使用的插件的列表。
  • 现在,在“Add Temporarily”(临时添加)模式下,延音踏板能够在控制“自动琶音器”插件中的“Latch”按钮时持续工作。
  • “自动琶音器”中增加了一个选项,可以从源素材而非应用琶音的结果创建片段。
  • 载入包含 Bass Amp Designer 插件实例的 Patch 不会再导致爆裂噪声。
  • 现在,如果在插件管理器中重命名了某个插件,则将指针悬停在这个插件上方时,帮助标记会显示编辑后的名称。
  • I/O 插件的立体声版本增加了一个发送和接收中间/侧面信号的选项。
  • 现在,可以在 EFM1 乐器插件中调整弯音范围
  • “调制器”MIDI 插件现在提供 1/128 低频振荡器速率。
  • 撤销 Patch 载入不会再导致其他 Kontakt 乐器上的样本意外地重新载入。
  • 更改采样速率不会再导致意外更改“镶边”、“合唱”、Vintage Clavinet、Retrosynth 和 Pedalboard“合唱和镶边”插件的声音。
  • 插件管理器不允许再使用重复的自定插件名称。
  • 更改分配到轨道的软件乐器插件不会再导致删除轨道上的控制器数据。
  • Space Designer 能够再次载入存储到 Logic 9 中自定位置的插件预置文件。
  • 现在,在 Logic Pro 录音期间插入的插件在录音停止时会变成可用状态。
  • 现在,当通道条中插件的顺序发生改变或在插入了新的插件时,受 Scripter 插件的推子事件控制的插件参数将保持可用状态。
  • 在插件管理器中重命名类别不会再导致这个类别被意外地移动到列表的底部。
  • 现在,在视图更改为“预置”或“控制”然后再改回“拆分”时,在“Vintage B3 Organ Split”(Vintage B3 Organ 拆分)视图中设为“Multi”(多)的键盘会维持这个设置不变。
  • 现在,在第二次打开“延迟设计师”插件的实例时,这个插件中的网格会保持可见。
  • 现在,第三方音频单元插件能够在控制视图中正确地显示指示器。
  • 现在,在控制视图中为第三方音频单元插件中的参数键入值能够可靠地工作。
  • 现在,Amp Designer 中的“Mic Position”(麦克风位置)更容易调整,不会意外关闭位置显示。
  • 现在,在 Plectratone、Dulcitone 和 Belltone 模式下,延音踏板能够正常地配合 Vintage Clav 使用。
  • 现在,在 RetroSynth 或 MIDI 调制器的 ENV 显示中使用搓擦条调整“起音”、“保持”或“释音”时间时,能够可靠地更新这个显示中的包络点
  • 在 Modulation Delay 中启用“Constant Mod”(恒定调制)不会再导致“延迟”和“调制”设置增加。
  • Logic Pro X 现在支持 Audio Unit v3 插件。

混音器

  • 现在,“使用下一个通道新建轨道”命令能够保留当前选定轨道的输入设置。 
  • 在“混音器”和“轨道头”中,环绕声通道条上的电平指示不会再在播放立体声片段时卡住。
  • 现在,从发送到辅助(已分配给轨道)的轨道创建 Track Stack 能够正确地维持到现有辅助的路径。
  • 在复制总和堆栈时,会正确地复制这个总和堆栈中将输出发送到堆栈外部的子轨道的路径。
  • 现在又可以在混音器中选择单一折叠夹通道。
  • 现在,通过点按轨道头中的 + 按钮在总和堆栈中创建的轨道能够正确地发送到总和总线。
  • 现在可以只复制/粘贴插件,或只复制/粘贴通道条的发送。
  • 按住 Control 键并点按混音器通道条不会再意外地取消选中多个已选择的通道条。
  • 现在,点按“发送”或“输出”插槽时,总线会按名称而不是编号列出。
  • 现在,“发送”和“输出”菜单中的总线标签会显示已分配的路径。
  • 现在,用于 Track Stack 发送的总线会在以堆栈名称命名的子菜单中分组。
  • 当选中多个通道条时,按住 Option 键并点按某个通道上的推子或控件可在所有选定通道上将这个控件设为默认状态。
  • 现在,当所有轨道都已分配到现有的 VCA 时,可以创建新的 VCA。
  • 当在“混音器”中选中多个通道条,但在轨道列表中只选择一个通道条时,在轨道头或通道条检查器中调整控件将只影响选定的轨道。在“混音器”中调整控件会继续影响此处选中的所有通道条。
  • 在 Patch 资源库打开的情况下创建环绕声音轨不会再创建单声道信号路径。
  • 现在,可以在“混音器”中更方便地通过橡胶带选择通道条的底部,而不会意外地移动推子。
  • 现在,软件乐器可以直接用作“侧链”输入。
  • 现在,从环绕声通道条创建的辅助会配置为环绕声。
  • 现在,在向总线分配通道条输入时,已分配总线的标签会持续显示。

全局轨道

  • 现在,当插入部分包含不同的调号时,“在播放头插入剪开的部分”命令能够在插入部分后正确维持调号。
  • 现在,在音频文件中的锚点位置发生更改后,节拍映射轨道中的瞬变会在它们的正确位置显示。
  • 现在,您可以将速度轨道中的“按平均值替换”命令分配给键盘命令。
  • 在移到其他时间位置时,包含非整数值的速度事件不会再四舍五入到整数值。
  • 现在,可以对编配标记使用胶水工具。
  • 现在,在 LCD 中编辑拍号将更改当前拍号,而不是在当前播放头位置添加一个新的拍号。
  • 现在,节拍映射轨道会在音频片段的锚点位置发生更改时立即更新。
  • 现在,音乐律动匹配轨道能够在编配标记发生移动时可靠地维持量化。
  • 现在,“选定所有后续”命令能够可靠地只选择跟随当前选择的速度事件。
  • 现在,拍号更改能够在“钢琴卷帘”和“音轨”编辑器中正确显示。
  • 现在又可以从全局轨道标记 Set 菜单中删除标记 Set。
  • 为了减少意外创建标记的情况,通过将活跃的循环向下拖到小节标尺的下半部分来创建标记的功能现在要求从循环范围内开始这个操作。 
  • 现在能够以低垂直缩放比例从全局拍号轨道打开调号编辑器。
  • 现在又可以在速度轨道中通过橡胶带选择多个点并将它们拖动或复制到新的位置。
  • “全选”操作现在会包含已打开全局轨道中的所有事件。
  • 在 LCD 中再次更改拍号可在包含当前播放头位置的小节处插入新的拍号。

编辑

  • 在编辑器中使用“选定所有后续”命令时,不会再意外选中标记。
  • 现在,命令“MIDI”>“按清晰度 ID 分离”将根据清晰度 ID 命名生成的轨道(如果有可用于它们的名称)。
  • 使用“采集为录音”命令合并到现有片段的 MIDI 录音不会再取消选中合并的片段。
  • 现在,可以在“钢琴卷帘”中解锁 SMPTE 锁定事件。
  • 在“钢琴卷帘”中添加 MIDI 画笔数据不会再将新的点放置在播放头处,而是会放置在点按位置处。
  • 重复功能现在可用于选取框所选内容及“钢琴卷帘”中的时间控制柄。
  • 如果播放头位于选定片段界限内,则启用了“内容链接”模式的“钢琴卷帘”区域或窗口会在播放头周围持续显示这个区域。
  • 如果“钢琴卷帘”中的“跟随播放头”因为选择了远离播放头的片段而关闭,该功能现在会在选中播放头范围内的片段时自动重新打开。
  • 在“钢琴卷帘”中点按量化强度或量化摇摆滑块而不移动它们时,不会再导致 MIDI 数据跳转到量化位置。
  • 现在,在“钢琴卷帘”中使用铅笔工具创建的音符会匹配之前创建的音符的 MIDI 通道。
  • 在显示鼓名称的情况下,“钢琴卷帘”不会再在循环模式下切换录音时意外地垂直滚动。
  • 如果可在“钢琴卷帘”中同时看到锁定轨道和解锁轨道的片段,则调整解锁解锁轨道中的音符时不会再显示“此轨道已被保护,无法更改”错误。
  • 现在,当链接按钮处于停用状态时,“钢琴卷帘”显示能够在录音期间正常工作。
  • 现在,在录音后打开“钢琴卷帘”时,这个视图会自动定位和缩放,以显示录音内容。
  • 现在,当“时间显示”设为“SMPTE/EBU 带样本”且“事件列表”设为将长度和位置显示为时间时,可以在“事件列表”中按样本调整位置和长度。
  • 在“事件列表”中向 SMPTE 锁定音符应用量化时,不会再导致它们的位置或长度发生意外偏移。
  • 现在,在“事件列表”中设定多个选定片段的开始时间时,可以正确地设定开始时间。
  • 现在又可以使用 Shift-Option 组合键在“事件列表”中将多个选定事件设为同一个值。
  • 现在,使用 + 或 - 键调整上次在“事件列表”中点按的值以进行编辑时,能够可靠地影响正确的栏位。
  • 现在,当“事件列表”设为将事件位置和长度显示为时间时,事件浮动窗口会显示 SMPTE 时间。
  • 现在,当事件浮动窗口处于打开状态时,用于其他区域的键盘命令能够正常工作。
  • 现在,文本工具可在音频文件编辑器中的“Flex Pitch”视图中正常工作。
  • 在“项目音频”窗口中使用显示三角形关闭组时,不会再关闭这个组中所有音频文件的显示三角形。
  • 现在,可以在逐步编辑器中最下方的主道下方使用橡胶带选择。
  • 现在,在逐步编辑器中显示所选事件数量的计数器会在选择发生更改时立即更新。
  • 现在,用于逐步编辑器的自动主道 Set 可在所有模板中使用。
  • 现在,音轨编辑器中的片段标题能够可靠地只显示选定轨道的片段。
  • 现在,在“多乐器”中选取 Patch 时,能够正确显示当前选定音色库的 Patch 名称。
  • 不能再在“环境”的“所有对象”分层上创建对象,因为这可能会产生无法工作的对象。

导出和渲染

  • 轨道原位并轨时,插件侧链设置现在能以正确的方式影响结果。
  • 并轨多声道软件乐器时,并轨的所有源片段现在都能被正确静音。
  • 将项目导出为 MIDI 文件时,现在会包含替身片段和乐段。
  • “将选定部分导出为 MIDI 文件”现在可以在当前会话中记住上次使用的导出位置。
  • Logic Pro 现在能够导出 Final Cut Pro XML 1.5 版本的文件。
  • 将 PCM 并轨选项设为 16 位时,Logic Pro 现在能够创建 16 位 Apple Lossless 文件。
  • 在从 1 1 1 1 以外位置开始的项目中,导出项目部分内容的操作现在能够导出正确的部分。
  • 从片段创建 Apple 乐段时,不会再意外停用“并轨项目”对话框中的“正常化”设置。
  • 对导出 MusicXML 文件做了多项改进。
  • 现在,如果立体声音频设备处于活跃状态时并轨环绕声混音,会进行环绕声并轨。
  • 对新轨道进行原位并轨时,新创建的轨道将包含与原轨道相同的 VCA 分配。
  • 增加了将所选内容导出为音频文件的选项。
  • 包含无声片段的并轨不会再在无声部分开始处包含很响的咔哒声。
  • 现在,Apple 乐段能够转换成 CAF 文件。
  • 导出使用辅助的多输出乐器时,不会再意外地向乐器的主轨道添加来自辅助的信号。
  • 并轨后的片段现在能够可靠地维持用户创建的名称,并且当将它添加到轨道时,软件会正常地按照这个片段为轨道命名。
  • 当将轨道、片段或所选内容导出为音频文件时,可以使用众多新增选项设置自定文件名称。

导入

  • 对于用 Logic Pro 直接打开的 MIDI 文件,LCD 现在能够可靠地显示正确的拍号。
  • 将 MIDI 文件作为新的 Logic Pro 项目打开时,现在将包含这个 MIDI 文件中的拍号信息。
  • 现在可以将 B 格式环绕声文件拖放到 Impulse Response Utility 中。
  • Logic Pro 现在能够导入 Final Cut Pro XML 1.6 版本的文件。
  • 自动转换成 PCM 的压缩音频文件现在将转换成音频文件录音类型。
  • 现在,当 AAF 或 OMF 文件内含的轨道在名称中包含特殊字符时,Logic Pro 能够正确处理这些文件。
  • 向项目中导入采样速率大于 44.1 kHz 的音乐备忘录文件时,现在会将音乐备忘录文件转换到项目采样速率。
  • 播放期间从其他项目导入轨道不会再导致音轨停止输出声音。
  • 当导入较大的 FCPX XML 文件时,Logic Pro 现在会显示进度条。
  • 在导入包含多个缺失资源的 FCPX XML 文件时,现在可以选择跳过所有缺失文件。
  • 导入的 FCPX XML 文件不会再包含大量的多余轨道。
  • 改进了之前 Logic Pro 版本中的 .LSO 文件转换功能。
  • 将速度信息写入从 Pro Tools 导出的音频文件时,不会再导致白噪声爆发。

乐谱

  • 现在,“显示复音”视图中会显示所有五线谱的乐谱符号元事件。
  • 乐谱中用于向音符分配颜色的关联菜单现在会显示实际颜色及对应的名称。
  • 现在可以同时选择多个乐谱 Set。
  • 现在又可以从乐谱中的和弦符号移除扩展。
  • 撤销功能现在适用于乐谱编辑器中的和弦符号更改。
  • 使用 MIDI 汇整中的铅笔插入到乐谱中的音符现在会立即显示在乐谱轨道视图中。
  • 现在,手动简并的换行符会在更改缩放比例时保持不变。
  • 当在轨道中最后一个片段的结尾放置无换行符对象后,这个片段的页面视图不会再错误地显示多余的括号(从这个片段的结尾到项目的结尾之间没有五线谱)。
  • 现在,按住 Shift 键并拖动鼠标可以向多个选定片段插入乐谱符号。
  • 现在,当谱号更改后,在第一个非独立音符所在位置插入独立音符或花音时,独立音符会受到谱号的影响。
  • 现在,乐谱会立即更新,以显示使用箭头键所选内容中的更改。
  • 现在,在设为线性视图的乐谱窗口中拖动播放头能够正确地吸附到标尺。
  • 现在,当正在拖入乐谱中的符号与现有符号垂直对齐时,会显示一条参考线。
  • 在被拖入乐谱时,和弦网格现在会以正确大小显示。
  • “Score project setting Time Signatures: Hide All”(乐谱项目设定拍号:全部隐藏)现在能够正常工作,以隐藏用户创建的拍号。
  • 现在,在乐谱中右键点按文本和歌词会显示一个关联菜单,其中提供了对齐文本、调整字体和设定文本样式的选项。 
  • 现在,可以在乐谱 Set 窗口中将乐器拖动到新的位置。
  • 当缩放比例高于 150% 时,页面视图中的拍号不会再显示得太大。
  • 乐谱窗口不会再在极少数情况下显示重复的调号。
  • Courtesy Signature 更改不会再显示在五线谱线条结尾的右侧。
  • 手动插入的谱号不会再显示在五线谱线条结尾的右侧。

控制表面和 MIDI 硬件

  • 在退出 Logic Pro 时,EuCon 控制表面上的推子和按钮现在能够正确更新。
  • 控制表面安装窗口现在会显示支持的 MIDI 硬件控制器。
  • Arturia KeyLab 25 现在是受支持的 MIDI 硬件设备。
  • 现在,Logic Remote 在 MIDI 自动琶音器、EFM1、ES1、ES2 和 EXS24 插件中包含了对一些之前缺失的参数的访问。
  • Logic Remote 现在会在 EFM1 上显示用于 MIDI 单声道模式和弯音范围的控件。
  • Logic Remote 现在会在 ES1 上显示用于 MIDI 模式和滤音器增强的控件。
  • Logic Remote 现在会在 ES2 上显示用于 MIDI 单声道模式和音高范围的控件。
  • Logic Remote 现在会显示用于 MIDI 单声道模式、音高范围、低频振荡器三角形和上一个/下一个乐器的控件。
  • 现在,当将轨道拖到 Logic Pro 中的新位置时,Logic Remote 的轨道选择箭头能够正常更新。
  • 在 Logic Pro 已打开“存储”对话框的情况下,在 Logic Remote 上按“存储为”时,不会再导致显示多个不需要的“存储”对话框。
  • 在 Logic Remote 中选择立体声输出通道条不会再在 Logic Pro 中选择意外的轨道。

视频

  • 现在可以通过点按两下视频窗口的标题来自动缩放视频窗口的大小。
  • 现在,在影片缩略图上长按可以显示影片的位置。
  • 在选择 AAC 格式的情况下,“将音频导出至影片”现在能够在第一次导出后可靠工作。
  • 现在又可以向 Logic Pro 项目中载入包含 MPEG2 或 AC3 编码音轨的影片。
  • 现在,在启用循环后在替换模式下手动设定入点和出点时,可以正常抹掉现有片段。

同步

  • 现在,当 Logic Pro 处于低延迟模式时,MIDI 时钟能够在正确的时间传输。

MIDI

  • 当物理输入上存在 64 个以上的 MIDI 输入端口时,输入端口 65 或以上端口的 MIDI 不会再错误地发送到端口 1 及以上端口。
  • 改善了向外发送 MIDI 的 MIDI 轨道的时序。

声音和内容

  • 使用箭头键停止 Drum Machine Designer 鼓件的声音时,声音资源库中的选择不会再意外跳动。

常规信息

  • 当将“时间标尺”设为显示时间时,它的格式现在将反映“显示”>“通用”>“Show Time As”(时间显示为)偏好设置。
  • 现在又可以将轨道上“仅来源”模式下会冻结的插件参数自动化。
  • 右键点按选取框所选内容不会再意外分开所选内容。
  • 现在可以在“编辑备选”窗口中选择多个备选。
  • 选择一些文件,然后从要添加的文件列表中移除它们时,项目音频的“添加音频文件”对话框中的“完成”按钮不会再更改为“添加”。
  • 现在,隐藏再重新显示检查器时,检查器中各个显示三角形的状态将保持不变。
  • LCD 显示中显示的 SMPTE 时间现在能够正确匹配“速度编辑器”和“速度操作”窗口中显示的 SMPTE 时间。
  • “轨道”区域中的录音就绪按钮现在能够可靠地与“混音器”上的相应按钮同步闪烁。
  • 现在,按下工具栏中“导出”按钮时显示的选项与从主菜单中选取“文件”>“导出”时显示的选项一致。
  • 现在,当打开多个同类窗口时,将为每个窗口保持独立的缩放记忆。
  • 现在,当在“轨道”区域中选择包含单个轨道的文件夹时,启用了内容链接的编辑器会显示这个轨道的内容。
  • 当将轨道拖到总和堆栈旁边的位置时,软件不会再错误地将轨道放入总和堆栈内。
  • 当将堆栈内的轨道打包到文件夹时,不会再在这个文件夹中创建不必要的堆栈主轨道副本。
  • 当主窗口关闭时,“将片段吸附到相对值”与“将片段吸附到绝对值”设置将在打开新的主窗口时保持不变。
  • 现在,在“音符过零拆分点”对话框、“在多个轨道上粘贴”对话框和“Set All Tracks to Write”(将所有轨道设定为 Write)对话框中选取的设置在重新启动 Logic Pro 后保持不变。
  • 现在,在 MIDI 片段左边沿处开始的选取框选定内容和拆分音符能够正确触发“音符过零拆分点”对话框。
  • 现在,时间标尺中的音位标记标签将遵循“等份”格式设置。
  • 现在,在分配到锁相编辑组的轨道上使用渐变工具会将渐变应用到此组中的所有轨道。
  • 现在,当循环模式的项目录音设置设为“合并”时,采集录音能够正确地与现有片段合并。
  • 当辅助作为 Patch 的一部分随轨道添加到项目中时,如果辅助已分配到项目中的轨道,删除轨道不会再同时删除这些辅助。
  • Drum Machine Designer 实例创建撤销操作现在能够正常工作。
  • 在合并模式下创建重叠 MIDI 录音后,MIDI 片段移调设置不会再意外还原为 0。
  • 取消按选取框选定内容等份 MIDI 片段不会再不会导致删除这个片段。
  • 当节拍器处于简单模式时,现在又可以在音频录音期间打开或关闭节拍器咔嗒声。
  • 不管缩放比例如何,渐变工具现在都能可靠地在已编组轨道上创建渐弱。
  • 现在,使用“创建轨道”或“创建轨道并静音”录音选项时,当录音在循环模式下多次经过多个轨道时,轨道能够可靠地维持正确的顺序。
  • 现在,在“选择备选和备份”对话框中连按两下备选或备份可以将其载入。
  • 现在,在主窗口中使用重复后执行撤销能够维持片段选择。
  • 可以再次通过以下方式将片段检查器中的值设为默认值:高亮显示并删除值,然后按 Return 键。
  • 吸附到过零点现在在音频片段通过以下方式分开时应用:使用剪刀工具剪切、点按选取框所选内容、连按两下选取框所选内容,或片段修剪。
  • 当在循环模式下录音替换音频时,循环区域右侧的片段不会再不会在录音停止时被选中。
  • 在将插件拖到不同的通道条后执行撤销时,不会再撤销上次应用到插件的参数更改。
  • 现在,通过在替换模式下基于现有片段手动设定入点创建的 MIDI 片段能够正常播放。
  • Apple 乐段变奏下拉菜单不会再显示名称相似的无关乐段。
  • 当无重叠模式处于启用状态时,使用移到原始录音位置命令移动的片段不会再与其他片段重叠。
  • 现在,如果从控制条移除了替换按钮,替换模式会自动停用。
  • 现在,可以在偏好设置窗口已打开的情况下打开项目设置窗口。
  • 缩放各个轨道的键盘命令现在会应用到所有选定的轨道。
  • 现在,当在从 1 1 1 1 以外的位置开始的项目中使用“在原来的位置粘贴”命令时,数据会放置在正确的位置。
  • 现在可以复制/粘贴组设置。
  • 现在可以在执行“按片段名称给轨道命名”命令后进行撤销操作。
  • 现在,不能再将选取框所选内容拖到项目开始位置之前的点。
  • 现在,从 1 1 1 1 之前的位置复制的片段会正确放置在所选位置。
  • “移除重叠”命令不会再失效。
  • 当无重叠模式处于启用状态时,将片段复制到汇整折叠夹的左侧不会再导致汇整折叠夹被意外删除。
  • 已关闭的 Track Stack 中的片段长度不会再被意外更改。
  • “项目管理”>“整理”命令不会再移除属于其他项目备选的音频文件。
  • 现在,在复制轨道及它的内容时,新轨道会包含原始片段而非替身的副本。
  • 现在,“从选择位置播放”键盘命令会对音频片段中选定的 Flex 变音音符做出响应。
  • 缩放以适合键盘命令现在能够在选取框选定区域上正常工作。
  • 当使用“片段长度”拆分片段时,如果片段长度包含的 MIDI CC 数据全部位于拆分左侧,则拆分点右侧的新片段现在会包含正确值的 MIDI CC 信息,以确保它能够像拆分前一样播放。
  • 现在,可以通过从右向左轻扫来向多个选定片段应用交叉渐变。 
  • 现在,可以使用渐变工具向同一轨道上的多个选定片段应用渐强和渐弱。
  • 撤销音轨创建不会再导致意外选中已关闭堆栈中的轨道。
  • 使用录音重复键盘命令不会再导致最近录制的片段被删除(如果在录音期间调整过轨道音量)。
  • 在分开片段锚点未放置在开始位置的音频片段时,不会再导致两个生成的片段之间出现意外的空隙。
  • 现在又可以将音频输入设备设为“无”。
  • 粘合间插环绕声片段不会再导致生成单声道文件。
  • 现在可以使用向下和向上箭头键浏览启动对话框中的选项。
  • 现在可以为轨道头设定默认配置。
  • 在音频文件浏览器中选中“选定未使用的”选项时,删除文件操作只会删除未在任何其他项目备选中使用的文件。备选使用的文件会被从当前备选的音频文件浏览器中移除,但仍保留在硬盘驱动器上。
  • 现在,当轨道自动化可见时,可以使用 Option 键访问循环工具。
  • 现在,文件选择器中的最近使用的项目列表会显示存储到 iCloud 的项目。
  • 现在,缩放以适合能够在轨道自动化可见时正常工作
  • 现在,当快速入点处于启用状态时,可以在播放期间插入插件。
  • 自动生成的交叉渐变不会再在调整左片段边沿时消失。
  • 现在,当片段的左角落发生更改时,Pickup Clock 会将音符事件移动到适当的位置。
  • 当其他窗口具有键盘焦点时,音乐键入窗口不会再在按下 Command - W 键时关闭。
  • 现在,当做出选取框选择时,跟随会停用。
  • 现在,当在轨道区域中抓取片段时,帮助标记会显示所选片段的编号。
  • 长按片段边界不会再意外创建撤销步骤。
  • 现在,当轨道区域中没有片段且音序器停止时,在乐段浏览器中播放的乐段将按它的原始速度播放。
  • 现在,音乐键入键盘可在音轨编辑器中启用了 Flex Pitch 的情况下使用。
  • 使用惯性滚动期间按下 Option 键不会再导致视图被缩放。
  • 现在,当将光标悬停在控制按钮上时,帮助标记会显示已分配的键盘命令。
  • 现在,按住 Control 键并点按轨道头中的独奏按钮能够正常激活“Solo Safe”(独奏(安全))。
  • 在某个窗口中设定工具光标后,当焦点切换到其他窗口时,光标不会再偶尔保留在原来窗口中。
  • 现在,当将拖移模式设为交叉渐变时,从项目音频或所有文件浏览器拖动片段时可正常设定交叉渐变。
  • 现在,SMPTE 锁定的标记能够在帧速率发生更改时可靠地维持其位置。
  • 当循环的 MIDI 片段不在下一小节开始位置前至少一个时钟音位处结尾时,合并循环的片段不会再导致产生额外的 MIDI 音符。
  • 主窗口中的混音器高度现在能够可靠地存储在屏幕设置中。
  • 键盘命令中包含 Command 键修饰符的工具现在能够在释放键盘命令组合时正确地切换到上一个工具。
  • 关联菜单项“移除渐变”现在能够正确地从所有选定片段中移除同类渐变。
  • “切换缩放以适合所选内容或所有内容”键盘命令现在能够正确处理选定的 Track Stack 容器。
  • 自动缩放轨道的大小不会再在启用再停用自动化视图后增加。
  • 独奏工具现在能够正确地配合 Force Touch 触控板使用。
  • 现在,您不必开始和停止播放就能听到在播放期间更改片段增益所产生的效果。
  • 现在,可以通过长按片段或某个乐段来拖动循环片段。

 

进一步了解

有关非 Apple 制造的产品或非 Apple 控制或测试的独立网站的信息仅供参考,不代表 Apple 的任何建议或保证。Apple 对于第三方网站或产品的选择、性能或使用不承担任何责任。Apple 对于第三方网站的准确性和可靠性不作任何担保。互联网的使用具有一定风险。请联系供应商以了解其他信息。其他公司和产品名称可能是其各自所有公司的商标。

发布日期: