เกี่ยวกับเนื้อหาความปลอดภัยของ Safari 12.0.2

เอกสารนี้จะอธิบายเกี่ยวกับเนื้อหาความปลอดภัยของ Safari 12.0.2

เกี่ยวกับรายการอัพเดทความปลอดภัยของ Apple

เพื่อเป็นการปกป้องลูกค้าของเรา Apple จะไม่เปิดเผย อภิปราย หรือยืนยันปัญหาด้านความปลอดภัยจนกว่าจะมีการตรวจสอบ และมีแพตช์หรือมีการเปิดตัวออกมาแล้ว รายการที่เปิดตัวล่าสุดจะแสดงอยู่ในหน้ารายการอัพเดทความปลอดภัยของ Apple

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับความปลอดภัย โปรดดูที่หน้าความปลอดภัยของผลิตภัณฑ์ Apple คุณสามารถเข้ารหัสการสื่อสารกับ Apple ได้โดยใช้คีย์ PGP สำหรับความปลอดภัยของผลิตภัณฑ์ Apple

เอกสารด้านความปลอดภัยของ Apple จะอ้างอิงช่องโหว่ต่างๆ ตาม CVE-ID หากทำได้

Safari 12.0.2

เปิดตัวเมื่อวันที่ 5 ธันวาคม 2018

Safari

มีให้สำหรับ: macOS Sierra 10.12.6, macOS High Sierra 10.13.6 และ macOS Mojave 10.14.1

ผลกระทบ: การเข้าชมเว็บไซต์ที่ประสงค์ร้ายอาจทำให้เกิดการปลอมแปลงแถบที่อยู่

คำอธิบาย: ปัญหาตรรกะได้รับการแก้ไขแล้วด้วยการปรับปรุงการจัดการสถานะให้ดียิ่งขึ้น

CVE-2018-4440: Wenxu Wu จาก Tencent Security Xuanwu Lab (xlab.tencent.com)

Safari

มีให้สำหรับ: macOS Sierra 10.12.6, macOS High Sierra 10.13.6 และ macOS Mojave 10.14.1

ผลกระทบ: การเข้าดูเว็บไซต์ที่ประสงค์ร้ายอาจทำให้เกิดการปลอมแปลงอินเทอร์เฟซผู้ใช้

คำอธิบาย: ปัญหาตรรกะได้รับการแก้ไขแล้วด้วยการปรับปรุงการตรวจสอบให้ดียิ่งขึ้น

CVE-2018-4439: xisigr จาก Tencent's Xuanwu Lab (tencent.com)

Safari

มีให้สำหรับ: macOS Sierra 10.12.6, macOS High Sierra 10.13.6 และ macOS Mojave 10.14.1

ผลกระทบ: ผู้ใช้อาจไม่สามารถลบประวัติการเรียกดูได้ทั้งหมด

คำอธิบาย: "ล้างประวัติและข้อมูลเว็บไซต์" ไม่ล้างประวัติ ปัญหานี้ได้รับการแก้ไขแล้วด้วยการปรับปรุงการลบข้อมูลให้ดียิ่งขึ้น

CVE-2018-4445: William Breuer

WebKit

มีให้สำหรับ: macOS Sierra 10.12.6, macOS High Sierra 10.13.6 และ macOS Mojave 10.14.1

ผลกระทบ: การประมวลผลคอนเทนต์เว็บที่ออกแบบมาเพื่อประสงค์ร้ายอาจทำให้มีการใช้โค้ดโดยอำเภอใจ

คำอธิบาย: ปัญหาหลายประการเกี่ยวกับความเสียหายของหน่วยความจำได้รับการแก้ไขแล้วด้วยการปรับปรุงการจัดการหน่วยความจำให้ดียิ่งขึ้น

CVE-2018-4437: HyungSeok Han, DongHyeon Oh และ Sang Kil Cha จาก KAIST Softsec Lab ประเทศเกาหลี

CVE-2018-4464: HyungSeok Han, DongHyeon Oh และ Sang Kil Cha จาก KAIST Softsec Lab ประเทศเกาหลี

WebKit

มีให้สำหรับ: macOS Sierra 10.12.6, macOS High Sierra 10.13.6 และ macOS Mojave 10.14.1

ผลกระทบ: การประมวลผลคอนเทนต์เว็บที่ออกแบบมาเพื่อประสงค์ร้ายอาจทำให้มีการใช้รหัสโดยอำเภอใจ

คำอธิบาย: ปัญหาหน่วยความจำเสียหายได้รับการแก้ไขแล้วด้วยการปรับปรุงการจัดการหน่วยความจำให้ดียิ่งขึ้น

CVE-2018-4441: lokihardt จาก Google Project Zero

CVE-2018-4442: lokihardt จาก Google Project Zero

CVE-2018-4443: lokihardt จาก Google Project Zero

WebKit

มีให้สำหรับ: macOS Sierra 10.12.6, macOS High Sierra 10.13.6 และ macOS Mojave 10.14.1

ผลกระทบ: การเข้าดูเว็บไซต์ที่ออกแบบมาเพื่อประสงค์ร้ายอาจทำให้ข้อมูลสำคัญรั่วไหลได้

คำอธิบาย: ปัญหาตรรกะได้รับการแก้ไขแล้วด้วยการปรับปรุงการจัดการสถานะให้ดียิ่งขึ้น

CVE-2018-4444: James Lee (@Windowsrcer) จาก S2SWWW (s2swww.com)

เพิ่มรายการเมื่อวันที่ 3 เมษายน 2019

WebKit

มีให้สำหรับ: macOS Sierra 10.12.6, macOS High Sierra 10.13.6 และ macOS Mojave 10.14.1

ผลกระทบ: การประมวลผลคอนเทนต์เว็บที่ออกแบบมาเพื่อประสงค์ร้ายอาจทำให้มีการใช้โค้ดโดยอำเภอใจ

คำอธิบาย: มีปัญหาตรรกะที่ส่งผลให้หน่วยความจำเสียหาย ปัญหานี้ได้รับการแก้ไขแล้วด้วยการปรับปรุงการจัดการสถานะให้ดียิ่งขึ้น

CVE-2018-4438: lokihardt จาก Google Project Zero, Qixun Zhao จาก Qihoo 360 Vulcan Team

อัพเดทรายการเมื่อวันที่ 22 มกราคม 2019

ข้อมูลเกี่ยวกับผลิตภัณฑ์ที่ไม่ได้ผลิตโดย Apple หรือเว็บไซต์อิสระที่ไม่ได้ควบคุมหรือทดสอบโดย Apple มีให้โดยไม่มีคำแนะนำหรือการรับรองใดๆ Apple ไม่ขอรับผิดชอบในส่วนที่เกี่ยวกับการเลือก ประสิทธิภาพ หรือการใช้งานเว็บไซต์หรือผลิตภัณฑ์ของบริษัทอื่น Apple ไม่รับรองความถูกต้องหรือความน่าเชื่อถือของเว็บไซต์ของบริษัทอื่น ความเสี่ยงต่างๆ ในการใช้งานอินเทอร์เน็ตถือเป็นเรื่องปกติที่เกิดขึ้นได้ ติดต่อผู้จำหน่ายสำหรับข้อมูลเพิ่มเติม ชื่อบริษัทและชื่อผลิตภัณฑ์อื่นอาจเป็นเครื่องหมายการค้าของเจ้าของแต่ละราย

วันที่เผยแพร่: