Проблемы системы безопасности, устраняемые обновлением Swift 5.1.1 для Ubuntu

В этом документе описаны проблемы системы безопасности, устраняемые обновлением Swift 5.1.1 для Ubuntu.

Сведения об обновлениях системы безопасности Apple

В целях защиты клиентов компания Apple не разглашает информацию о проблемах безопасности, не подтверждает ее и не участвует в ее обсуждении до тех пор, пока не будет завершено изучение соответствующей проблемы и не будут опубликованы исправления или новые выпуски. Список последних выпусков представлен на странице Обновления системы безопасности Apple.

В документах Apple о безопасности уязвимости идентифицируются с помощью кода CVE-ID, когда это возможно.

Дополнительную информацию о безопасности см. на странице Безопасность продуктов Apple.

Swift 5.1.1 для Ubuntu

Дата выпуска: 11 октября 2019 г.

Платформа

Целевые продукты: Ubuntu 14.04, 16.04 и 18.04

Воздействие. Неправильное управление дескрипторами файлов в URLSession могло приводить к случайному раскрытию данных.

Описание. Эта проблема устранена путем исправления логики управления дескрипторами файлов URLSession в соответствии с версией Swift 5.0.

CVE-2019-8790: специалисты Apple

Информация о продуктах, произведенных не компанией Apple, или о независимых веб-сайтах, неподконтрольных и не тестируемых компанией Apple, не носит рекомендательного характера и не рекламируются компанией. Компания Apple не несет никакой ответственности за выбор, функциональность и использование веб-сайтов или продукции сторонних производителей. Компания Apple также не несет ответственности за точность или достоверность данных, размещенных на веб-сайтах сторонних производителей. Помните, что использование любых сведений или продуктов, размещенных в Интернете, сопровождается риском. За дополнительной информацией обращайтесь к поставщику. Другие названия компаний или продуктов могут быть товарными знаками соответствующих владельцев.

Дата публикации: