Проблемы безопасности, устраняемые обновлением Xcode 9.3

В настоящем документе описаны проблемы системы безопасности, устраняемые обновлением Xcode 9.3.

Сведения об обновлениях системы безопасности Apple

В целях защиты клиентов компания Apple не разглашает информацию о проблемах безопасности, не подтверждает ее и не участвует в ее обсуждении до тех пор, пока не будет завершено изучение соответствующей проблемы и не будут опубликованы исправления или новые выпуски. Список последних выпусков представлен на странице Обновления системы безопасности Apple.

Дополнительную информацию о безопасности см. на странице Безопасность продуктов Apple. Зашифровать информацию, передаваемую в Apple, можно с помощью PGP-ключа безопасности продуктов Apple.

В документах Apple о безопасности уязвимости идентифицируются с помощью кода CVE-ID, когда это возможно.

Xcode 9.3

Дата выпуска: 29 марта 2018 г.

LLVM

Целевые продукты: ОС macOS High Sierra 10.13.2 или более поздних версий

Воздействие. В этом обновлении был устранен ряд проблем с системой LLVM.

Описание. Был устранен ряд проблем посредством обновления текущей версии LLVM, поставляемой в комплекте с Xcode.

CVE-2018-4164: обнаружено с помощью инструмента OSS-Fuzz.

 

Информация о продуктах, произведенных не компанией Apple, или о независимых веб-сайтах, неподконтрольных и не тестируемых компанией Apple, не носит рекомендательного характера и не рекламируются компанией. Компания Apple не несет никакой ответственности за выбор, функциональность и использование веб-сайтов или продукции сторонних производителей. Компания Apple также не несет ответственности за точность или достоверность данных, размещенных на веб-сайтах сторонних производителей. Помните, что использование любых сведений или продуктов, размещенных в Интернете, сопровождается риском. За дополнительной информацией обращайтесь к поставщику. Другие названия компаний или продуктов могут быть товарными знаками соответствующих владельцев.

Дата публикации: