Проблемы безопасности, устраняемые обновлением ОС OS X Server 4.1

Здесь приведены сведения о проблемах безопасности, устраненных обновлением ОС OS X Server 4.1.

В целях защиты клиентов компания Apple не разглашает информацию о проблемах безопасности, не подтверждает ее и не участвует в ее обсуждении до тех пор, пока не будет полностью завершено изучение соответствующей проблемы и не будут опубликованы все необходимые исправления и выпуски. Дополнительные сведения об обеспечении безопасности продуктов Apple см. на веб-сайте Безопасность продуктов Apple.

Информацию об обеспечении безопасности продуктов Apple с помощью PGP-ключа см. в статье Использование PGP-ключа безопасности продуктов Apple.

Там, где это возможно, для ссылки на дополнительную информацию об уязвимостях используются идентификаторы CVE.

Сведения о других обновлениях системы безопасности см. в статье Обновления системы безопасности Apple.

ОС OS X Server 4.1

  • Dovecot

    Доступно для: ОС OS X Yosemite 10.10 и более поздних версий.

    Воздействие. Злоумышленник может расшифровать данные, защищенные SSL.

    Описание. Был возможен ряд атак на конфиденциальность SSL 3.0, при которых комплект шифров использует блочный шифр в режиме CBC. Путем блокировки TLS 1.0 и увеличения числа попыток соединения злоумышленник мог вызвать принудительное использование SSL 3.0 даже для серверов, поддерживающих лучшую версию (TLS). Проблема была решена отключением поддержки SSL 3.0 в Dovecot.

    Идентификатор CVE

    CVE-2014-3566

  • Брандмауэр

    Доступно для: ОС OS X Yosemite 10.10 и более поздних версий.

    Воздействие. Пользовательские правила в брандмауэре могли не применяться

    Описание. Для ссылки на файлы настройки брандмауэра использовался неправильный путь. Проблема была решена исправлением пути, использовавшегося для ссылки на правильный файл настройки брандмауэра.

    Идентификатор CVE

    CVE-2015-1150: Фил Шумм (Phil Schumm), Research Computing Group, университет Чикаго

  • Postfix

    Доступно для: ОС OS X Yosemite 10.10 и более поздних версий.

    Воздействие. Злоумышленник может расшифровать данные, защищенные SSL.

    Описание. Был возможен ряд атак на конфиденциальность SSL 3.0, при которых комплект шифров использует блочный шифр в режиме CBC. Путем блокировки TLS 1.0 и увеличения числа попыток соединения злоумышленник мог вызвать принудительное использование SSL 3.0 даже для серверов, поддерживающих лучшую версию (TLS). Проблема была решена отключением поддержки SSL 3.0 в Postfix.

    Идентификатор CVE

    CVE-2014-3566

  • Wiki Server

    Доступно для: ОС OS X Yosemite 10.10 и более поздних версий.

    Воздействие. Управление доступом могло не работать на мобильных устройствах

    Описание. Управление доступом для вики-страниц «Действия» и «Люди» не работало на клиентах iPad. Проблема была решена улучшением проверки управления доступом.

    Идентификатор CVE

    CVE-2015-1151

Информация о продуктах, произведенных не компанией Apple, или о независимых веб-сайтах, неподконтрольных и не тестируемых компанией Apple, не носит рекомендательного характера и не рекламируются компанией. Компания Apple не несет никакой ответственности за выбор, функциональность и использование веб-сайтов или продукции сторонних производителей. Компания Apple также не несет ответственности за точность или достоверность данных, размещенных на веб-сайтах сторонних производителей. Помните, что использование любых сведений или продуктов, размещенных в Интернете, сопровождается риском. За дополнительной информацией обращайтесь к поставщику. Другие названия компаний или продуктов могут быть товарными знаками соответствующих владельцев.

Дата публикации: