Despre conținutul de securitate din SwiftNIO SSL 2.4.1

Acest document descrie conținutul de securitate din SwiftNIO SSL 2.4.1.

Despre actualizările de securitate Apple

Pentru protecția clienților noștri, Apple nu divulgă, nu discută și nu confirmă problemele de securitate până când nu se efectuează o investigație și până când nu sunt disponibile corecții sau versiuni noi. Versiunile recente sunt listate pe pagina Actualizări de securitate Apple.

Documentele de securitate Apple menționează vulnerabilitățile după CVE-ID (ID CVE), atunci când este posibil.

Pentru informații suplimentare despre securitate, consultă pagina referitoare la securitatea produselor Apple.

SwiftNIO SSL 2.4.1

Publicare: vineri, 4 octombrie 2019

SwiftNIO

Disponibilitate pentru: SwiftNIO SSL 2.0.0 – 2.4.0 pe Ubuntu 14.04 și versiuni ulterioare

Impact: o aplicație SwiftNIO care folosește TLS poate executa un cod arbitrar

Descriere: problema a fost rezolvată prin semnalarea faptului că nu este necesară o stivă executabilă.

CVE-2019-8849: Apple

Informațiile despre produsele care nu sunt fabricate de Apple sau despre site-urile web independente care nu sunt controlate sau testate de Apple sunt furnizate fără recomandare sau aprobare. Apple nu își asumă nicio responsabilitate în ceea ce privește selectarea, funcționarea sau utilizarea site-urilor web sau produselor de la terți. Apple nu face niciun fel de declarații privind acuratețea sau fiabilitatea site-urilor web terțe. Contactează furnizorul acestor produse pentru a obține mai multe informații.

Data publicării: