Despre conținutul de securitate din Swift 5.1.1 pentru Ubuntu.

Acest document descrie conținutul de securitate din Swift 5.1.1 pentru Ubuntu.

Despre actualizările de securitate Apple

Pentru protecția clienților noștri, Apple nu divulgă, nu discută și nu confirmă problemele de securitate până când nu se efectuează o investigație și până când nu sunt disponibile corecții sau versiuni noi. Versiunile recente sunt listate pe pagina Actualizări de securitate Apple.

Documentele de securitate Apple menționează vulnerabilitățile după CVE-ID (ID CVE), atunci când este posibil.

Pentru informații suplimentare despre securitate, consultă pagina referitoare la securitatea produselor Apple.

Swift 5.1.1 pentru Ubuntu

Publicare: 11 octombrie 2019

Foundation

Disponibilitate pentru: Ubuntu 14.04, 16.04 și 18.04

Impact: gestionarea incorectă a descriptoarelor de fișiere din URLSession ar fi putut duce la dezvăluirea nedorită a datelor

Descriere: această problemă a fost rezolvată prin actualizarea logicii incorecte de gestionare a descriptorilor de fișiere URLSession, pentru a corespunde cu Swift 5.0.

CVE-2019-8790: Apple

Informaţiile despre produsele care nu sunt fabricate de Apple sau despre site-urile web independente care nu sunt controlate sau testate de Apple sunt furnizate fără recomandare sau aprobare. Apple nu îşi asumă nicio responsabilitate în ceea ce priveşte selectarea, funcţionarea sau utilizarea site-urilor web sau produselor de la terţi. Apple nu face niciun fel de declaraţii privind acurateţea sau fiabilitatea site-urilor web terţe. La utilizarea Internetului, riscurile sunt inerente. Contactează distribuitorul pentru informaţii suplimentare. Alte nume de companii şi produse pot fi mărci comerciale ale proprietarilor respectivi.

Data publicării: