macOS High Sierra

Se for pedido para confiar ou atualizar um plug-in

Alguns sites usam plug-ins para exibir vídeos, animação ou outros conteúdos especiais. Entre os exemplos mais comuns estão Adobe Flash Player, QuickTime e Oracle Java. Contudo, plug-ins podem ser explorados e talvez representem risco à segurança ou privacidade. Você pode optar por usar apenas alguns plug-ins em sites confiáveis de sua escolha.

Um diálogo pode ser exibido ao visitar um site que tenha conteúdo de plug-in ou ao alterar a política de bloqueio de um plug-in no painel Sites, nas preferências do Safari.

Se o conteúdo do plug-in não estiver visível e o diálogo perguntar: Deseja usar o [nome do plug-in] em [endereço do site]?

Em todos os sites, o Safari desativa os plug-ins comuns a seguir por padrão: Flash, Java, QuickTime e Silverlight. Você terá as escolhas a seguir:

  • Usar Sempre: o Safari usará o plug-in para mostrar o conteúdo do site. O plug-in permanece ativado no site contanto que você o visite regularmente.

  • Cancelar: o Safari não usará o plug-in para mostrar o conteúdo do site. Para usar o plug-in para mostrar o conteúdo do site ao visitá-lo novamente, escolha Visualizar > Recarregar com Plug-ins ou mantenha o ícone Recarregar pressionado na extremidade direita do campo de Busca Inteligente e escolha “Recarregar com Plug-ins”.

  • Usar Uma Vez: o Safari usará o plug-in para mostrar o conteúdo do site agora, mas não quando você visitá-lo novamente. Para usar o plug-in para mostrar o conteúdo do site ao visitá-lo novamente, escolha Visualizar > Recarregar com Plug-ins ou mantenha o ícone Recarregar pressionado (à direita do campo de Busca Inteligente) e escolha “Recarregar com Plug-ins”.

Se o conteúdo do plug-in estiver visível e o diálogo perguntar: Deseja confiar no site [endereço do site] para que use o plug-in [nome do plug-in]?

Você terá as escolhas a seguir:

  • Confiar: o Safari usa o plug-in para exibir o conteúdo desse site e não perguntará sobre esse plug-in quando você visitar esse site novamente.

  • Cancelar: o Safari mostra um marcador de posição “[Plug-in] bloqueado para este site” em vez do conteúdo do plug-in nesse site no momento e quando você visitá-lo novamente. Para ver o conteúdo do plug-in, clique no marcador de posição e clique em Confiar.

Se o conteúdo do plug-in não estiver visível e o diálogo perguntar: Deseja confiar no site [endereço do site] para que use o plug-in [nome do plug-in]?

Você terá as escolhas a seguir:

  • Nunca para este site: o Safari não permite que o site use o plug-in.

  • Confiar: o Safari permite que o site use o plug-in e não perguntará sobre isso quando você visitá-lo novamente.

  • Agora Não: o Safari não permite que o site use o plug-in no momento, mas pergunta sobre ele novamente na próxima vez em que você visitá-lo.

Se o diálogo perguntar: Tem certeza de que deseja confiar no site ou em todos os sites para que executem [nome do plug-in] no modo inseguro?

Você terá as escolhas a seguir:

  • Confiar: o Safari usa o plug-in no modo inseguro. O plug-in pode acessar seus dados e documentos pessoais.

  • Cancelar: o Safari não usa o plug-in no modo inseguro. Quando um plug-in é executado no modo inseguro, ele pode acessar seus documentos e dados pessoais.

Se o diálogo disser que o plug-in precisa ser atualizado

Você terá as escolhas a seguir:

  • Transferir [Plug-in]: vai a um site de onde você pode obter uma atualização. Após transferi-la, instale a atualização, saia do Safari e reinicie-o.

  • Desativar [Plug-in]: o plug-in está desabilitado e o Safari tenta mostrar o conteúdo sem ele. Se não funcionar, um marcador de posição aparece nesse site até você atualizar o plug-in.

Se o diálogo disser que a sua versão do plug-in tem problemas críticos de segurança

  • Por padrão, o Safari não permite que o site use o plug-in.

    Para usar o plug-in mesmo assim, escolha Safari > Preferências e clique em Sites. Selecione o plug-in à esquerda, clique no menu pop-up desse site e escolha Ligado. A escolha pode representar um risco à segurança ou privacidade, portanto, escolha essa opção apenas para um site de sua confiança.

Para alterar a política de bloqueio de plug-in para visitas futuras a um site, escolha Safari > Preferências e clique em Sites. Selecione o site web e escolha as configurações de plug-in. Para obter mais informações sobre as opções de política, consulte Preferências de sites web.