Om sikkerhetsinnholdet i Sikkerhetsoppdatering 2018-001 Swift 4.1.1 for Ubuntu 14.04

Dette dokumentet beskriver sikkerhetsinnholdet i Sikkerhetsoppdatering 2018-001 Swift 4.1.1 for Ubuntu 14.04.

Om sikkerhetsoppdateringer fra Apple

Av hensyn til kundenes sikkerhet er det Apples praksis ikke å videreformidle, diskutere eller bekrefte sikkerhetsproblemer før det er foretatt en fullstendig undersøkelse og eventuelle nødvendige rettelser eller utgivelser er tilgjengelig. Nylige utgivelser er oppført på siden for Sikkerhetsoppdateringer fra Apple.

For mer informasjon om sikkerhet kan du gå til siden for Apple-produktsikkerhet. Du kan kryptere kommunikasjon med Apple ved å bruke PGP-nøkkelen for Apple-produktsikkerhet.

Apple-sikkerhetsdokumenter refererer til sårbarheter etter CVE-ID når det er mulig.

Sikkerhetsoppdatering 2018-001 Swift 4.1.1 for Ubuntu 14.04

Utgitt 4. mai 2018

Swift for Ubuntu

Tilgjengelig for: Ubuntu 14.04

Påvirkes ikke: Ubuntu 16.04 og 16.10

Virkning: En prosess kan få administrasjonsrettigheter og utføre vilkårlig kode

Beskrivelse: Det var et problem i bestemte versjoner av Swift på Ubuntu 14.04 der biblioteker lastes inn med skrive- eller utførelsesrettigheter. Problemet ble løst gjennom forbedrede tillatelser.

CVE-2018-4220: Apple

Informasjon om produkter som ikke er laget av Apple, samt uavhengige nettsteder som ikke kontrolleres eller testes av Apple, er gitt uten anbefaling eller godkjenning. Apple påtar seg ikke noe ansvar for utvalget av, bruken av eller ytelsen til nettsteder og produkter fra tredjeparter. Apple garanterer ikke for nøyaktigheten eller påliteligheten til tredjeparters nettsteder. Kontakt leverandøren for mer informasjon.

Publiseringsdato: