macOS High Sierra

Je wordt gevraagd om een plugin te vertrouwen of bij te werken

Op sommige websites wordt gebruikgemaakt van plugins om video, animaties of ander speciaal materiaal weer te geven. Enkele veelgebruikte plugins zijn Adobe Flash Player, QuickTime en Oracle Java. Plugins kunnen echter worden misbruikt en kunnen een veiligheids- of privacyrisico opleveren. Je kunt instellen dat alleen bepaalde plugins mogen worden gebruikt op vertrouwde websites die je selecteert.

Er kan een venster verschijnen als je een website bezoekt die pluginmateriaal heeft of als je het blokkeerbeleid voor een plugin wijzigt in het paneel 'Websites' in het voorkeurenvenster van Safari.

Het pluginmateriaal is niet zichtbaar en in het dialoogvenster staat de vraag: Wil je [naam plugin] gebruiken op [website]?

Voor alle websites zijn in Safari de volgende veelgebruikte plugins standaard uitgeschakeld: Flash, Java, QuickTime en Silverlight. Je kunt kiezen uit de volgende opties:

  • Gebruik elke keer: De plugin wordt gebruikt om materiaal op deze website weer te geven. Zolang je de website regelmatig bezoekt, blijft de plugin ingeschakeld voor deze website.

  • Annuleer: De plugin wordt niet gebruikt om materiaal op deze website weer te geven. Om de volgende keer dat je de website bezoekt de plugin te gebruiken om materiaal voor deze website weer te geven, kies je 'Weergave' > 'Laad opnieuw met plugins' of houd je het symbool voor opnieuw laden  rechts van het slimme zoekveld ingedrukt en kies je 'Laad opnieuw met plugins'.

  • Gebruik eenmalig: De plugin wordt nu gebruikt om materiaal voor deze website weer te geven. Als je deze website nogmaals bezoekt, moet je opnieuw toestemming voor deze plugin geven. Om de volgende keer dat je de website bezoekt de plugin te gebruiken om materiaal voor deze website weer te geven, kies je 'Weergave' > 'Laad opnieuw met plugins' of houd je het symbool voor opnieuw laden  rechts van het slimme zoekveld ingedrukt en kies je 'Laad opnieuw met plugins'.

Het pluginmateriaal is zichtbaar en in het dialoogvenster staat de vraag: Weet je zeker dat je de website [websiteadres] de plugin [pluginnaam] wilt laten gebruiken?

Je kunt kiezen uit de volgende opties:

  • Sta toe: De plugin wordt gebruikt om materiaal voor deze website weer te geven. Als je deze website nogmaals bezoekt, hoef je niet opnieuw toestemming voor deze plugin te geven.

  • Annuleer: In plaats van het pluginmateriaal op deze website wordt de plaatsaanduiding "[Plugin] is geblokkeerd voor deze website" weergegeven. De volgende keer dat je de website bezoekt, wordt deze plaatsaanduiding opnieuw weergegeven. Om het pluginmateriaal weer te geven, klik je op de plaatsaanduiding en klik je vervolgens op 'Sta toe'.

Het pluginmateriaal is niet zichtbaar en in het dialoogvenster staat de vraag: Weet je zeker dat je de website [websiteadres] de plugin [pluginnaam] wilt laten gebruiken?

Je kunt kiezen uit de volgende opties:

  • Nooit voor deze website: De website mag de plugin niet gebruiken.

  • Sta toe: De website mag de plugin gebruiken. Als je de website nogmaals bezoekt, hoef je niet opnieuw toestemming voor de plugin te geven.

  • Nu niet: De plugin mag nu voor de website worden gebruikt. Als je de website nogmaals bezoekt, wordt jou opnieuw gevraagd of de plugin mag worden gebruikt.

In het dialoogvenster staat de vraag: Sta je de website of alle websites toe om [pluginnaam] in de onveilige modus uit te voeren?

Je kunt kiezen uit de volgende opties:

  • Sta toe: De plugin wordt in de onveilige modus gebruikt. De plugin krijgt toegang tot je persoonlijke gegevens en documenten.

  • Annuleer: De plugin wordt niet in de onveilige modus gebruikt. Als een plugin in de onveilige modus wordt gebruikt, kan deze toegang verkrijgen tot je persoonlijke documenten en gegevens.

In het dialoogvenster staat dat de plugin moet worden bijgewerkt

Je kunt kiezen uit de volgende opties:

  • Download [plugin]: Hiermee ga je naar een website waar je een update kunt downloaden. Nadat je de update hebt gedownload, installeer je de update, stop je Safari en open je het programma opnieuw.

  • Schakel [Plugin] uit: De plugin wordt uitgeschakeld en er wordt geprobeerd om de inhoud zonder de plugin weer te geven. Als dat niet lukt, wordt er een plaatsaanduiding weergegeven op deze website totdat je de plugin hebt bijgewerkt.

In het dialoogvenster staat dat je pluginversie kritieke beveiligingsproblemen heeft

  • Bij de standaardinstelling van Safari mag de website de plugin niet gebruiken.

    Om de plugin toch te gebruiken, kies je 'Safari' > 'Voorkeuren' en klik je op 'Websites'. Selecteer de plugin aan de linkerkant, klik op het venstermenu voor deze website en kies 'Aan'. Als je deze optie inschakelt, kan er een veiligheids- of privacyrisico ontstaan. Kies deze optie daarom alleen voor een website die je vertrouwt.

Om het beleid voor het blokkeren van plugins te wijzigen voor toekomstige bezoeken aan een website, kies je 'Safari' > 'Voorkeuren' en klik je op 'Websites'. Selecteer de website en kies vervolgens de instellingen voor de plugin. Zie Websitevoorkeuren voor meer informatie over de beleidsopties.