MacのためのPages: 「Pages」で数学方程式を追加する

「Pages」で数学方程式を追加する

数式および方程式を書類に含めることができます。方程式を追加するには、「Pages」の方程式ダイアログ内で LaTeX コマンドまたは MathML 要素を使用して方程式を作成してから、その方程式を書類に挿入します。

方程式は、本文テキストと共に配置されるインラインオブジェクト、またはフローティングオブジェクトとして追加できます。インラインオブジェクトは、テキストフローの一部となり、テキストと一緒に移動します。フローティングオブジェクトは、ページ上の特定の位置に固定されます。フローティングオブジェクトは、ページ上の任意の位置にドラッグしたり、周りにテキストを回り込ませたり、テキストやその他のオブジェクトを前面や背面に重ねたりすることができます。

注記:数式を作成するためのアプリケーション「MathType 6.7d」以降をインストールしている場合は、それを使用できます。MathType ウインドウで記号をクリックしたり入力したりして方程式を作成します。

LaTeX または MathML で方程式を追加する

  1. 以下のいずれかを実行します:

    • インライン方程式を追加する:テキスト内に挿入ポイントを置くか、方程式で置き換えるテキストを選択します。インライン方程式は文書作成書類のみで使用できます。

    • フローティング方程式を追加する:書類の外をクリックして、何も選択されていないことを確認します。

  2. ツールバー「挿入」ボタン をクリックしてから、「方程式」を選択します。

    または、画面上部の「挿入」メニューで、「挿入」>「方程式」と選択することもできます。

  3. 「MathType」がインストールされている場合は、方程式の作成に「Pages」を使用するかどうかを尋ねるダイアログが表示されるので、「Pages を使用」をクリックします。

  4. LaTeX コマンドまたは MathML 要素を使用してフィールドに方程式を入力します。

    「方程式を編集」ダイアログ。LaTeX を使用して書き込まれた二次方程式の解の公式が「方程式を編集」フィールドに、公式のプレビューがその下に表示されています。

    サポートされる LaTeX コマンドまたは MathML 要素および属性については、Apple のサポート記事「Pages および iBooks Author での LaTeX と MathML の対応について」を参照してください。

  5. 「挿入」をクリックします。

    インライン方程式が書類の挿入ポイントに表示され、周りのテキストと同じサイズおよび色になります。周りのテキストのサイズと色を変更すると、この方程式のサイズと色も変更されます。

    フローティング方程式は、デフォルトのサイズと色で画面中央に表示されます。サイズと色は「フォーマット」 「フォーマット」ボタン サイドバーで変更できます。方程式をドラッグして、ページ上での位置を調整できます。

「MathType」を使って方程式を追加する

「MathType 6.7d」以降をインストールしている場合は、方程式を書類内に追加するために使用できます。

ヒント:「MathType」をデフォルトの方程式エディタに設定する場合は、画面上部の「Pages」メニューで「Pages」>「環境設定」と選択し、「一般」をクリックしてから、「MathType を使って方程式を挿入/編集」の横にあるチェックボックスを選択します。

  1. 以下のいずれかを実行します:

    • インライン方程式を追加する:テキスト内に挿入ポイントを置くか、方程式で置き換えるテキストを選択します。インライン方程式は文書作成書類のみで使用できます。

    • フローティング方程式を追加する:書類の外をクリックして、何も選択されていないことを確認します。

  2. ツールバー「挿入」ボタン をクリックしてから、「方程式」を選択します。

    「MathType」がデフォルトの方程式編集ツールに設定されている場合、最初に方程式を入力した後からは「MathType」が自動的に開きます。そうでない場合は、表示されるダイアログで「MathType を使用」をクリックします。

  3. 方程式を入力するには、MathType ウインドウ内で記号をクリックしたり入力したりします。

    MathType ツールの使用方法について詳しくは、「MathType」のヘルプを参照してください。

  4. 方程式を保存するには、画面上部の「ファイル」メニューで「ファイル」>「閉じてから Pages に戻る」と選択してから、表示されるダイアログで「はい」をクリックします。

    インライン方程式は、周りのテキストと同じサイズと色で挿入ポイントに表示されます。方程式を編集するには、方程式をダブルクリックして MathType ウインドウを開きます。

    フローティング方程式は画面中央に表示され、ページ上の新しい位置にドラッグすることができます。方程式を編集または外観を変更するには、方程式をダブルクリックして MathType で開いてから、ウインドウ下部のコントロールをダブルクリックします。

  5. 方程式をドラッグして、ページ上での位置を調整できます。

LaTeX または MathML でインライン方程式を編集する/削除する/移動する

インライン方程式は、追加した後で変更することができます。

  • 方程式を編集する:方程式をダブルクリックし、変更を加えてから「アップデート」をクリックします。

  • 方程式を移動する:方程式を選択し、本文テキスト、ヘッダ、またはフッタ内の新しい位置にドラッグします。

  • 方程式のサイズ、カラー、または配置を変更する:方程式をクリックし、「フォーマット」 「フォーマット」ボタン サイドバーの「テキスト」タブのコントロールを使用して、方程式のフォントサイズ、色、または配置を変更します。

  • 方程式をコピーする:方程式をクリックし、画面上部の「編集」メニューで「編集」>「コピー」と選択し、方程式をペーストしたい場所(表セル、またはページのヘッダやフッタ)に挿入ポイントを置いてから、「編集」>「ペースト」と選択します。ページ上のオブジェクト(図形など)を選択してから、「編集」>「ペースト」と選択して、方程式をフローティングオブジェクトとしてペーストすることもできます。

  • 方程式を削除する:方程式をクリックしてから、キーボードの Delete キーを押してください。

  • インライン方程式をフローティング方程式に変換する:文書作成書類で方程式を選択してから、「配置」サイドバーの「テキスト折り返し」ポップアップメニューをクリックして、方程式の周りにテキストを回り込ませる方法を選択します。

LaTeX または MathML でフローティング方程式を編集する/削除する/移動する

フローティング方程式は、追加した後で変更することができます。

  • 方程式を編集する:方程式をダブルクリックし、変更を加えてから「アップデート」をクリックします。

  • 方程式を移動する:方程式をドラッグして、ページ上の別の位置に移動します。

  • 方程式のサイズ、カラー、または配置を変更する:方程式をクリックしてから、サイドバーのコントロールを使用してフォントサイズと色を変更します。方程式のハンドルをドラッグしてフォントサイズを変更することもできます。

  • 方程式をコピーする:方程式をクリックし、「編集」>コピーと選択して、方程式を置きたいページまでスクロールしてから、「編集」>「ペースト」と選択します。表のセルやページのヘッダまたはフッタに挿入ポイントを置いてから、「編集」>「ペースト」と選択して、方程式をインラインオブジェクトとしてペーストすることもできます。

  • 方程式を削除する:方程式をクリックしてから、キーボードの Delete キーを押してください。

  • フローティング方程式をインライン方程式に変換する:文書作成書類で方程式を選択し、「配置」サイドバーの「テキストと移動」ボタンをクリックします。「テキスト折り返し」ポップアップメニューをクリックして、「インライン(テキストあり)」を選択します。方程式を最終的な位置にドラッグします。

公開日: 2018/11/22
役に立ちましたか?