MacのためのPages: 「Pages」でセルの内容を追加する/編集する

「Pages」でセルの内容を追加する/編集する

表のセルに内容を追加する方法はいくつかあります。新しい内容を入力したり、内容を別の場所からコピー&ペーストしたり、自動入力を使ってパターンを自動的に入力したりできます。内容を追加した後でも、いつでもセルを編集または消去できます。

注記:表に内容を追加できない場合は、ロックが解除されていることを確認してください。表をクリックしてから、画面上部の「配置」メニューで、「配置」>「ロック解除」と選択します。

セルに内容を追加する

  • 内容を空のセルに追加する:セルをクリックしてから、入力を始めます。

    「Pages」では、入力テキストに合わせて、オートコンプリート候補のリストが表示されます。このリストには、以前にその列に入力したテキストが含まれますが、ヘッダまたはフッタのテキストは含まれません。リストをスクロールするには Tab キーを押します。入力したい候補を選択して Return キーを押すと、セルに入力されます。オートコンプリートは「Pages」の環境設定でオン/オフを切り替えることができます。

  • 段落をセル内にペーストする: ペーストしたい段落をコピーし、セルをダブルクリックしてから、画面上部の「編集」メニューで「編集」>「ペースト」と選択します。

  • 内容を編集する:セルをダブルクリックして挿入ポイントを表示してから、入力します。挿入ポイントを移動するには、移動先をクリックしてから、入力します。

  • 内容を置き換える:セルをクリックしてから、入力を始めます。既存の内容が上書きされます。

  • すべての内容を削除する:セルをクリックしてから、キーボードの Delete キーを押します。

セルに特定のデータフォーマットを設定する方法については、さまざまな種類のデータを表示するためにセルをフォーマットするを参照してください。

表のセルにオブジェクトを追加したり、表のセルにリンクを挿入したり、表のセルに方程式を挿入したりすることもできます。

セルに合わせてテキストを折り返す

すべてのテキストをセル内に表示するのに十分なセル幅がない場合は、テキストを折り返して、セルに複数の行を表示させることができます。

  • 1 つのセルのテキストを折り返す/折り返しを解除する: 表をクリックして、Control キーを押したままセルをクリックしてから、ショートカットメニューから「テキストを折り返す」を選択します。折り返しが有効なときはチェックマークが表示されます。テキストの折り返しを解除するには、「テキストを折り返す」の選択を解除します。

  • 行、列、または表全体のテキストを折り返す/折り返しを解除する:行または列を選択するか、表を選択します。「フォーマット」  サイドバーの「表」タブをクリックしてから、上部付近にある「スタイル」ボタンをクリックします。「テキストを折り返す」チェックボックスを選択または選択解除します。

セルの範囲から内容を消去する

  1. 1 つまたは複数のセルを選択します。

  2. 以下のいずれかを実行します:

    • 内容は削除するけれども、セルのデータフォーマット、テキストスタイル、およびセルスタイルは保持する:Delete キーを押します。

    • すべてのデータ、フォーマット、およびスタイルを削除する:画面上部の「編集」メニューで、「編集」>「すべてを消去」と選択します。

セルを自動入力する

同じ数式、データ、または論理的に連続したデータ(連続した数字、日付、文字など)をセル、行または列にすばやく入力できます。

必要に応じて以下の操作を実行します:

  • 隣接するセルの内容を 1 つまたは複数のセルに自動入力する:コピーしたい内容が入ったセルを選択してから、選択範囲の枠線の上までポインタを移動して、黄色の自動入力ハンドルを表示させます。そこに内容を追加したいセルを覆うようにハンドルをドラッグします。

    選択したセルと黄色のハンドル。これをドラッグすることでセルを自動入力できます。

    選択したセルに関連付けられているすべてのデータ、セルフォーマット、数式、または塗りつぶしが追加されますが、コメントは追加されません。自動入力を実行すると、追加しようとしている内容で既存のデータが上書きされます。

  • 隣接するセルの連続的な内容またはパターンをセルに自動入力する: 入力したい行または列の最初の 2 つの本体セル(ヘッダセルまたはフッタセル以外)に、連続データの最初の 2 つの項目を入力します。たとえば、「A」および「B」と入力します。これらのセルを選択し、選択範囲の枠線の上までポインタを移動し、黄色の自動入力ハンドル(ドット)を表示させてから、データを入力したいセルを覆うようにハンドルをドラッグします。

    値のパターンを使用してセルを自動入力することもできます。たとえば、最初に選択したセルが 1 と 4 であれば、隣接する 2 つのセルに向かってドラッグすると、3 ずつ加算され、7、10 という値が入ります。

自動入力機能では、グループのセル間の現在の関係について設定は行われません。したがって、処理後に特定のセルの値を変更しても、ほかのセルには影響しません。

セルを自動入力するとき、それらのセルを参照するすべての数式は、新しい値で自動的にアップデートされます。

オートコンプリート候補のオン/オフを切り替える

「Pages」では、セルに入力するのに合わせて、オートコンプリート候補のリストを表示できます。このリストには、以前にその列に入力したテキストが含まれますが、ヘッダまたはフッタのテキストは含まれません。オートコンプリートはデフォルトではオンですが、いつでもオン/オフを切り替えることができます。

  1. 画面上部の「Pages」メニューで、「Pages」>「環境設定」と選択します。

  2. 環境設定ウインドウの上部にある「一般」をクリックします。

  3. 「編集」セクションで、「表のセルの編集中に候補を表示」を選択または選択解除します。

オブジェクトを表のセルに追加する

イメージ、線、図形、およびテキストボックスなどのオブジェクトを表のセルにペーストすることができます。すでにオブジェクトのあるセルにテキストを追加することもできます。

注記:オブジェクトが含まれるテキストをペーストするには、最初にオブジェクトを「テキストと共に移動」に設定し、オブジェクトのテキスト折り返しを「インライン(テキストあり)」に設定して、オブジェクトをインラインオブジェクトにする必要があります。インラインオブジェクトをテキストに追加する方法については、オブジェクトをテキストと共に配置するを参照してください。

  1. 書類(または別の書類)でオブジェクト(イメージ、線、図形、またはテキストボックス)を選択するか、またはインラインオブジェクトが含まれるテキストを選択してから、「編集」>「カット」または「編集」>「コピー」と選択します。

  2. オブジェクトを追加したいセルをダブルクリックします(すでにテキストが含まれているセルでも可能です)。

  3. すでにセルに内容が含まれている場合、内容をペーストしたい場所を再びクリックしてから、「編集」>「ペースト」と選択します。

セル内のムービーをペーストすると、ポスターイメージのみが表示され、ムービーは再生されません。ただし、ムービーのプロパティは保持されるため、ムービーを別の場所にコピー&ペーストすると、新しい場所で再生されます。

セルからオブジェクトを削除するには、セル内でオブジェクトの右側に挿入ポイントを置いてから、キーボードの Delete キーを押します。

表のセルの行および列を表示する

ポインタを表上で移動するのに合わせて、セルの行および列を青色で一時的にハイライトすることができます。大きな表では、特定のセルの列参照や行参照を識別するのに役立ちます。

  • Option キーを押したまま、セル上でポインタを移動します。

表のセルをコピーする/移動する

表のセルをコピーしたりセルのデータを表内の新しい場所に移動すると、セルのデータフォーマット、塗りつぶし、枠線、コメントなどのセルのプロパティもすべてコピーまたは移動されます。

  1. コピーまたは移動したいセルを選択します。

  2. 以下のいずれかを実行します:

    • データを移動する: セルを選択してから、選択範囲をクリックして押さえ、セルが表から持ち上がったら、表内の別の場所までドラッグします。既存のデータは新しいデータによって置き換えられます。

    • ペーストして既存の内容を上書きする: 画面上部の「編集」メニューで、「編集」>「コピー」と選択します。データをペーストしたい位置の左上のセルを選択してから(または、ペーストするセルと同じ大きさの領域を選択してから)、「編集」>「ペースト」と選択します。

      データ範囲に数式が含まれていて、結果のみをペーストしたい場合は、「数式の結果をペースト」を選択します。

      注記:ペーストする前に、1 つのセルだけを選択するか、ペーストするセルと同じサイズの領域を選択してください。

    • 上書きせずペーストする: 「編集」>「コピー」と選択し、コピー先のセルを選択してから、画面上部の「挿入」メニューで「挿入」>「コピーした行」または「挿入」>「コピーした列」と選択します。コピーされるセルの分だけ、新しい行または列が追加されます。

    • セルスタイルをペーストする:画面上部の「フォーマット」メニューから「フォーマット」>「スタイルをコピー」と選択します。スタイルをコピーしたいセルを選択してから、「フォーマット」>「スタイルをペースト」と選択します。

    • スタイルなしでセルの内容をペーストする: 「編集」>「コピー」と選択し、ペーストしたいセルを選択してから、「編集」>「ペーストしてスタイルを合わせる」と選択します。ペーストされたセルは、新しい位置のフォーマットが採用されます。

    • 既存の表の外側にペーストして新しい表を作成する: セルを表の外側にドラッグします。ペーストされたセルを含む新しい表が作成されます。

非表示データを含むセル(非表示またはフィルタリングされたセル)の範囲をコピーすると、非表示データもコピーされます。配列が一致する非表示セルを含むセルの範囲をペーストすると、非表示データもペーストされます。それ以外の場合、非表示の内容はペーストされません。

公開日: 2018/11/22
役に立ちましたか?