Pages for Mac: Add, delete, or rearrange pages in a Pages document

Add, delete, or rearrange pages in a Pages document

In Pages, you can create both word-processing and page layout documents, but you add and manage pages differently for each. In word-processing documents, pages are added automatically as your typing reaches the end of a page, but you can also add pages manually. In page layout documents, you add pages manually as you need them.

You can also duplicate, delete, and rearrange sections (in a word-processing document) and pages (in a page layout document), and combine documents or move content between documents of the same type.

Note: Before you start any of the tasks below, determine which type of document you have (the template you started with is designed for one or the other). To see if you have a word-processing or page layout document, click the Document radio button in the toolbar, then click Document. If the Document Body checkbox is selected, it’s a word-processing document. If the checkbox is unselected, it’s a page layout document.

Add a new page

  • In a word-processing document: Place the insertion point anywhere in the page you want the new page to follow, then click the Add Page button in the toolbar.

  • In a page layout document: Click in the page you want the new page to follow, then click the Add Page button in the toolbar. A blank page is automatically added, or if there are other master pages for the template, choose the one you want to add.

Duplicate pages

In a word-processing document you can duplicate a section, then delete any pages you don’t want to keep. In a page layout document, you can duplicate individual pages.

  1. Click the View menu button in the toolbar, then choose Page Thumbnails.

  2. Select the page thumbnails of pages you want to duplicate, then choose Edit > Duplicate Selection (from the Edit menu at the top of your screen).

    The duplicate section or pages are added below the original.

  3. Do any of the following:

    • Remove unwanted pages in the new section: In a word-processing document, select all the text and objects on the pages, then press Delete on your keyboard. As a page is cleared, it’s removed.

    • Move a section or page: In the sidebar, select the section or page you want to move, then drag it to where you want it in the document. You can move multiple pages at a time, but only one section at a time.

Delete a page

  • In a word-processing document: Select all the text and objects on the page (or multiple pages), then press Delete on your keyboard until the page is cleared.

    If the page you want to delete is blank, click at the beginning of the next page (to place the insertion point before the first text or graphic), then press Delete on your keyboard. Sometimes a blank page has formatting elements you can’t see, like paragraph breaks. If you delete these elements, the page is deleted. You can also show formatting symbols to see if thereʼs something hidden.

  • In a page layout document: Click the View menu button in the toolbar, choose Page Thumbnails, select the page thumbnail, then press Delete on your keyboard. To select multiple pages, press the Command key as you select page thumbnails.

If you accidentally delete a page and want it back, choose Edit > Undo (from the Edit menu at the top of the screen), or press Command-Z on your keyboard.

Rearrange pages in a word-processing document

Because text flows from one page to another in word-processing documents, you can’t rearrange the pages in a section. You can, however, cut content from one page and paste it to another.

Here is an example of one way to cut text and objects and paste them to a different location in the same document:

  1. Click where you want your content to appear, then click the Add Page button in the toolbar.

    This adds two page breaks, which creates a blank page where you can place the moved content.

  2. Select the text you want to move (objects set to move with text are also included), then choose Edit > Cut (from the Edit menu at the top of your screen).

    The content is removed from your document, and a copy of it is saved to your computer’s Clipboard. If you make a mistake, press Command-Z on your keyboard to undo the action.

  3. Click in the blank page, then choose Edit > Paste.

    If you didn’t move everything at once, keep cutting and pasting until all the content is where you want it.

  4. To remove the page break, place the insertion point before the text you moved, then press Delete on your keyboard.

    If this causes your text to run into the preceding text, press Return on your keyboard to move it down to the next line.

  5. To remove the second page break, place the insertion point immediately before the text that follows the content you moved, then press Delete on your keyboard.

Rearrange pages in a page layout document

  1. Click the View menu button in the toolbar, then choose Page Thumbnails.

  2. Select the page thumbnail, then drag it to where you want it.

Tip: To rearrange more than one page, press the Command key as you click the page thumbnails you want to rearrange, then release the Command key. Control-click one of the selected page thumbnails, then choose Cut. Control-click the page thumbnail you want the content to follow, then choose Paste.

Copy and paste pages between documents

A quick way to reuse content is to copy a section from one word-processing document to another, or copy a page from one page layout document to another (you can also copy and paste within the same document). You can’t copy sections or pages between word-processing and page layout documents.

  1. In the document you want to copy from, click the View menu button and choose Page Thumbnails.

  2. Do one of the following:

    • Copy a section in a word-processing document: Control-click a page thumbnail in the section you want to copy.

    • Copy a page in a page layout document: Control-click the page thumbnail you want to copy.

    • Copy multiple pages in a page layout document: Press Shift or Command while you click pages, then Control-click one of the selected thumbnails.

  3. In the shortcut menu, choose Copy (or Cut if you want to remove the original page).

    Page Thumbnails view with one thumbnail selected and the shortcut menu open.
  4. Open the document you want to paste to, then show the page thumbnails.

  5. Control-click the page thumbnail you want the pasted content to follow, then choose Paste.

    In word-processing documents, the section is pasted after the last page of the section you selected.

    Note: You can’t paste a section or pages at the start of a document. Instead, paste after the first page or section, then rearrange them.

When you copy pages from a document that uses a different starting template, or pages that use master pages you created yourself, the pages are copied along with the master pages they’re based on.

Published Date: Jul 23, 2019
Helpful?
12% of people found this helpful.