Macの「プレビュー」で3Dファイルを表示する
「プレビュー」で3Dファイルを表示し、ビューポート(3Dファイルを表示したり、内部で移動したり、操作したりできる表示領域)での表示方法を変更できます。3Dファイルには、シーンやオブジェクトが含まれます。シーンを表示すると、そのシーンの中に立っているかのように周囲を見回すことができます。オブジェクトを表示すると、任意の方向にオブジェクトを回転できます。
注記: SceneKit(.scn)ファイルとCollada(.dae)ファイルでは、3Dの表示と編集の一部の機能を使用できません。
3Dファイルを開く
Macでプレビューアプリ
に移動します。
「ファイル」>「開く」と選択します。
ファイルが格納されているフォルダに移動してから、ファイルをダブルクリックします。
注記: USDファイルは独立再生形式にできますが、シーンまたはアセットを表示するために必要なほかのファイルを参照することもよくあります。USDファイルを元のフォルダの外に移動しないでください。移動すると、シーンを表示できなくなることがあります。フォルダに複数のUSDファイルが含まれている場合もあります。
3Dシーンを探索する
周回、パン、および拡大/縮小によって、シーン内を移動できます。
Macでプレビューアプリ
に移動します。
3Dファイルを開いてから、以下のいずれかの操作を行います:
周回する: ビューポート内の任意の場所をドラッグして、シーン内を移動します。
パンする: トラックパッドで2本指でドラッグするか、中央マウスボタンを押したままドラッグします。
拡大/縮小する: トラックパッドで2本指でピンチするか、マウスでスクロールするか、右マウスボタンを使用してドラッグします。
選択部分に合わせて拡大する: 「表示」>「選択部分に合わせて拡大」と選択するか、Shift+Command+8キーを押します。何も選択していない場合は、シーン全体がビューポートの大きさに合わせて表示されます。
シーンの表示を変更するだけでなく、シーンの向きやサイズを永続的に変更するには、Macの「プレビュー」で3Dファイルを編集するの「ステージを調整する」を参照してください。
シーン内のオブジェクトをブラウズする
3Dシーンは、図形、ライト、カメラ、マテリアルなどのオブジェクトを表現し、階層的に配置されている、プリミティブで構成されます。3Dシーン内のプリミティブは「オブジェクト階層」パネルでブラウズできます。
Macでプレビューアプリ
に移動します。
3Dファイルを開いてから、「表示」>「オブジェクト階層」と選択します。
以下のいずれかの操作を行います:
グループまたはプリミティブを選択する: 名前をクリックするか、上矢印キーまたは下矢印キーを押します。
グループを展開する/折りたたむ:
または
をクリックするか、右矢印キーまたは左矢印キーを押します。
グループまたはプリミティブを非表示にする/表示する: 名前の横にある
をクリックします。
プリミティブをファイル参照ルートとしてマークする: Controlキーを押しながらプリミティブをクリックして、「ファイル参照ルート」を選択します。名前の横に星印が表示されます。ファイル参照ルートは、ほかのファイルがこのファイルを参照するときにデフォルトで使用されるプリミティブであり、何も選択されていないときに新しいプリミティブが追加される場所でもあります。
カメラの視点で表示する
3Dファイルで定義されている任意のカメラの視点から、または「視点」(「カメラ」パネルで常に先頭に表示されるデフォルトの表示)からシーンを表示できます。
Macでプレビューアプリ
に移動します。
3Dファイルを開いてから、「表示」>「カメラ」と選択します。
「カメラ」パネルでカメラのサムネールをクリックして、その視点からシーンを表示します。
サムネールには、各カメラの向きを反映したライブプレビューが表示され、現在の視点になっているカメラがハイライト表示されます。デフォルト表示に戻すには、「視点」をクリックします。
選択したカメラをロックまたはロック解除するには、
をクリックします。
ロックすると、そのカメラの視点で表示している間は、周回、パン、拡大/縮小ができなくなります。ただし、変換ハンドルを使用してプリミティブを移動したり、「オブジェクトのプロパティ」でカメラのプロパティを編集したりすることはできます。ロック状態はファイルには保存されません。また、アニメーションの動きがあるカメラのロックは解除できません。「視点」では常に自由に移動できるため、カメラのロックは使用できません。
レンダリングスタイルを選択する
Macでプレビューアプリ
に移動します。
3Dファイルを開いてから、「表示」>「3Dレンダリング」と選択します。
以下のいずれかの操作を行います:
Appleプラットフォームでコンテンツがどのように表示されるかを見る: 「RealityKit」を選択します(デフォルトで選択されています)。
幅広いUSD互換性を維持できる一般的なレンダラを使用する: 「OpenUSD Storm」を選択します。
高品質な物理ベースレンダリングを行う: 「Raytracer」を選択します。
ライトとマテリアルをリアルに表現するようにシーンをレンダリングして写真のように見せる: 「フォトリアルレンダリング」を選択します。または、
をクリックしてから、
をクリックすることもできます。「フォトリアルレンダリング」がオンのときは、「レンダラ」と「環境」のコントロールは使用できません。シーンにライトがない場合は、ダイアログが表示されるので、「このまま有効にする」をクリックして続けるか、「キャンセル」をクリックします。ライトを追加するには、プリミティブを追加するを参照してください。
ライティング環境を選択する: 「環境」の下で、「スタジオ」、「曇り」、「晴れ」、「夕暮れ」、「夜間」、「都市の夜」、「オフィスインテリア」のいずれかを選択します。または、
をクリックし、
をクリックしてから、オプションを選択することもできます。「フォトリアルレンダリング」がオンのときは、「環境」コントロールは使用できません。
デフォルトのレンダラを変更するには、「プレビュー」>「設定」と選択し、「3D」をクリックしてから、「デフォルトレンダラ」ポップアップメニューから新しいレンダラを選択します。
ビューポートの表示を調整する
シャドウの距離、露出、およびガンマを調整して、ビューポートでのシーンの表示方法を変更できます。
Macでプレビューアプリ
に移動します。
3Dファイルを開いてから、
をクリックします。
ツールバーで
をクリックします。
以下のいずれかの操作を行います:
シーン内でシャドウが投射される距離を制御する: レンダリングスタイルとして「Raytracer」が選択され、「フォトリアルレンダリング」がオフになっている状態で、「シャドウの距離」スライダをドラッグするか、値を入力します。
シーンを明るくする/暗くする: 「露出」スライダをドラッグするか、値を入力します。
シーンの色調範囲を調整する: 「ガンマ」スライダをドラッグするか、値を入力します。
シャドウの距離、露出、ガンマをデフォルトにリセットする: 「すべてをリセット」をクリックします。
アニメーションを再生する
3Dファイルにアニメーションが含まれている場合は、再生コントロールを使って再生できます。アニメーションはデフォルトでループ再生されます。
Macでプレビューアプリ
に移動します。
3Dファイルを開いてから、ポインタを表示の下部に移動して再生コントロールを表示するか、スペースバーを押します。
以下のいずれかの操作を行います:
再生する/一時停止する: 再生コントロールの
または
をクリックするか、スペースバーを押します。
アニメーションをループ再生せずに1回だけ再生する: Optionキーを押しながら
をクリックします。
前後に5単位スキップする:
または
をクリックします。
測定単位を切り替える: 現在の測定値をクリックして、フレーム(デフォルト)と分:秒を切り替えます。
特定のフレームに移動する: 再生バーのスクラバーをドラッグします。
注記: 再生中は、オブジェクトの選択または移動、注釈の追加または編集、ツールバーのツールの使用はできません。ただし、プロパティを変更したり、プリミティブを追加または削除したり、操作を元に戻したりすることはできます。
ファイルの情報を表示する
「インスペクタ」サイドバーで、3Dファイルの情報(ファイル名、ファイルサイズ、作成日、変更日、オブジェクト、マテリアル、ライトなど)を表示できます。
Macでプレビューアプリ
に移動します。
3Dファイルを開いてから、ツールバーの
をクリックします。
Apple Vision Proを使用して、Macに保存されているUSDファイル、画像、およびPDFを表示することもできます。MacにあるコンテンツをApple Vision Proで表示するを参照してください。