Macの「プレビュー」で3Dファイルを編集する
Macの「プレビュー」で、3Dシーン内のプリミティブの移動、回転、およびサイズ調整、プロパティの編集、注釈の追加を行うことができます。
注記: 「プレビュー」では、単一レイヤーのUSD、USDA、USDC、およびUSDZファイルを直接編集できます。その他のフォーマット(複数のレイヤーで構成されるUSDファイルなど)では、ファイルを初めて編集したときに変更内容がそのコピーに保存され、元のファイルは変更されません。
プリミティブを移動する/回転させる/サイズ調整する
Macでプレビューアプリ
に移動します。
3Dファイルを開きます。
ビューポートでプリミティブをクリックします(または、「表示」>「オブジェクト階層」と選択してから、プリミティブを選択します)。ビューポート内のグループ化されたオブジェクトの、グループ全体ではなく一部を選択するには、Optionキーを押しながらクリックします。
以下のいずれかの操作を行って、「移動」、「回転」、または「サイズ調整」を選択します:
をクリックしてから、いずれかを選択します。
「ツール」>「3Dマニピュレータ」と選択してから、いずれかを選択します。
Option+Wキー、Option+Eキー、またはOption+Rキーを押します。
ピボットポイントを変更またはリセットするには、「ツール」>「3Dマニピュレータ」>「ピボットを調整」と選択してから、オプションを選択します。
ビューポートで、色分けされた変形ハンドルをドラッグします。
x軸のハンドルは赤、y軸のハンドルは緑、z軸のハンドルは青、スクリーン空間ハンドルはグレイです。
ヒント: プリミティブを複製するには、Optionキーを押しながら変換ハンドルのいずれかをドラッグします。移動しているオブジェクトを別のオブジェクトの表面にスナップさせるには、グレイのスクリーン空間ハンドルをShiftキーを押しながらドラッグします。
プリミティブのプロパティを編集する
「オブジェクトのプロパティ」パネルで、選択したプリミティブの変換値、可視性、マテリアル、外観などのプロパティを表示および編集できます。マテリアルや外観などの一部のプロパティは、レンダリングスタイルによっては動作しません。
Macでプレビューアプリ
に移動します。
3Dファイルを開いて、「表示」>「オブジェクト階層」と選択してから、プロパティを編集したいプリミティブを選択します。ビューポートでプリミティブをクリックして選択することもできます。
注記: 複数のプリミティブを同時に編集する場合は、「オブジェクト階層」パネルでCommandキーを押しながら各プリミティブをクリックします(または、Shiftキーを押しながら範囲をクリックして選択します)。
「ツール」>「オブジェクトのプロパティを表示」と選択します。
以下のいずれかの操作を行います:
変換値を編集する: 「変換」、「回転」、または「サイズ調整」の行でフィールドを選択してから、X、Y、Zの値を入力します。「変換」と「サイズ調整」はシーンの測定単位、「回転」は角度で指定します。ドラッグ中にフィールドをクリックして、値を増減することもできます。フィールドを選択すると、対応する変換ツールが自動的に選択されます。
「縦横比を固定」のオン/オフを切り替える:
をクリックします。このボタンは常に表示され、オンにすると塗りつぶされます。これにより、X、Y、Zの値が同じになるのではなく、値間の比率が保持されます。
プリミティブを非表示にする/表示する: 「表示」を選択または選択解除します。(このオプションを表示するには、「図形」の横にある
をクリックする必要がある場合があります。)
マテリアルを変更する: 「マテリアル」ポップアップメニューをクリックして、マテリアルを選択します。
カラーを調整する: 現在のカラーまたはカラーホイールをクリックしてから、カラーを選択します。このオプションは、マテリアルが「なし」に設定されているときにのみ使用できます。
マテリアルのカラーを編集する: マテリアルプリミティブが選択されている場合は(ビューポートでOption+Shiftキーを押しながらクリックするか、「オブジェクト階層」パネルで
のマークが付いているプリミティブをクリックします)、「プロパティ」の下の「拡散カラー」、「エミッシブカラー」、または「鏡面反射カラー」の横にある現在のカラーまたはカラーホイールをクリックしてから、カラーを選択します。カラーフィールドが淡色表示になっている場合は、テクスチャが適用されています。その場合は、Controlキーを押しながらクリックしてから、「値をリセット」を選択してテクスチャを削除し、カラーを直接編集します。
不透明度を調整する: 「不透明度」スライダを左右にドラッグするか、値をパーセントで入力します。不透明度のレンダリングは、レンダリングスタイルによって変わります。「Raytracer」を選択すると最良の結果が得られます。
カメラの焦点距離または絞りを編集する: カメラプリミティブが選択されている場合は、「焦点距離」または「垂直アパーチャ」の行でフィールドを選択してから、値を入力します。焦点距離はミリメートル単位です。
カメラの解像度を編集する: カメラプリミティブが選択されている場合は、「解像度」行でフィールドを選択してから、WまたはHの値をピクセル単位で入力します。
カメラの瞳孔間距離または収束距離を編集する: カメラプリミティブが選択されている場合は、「瞳孔間距離」または「コンバージェンスの距離」の行でフィールドを選択してから、シーンの測定単位で値を入力します。
ライトのサイズを編集する: ライトプリミティブが選択されている場合は、「サイズ」行で「幅」または「高さ」フィールドを選択してから、シーンの測定単位で値を入力します。デフォルトでは、一方の値を調整すると、アスペクト比を一定に保つようにもう一方のフィールドがアップデートされます。各値を個別に調整する場合は、
をクリックします。
ライトのコーンを編集する: ライトプリミティブが選択されている場合は、「コーン角度」フィールドに値を度数で入力するか、「コーンの柔らかさ」スライダをドラッグします。
ライトのカラーを調整する: ライトプリミティブが選択されている場合は、「カラー」の横にある現在のカラーまたはカラーホイールをクリックしてから、カラーを選択します。代わりに「色温度」が表示される場合は、フィールドを選択してから、K値を入力します。ファイルの作成方法に応じて2つのオプションのいずれかのみが表示され、切り替えることはできません。
ライトのテクスチャを変更する: ライトプリミティブが選択されている場合は、「テクスチャ」フィールドをクリックしてから、画像ファイルを選択します。
ライトの強度を調整する: ライトプリミティブが選択されている場合は、「強度」フィールドを選択してから、値を入力します。
バリアントを切り替える: 選択したプリミティブにバリアントセットが含まれる場合は、「種類」の下にある「マテリアル」や「アニメーション」などのポップアップメニューからオプションを選択します。
プリミティブを追加する
3Dシーンに図形、カメラ、ライトを追加できます。
Macでプレビューアプリ
に移動します。
3Dファイルを開いてから、「ツール」>「シーンに追加」と選択します。
プリミティブのタイプを選択します:
新しいプリミティブの配置先は、現在の選択項目によって異なります。トランスフォームまたはスコープを選択すると、新しいプリミティブがその子として追加され、ジオメトリを選択すると、その選択項目の上にある最も近いトランスフォームまたはスコープ内に兄弟として追加されます。何も選択していない場合は、新しいプリミティブがシーンのルートに追加されます。トランスフォームとスコープにはビューポートでクリックできる表示要素がないため、新しいプリミティブの配置先に設定するには、「オブジェクト階層」パネルでいずれかを選択します。
プリミティブのコンテクストメニューを使用する
「オブジェクト階層」パネルでControlキーを押しながらプリミティブをクリックして、名前の変更、複製、削除を行うか、その他のいくつかの操作から選択します。
Macでプレビューアプリ
に移動します。
3Dファイルを開いてから、「表示」>「オブジェクト階層」と選択します。
「オブジェクト階層」パネルで、変更したいプリミティブを選択します。
以下のいずれかの操作を行います:
名前を変更する: Returnキーを押してから、新しい名前を入力します。Finderでの操作と同様に、名前をもう一度クリックすることもできます。
複製する: Controlキーを押しながらプリミティブをクリックして、「複製」を選択します。
削除する: Deleteキーを押すか、Controlキーを押しながらプリミティブをクリックして、「削除」を選択します。
選択したほかのプリミティブとグループ化する: Controlキーを押しながら選択したプリミティブのいずれかをクリックし、「選択部分を使用してグループを新規作成」を選択します。
ビューポートでクリックしたときに一連のプリミティブを1つのプリミティブとして動作させる: Controlキーを押しながら選択したプリミティブのいずれかをクリックし、「グループとして選択」を選択します。
カットする: Command+Xキーを押すか、Controlキーを押しながらプリミティブをクリックして、「カット」を選択します。
コピーする: Command+Cキーを押すか、Controlキーを押しながらプリミティブをクリックして、「コピー」を選択します。
ペーストする: Command+Vキーを押すか、Controlキーを押しながらプリミティブをクリックして、「ペースト」を選択します。ペーストしたプリミティブがポインタの位置に表示されます。
注記: 「プレビュー」の別々のウインドウ間でカット、コピー、ペーストを行うことができます。この方法を使用すれば、1つのシーンから別のシーンにプリミティブを簡単に移動できます。
無効にする: Controlキーを押しながらプリミティブをクリックして、「無効にする」を選択します。
注記: 「オブジェクトのプロパティ」の「表示」でプリミティブを非表示にすると、そのプリミティブはシーンには残りますが、描画されなくなります。無効にすると、プリミティブとその内容がシーンから完全に削除されますが、ファイルからは削除されないため、あとで有効に戻すことができます。無効化したプリミティブはシーンから削除されるため、それらを参照しているもの(マテリアルバインディングなど)は参照先がなくなって、ダングリング状態になります。
ヒント: 「プレビュー」では無効にされたグループのコンテンツは読み込まれないため、大きいグループを無効にすると、重いファイルを軽くして作業できます。
Apple Vision Proで編集可能にする: Controlキーを押しながらプリミティブをクリックして、「Apple Vision Proで編集可能」を選択します。これにより、Apple Vision Proで操作できるプリミティブとしてフラグが立てられますが、「プレビュー」内では何も変わりません。
ファイル参照ルートとしてマークする: Controlキーを押しながらプリミティブをクリックして、「ファイル参照ルート」を選択します。名前の横に星印が表示されます。ほかのファイルがこのファイルを参照するときに、デフォルトでこのプリミティブが使用されます。また、何も選択されていないときに新しいプリミティブが追加される場所でもあります。
シーン階層を再整理する
「オブジェクト階層」パネルでプリミティブをドラッグして、親を変更したり並べ替えたりできます。
Macでプレビューアプリ
に移動します。
3Dファイルを開いてから、「表示」>「オブジェクト階層」と選択します。
以下のいずれかの操作を行います:
プリミティブの親を変更する: 新しい親にしたいトランスフォームまたはスコープにドラッグします。
プリミティブを並べ替える: 同じ親の中で新しい位置にドラッグします。
注記: マテリアルはジオメトリの下にネストすることもできますが、シェーダはマテリアルの下にしかネストできません。
ステージを調整する
視点だけでなく、シーン全体をサイズ変更したり、回転させたり、方向変更したりできます。ビューポートを回転させてシーンを別の角度から見る場合とは異なり、ステージを調整すると、ファイルが変更されます。
Macでプレビューアプリ
に移動します。
3Dファイルを開いてから、以下のいずれかの操作を行います:
90度回転させる: 左に回転させるには
をクリックし、右に回転させるにはOptionキーを押したままクリックします。
特定の角度で回転させる: 「ツール」>「サイズを調整」と選択し、「コンテンツの向き」の下にある「X軸で回転」、「Y軸で回転」、または「Z軸で回転」フィールドに値を入力してから、「OK」をクリックします。
モデルの向きを変更する: 「ツール」>「サイズを調整」と選択し、「シーン設定」の下にある「方向」ポップアップメニューから「Y(上方向)」または「Z(上方向)」を選択してから、「OK」をクリックします。「シーン設定」の下にある「単位」ポップアップメニューから測定単位を選択することもできます。
モデルのサイズを変更する: 「ツール」>「サイズを調整」と選択し、「コンテンツのサイズ」の下にある「高さ」、「幅」、「奥行き」、または「サイズ調整」フィールドに値を入力してから、「OK」をクリックします。「コンテンツのサイズ」の下にあるポップアップメニューから測定単位を選択することもできます。
注記: デフォルトでは「コンテンツのサイズと向きを保持」が選択されているため、「高さ」、「幅」、「奥行き」、「サイズ調整」のいずれかのフィールドを変更すると、ほかのフィールドも同じ比率を保つようにアップデートされます。各フィールドを個別に調整する場合は、このオプションの選択を解除します。
3Dファイルに注釈を付ける
3Dシーンにテキスト注釈を追加できます。
Macでプレビューアプリ
に移動します。
3Dファイルを開いて、
をクリックしてから、
をクリックします。
ビューポートに注釈アイコンが表示されます。
注釈アイコンをクリックしてから、注釈を入力します。
注釈の外側をクリックして保存します。注釈をドラッグして別の位置に移動することもできます。
以下のいずれかの操作を行います:
カラーを変更する: Controlキーを押しながら注釈をクリックして、カラーを選択します。
削除する: Controlキーを押しながら注釈をクリックして、「削除」を選択します。
オブジェクトの表面にスナップする: 注釈をオブジェクトにドラッグします。
ヒント: 新しい注釈に表示される作成者名を変更するには、「プレビュー」>「設定」と選択し、「一般」をクリックしてから、「名前」フィールドに名前を入力します。
すべての注釈とその内容を表示するには、「表示」>「メモ」と選択します。注釈が複数ある場合は、注釈内で または
をクリックして、前の注釈または次の注釈に移動します。カメラがシーン内を自動的に移動し、注釈が画面内に収まるようにします。