macOS Sierra 10.12.3 のセキュリティコンテンツについて

macOS Sierra 10.12.3 のセキュリティコンテンツについて説明します。

Apple セキュリティアップデートについて

Apple では、ユーザ保護の観点から、調査が終了してパッチやリリースが公開されるまでは、セキュリティ上の問題を公開、説明、または是認いたしません。最近のリリースについては、「Apple セキュリティアップデート」ページに一覧形式でまとめています。

セキュリティについて詳しくは、Apple 製品のセキュリティに関するページを参照してください。Apple との通信は、Apple Product Security PGP キーで暗号化できます。

Apple のセキュリティ関連の文書では、可能な場合、脆弱性の CVE-ID に言及しています。

macOS Sierra 10.12.3

2017 年 1 月 23 日リリース

APNs サーバ

対象 OS:macOS Sierra 10.12.2

影響:ネットワーク上の特権的な地位を悪用した攻撃者に、ユーザのアクティビティを追跡される可能性がある。

説明:クライアント証明書がプレーンテキストで送信されていました。この問題は、証明書の処理を改善することで解決されました。

CVE-2017-2383:ミュンヘン工科大学 (TUM) の Matthias Wachs 氏および Quirin Scheitle 氏

2017 年 3 月 28 日に追加

apache_mod_php

対象 OS:macOS Sierra 10.12.2

影響:PHP に複数の脆弱性がある。

説明:PHP をバージョン 5.6.28 にアップデートすることで、複数の脆弱性に対処しました。

CVE-2016-8670

CVE-2016-9933

CVE-2016-9934

Bluetooth

対象 OS:macOS Sierra 10.12.2

影響:アプリケーションにカーネル権限を取得され、任意のコードを実行される可能性がある。

説明:メモリ管理を強化し、解放済みメモリ使用 (use-after-free) の脆弱性に対処しました。

CVE-2017-2353:Google Project Zero の Ian Beer 氏

グラフィックドライバ

対象 OS:macOS Sierra 10.12.2

影響:アプリケーションにカーネル権限を取得され、任意のコードを実行される可能性がある。

説明:入力検証を強化し、メモリ破損の脆弱性に対処しました。

CVE-2017-2358:Team Pangu および lokihardt 氏 (PwnFest 2016 にて)

ヘルプビューア

対象 OS:macOS Sierra 10.12.2

影響:悪意を持って作成された Web コンテンツを処理すると、任意のコードを実行される可能性がある。

説明:URL の検証を強化し、クロスサイトスクリプティングの脆弱性に対処しました。

CVE-2017-2361:Google Project Zero の lokihardt 氏

IOAudioFamily

対象 OS:macOS Sierra 10.12.2

影響:アプリケーションが、カーネルメモリのレイアウトを判断できる可能性がある。

説明:メモリ管理を強化し、未初期化メモリの脆弱性に対処しました。

CVE-2017-2357:Team Pangu および lokihardt 氏 (PwnFest 2016 にて)

カーネル

対象 OS:macOS Sierra 10.12.2

影響:アプリケーションにカーネル権限を取得され、任意のコードを実行される可能性がある。

説明:メモリ処理を強化し、バッファオーバーフローの脆弱性に対処しました。

CVE-2017-2370:Google Project Zero の Ian Beer 氏

カーネル

対象 OS:macOS Sierra 10.12.2

影響:アプリケーションにカーネル権限を取得され、任意のコードを実行される可能性がある。

説明:メモリ管理を強化し、解放済みメモリ使用 (use-after-free) の脆弱性に対処しました。

CVE-2017-2360:Google Project Zero の Ian Beer 氏

libarchive

対象 OS:macOS Sierra 10.12.2

影響:悪意を持って作成されたアーカイブを解凍すると、任意のコードが実行される可能性がある。

説明:メモリ処理を強化し、バッファオーバーフローの脆弱性に対処しました。

CVE-2016-8687:Gentoo の Agostino Sarubbo 氏

Vim

対象 OS:macOS Sierra 10.12.2

影響:悪意を持って作成されたファイルを開くと、アプリケーションが予期せず終了したり、任意のコードが実行される可能性がある。

説明:modelines における入力検証に脆弱性がありました。この問題は、入力検証を強化することで解決されました。

CVE-2016-1248:Florian Larysch 氏

macOS Sierra 10.12.3 には、Safari 10.0.3 のセキュリティコンテンツが含まれています。

Apple 製以外の製品に関する情報や、Apple が管理または検証していない個々の Web サイトは、推奨や承認なしで提供されています。Apple は他社の Web サイトや製品の選定、性能、使用については一切責任を負いません。Apple は他社の Web サイトの正確性や信頼性については一切明言いたしません。インターネットの使用にはリスクがつきものです。詳しくは各社にお問い合わせください。その他の会社名や製品名は、それぞれの所有者の商標である場合があります。

公開日: