Mengenai konten keamanan iOS 10.2.1

Dokumen ini menjelaskan konten keamanan iOS 10.2.1.

Mengenai pembaruan keamanan Apple

Demi melindungi pelanggan kami, Apple tidak mengungkapkan, membahas, atau mengonfirmasi masalah keamanan hingga investigasi telah dilakukan dan perbaikan program atau rilis telah tersedia. Rilis terbaru tercantum di halaman pembaruan keamanan Apple.

Untuk informasi lebih lanjut mengenai keamanan, kunjungi halaman Keamanan Produk Apple. Anda dapat mengenkripsi komunikasi dengan Apple menggunakan Kunci PGP Keamanan Produk Apple.

Dokumen keamanan Apple memberikan referensi tentang kerentanan menurut CVE-ID jika memungkinkan.

iOS 10.2.1

Dirilis pada 23 Januari 2017

Server APN

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Penyerang di posisi jaringan dengan hak istimewa dapat melacak aktivitas pengguna

Deskripsi: Sertifikat klien dikirimkan dalam bentuk teks biasa. Masalah ini telah diatasi melalui penanganan sertifikat yang lebih baik.

CVE-2017-2383: Matthias Wachs dan Quirin Scheitle dari Technical University Munich (TUM)

Entri ditambahkan pada 28 Maret 2017

Riwayat Panggilan

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Memperbarui riwayat panggilan CallKit yang dikirimkan ke iCloud

Deskripsi: Masalah muncul saat mencegah mengunggah riwayat panggilan CallKit ke iCloud.   Masalah ini diatasi melalui logika yang lebih baik.

CVE-2017-2375: Elcomsoft

Entri ditambahkan pada 21 Februari 2017

Kontak

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Memproses kartu kontak perusak yang berbahaya dapat mengakibatkan aplikasi berhenti tiba-tiba

Deskripsi: Masalah validasi input muncul saat menguraikan kartu kontak. Masalah ini telah diatasi melalui validasi input yang lebih baik.

CVE-2017-2368: Vincent Desmurs (vincedes3)

Kernel

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Aplikasi dapat mengeksekusi kode arbitrer dengan hak istimewa kernel

Deskripsi: Masalah kelebihan penyangga telah diatasi melalui penanganan memori yang lebih baik.

CVE-2017-2370: Ian Beer dari Google Project Zero

Kernel

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Aplikasi dapat mengeksekusi kode arbitrer dengan hak istimewa kernel

Deskripsi: Masalah penggunaan setelah pengosongan telah diatasi melalui pengelolaan memori yang lebih baik.

CVE-2017-2360: Ian Beer dari Google Project Zero

libarchive

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Membuka arsip perusak yang berbahaya dapat mengakibatkan eksekusi kode arbitrer

Deskripsi: Masalah kelebihan penyangga telah diatasi melalui penanganan memori yang lebih baik.

CVE-2016-8687: Agostino Sarubbo dari Gentoo

Buka dengan iPhone

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Apple Watch dapat terbuka saat dilepas dari pergelangan tangan pengguna

Deskripsi: Masalah logika telah diatasi melalui manajemen status yang lebih baik.

CVE-2017-2352: Ashley Fernandez dari raptAware Pty Ltd

Entri diperbarui pada 25 Januari 2017

WebKit

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Memproses konten web yang dibuat untuk kejahatan dapat menarik lintas asal data

Deskripsi: Masalah akses prototipe telah diatasi melalui penanganan eksepsi yang lebih baik.

CVE-2017-2350: Gareth Heyes dari Portswigger Web Security

WebKit

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Memproses konten web perusak yang berbahaya dapat mengakibatkan eksekusi kode arbitrer

Deskripsi: Beberapa masalah kerusakan memori telah diatasi melalui penanganan memori yang lebih baik.

CVE-2017-2354: Neymar dari Xuanwu Lab, Tencent (tencent.com) bekerja sama dengan Zero Day Initiative Trend Micro

CVE-2017-2362: Ivan Fratric dari Google Project Zero

CVE-2017-2373: Ivan Fratric dari Google Project Zero

WebKit

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Memproses konten web perusak yang berbahaya dapat mengakibatkan eksekusi kode arbitrer

Deskripsi: Masalah inisialisasi memori telah diatasi melalui penanganan memori yang lebih baik.

CVE-2017-2355: Team Pangu dan lokihardt di PwnFest 2016

WebKit

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Memproses konten web perusak yang berbahaya dapat mengakibatkan eksekusi kode arbitrer

Deskripsi: Beberapa masalah kerusakan memori telah diatasi melalui validasi input yang lebih baik.

CVE-2017-2356: Team Pangu dan lokihardt di PwnFest 2016

CVE-2017-2369: Ivan Fratric dari Google Project Zero

CVE-2017-2366: Kai Kang dari Xuanwu Lab, Tencent (tencent.com)

WebKit

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Memproses konten web yang dibuat untuk kejahatan dapat menarik lintas asal data

Deskripsi: Masalah validasi muncul saat menangani pemuatan halaman. Masalah ini diatasi melalui logika yang lebih baik.

CVE-2017-2363: lokihardt dari Google Project Zero

CVE-2017-2364: lokihardt dari Google Project Zero

WebKit

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Situs web berbahaya dapat membuka popup

Deskripsi: Masalah muncul saat menangani pemblokiran popup. Masalah ini telah diatasi melalui validasi input yang lebih baik.

CVE-2017-2371: lokihardt dari Google Project Zero

WebKit

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Memproses konten web yang dibuat untuk kejahatan dapat menarik lintas asal data

Deskripsi: Masalah validasi muncul saat mengatasi penanganan variabel. Masalah ini telah diatasi dengan peningkatan validasi.

CVE-2017-2365: lokihardt dari Google Project Zero

WiFi

Tersedia untuk: iPhone 5 dan versi lebih baru, iPad generasi ke-4 dan versi lebih baru, iPod touch generasi ke-6 dan versi lebih baru

Dampak: Perangkat dalam kondisi terkunci dapat dimanipulasi untuk menampilkan layar utama secara sekilas

Deskripsi: Masalah muncul saat menangani input pengguna yang menyebabkan perangkat menampilkan layar utama bahkan dalam kondisi terkunci. Masalah ini telah diatasi melalui validasi input yang lebih baik.

CVE-2017-2351: Hemanth Joseph, Sriram (@Sri_Hxor) dari Primefort Pvt. Ltd., Mohamd Imran

Entri diperbarui pada 21 Februari 2017

Penghargaan tambahan

Pengerasan WebKit

Kami ingin mengucapkan terima kasih kepada Ben Gras, Kaveh Razavi, Erik Bosman, Herbert Bos, dan Cristiano Giuffrida dari grup vusec di Vrije Universiteit Amsterdam atas bantuan mereka.

Informasi tentang produk yang tidak diproduksi oleh Apple, atau situs web independen tidak dikendalikan atau diuji oleh Apple, disediakan tanpa rekomendasi atau persetujuan. Apple tidak bertanggung jawab terkait pemilihan, kinerja, atau penggunaan situs web atau produk pihak ketiga. Apple tidak memberikan pendapat terkait akurasi atau keandalan situs web pihak ketiga. Risiko adalah hal tak terpisahkan dari penggunaan Internet. Hubungi vendor untuk informasi selengkapnya.

Tanggal Dipublikasikan: