3D-tiedoston muokkaaminen Macin Esikatselussa
Käännä (siirrä), pyöritä ja skaalaa 3D-tilanteen primejä, muokkaa niiden ominaisuuksia ja lisää merkintöjä Macin Esikatselussa.
Huomautus: Esikatselu muokkaa yhden tason USD-, USDA-, USDC- ja USDZ-tiedostoja suoraan. Muissa muodoissa – mukaan lukien useista tasoista koostuvat USD-tiedostot – Esikatselu tallentaa muutoksesi kopioon, kun editoit tiedostoa ensimmäisen kerran, ja jättää alkuperäisen muuttumattomana.
Primin siirtäminen, pyörittäminen tai skaalaaminen
Avaa Macissa Esikatselu-appi
.
Klikkaa primiä näyttöikkunassa (tai valitse Näytä > Objektihierarkia ja valitse sitten prim). Jos haluat valita ryhmässä olevan objektin tietyn osan koko ryhmän sijaan, optio-klikkaa sitä.
Valitse Siirrä, Pyöritä tai Skaalaa tekemällä jokin seuraavista:
Klikkaa
ja valitse jokin.
Valitse Työkalut > 3D-käsittelijä ja valitse jokin.
Paina optio-W, optio-E tai optio-R.
Jos haluat muuttaa tai nollata tukipisteen, valitse Työkalut > 3D-käsittelijä > Säädä tukipistettä ja valitse sitten vaihtoehto.
Vedä värillisiä muunnoskahvoja näyttöikkunassa.
X-akselin kahva on punainen, y-akselin kahva on vihreä, z-akselin kahva on sininen ja näytön tilan kahva on harmaa.
Vinkki: Monista prim pitämällä optio-vetämällä yhtä sen muunnoskahvoista. Jos haluat kiinnittää objektin toisen pinnalle sen siirtämisen aikana, pidä vaihtonäppäintä painettuna vetäessäsi harmaata näytön tilan kahvaa.
Prim-ominaisuuksien muokkaaminen
Voit tarkastella ja muokata valitun primin ominaisuuksia Objektin ominaisuudet -paneelissa, mukaan lukien sen muunnosarvot, näkyvyys, materiaali ja ulkoasu. Kaikki ominaisuudet, kuten materiaaliin ja ulkoasuun liittyvät ominaisuudet, eivät toimi kaikkien mallinnustyylien kanssa.
Avaa Macissa Esikatselu-appi
.
Avaa 3D-tiedosto, valitse Näytä > Objektihierarkia ja valitse sitten prim, jonka ominaisuuksia haluat muokata. Voit myös valita primin klikkaamalla sitä näyttöikkunassa.
Huomautus: Muokkaa useita primejä samanaikaisesti komento-klikkaamalla kutakin Objektihierarkia-paneelissa (tai valitse useita peräkkäisiä vaihto-klikkaamalla).
Valitse Työkalut > Näytä objektin ominaisuudet.
Tee jokin seuraavista:
Muunnosarvon muokkaaminen: Valitse Käännä-, Pyöritä- tai Skaalaa-rivillä kenttä ja syötä arvo X:lle, Y:lle tai Z:lle – tilanteen mittayksikössä Käännä- ja Skaalaa-kohdissa tai asteina Pyöritä-kohdassa. Voit myös lisätä tai vähentää kentän arvoa klikkaamalla sitä samalla, kun vedät ylös tai alas. Kun valitset kentän, vastaava muunnostyökalu valitaan automaattisesti.
Kiinnitä kuvasuhde -ominaisuuden laittaminen päälle tai pois päältä: Klikkaa
. Se näkyy aina ja täyttyy, kun se on päällä. Tällä säilytetään X-, Y- ja Z-arvojen väliset mittasuhteet sen sijaan, että ne tehtäisiin yhtä suuriksi.
Primin näyttäminen tai kätkeminen: Valitse Näkyvä tai poista sen valinta. (Sinun on ehkä klikattava Kuvio-kohdan vieressä
, jotta saat tämän vaihtoehdon näkyviin.)
Materiaalin muuttaminen: Klikkaa Materiaali-ponnahdusvalikkoa ja valitse materiaali.
Värin säätäminen: Klikkaa nykyistä väriä tai väriympyrää ja valitse väri. Tämä on saatavilla vain, kun materiaaliksi on asetettu Ei mitään.
Materiaalin värien muokkaaminen: Jos materiaali-prim on valittuna (optio-vaihto-klikkaamalla sitä näyttöikkunassa tai klikkaamalla Objektihierarkia-paneelissa
), klikkaa nykyistä väriä tai väriympyrää, joka on Ominaisuudet-kohdan alla olevien Hajaväri-, Säteilevä väri- tai Peilimäinen väri -kohtien vieressä, ja valitse sitten väri. Jos värikenttä on himmennetty, siihen on sovellettu tekstuuria. Control-klikkaa sitä ja valitse sitten Nollaa arvo, jolloin tekstuuri poistetaan ja väriä voidaan muokata suoraan.
Peittävyyden säätäminen: Vedä Peittävyys-liukusäädintä vasemmalle tai oikealle tai syötä arvo prosentteina. Peittävyyden mallinnus vaihtelee mallinnustyylin mukaan, Raytracer tuottaa parhaat tulokset.
Kameran polttovälin tai aukon muokkaaminen: Jos kamera-prim on valittuna, valitse Polttoväli- tai Pystysuuntainen aukko -rivin kenttä ja syötä arvo. Polttoväli on millimetreinä.
Kameran tarkkuuden muokkaaminen: Jos kamera-prim on valittuna, valitse Tarkkuus-rivillä kenttä ja syötä L- tai K-kohtaan arvo pikseleinä.
Kameran silmäterien välin tai konvergenssietäisyyden muokkaaminen: Jos kamera-prim on valittuna, valitse Silmäterien väli- tai Konvergenssietäisyys-rivin kenttä ja syötä arvo tilanteen mittayksikössä.
Valon koon muokkaaminen: Jos valo-prim on valittuna, valitse Koko-rivin Leveys- tai Korkeus-kenttä ja syötä arvo tilanteen mittayksikössä. Oletuksena yhden arvon säätäminen päivittää toisen kentän, jotta kuvasuhde pysyy vakiona. Säädä kutakin arvoa erikseen klikkaamalla
.
Valon kartion muokkaaminen: Jos valo-prim on valittuna, syötä Kartion kulma -kenttään arvo asteina tai vedä Kartion pehmeys -liukusäädintä.
Valon värin säätäminen: Jos valo-prim on valittuna, klikkaa Väri-kohdan vieressä olevaa nykyistä väriä tai väriympyrää ja valitse väri. Jos näkyviin tulee sen sijaan Värilämpötila, valitse kenttä ja syötä arvo K:na. Vain toinen näistä kahdesta näkyy riippuen siitä, miten tiedosto on luotu, eikä niiden välillä ole mahdollista vaihtaa.
Valon tekstuurin muuttaminen: Jos valo-prim on valittuna, klikkaa Tekstuuri-kenttää ja valitse kuvatiedosto.
Valon voimakkuuden säätäminen: Jos valo-prim on valittuna, valitse Voimakkuus-kenttä ja syötä arvo.
Variantin vaihtaminen: Jos valitussa primissa on varianttiryhmiä, valitse Variantit-kohdan alla olevasta ponnahdusvalikosta vaihtoehto, kuten Materiaali tai Animaatio.
Primin lisääminen
Voit lisätä 3D-tilanteeseen kuvioita, kameroita ja valoja.
Avaa Macissa Esikatselu-appi
.
Avaa 3D-tiedosto ja valitse Työkalut > Lisää tilanteeseen.
Prim-tyypin valitseminen:
Mihin uusi prim lisätään, riippuu siitä, mitä on valittu: Kun valitaan muunnos tai laajuus, uusi prim lisätään sen alatasoon, ja kun valitaan geometria, se lisätään sen rinnakkaistasoon valinnan yläpuolella olevaan lähimpään muunnokseen tai laajuuteen. Jos mitään ei ole valittu, uusi prim lisätään tilanteen juureen. Koska muunnoksilla ja laajuuksilla ei ole mitään näkyvää, johon klikata näyttöikkunassa, valitse jokin Objektihierarkia-paneelista määrittääksesi, mihin uusi prim lisätään.
Primin kontekstivalikon käyttäminen
Control-klikkaa primiä Objektihierarkia-paneelissa ja nimeä se uudelleen, monista se, poista se tai valitse useista muista toiminnoista.
Avaa Macissa Esikatselu-appi
.
Avaa 3D-tiedosto ja valitse Näytä > Objektihierarkia.
Valitse Objektihierarkia-paneelissa prim, jota haluat muuttaa.
Tee jokin seuraavista:
Nimeäminen uudelleen: Paina rivinvaihtonäppäintä ja syötä uusi nimi. Voit myös klikata nimeä toisen kerran, kuten Finderissa.
Monistaminen: Control-klikkaa primiä ja valitse sitten Monista.
Poistaminen: Paina Poista tai control-klikkaa primiä ja valitse sitten Poista.
Ryhmittäminen muiden valittujen primien kanssa: Control-klikkaa yhtä valituista primeistä ja valitse Uusi ryhmä valinnalla.
Primijoukon käsitteleminen yhtenä klikattaessa näyttöikkunassa: Control-klikkaa yhtä valituista primeistä ja valitse sitten Valitse ryhmänä.
Leikkaaminen: Paina komento-X tai control-klikkaa primiä ja valitse Leikkaa.
Kopioiminen: Paina komento-C tai control-klikkaa primiä ja valitse Kopioi.
Sijoittaminen: Paina komento-V tai control-klikkaa primiä ja valitse Sijoita. Sijoitettu prim tulee näkyviin osoittimen kohdalle.
Huomautus: Voit leikata, kopioida ja sijoittaa eri Esikatselu-ikkunoiden välillä – kätevä tapa siirtää prim tilanteesta toiseen.
Poistaminen käytöstä: Control-klikkaa primiä ja valitse sitten Poista käytöstä.
Huomautus: Kun prim kätketään (näkyy Objektiominaisuudet-kohdassa), se pysyy tilanteessa, mutta sitä ei piirretä. Kun se poistetaan käytöstä, se ja sen sisältö poistetaan kokonaan tilanteesta, mutta niitä ei poisteta tiedostosta, joten voit ottaa ne käyttöön myöhemmin uudelleen. Koska käytöstä poistetut primit poistetaan tilanteesta, niihin viittaavat asiat – esimerkiksi materiaalisidos – jäävät ilman viittausta.
Vinkki: Suuren ryhmän käytöstä poistaminen voi tehdä raskaasta tiedostosta helpomman käsitellä, koska Esikatselu ei lataa käytöstä poistetun ryhmän sisältöä.
Muokattavaksi merkitseminen Apple Vision Prossa: Control-klikkaa primiä ja valitse sitten Muokattavissa Apple Vision Prossa. Tällä merkitset primin sellaiseksi, jonka kanssa voit olla vuorovaikutuksessa Apple Vision Pron kanssa – Esikatselussa itsessään ei tapahdu mitään muutoksia.
Tiedostoviittauksen juureksi merkitseminen: Control-klikkaa primiä ja valitse sitten Tiedostoviittauksen juuri. Sen nimen viereen tulee tähti. Muut tiedostot käyttävät tätä primiä oletuksena, kun ne viittaavat tähän tiedostoon, ja uudet primit lisätään tähän, kun mitään ei ole valittuna.
Tilannehierarkian järjestäminen uudelleen
Voit muuttaa primin ylätason kohdetta tai muuttaa primien järjestystä vetämällä niitä Objektihierarkia-paneelissa.
Avaa Macissa Esikatselu-appi
.
Avaa 3D-tiedosto ja valitse Näytä > Objektihierarkia.
Tee jokin seuraavista:
Primin ylätason kohteen vaihtaminen: Vedä se muunnokseen tai laajuuteen, josta haluat tehdä uuden ylätason kohteen.
Primin järjestäminen uudelleen: Vedä se uuteen paikkaan saman ylätason sisällä.
Huomautus: Materiaaleja voidaan myös sijoittaa geometrian alle, mutta varjostinta voidaan sijoittaa vain materiaalin alle.
Lavan säätäminen
Voit muuttaa koko tilanteen kokoa, pyörittää sitä tai muuttaa sen suuntaa sen sijaan, että muuttaisit vain omaa näkymääsi. Lavan säätäminen muuttaa tiedostoa, toisin kuin näyttöikkunan kiertäminen, kun katsotaan tilannetta eri kulmasta.
Avaa Macissa Esikatselu-appi
.
Avaa 3D-tiedosto ja tee sitten jokin seuraavista:
Pyörittäminen 90 astetta: Pyöritä vasemmalle klikkaamalla
tai oikealle optio-klikkaamalla sitä.
Pyörittäminen tietyn määrän verran: Valitse Työkalut > Säädä kokoa, syötä arvot Sisällön suunta -kohdan alla olevassa Pyöritä X-, Pyöritä Y- tai Pyöritä Z -kentässä ja klikkaa OK.
Mallin suunnan muuttaminen: Valitse Työkalut > Säädä kokoa, valitse Tilanneasetukset-kohdan alla olevasta Suunta-ponnahdusvalikosta Y ylös tai Z ylös ja klikkaa OK. Voit myös valita mittayksikön Tilanneasetukset-kohdan alla olevasta Yksiköt-ponnahdusvalikosta.
Mallin koon muuttaminen: Valitse Työkalut > Säädä kokoa, syötä arvot Sisällön koko -kohdan alla olevissa Korkeus-, Leveys-, Syvyys- tai Skaalaa-kentissä ja klikkaa OK. Voit myös valita mittayksikön Sisällön koko -kohdan alla olevasta ponnahdusvalikosta.
Huomautus: Oletuksena Säilytä sisällön koko ja suunta on valittuna, joten Korkeus-, Leveys-, Syvyys- tai Skaalaa-kentän muuttaminen päivittää muut kentät samassa mittasuhteessa. Poista valinta, jos haluat säätää kutakin kenttää erikseen.
Merkintöjen lisääminen 3D-tiedostoon
Voit lisätä 3D-tilanteeseen tekstimuotoisia merkintöjä.
Avaa Macissa Esikatselu-appi
.
Avaa 3D-tiedosto, klikkaa
ja klikkaa sitten
.
Merkintäkuvake tulee näkyviin näyttöikkunaan.
Klikkaa merkintäkuvaketta ja kirjoita sitten merkintä.
Tallenna merkintä klikkaamalla missä tahansa merkinnän ulkopuolella. Voit myös vetää merkinnän toiseen paikkaan.
Tee jokin seuraavista:
Värin vaihtaminen: Control-klikkaa merkintää ja valitse sitten väri.
Poistaminen: Control-klikkaa merkintää ja valitse sitten Poista.
Kiinnittäminen kohteen pintaan: Vedä merkintä kohteeseen.
Vinkki: Jos haluat muuttaa uusien merkintöjen kirjoittajan nimeä, valitse Esikatselu > Asetukset, klikkaa Yleiset ja kirjoita Nimi-kenttään nimi.
Näytä kaikki merkinnät ja niiden sisältö valitsemalla Näytä > Merkinnät. Jos merkintöjä on useita, voit siirtyä edelliseen tai seuraavaan merkintään klikkaamalla merkinnän sisällä tai
. Kamera liikkuu automaattisesti siten, että merkintä on kuvassa.