System requirements for iCloud

These are the recommended system requirements and minimum system requirements for iCloud.

Recommended system requirements

iCloud requires an Apple ID, an active Internet connection, and up to date software. If you meet the recommended system requirements below, you can take advantage of the latest iCloud features and get the best overall experience. To see the minimum requirements for each feature, you can review the minimum requirements table at the bottom of this page.

iPhone, iPad, and iPod touch

  • iOS 10
  • iWork for iOS (Pages 2.5 or later, Numbers 2.5 or later, Keynote 2.5 or later)1

Mac

  • macOS Sierra
  • iTunes 12.5
  • Safari 9.1 or later, Firefox 22 or later, or Google Chrome 28 or later
  • iWork for Mac (Pages 5.5 or later, Numbers 3.5 or later, Keynote 6.5 or later)1

PC

  • Microsoft Windows 10
  • iCloud for Windows 6
  • iTunes 12.5
  • Outlook 2007 - Outlook 20162
  • Internet Explorer 11 or later, Firefox 45 or later, or Google Chrome 50 or later (desktop mode only)

Apple TV

  • Apple TV software 7.2.1 or later

Minimum system requirements by feature

To use iCloud, you need at least iOS 5 on iPhone 3GS, iPod touch (3rd generation), iPad, or iPad mini; or at least OS X Lion 10.7.5 on a Mac.

Review this table for specific requirements of each iCloud feature.

iCloud feature  Minimum requirements 
iPhone, iPad, iPod touch  Mac  Windows   Apple TV  
Back to My Mac OS X Lion v10.7.5
Backup and Restore iOS 5
Bookmarks iOS 5
  • OS X Lion v10.7.5
  • Safari 5.1.1
  • Windows 7
  • iCloud Control Panel 3.1
  • Internet Explorer 9 or later
  • Firefox 22
  • Google Chrome 28 in desktop mode only
Calendar, Contacts, Mail iOS 5 OS X Lion v10.7.5
  • Windows 7
  • iCloud Control Panel 3.1
  • Outlook 2007 - Outlook 2016 or an up-to-date web browser
Mail Drop (send attachments) iOS 9.2
  • OS X Yosemite (for Mail app) or iCloud.com/mail from an up-to-date web browser (Safari 7.2 or later to upload packages, such as iWork files)
  • An email account that supports IMAP
  • Windows 7
  • iCloud.com/mail from an up-to-date web browser
  • An email account that supports IMAP
Family Sharing iOS 8
  • OS X Yosemite
  • iTunes 12
Apple TV software 7.0
Find My Friends
  • iOS 5 
  • iOS 6 (for location-based alerts)
  • iOS 8 (for Family Sharing)
  • Safari 6
  • Firefox 22
  • Google Chrome 35
  • Internet Explorer 10
  • Firefox 22
  • Google Chrome 35
Find My iPhone
  • iOS 5 
  • iOS 6 (for Lost Mode)
  • iOS 7 (for Activation Lock)
  • OS X Lion v10.7.5
  • (Lost Mode and Activation Lock aren't available on OS X)
Find My iPhone app

iOS 8

iCloud Drive iOS 8 OS X Yosemite
iCloud Photo Sharing iOS 7
  • OS X Mavericks v10.9
  • iPhoto '11 9.5 or Aperture 3.5
  • Photos version 1.0
  • Windows 7
  • iCloud Control Panel 3.1
Apple TV software 5.3
iCloud Photo Library iOS 8.3 OS X Yosemite 10.10.3
My Photo Stream iOS 5.1 
  • OS X Lion v10.7.5
  • iPhoto ’11 9.2.2 or Aperture 3.2.3
  • Photos v1.0
  • Windows 7
  • iCloud Control Panel 3.1
Apple TV software 5.0
iCloud Tabs iOS 6
  • OS X Mountain Lion v10.8.2
  • Safari 6
iCloud.com
  • Safari 6
  • Firefox 21
  • Google Chrome 35
  • Internet Explorer 10
  • Firefox 21
  • Google Chrome 35
iTunes Match iOS 5.0.1

iTunes 10.5.1

iTunes 10.5.1

Apple TV software 4.4
iWork for iCloud
  • Safari 6.0.3
  • Google Chrome 27.0.1
  • Internet Explorer 11
  • Google Chrome 27.0.1
Keychain 4

iOS 8.4.1

OS X Yosemite 10.10.5

Reading List iOS 5 Safari 5.1 —  — 
Two-factor authentication iOS 9 OS X El Capitan

iCloud for Windows 5

Two-step verification  iOS 7 OS X Mavericks v10.9 —  — 

Some features aren't available in all countries. Access to some services is limited to 10 devices.

  1. You can buy iWork for iOS and iWork for Mac from the App Store if they didn't come free with your iOS device or Mac. 
  2. Outlook 2010 Personal Edition and Outlook Click-to-Run installations aren't supported. Check to see if Outlook is a Click-to-Run application on your computer
  3. If you have two-factor authentication and you use iCloud Keychain, you'll need iOS 9 and OS X El Capitan.
  4. If you don’t meet the minimum system requirements, your data is still protected by two-step verification. However, if you change your Apple ID password while you're signed in to iCloud on devices that don't meet the minimum requirements, you might see these issues.

Information about products not manufactured by Apple, or independent websites not controlled or tested by Apple, is provided without recommendation or endorsement. Apple assumes no responsibility with regard to the selection, performance, or use of third-party websites or products. Apple makes no representations regarding third-party website accuracy or reliability. Risks are inherent in the use of the Internet. Contact the vendor for additional information. Other company and product names may be trademarks of their respective owners.

Last Modified: