macOS High Sierra

Create and work with documents

You can use macOS apps—such as Pages or TextEdit—or apps from the Mac App Store to create reports, essays, spreadsheets, financial charts, presentations, slideshows, and more.

A document in the Pages app on the desktop.

Create documents

  • Open an app that lets you create documents, then click New Document in the Open dialog, or choose File > New.

    For example, open TextEdit to create a plain text, rich text, or HTML document.

    Open TextEdit for me

Many Mac computers come with Apple apps that you can use to create spreadsheets, presentations, reports, and more.

  • Pages: Create letters, reports, flyers, posters, and more. This word processing app includes many templates that make it easy to create beautiful documents.

    Open Pages for me (if installed)

  • Numbers: Create spreadsheets to organize and present your data. Start with a template, then modify it however you like—add formulas, charts, images, and more.

    Open Numbers for me (if installed)

  • Keynote: Create compelling presentations with images, media, charts, slide animations, and more.

    Open Keynote for me (if installed)

If you don’t have Numbers, Keynote, or Pages on your Mac, you can get them from the App Store.

Open App Store for me

They’re also available for your iOS devices (from the App Store) and on iCloud.com.

Format documents

There are several ways to format and work with text in your documents:

  • Change fonts and styles: In a document, choose Format or Format > Font, then Show Fonts. Or choose Format > Styles or Format > Font > Styles. For more information, see Format text in documents with fonts and styles.

  • Change colors: In a document, choose Format > Show Colors, or Format > Font > Show Colors. For more information, see Use colors in documents.

  • Enter different types of characters: You can enter characters with accent marks or diacritic marks.

  • Check spelling: In most apps, spelling is checked while you type, and mistakes are automatically corrected. You can turn off these features or use other options. For more information, see Check spelling and grammar.

The app you’re using—such as TextEdit, Pages, Numbers, or Keynote—may provide additional ways to format and work with text, and with images and objects. To open an app’s online help to learn more, choose Help in the menu bar while working in the app.

Save documents

Many apps save your documents automatically (a feature known as Auto Save) while you work. You can save a document at any time.

  • Save a document: Choose File > Save, enter a name, choose where to save the document (to see more locations, click the down arrow button ), then click Save.

    When you save your document, you can add tags to help you find it later. You may be able to save your document in iCloud Drive so it’s available on your computers and iOS devices set up with iCloud Drive.

  • Save a document with another name: Choose File > Save As, then enter a new name. If you don’t see Save As, press and hold the Option key, then open the File menu again.

  • Save a document as a copy: Choose File > Duplicate or File > Save As.

You can also save a document as a PDF.

Find documents

There are several ways to find documents that you have created or saved on your Mac:

  • Ask Siri: You can have Siri look for one file or a set of files and then follow up to narrow the scope of what Siri finds. Learn more about Siri.

    Here are examples of things you can ask Siri:

    • “Show me the files I worked on last week about kitchen remodel”

    • “Just the ones tagged appliances”

  • Use Spotlight: Click the Spotlight icon in the menu bar, then enter the name of your document. You can also use Spotlight to specify criteria to narrow the scope of your searches.

  • Use tags: If you tagged your document, click the Finder icon in the Dock to open a Finder window, then click the tag in the Finder sidebar. For more information, see Use tags to organize files.

  • Use the Recents folder: In the sidebar of a Finder window, click Recents.

  • Use the Recent Items menu: If you worked on a document recently, choose Apple menu > Recent Items.

In some apps, you can open recent documents by choosing File > Open Recent, then the document.