Informationen zum Sicherheitsinhalt von Swift 5.1.1 für Ubuntu

In diesem Dokument wird der Sicherheitsinhalt von Swift 5.1.1 für Ubuntu beschrieben.

Informationen zu Apple-Sicherheitsupdates

Zum Schutz unserer Kunden werden Sicherheitsprobleme von Apple erst dann bekannt gegeben, besprochen und bestätigt, wenn eine vollständige Untersuchung stattgefunden hat und alle erforderlichen Patches oder Programmversionen verfügbar sind. Die neuesten Programmversionen finden Sie auf der Seite Apple-Sicherheitsupdates.

Nach Möglichkeit werden in Sicherheitsdokumenten von Apple zur Bezugnahme auf Schwachstellen CVE-IDs verwendet.

Weitere Informationen zur Sicherheit finden Sie auf der Seite zur Apple-Produktsicherheit.

Swift 5.1.1 für Ubuntu

Veröffentlicht am 11. Oktober 2019

Foundation

Verfügbar für: Ubuntu 14.04, 16.04 und 18.04

Auswirkung: Die fehlerhafte Verwaltung von Dateibeschreibungen in "URLSession" konnte zur unbeabsichtigten Offenlegung von Daten führen

Beschreibung: Dieses Problem wurde behoben, indem die fehlerhafte Logik für die Verwaltung von Dateibeschreibungen in "URLSession" an Swift 5.0 angepasst wurde.

CVE-2019-8790: Apple

Informationen zu nicht von Apple gefertigten Produkten sowie nicht von Apple gesteuerte oder geprüfte unabhängige Websites werden ohne Empfehlung und Unterstützung zur Verfügung gestellt. Apple übernimmt keine Verantwortung für die Auswahl, Leistung oder Nutzung von Websites und Produkten Dritter. Apple übernimmt keine Garantie für die Richtigkeit und Zuverlässigkeit von Drittanbieter-Websites. Die Nutzung des Internets birgt Risiken. Kontaktieren Sie den Hersteller, um zusätzliche Informationen zu erhalten. Andere Produkt- und Firmennamen sind möglicherweise Marken ihrer jeweiligen Eigentümer.

Veröffentlichungsdatum: