Om sikkerhedsindholdet i SwiftNIO HTTP/2 1.5.0

Dette dokument beskriver sikkerhedsindholdet i SwiftNIO HTTP/2 1.5.0.

Om Apple-sikkerhedsopdateringer

Med henblik på beskyttelse af vores kunder videregiver, drøfter eller bekræfter Apple ikke sikkerhedsanliggender, før en undersøgelse har fundet sted, og programrettelser eller versioner er tilgængelige. De nyeste versioner kan ses på siden om Apple-sikkerhedsopdateringer.

Apple sikkerhedsdokumenterer om muligt henvisninger til sikkerhedsproblemer med et CVE-id.

Få flere oplysninger om sikkerhed på siden om Apple-produktsikkerhed.

SwiftNIO HTTP/2 1.5.0

Udgivet d. 13. august 2019

SwiftNIO HTTP/2

Fås til: SwiftNIO HTTP/2 1.0.0 til og med 1.4.0 i macOS Sierra 10.12 og nyere versioner samt Ubuntu 14.04 og nyere versioner

Effekt: En HTTP/2-server kan forbruge ubegrænsede mængder hukommelse ved modtagelse af bestemte trafikmønstre og i sidste ende opbruge alle ressourcer

Beskrivelse: Problemet er løst via forbedret administration af bufferstørrelse.

CVE-2019-9512: Jonathan Looney fra Netflix

CVE-2019-9514: Jonathan Looney fra Netflix

CVE-2019-9515: Jonathan Looney fra Netflix

CVE-2019-9516: Jonathan Looney fra Netflix

SwiftNIO HTTP/2

Fås til: SwiftNIO HTTP/2 1.0.0 til og med 1.4.0 i macOS Sierra 10.12 og nyere versioner samt Ubuntu 14.04 og nyere versioner

Effekt: En HTTP/2-server kan forbruge for mange CPU-ressourcer ved modtagelse af bestemte trafikmønstre

Beskrivelse: Problemet er løst via forbedret godkendelse af input.

CVE-2019-9518: Piotr Sikora fra Google, Envoy Security Team

Oplysninger om produkter, der ikke er produceret af Apple, eller uafhængige websteder, der ikke styres eller testes af Apple, leveres uden Apples anbefaling eller godkendelse. Apple påtager sig intet ansvar, hvad angår valg, ydeevne eller brug af websteder eller produkter fra andre producenter. Apple giver ingen erklæringer med hensyn til nøjagtigheden eller pålideligheden af websteder fra andre producenter. Kontakt producenten for at få flere oplysninger.

Udgivelsesdato: