Om sikkerhedsindholdet i Safari 12.0.1

I dette dokument beskrives sikkerhedsindholdet i Safari 12.0.1.

Om Apple-sikkerhedsopdateringer

Med henblik på beskyttelse af vores kunder videregiver, drøfter eller bekræfter Apple ikke sikkerhedsanliggender, før en undersøgelse har fundet sted, og programrettelser eller versioner er tilgængelige. De nyeste versioner kan ses på siden om Apple-sikkerhedsopdateringer.

Få flere oplysninger om sikkerhed på siden om Apple-produktsikkerhed. Du kan kryptere din kommunikation med Apple ved hjælp af PGP-nøglen til Apple-produktsikkerhed.

Apple sikkerhedsdokumenterer om muligt henvisninger til sikkerhedsproblemer med et CVE-id.

Safari 12.0.1

Udgivet 30. oktober 2018

Læser i Safari

Fås til: macOS Sierra 10.12.6, macOS High Sierra 10.13.6 og macOS Mojave 10.14

Effekt: Aktivering af funktionen Læser i Safari på en skadelig webside kan føre til universel scripting på tværs af websteder.

Beskrivelse: Et logikproblem er løst via forbedret godkendelse.

CVE-2018-4374: Ryan Pickren (ryanpickren.com)

Læser i Safari

Fås til: macOS Sierra 10.12.6, macOS High Sierra 10.13.6 og macOS Mojave 10.14

Effekt: Aktivering af funktionen Læser i Safari på en skadelig webside kan føre til universel scripting på tværs af websteder.

Beskrivelse: Der var et problem med scripting på tværs af websteder i Safari. Problemet er løst ved forbedret validering af URL-adresser.

CVE-2018-4377: Ryan Pickren (ryanpickren.com)

WebKit

Fås til: macOS Sierra 10.12.6, macOS High Sierra 10.13.6 og macOS Mojave 10.14

Effekt: Behandling af webindhold med skadelig kode kan føre til kørsel af vilkårlig kode

Beskrivelse: Flere problemer med beskadiget hukommelse er løst via forbedret hukommelseshåndtering.

CVE-2018-4372: HyungSeok Han, DongHyeon Oh og Sang Kil Cha fra KAIST Softsec Lab, Korea

CVE-2018-4373: ngg, alippai, DirtYiCE, KT fra Tresorit, der arbejder med Trend Micros Zero Day Initiative

CVE-2018-4375: Yu Haiwan og Wu Hongjun fra Nanyang Technological University, der arbejder med Trend Micros Zero Day Initiative

CVE-2018-4376: 010, der arbejder med Trend Micros Zero Day Initiative

CVE-2018-4382: lokihardt fra Google Project Zero

CVE-2018-4386: lokihardt fra Google Project Zero

CVE-2018-4392: zhunki fra 360 ESG Codesafe Team

CVE-2018-4416: lokihardt fra Google Project Zero

WebKit

Fås til: macOS Sierra 10.12.6, macOS High Sierra 10.13.6 og macOS Mojave 10.14

Effekt: Et skadeligt websted kan muligvis fremkalde et Denial of Service-angreb

Beskrivelse: Et problem med manglende ressourcer er løst via forbedret godkendelse af input.

CVE-2018-4409: Sabri Haddouche (@pwnsdx) fra Wire Swiss GmbH

WebKit

Fås til: macOS Sierra 10.12.6, macOS High Sierra 10.13.6 og macOS Mojave 10.14

Effekt: Behandling af webindhold med skadelig kode kan føre til kodekørsel

Beskrivelse: Et problem med beskadiget hukommelse er løst via forbedret validering.

CVE-2018-4378: en anonym programmør, zhunki fra 360 ESG Codesafe Team

Oplysninger om produkter, der ikke er fremstillet af Apple, eller selvstændige websteder, der ikke er styret eller testet af Apple, er ikke udtryk for anbefalinger eller godkendelser fra Apples side. Apple påtager sig intet ansvar med hensyn til udvalget af disse produkter, produkternes funktionsevne eller brugen af produkterne. Apple giver ingen garanti for, at indholdet på websteder, som Apple ikke står bag, er pålideligt og præcist. Det er forbundet med en naturlig risiko at bruge internettet. Kontakt producenten for at få yderligere oplysninger. Andre virksomheds- og produktnavne kan være varemærker tilhørende de respektive ejere.

Udgivelsesdato: