نبذة عن محتوى أمان SwiftNIO SSL 2.4.1

يتناول هذا المستند محتوى أمان SwiftNIO SSL 2.4.1.

حول تحديثات أمان Apple

لحماية عملائنا، تحرص Apple على عدم الإفصاح عن مشاكل الأمان أو طرحها للنقاش أو تأكيدها حتى يتم تقصي الأمر وتوفير تصحيحات أو إصدارات جديدة. يتم إدراج أحدث الإصدارات في صفحة تحديثات أمان Apple.

تشير مستندات الأمان في Apple إلى الثغرات الأمنية من خلال CVE-ID إن أمكن ذلك.

للحصول على مزيد من المعلومات حول الأمان، يمكنك الاطلاع على صفحة أمان منتجات Apple.

SwiftNIO SSL 2.4.1

تاريخ الإصدار: 4 أكتوبر 2019

SwiftNIO

متوفر لما يلي: SwiftNIO SSL 2.0.0 إلى 2.4.0 على Ubuntu 14.04 والإصدارات الأحدث

التأثير: قد يتمكّن أحد تطبيقات SwiftNIO الذي يستخدم TLS من تنفيذ تعليمة برمجية عشوائية

الوصف: تمت معالجة المشكلة من خلال الإشارة إلى أن تكديس قابل للتنفيذ غير مطلوب.

CVE-2019-8849:‏ Apple

يتمّ تقديم المعلومات حول المنتجات التي لم تُصنّعها شركة Apple أو مواقع الويب المستقلة التي لا تخضع للمراقبة أو الاختبار من جانب Apple بدون توصيات أو موافقة. ولا تتحمّل Apple أية مسؤولية فيما يتعلق باختيار مواقع الويب والمنتجات التابعة لجهات خارجية أو أدائها أو استخدامها. ولا تُقدّم شركة Apple أية ضمانات فيما يتعلق بدقة أو موثوقية مواقع الويب التابعة لجهات خارجية. المخاطر ملازمة لاستخدام الإنترنت. للحصول على مزيد من المعلومات، يُمكنك الاتصال بالبائع. قد تكون أسماء الشركات والمنتجات الأخرى علامات تجارية لمالكيها المعنيين.

تاريخ النشر: