نبذة حول محتوى أمان SwiftNIO 1.8.0

يتناول هذا المستند محتوى أمان SwiftNIO 1.8.0.

حول تحديثات أمان Apple

لحماية عملائنا، تحرص Apple على عدم الإفصاح عن مشاكل الأمان أو طرحها للنقاش أو تأكيدها حتى يتم تقصي الأمر وتوفير تصحيحات أو إصدارات جديدة. يتم إدراج أحدث الإصدارات في صفحة تحديثات أمان Apple.

للحصول على مزيد من المعلومات حول الأمان، يمكنك الاطلاع على صفحة أمان منتجات Apple. يمكنك تشفير الاتصالات مع Apple باستخدام مفتاح PGP لأمان منتجات Apple.

تشير مستندات الأمان في Apple إلى الثغرات الأمنية من خلال CVE-ID إن أمكن ذلك.

SwiftNIO 1.8.0

تاريخ الإصدار 27 يونيو 2018

SwiftNIO

متوفر لما يلي: macOS Sierra 10.12 والإصدارات الأحدث وUbuntu 14.04 والإصدارات الأحدث

التأثير: قد يتمكن مخترق عن بُعد من الكتابة فوق ذاكرة عشوائية

الوصف: تمت معالجة مشكلة تجاوز سعة المخزن المؤقت من خلال التحقق المُحسّن من الحجم.

CVE-2018-4281:‏ Apple

تتضمن الإصدارات التالية أيضًا محتوى أمان SwiftNIO 1.8.0: 1.0.1،‏ 1.1.1،‏ 1.2.2،‏ 1.3.2،‏ 1.4.3،‏ 1.5.2،‏ 1.6.2،‏ 1.7.3.

يتمّ تقديم المعلومات حول المنتجات التي لم تُصنّعها شركة Apple أو مواقع الويب المستقلة التي لا تخضع للمراقبة أو الاختبار من جانب Apple بدون توصيات أو موافقة. ولا تتحمّل Apple أية مسؤولية فيما يتعلق باختيار مواقع الويب والمنتجات التابعة لجهات خارجية أو أدائها أو استخدامها. ولا تُقدّم شركة Apple أية ضمانات فيما يتعلق بدقة أو موثوقية مواقع الويب التابعة لجهات خارجية. المخاطر ملازمة لاستخدام الإنترنت. للحصول على مزيد من المعلومات، يُمكنك الاتصال بالبائع. قد تكون أسماء الشركات والمنتجات الأخرى علامات تجارية لمالكيها المعنيين.

تاريخ النشر: