關於 Xcode 11.0 的安全性內容

本文說明 Xcode 11.0 的安全性內容。

關於 Apple 安全性更新

為保障客戶的安全,Apple 在進行調查並提供修補程式或版本之前,不會揭露、討論或確認安全性問題。最新版本列於「Apple 安全性更新」頁面上。

Apple 安全性文件會盡可能以 CVE-ID 參照安全漏洞。

如需安全性的詳細資訊,請參閱 Apple 產品安全性頁面。

Xcode 11.0

2019 年 9 月 19 日發行

IDE SCM

適用於:macOS Mojave 10.14.4 和以上版本

影響:libssh2 存在多個問題

說明:更新至 2.16 版後,已解決多個問題。

CVE-2019-3855:Chris Coulson

ld64

適用於:macOS Mojave 10.14.4 和以上版本

影響:在沒有正確輸入驗證的情況下進行編譯,可能讓攻擊者以使用者權限執行任意程式碼

說明:更新至 ld64-507.4 版後,已解決 Xcode 工具鏈中 ld64 的多個問題。

CVE-2019-8721:奇虎 360 Nirvan Team 的 Pan ZhenPeng

CVE-2019-8722:奇虎 360 Nirvan Team 的 Pan ZhenPeng

CVE-2019-8723:奇虎 360 Nirvan Team 的 Pan ZhenPeng

CVE-2019-8724:奇虎 360 Nirvan Team 的 Pan ZhenPeng

otool

適用於:macOS Mojave 10.14.4 和以上版本

影響:處理惡意製作的檔案可能導致執行任意程式碼

說明:改進狀態管理機制後,已解決記憶體損毀問題。

CVE-2019-8738:奇虎 360 Nirvan Team 的 Pan ZhenPeng(@Peterpan0927)

CVE-2019-8739:奇虎 360 Nirvan Team 的 Pan ZhenPeng(@Peterpan0927)

對於非 Apple 製造之產品相關資訊,或是非 Apple 控制或測試之獨立網站,不得解釋 Apple 為其推薦或背書。Apple 對於協力廠商網站或產品的選擇、效能或使用,概不負責。Apple 對於協力廠商網站的準確性或可靠性不具有任何立場。使用 Internet 本具風險。如需更多資訊,請聯絡廠商。其他公司及產品名稱可能是其各自擁有者的商標。

發佈日期: