關於 macOS High Sierra 10.13.2、安全性更新 2017-002 Sierra 和安全性更新 2017-005 El Capitan 的安全性內容

本文說明 macOS High Sierra 10.13.2、安全性更新 2017-002 Sierra 和安全性更新 2017-005 El Capitan 的安全性內容。

關於 Apple 安全性更新

為保障客戶的安全,Apple 在進行調查並提供修補程式或版本之前,不會揭露、討論或確認安全性問題。最新版本列於「Apple 安全性更新」頁面上。

如需安全性的詳細資訊,請參閱 Apple 產品安全性頁面。您可以使用 Apple 產品安全性 PGP 金鑰來加密與 Apple 的通訊。

Apple 安全性文件會盡可能以 CVE-ID 參照安全漏洞。

macOS High Sierra 10.13.2、安全性更新 2017-002 Sierra 和安全性更新 2017-005 El Capitan

2017 年 12 月 6 日發佈

Apache

適用於:macOS High Sierra 10.13.1、macOS Sierra 10.12.6、OS X El Capitan 10.11.6

影響:處理惡意製作的 Apache 配置指令可能導致程序記憶體內容洩漏

說明:更新至 2.4.28 版後,已解決多個問題。

CVE-2017-9798

curl

適用於:macOS High Sierra 10.13.1、macOS Sierra 10.12.6、OS X El Capitan 10.11.6

影響:惡意 FTP 伺服器可能得以指示用戶端讀取超出界限的記憶體

說明:剖析 FTP PWD 回應時,出現超出界限的讀取問題。改進界限檢查機制後,已解決此問題。

CVE-2017-1000254:Max Dymond

目錄工具程式

適用於:macOS High Sierra 10.13 和 macOS High Sierra 10.13.1

不受影響:macOS Sierra 10.12.6 和之前版本

影響:攻擊者可能不需提供管理者密碼即可略過管理者認證

說明:驗證憑證時,出現邏輯問題。改進憑證驗證機制後,已解決此問題。

CVE-2017-13872

Intel 顯示卡驅動程式

適用於:macOS High Sierra 10.13.1

影響:應用程式可能以核心權限執行任意程式碼

說明:改進記憶體處理機制後,已解決記憶體損毀問題。

CVE-2017-13883:滴滴美國研究院的 Yu Wang

CVE-2017-7163:滴滴美國研究院的 Yu Wang

CVE-2017-7155:滴滴美國研究院的 Yu Wang

2017 年 12 月 21 日更新項目

Intel 顯示卡驅動程式

適用於:macOS High Sierra 10.13.1

影響:本機使用者可能導致系統意外終止或讀取核心記憶體

說明:出現超出界限的讀取問題,導致核心記憶體內容洩漏。改進輸入驗證機制後,已解決此問題。

CVE-2017-13878:Google Project Zero 的 Ian Beer

Intel 顯示卡驅動程式

適用於:macOS High Sierra 10.13.1

影響:應用程式可能以系統權限執行任意程式碼

說明:改進界限檢查機制後,已解決超出界限的讀取問題。

CVE-2017-13875:Google Project Zero 的 Ian Beer

IOAcceleratorFamily

適用於:macOS High Sierra 10.13.1、macOS Sierra 10.12.6、OS X El Capitan 10.11.6

影響:應用程式可能以系統權限執行任意程式碼

說明:改進記憶體處理機制後,已解決記憶體損毀問題。

CVE-2017-7159:由 KAIST SoftSec(softsec.kaist.ac.kr)的 HyungSeok Han(daramg.gift)開發的 IMF 發現

2017 年 12 月 21 日更新項目

IOKit

適用於:macOS High Sierra 10.13.1

影響:應用程式可能以系統權限執行任意程式碼

說明:核心有輸入驗證問題。改進輸入驗證機制後,已解決此問題。

CVE-2017-13848:MWR InfoSecurity 的 Alex Plaskett

CVE-2017-13858:匿名研究員

IOKit

適用於:macOS High Sierra 10.13.1、macOS Sierra 10.12.6、OS X El Capitan 10.11.6

影響:應用程式可能以系統權限執行任意程式碼

說明:改進狀態管理機制後,已解決多個記憶體損毀問題。

CVE-2017-13847:Google Project Zero 的 Ian Beer

IOKit

適用於:macOS High Sierra 10.13.1、macOS Sierra 10.12.6、OS X El Capitan 10.11.6

影響:應用程式可能以核心權限執行任意程式碼

說明:改進記憶體處理機制後,已解決記憶體損毀問題。

CVE-2017-7162:騰訊科恩實驗室(@keen_lab)(與趨勢科技的 Zero Day Initiative 計劃合作)

2018 年 1 月 10 日更新項目

核心

適用於:macOS High Sierra 10.13.1

影響:應用程式可能得以讀取核心記憶體(Meltdown)

說明:系統若配備會進行推測執行和間接分支預測的微處理器,可能會導致具有本機使用者存取權的攻擊者透過對資料快取進行旁通道分析的方式,取得未經授權的資訊。

CVE-2017-5754:Google Project Zero 的 Jann Horn;Graz University of Technology 的 Moritz Lipp;Graz University of Technology 的 Michael Schwarz;Graz University of Technology 的 Daniel Gruss;Cyberus Technology GmbH 的 Thomas Prescher;Cyberus Technology GmbH 的 Werner Haas;Graz University of Technology 的 Stefan Mangard;Paul Kocher;University of Pennsylvania 和 University of Maryland 的 Daniel Genkin;University of Adelaide 和 Data61 的 Yuval Yarom;以及 Rambus(Cryptography Research Division)的 Mike Hamburg

2018 年 1 月 5 日更新項目

核心

適用於:macOS High Sierra 10.13.1、macOS Sierra 10.12.6、OS X El Capitan 10.11.6

影響:應用程式可能以核心權限執行任意程式碼

說明:改進記憶體處理機制後,已解決記憶體損毀問題。

CVE-2017-13862:Apple

CVE-2017-13867:Google Project Zero 的 Ian Beer

2017 年 12 月 21 日更新項目

核心

適用於:macOS High Sierra 10.13.1、macOS Sierra 10.12.6、OS X El Capitan 10.11.6

影響:應用程式可能得以讀取受限制的記憶體

說明:改進界限檢查機制後,已解決超出界限的讀取問題。

CVE-2017-13833:Brandon Azad

核心

適用於:macOS High Sierra 10.13.1

影響:應用程式可能以核心權限執行任意程式碼

說明:改進記憶體處理機制後,已解決記憶體損毀問題。

CVE-2017-13876:Google Project Zero 的 Ian Beer

核心

適用於:macOS High Sierra 10.13.1、macOS Sierra 10.12.6、OS X El Capitan 10.11.6

影響:應用程式可能得以讀取受限制的記憶體

說明:改進記憶體處理機制後,已解決類型混淆問題。

CVE-2017-13855:Google Project Zero 的 Jann Horn

核心

適用於:macOS High Sierra 10.13.1

影響:應用程式可能得以讀取受限制的記憶體

說明:改進輸入清理機制後,已解決驗證問題。

CVE-2017-13865:Google Project Zero 的 Ian Beer

核心

適用於:macOS High Sierra 10.13.1、macOS Sierra 10.12.6、OS X El Capitan 10.11.6

影響:應用程式可能得以讀取受限制的記憶體

說明:改進輸入清理機制後,已解決驗證問題。

CVE-2017-13868:Brandon Azad

CVE-2017-13869:Google Project Zero 的 Jann Horn

核心

適用於:macOS High Sierra 10.13.1、macOS Sierra 10.12.6、OS X El Capitan 10.11.6

影響:本機使用者可能導致系統意外終止或讀取核心記憶體

說明:核心有輸入驗證問題。改進輸入驗證機制後,已解決此問題。

CVE-2017-7154:Google Project Zero 的 Jann Horn

2017 年 12 月 21 日新增項目

郵件

適用於:macOS High Sierra 10.13.1

影響:如果未安裝收件人的 S/MIME 憑證,S/MIME 加密的電子郵件可能會意外地以未加密的方式傳送

說明:改進狀態管理機制後,已解決不一致使用者介面問題。

CVE-2017-13871:GPGTools 的 Lukas Pitschl

2017 年 12 月 21 日更新項目

郵件草稿

適用於:macOS High Sierra 10.13.1

影響:具有網路特殊權限的攻擊者可能得以攔截郵件

說明:S/MIME 憑證有加密問題。增加檢查機制和使用者控制後,已解決此問題。

CVE-2017-13860:INNEO Solutions GmbH 的 Michael Weishaar

2018 年 1 月 10 日更新項目

OpenSSL

適用於:macOS High Sierra 10.13.1、macOS Sierra 10.12.6、OS X El Capitan 10.11.6

影響:應用程式可能得以讀取受限制的記憶體

說明:剖析 X.509 IPAddressFamily 時,出現超出界限的讀取問題。改進界限檢查機制後,已解決此問題。

CVE-2017-3735:OSS-Fuzz 發現

螢幕共享伺服器

適用於:macOS High Sierra 10.13.1、macOS Sierra 10.12.6

影響:具有螢幕共享存取權限的使用者可能得以存取可由 root 讀取的任何檔案

說明:處理螢幕共享作業時,出現權限問題。改進權限處理機制後,已解決此問題。

CVE-2017-7158:多倫多的 Trevor Jacques

2017 年 12 月 21 日更新項目

對於非 Apple 製造之產品相關資訊,或是非 Apple 控制或測試之獨立網站,不得解釋 Apple 為其推薦或背書。Apple 對於協力廠商網站或產品的選擇、效能或使用,概不負責。Apple 對於協力廠商網站的準確性或可靠性不具有任何立場。使用 Internet 本具風險。如需更多資訊,請聯絡廠商。其他公司及產品名稱可能是其各自擁有者的商標。

發佈日期: