关于系统扩展与 macOS

某些系统扩展与当前版本的 macOS 不兼容或将与后续 macOS 版本不兼容。请了解在看到有关系统扩展或内核扩展的提醒时,该怎么做。 

系统扩展在后台运行,旨在扩展 Mac 的功能。有些 App 会安装内核扩展(简称 kext),这类扩展是一种系统扩展,采用传统的方式运行,安全性和可靠性不如现代的替代方案。您的 Mac 会将这些内核扩展识别为旧版系统扩展。

Apple 已于 2019 年通知开发者,macOS Catalina 将是最后一版完全支持旧版系统扩展的 macOS,而我们也一直在协助开发者过渡他们的软件。


如果您收到有关系统扩展的提醒

您可能会在 Mac 上看到一个提醒,指示某个程序已载入或试图载入一个经过相关开发者签名的系统扩展。 

  • 这个提醒可能会要求您打开“安全性与隐私”偏好设置以允许相应的扩展。您还可能需要重新启动 Mac。 
  • 这个提醒可能要求您联系开发者寻求支持,因为相应的扩展需要进行更新或将与后续 macOS 版本不兼容。
  • 这个提醒可能通知您,相应的扩展将损害您的电脑,已被阻止。

在搭载 Apple 芯片的 Mac 上,您可能首先需要使用“启动安全性实用工具”将安全策略设置为“降低安全性”,并选择“允许用户管理来自被认可开发者的内核扩展”复选框。

系统管理员还可以使用移动设备管理 (MDM) 来管理旧版系统扩展。 

如有必要,请联系开发者,以了解软件有没有更新版本或是不是计划推出更新版本。开发者或许还能够解释如何移除或停用扩展,以及这样做的后果。

如需了解适用于开发者的技术详情,请参阅已弃用的内核扩展和备选系统扩展

 

 

有关非 Apple 制造的产品或非 Apple 控制或测试的独立网站的信息仅供参考,不代表 Apple 的任何建议或保证。Apple 对于第三方网站或产品的选择、性能或使用不承担任何责任。Apple 对于第三方网站的准确性和可靠性不作任何担保。联系供应商以了解其他信息。

发布日期: