关于 Safari 10.1.1 的安全性内容

本文介绍了 Safari 10.1.1 的安全性内容。

关于 Apple 安全性更新

为保护我们的客户,在没有进行调查并推出修补程序或发行版本之前,Apple 不会透露、讨论或确认安全性问题。“Apple 安全性更新”页面上列出了近期发布的版本。

如果需要了解有关安全性的更多信息,请参阅“Apple 产品安全性”页面。您可以使用 Apple 产品安全性 PGP 密钥对与 Apple 的通信进行加密。

如果可能,Apple 安全性文稿会引用 CVE-ID 中列出的安全漏洞。

Safari 10.1.1

2017 年 5 月 15 日发布

JavaScriptCore

适用于:OS X Yosemite 10.10.5、OS X El Capitan 10.11.6 和 macOS Sierra 10.12.5

影响:处理恶意制作的 Web 内容可能会导致应用程序意外终止或任意代码执行

描述:已通过改进内存处理解决多个内存损坏问题。

CVE-2017-7005:Google Project Zero 的 lokihardt

条目添加于 2017 年 6 月 9 日

Safari

适用于:OS X Yosemite 10.10.5、OS X El Capitan 10.11.6 和 macOS Sierra 10.12.5

影响:访问恶意制作的网页可能会导致应用程序拒绝服务

描述:已通过改进内存处理解决 Safari 的“历史记录”菜单问题。

CVE-2017-2495:Gehirn Inc. 的 Tubasa Iinuma (@llamakko_cafe)

Safari

适用于:OS X Yosemite 10.10.5、OS X El Capitan 10.11.6 和 macOS Sierra 10.12.5

影响:访问恶意网站可能会导致地址栏欺诈

描述:已通过改进状态管理解决用户界面不一致问题。

CVE-2017-2500:腾讯安全平台部的 Zhiyang Zeng 和 Yuyang Zhou

CVE-2017-2511:腾讯安全平台部的 Zhiyang Zeng

WebKit

适用于:OS X Yosemite 10.10.5、OS X El Capitan 10.11.6 和 macOS Sierra 10.12.5

影响:处理恶意制作的 Web 内容可能会导致任意代码执行

描述:已通过改进内存处理解决多个内存损坏问题。

CVE-2017-2496:Apple

CVE-2017-2505:Google Project Zero 的 lokihardt

CVE-2017-2506:与 Trend Micro 的 Zero Day Initiative 合作的百度安全实验室的 Zheng Huang

CVE-2017-2514:Google Project Zero 的 lokihardt

CVE-2017-2515:Google Project Zero 的 lokihardt

CVE-2017-2521:Google Project Zero 的 lokihardt

CVE-2017-2525:与 Trend Micro 的 Zero Day Initiative 合作的腾讯玄武实验室 (tencent.com) 的 Kai Kang (4B5F5F4B)

CVE-2017-2526:与 Trend Micro 的 Zero Day Initiative 合作的腾讯玄武实验室 (tencent.com) 的 Kai Kang (4B5F5F4B)

CVE-2017-2530:百度安全实验室的 Wei Yuan、与 Trend Micro 的 Zero Day Initiative 合作的百度安全实验室的 Zheng Huang

CVE-2017-2531:Google Project Zero 的 lokihardt

CVE-2017-2538:与 Trend Micro 的 Zero Day Initiative 合作的 Richard Zhu (fluorescence)

CVE-2017-2539:与 Trend Micro 的 Zero Day Initiative 合作的 Richard Zhu (fluorescence)

CVE-2017-2544:与 Trend Micro 的 Zero Day Initiative 合作的 360 Security (@mj0011sec)

CVE-2017-2547:Google Project Zero 的 lokihardt、与 Trend Micro 的 Zero Day Initiative 合作的 Sniper 战队(科恩实验室和电脑管家团队)

CVE-2017-6980:Google Project Zero 的 lokihardt

CVE-2017-6984:Google Project Zero 的 lokihardt

条目更新于 2017 年 6 月 20 日

WebKit

适用于:OS X Yosemite 10.10.5、OS X El Capitan 10.11.6 和 macOS Sierra 10.12.5

影响:处理恶意制作的 Web 内容可能会导致通用跨站点脚本编写

描述:处理 WebKit 编辑器命令时存在逻辑问题。已通过改进状态管理解决这个问题。

CVE-2017-2504:Google Project Zero 的 lokihardt

WebKit

适用于:OS X Yosemite 10.10.5、OS X El Capitan 10.11.6 和 macOS Sierra 10.12.5

影响:处理恶意制作的 Web 内容可能会导致通用跨站点脚本编写

描述:处理 WebKit 容器节点时存在逻辑问题。已通过改进状态管理解决这个问题。

CVE-2017-2508:Google Project Zero 的 lokihardt

WebKit

适用于:OS X Yosemite 10.10.5、OS X El Capitan 10.11.6 和 macOS Sierra 10.12.5

影响:处理恶意制作的 Web 内容可能会导致通用跨站点脚本编写

描述:处理页面显示事件时存在逻辑问题。已通过改进状态管理解决这个问题。

CVE-2017-2510:Google Project Zero 的 lokihardt

WebKit

适用于:OS X Yosemite 10.10.5、OS X El Capitan 10.11.6 和 macOS Sierra 10.12.5

影响:处理恶意制作的 Web 内容可能会导致通用跨站点脚本编写

描述:处理 WebKit 缓存框架时存在逻辑问题。已通过改进状态管理解决这个问题。

CVE-2017-2528:Google Project Zero 的 lokihardt

WebKit

适用于:OS X Yosemite 10.10.5、OS X El Capitan 10.11.6 和 macOS Sierra 10.12.5

影响:处理恶意制作的 Web 内容可能会导致任意代码执行

描述:已通过改进内存处理解决多个内存损坏问题。

CVE-2017-2536:与 Trend Micro 的 Zero Day Initiative 合作的 Samuel Groß 和 Niklas Baumstark

WebKit

适用于:OS X Yosemite 10.10.5、OS X El Capitan 10.11.6 和 macOS Sierra 10.12.5

影响:处理恶意制作的 Web 内容可能会导致通用跨站点脚本编写

描述:加载框架时存在逻辑问题。已通过改进状态管理解决这个问题。

CVE-2017-2549:Google Project Zero 的 lokihardt

WebKit Web 检查器

适用于:OS X Yosemite 10.10.5、OS X El Capitan 10.11.6 和 macOS Sierra 10.12.5

影响:应用程序或许能够执行未签名的代码

描述:已通过改进内存处理解决内存损坏问题。

CVE-2017-2499:George Dan (@theninjaprawn)

其他表彰

Safari

由衷感谢 Flyin9_L (ZhenHui Lee) (@ACITSEC) 为我们提供的帮助。

有关非 Apple 制造的产品或非 Apple 控制或测试的独立网站的信息仅供参考,不代表 Apple 的任何建议或保证。Apple 对于第三方网站或产品的选择、性能或使用不承担任何责任。Apple 对于第三方网站的准确性和可靠性不作任何担保。互联网的使用具有一定风险。请联系供应商以了解其他信息。其他公司和产品名称可能是其各自所有公司的商标。

发布日期: