关于 Safari 10 的安全性内容

本文介绍了 Safari 10 的安全性内容。

关于 Apple 安全性更新

为保护我们的客户,在未进行调查并推出修补程序或发行版本之前,Apple 不会公开、讨论或确认安全性问题。“Apple 安全性更新”页面上列出了近期的发行版本。

有关安全性的更多信息,请参阅“Apple 产品安全性”页面。您可以使用 Apple 产品安全性 PGP 密钥对与 Apple 的通信进行加密。

如果可能,Apple 安全性文稿会引用 CVE-ID 中列出的漏洞。

Safari 10

发布于 2016 年 9 月 20 日

Safari 阅读器

适用于:OS X Yosemite v10.10.5、OS X El Capitan v10.11.6 和 macOS Sierra 10.12

影响:在恶意制作的网页上启用 Safari 阅读器功能可能导致普遍跨站点脚本编写

说明:多个验证问题已通过改进输入清理得到解决。

CVE-2016-4618:Erling Ellingsen

此条目更新于 2016 年 9 月 23 日

Safari 标签页

适用于:OS X Yosemite v10.10.5、OS X El Capitan v10.11.6 和 macOS Sierra 10.12

影响:访问恶意网站可能会遇到地址栏电子诈骗

说明:处理标签页会话时存在状态管理问题。此问题已通过会话状态管理得到解决。

CVE-2016-4751:Monzo Bank 的 Daniel Chatfield

WebKit

适用于:OS X Yosemite v10.10.5、OS X El Capitan v10.11.6 和 macOS Sierra 10.12

影响:处理恶意制作的 Web 内容可能会导致任意代码执行

说明:处理错误原型时存在解析问题。此问题已通过改进验证得到解决。

CVE-2016-4728:Daniel Divricean

WebKit

适用于:OS X Yosemite v10.10.5、OS X El Capitan v10.11.6 和 macOS Sierra 10.12

影响:访问恶意制作的网站可能会泄露敏感数据

说明:处理位置变量时存在权限问题。此问题已通过增加所有权检查得到解决。

CVE-2016-4758:Cure53 的 Masato Kinugawa

WebKit

适用于:OS X Yosemite v10.10.5、OS X El Capitan v10.11.6 和 macOS Sierra 10.12

影响:处理恶意制作的 Web 内容可能会导致任意代码执行

说明:多个内存损坏问题已通过改进内存处理得到解决。

CVE-2016-4611:Apple

CVE-2016-4729:Apple

CVE-2016-4730:Apple

CVE-2016-4731:Apple

CVE-2016-4734:Google Project Zero 的 Natalie Silvanovich

CVE-2016-4735:André Bargull

CVE-2016-4737:Apple

CVE-2016-4759:Palo Alto Networks 的 Tongbo Luo

CVE-2016-4762:百度安全实验室的 Zheng Huang

CVE-2016-4766:Apple

CVE-2016-4767:Apple

CVE-2016-4768:与 Trend Micro 的 Zero Day Initiative 合作的匿名人士

CVE-2016-4769:Palo Alto Networks 的 Tongbo Luo

WebKit

适用于:OS X Yosemite v10.10.5、OS X El Capitan v10.11.6 和 macOS Sierra 10.12

影响:恶意网站或许能够访问非 HTTP 服务

说明:Safari 对 HTTP/0.9 的支持允许使用 DNS 重新绑定跨协议利用非 HTTP 服务。此问题已通过限制 HTTP/0.9 对默认端口的响应和取消资源载入(如果文稿通过不同的 HTTP 协议版本载入)得到解决。

CVE-2016-4760:Jordan Milne

WebKit

适用于:OS X Yosemite v10.10.5、OS X El Capitan v10.11.6 和 macOS Sierra 10.12

影响:处理恶意制作的 Web 内容可能会导致任意代码执行

说明:多个内存损坏问题已通过改进状态管理得到解决。

CVE-2016-4733:Google Project Zero 的 Natalie Silvanovich

CVE-2016-4765:Apple

WebKit

适用于:OS X Yosemite v10.10.5、OS X El Capitan v10.11.6 和 macOS Sierra 10.12

影响:拥有特权网络地位的攻击者或许能够通过 HTTPS 使用 WKWebView 来拦截和修改应用程序的网络流量

说明:处理 WKWebView 时存在证书验证问题。此问题已通过改进验证得到解决。

CVE-2016-4763:一位匿名研究者

WebKit

适用于:OS X Yosemite v10.10.5、OS X El Capitan v10.11.6 和 macOS Sierra 10.12

影响:处理恶意制作的 Web 内容可能会导致任意代码执行

说明:多个内存损坏问题已通过改进状态管理得到解决。

CVE-2016-4764:Apple

此条目添加于 2016 年 11 月 3 日

有关非 Apple 制造的产品或非 Apple 控制或测试的独立网站的信息仅供参考,不代表 Apple 的任何建议或保证。Apple 对于第三方网站或产品的选择、性能或使用不承担任何责任。Apple 对于第三方网站的准确性和可靠性不作任何担保。互联网的使用具有一定风险。请联系供应商以了解其他信息。其他公司和产品名称可能是其各自所有公司的商标。

发布日期: