关于 Xcode 7.2 的安全性内容

本文介绍了 Xcode 7.2 的安全性内容。

为保护我们的客户,在未进行详尽调查并推出必要的修补程序或发行版之前,Apple 不会公开、讨论或确认安全性问题。要了解有关 Apple 产品安全性的更多信息,请参阅“Apple 产品安全性”网站。

有关 Apple 产品安全性 PGP 密钥的信息,请参阅“如何使用 Apple 产品安全性 PGP 密钥”。

如果可能,请使用 CVE ID 来查阅漏洞的详细信息。

要了解有关其他安全性更新的信息,请参阅“Apple 安全性更新”。

Xcode 7.2

  • Git

    适用于:OS X Yosemite v10.10.5 或更高版本

    影响:Git 中存在多个漏洞

    说明:2.5.4 之前的 Git 版本中存在多个漏洞。这些漏洞已通过将 Git 更新至版本 2.5.4 得到解决。

    CVE-ID

    CVE-2015-7082

  • IDE SCM

    适用于:OS X Yosemite v10.10.5 或更高版本

    影响:蓄意未跟踪文件可能会被上传至储存库

    说明:Xcode 没有执行 .gitignore 指令。此问题已通过新增对执行 .gitignore 文件的支持得到解决。

    CVE-ID

    CVE-2015-7056:Stephen Lardieri

  • otools

    适用于:OS X Yosemite v10.10.5 或更高版本

    影响:本地攻击者或许能够导致应用程序意外终止或任意代码执行

    说明:处理 mach-o 文件的过程中存在多个内存损坏问题。这些问题已通过改进内存处理得到解决。

    CVE-ID

    CVE-2015-7049:Qihoo 360 Nirvan Team 的 Proteas

    CVE-2015-7057:Qihoo 360 Nirvan Team 的 Proteas

有关非 Apple 制造的产品或非 Apple 控制或测试的独立网站的信息仅供参考,不代表 Apple 的任何建议或保证。Apple 对于第三方网站或产品的选择、性能或使用不承担任何责任。Apple 对于第三方网站的准确性和可靠性不作任何担保。互联网的使用具有一定风险。请联系供应商以了解其他信息。其他公司和产品名称可能是其各自所有公司的商标。

发布日期:Mon Dec 14 19:01:04 GMT 2015