关于 Xcode 6.3 的安全性内容

本文介绍了 Xcode 6.3 的安全性内容。

为保护我们的客户,在未进行详尽调查并推出必要的修补程序或发行版之前,Apple 不会公开、讨论或确认安全性问题。要了解有关 Apple 产品安全性的更多信息,请参阅“Apple 产品安全性”网站。

有关 Apple 产品安全性 PGP 密钥的信息,请参阅“如何使用 Apple 产品安全性 PGP 密钥”。

如果可能,请使用 CVE ID 来查阅漏洞的详细信息。

要了解有关其他安全性更新的信息,请参阅“Apple 安全性更新”。

Xcode 6.3

  • Clang

    适用于:OS X Yosemite v10.10 或更高版本

    影响:攻击者或许能够绕过堆栈卫士

    说明:Clang 中存在有时会导致堆栈 cookie 指针存储在堆栈自身中的注册分配问题。此问题已通过改进注册分配得到解决。

  • Swift

    适用于:OS X Yosemite v10.10 或更高版本

    影响:执行特定类型转换的 Swift 程序可能收到意外值

    说明:模拟器中存在可能导致转换返回意外值的整数溢出问题。此问题已通过改进检查得到解决。

    CVE-ID

    CVE-2015-1149

有关非 Apple 制造的产品或非 Apple 控制或测试的独立网站的信息仅供参考,不代表 Apple 的任何建议或保证。Apple 对于第三方网站或产品的选择、性能或使用不承担任何责任。Apple 对于第三方网站的准确性和可靠性不作任何担保。互联网的使用具有一定风险。请联系供应商以了解其他信息。其他公司和产品名称可能是其各自所有公司的商标。

发布日期: