SwiftNIO SSL 2.4.1'in güvenlik içeriği hakkında

Bu belgede SwiftNIO SSL 2.4.1'in güvenlik içeriği açıklanmaktadır.

Apple güvenlik güncellemeleri hakkında

Apple, müşterilerini korumak amacıyla, tam bir inceleme gerçekleştirilene ve yamalar veya sürümler kullanıma sunulana kadar güvenlik sorunlarını açıklamaz, tartışmaz veya onaylamaz. Son sürümler Apple güvenlik güncellemeleri sayfasında listelenmektedir.

Apple güvenlik belgelerinde güvenlik açıkları mümkün olduğunca CVE Kimliği ile belirtilir.

Güvenlik hakkında daha fazla bilgi için Apple Ürün Güvenliği sayfasına bakın.

SwiftNIO SSL 2.4.1

Yayınlanma tarihi: 4 Ekim 2019

SwiftNIO

İlgili sürümler: Ubuntu 14.04 ve sonraki sürümlerinde SwiftNIO SSL 2.0.0 ila 2.4.0

Etki: TLS kullanan bir SwiftNIO uygulaması rastgele kod yürütebilir

Açıklama: Çalıştırılabilir yığının gerekli olmadığı belirtilerek sorun giderildi.

CVE-2019-8849: Apple

Apple tarafından üretilmeyen ürünler veya Apple tarafından denetlenmeyen veya test edilmeyen bağımsız web siteleri hakkındaki bilgiler bir öneri veya onay niteliği taşımadan sunulmuştur. Üçüncü taraf web sitelerinin veya ürünlerinin seçilmesi, performansı veya kullanılması konusunda Apple hiçbir sorumluluk kabul etmez. Apple, üçüncü taraf web sitelerinin doğruluğu veya güvenilirliğiyle ilgili herhangi bir beyanda bulunmamaktadır. Ek bilgi için tedarikçi ile irtibat kurun.

Yayın Tarihi: