macOS Sierra 10.12.3의 보안 콘텐츠에 관하여

이 문서에서는 macOS Sierra 10.12.3의 보안 콘텐츠에 대해 설명합니다.

Apple 보안 업데이트에 관하여

Apple은 고객 보호를 위해 조사를 마치고 패치 또는 출시 버전을 제공할 때까지 보안 문제에 대해 공개하거나, 이야기하거나, 확인하지 않습니다. 최신 출시 버전은 Apple 보안 업데이트 페이지에 나와 있습니다.

보안에 관한 자세한 내용은 Apple 제품 보안 페이지를 참조합니다. Apple 제품 보안 PGP 키를 사용하여 Apple과의 통신을 암호화할 수 있습니다.

Apple 보안 문서는 가능한 경우 CVE-ID에서 취약점을 참조합니다.

macOS Sierra 10.12.3

2017년 1월 23일 출시

APN 서버

대상: macOS Sierra 10.12.2

영향: 네트워크에서 특별한 위치에 있는 공격자가 사용자의 활동을 추적할 수 있음

설명: 클라이언트 인증서가 일반 텍스트 형식으로 전송되었습니다. 이 문제는 인증서 처리 개선을 통해 해결되었습니다.

CVE-2017-2383: TUM(Technical University Munich)의 Matthias Wachs 및 Quirin Scheitle

2017년 3월 28일에 추가된 항목

apache_mod_php

대상: macOS Sierra 10.12.2

영향: PHP에서 여러 문제가 발생함

설명: PHP 버전 5.6.28로 업데이트하여 여러 문제가 해결되었습니다.

CVE-2016-8670

CVE-2016-9933

CVE-2016-9934

Bluetooth

대상: macOS Sierra 10.12.2

영향: 응용 프로그램이 커널 권한을 사용하여 임의 코드를 실행할 수 있음

설명: Use-after-free 문제는 메모리 관리 개선을 통해 해결되었습니다.

CVE-2017-2353: Google Project Zero의 Ian Beer

그래픽 드라이버

대상: macOS Sierra 10.12.2

영향: 응용 프로그램이 커널 권한을 사용하여 임의 코드를 실행할 수 있음

설명: 메모리 손상 문제는 입력 유효성 확인 개선을 통해 해결되었습니다.

CVE-2017-2358: PwnFest 2016의 Team Pangu 및 lokihardt

도움말 보기

대상: macOS Sierra 10.12.2

영향: 악의적으로 제작된 웹 콘텐츠를 처리하면 임의 코드가 실행될 수 있음

설명: 사이트 간 스크립팅 문제가 개선된 URL 유효성 확인을 통해 해결되었습니다.

CVE-2017-2361: Google Project Zero의 lokihardt

IOAudioFamily

대상: macOS Sierra 10.12.2

영향: 응용 프로그램에서 커널 메모리 레이아웃을 확인할 수 있음

설명: 초기화되지 않는 메모리 문제는 메모리 관리 개선을 통해 해결되었습니다.

CVE-2017-2357: PwnFest 2016의 Team Pangu 및 lokihardt

커널

대상: macOS Sierra 10.12.2

영향: 응용 프로그램이 커널 권한을 사용하여 임의 코드를 실행할 수 있음

설명: 버퍼 오버플로우 문제는 메모리 처리 개선을 통해 해결되었습니다.

CVE-2017-2370: Google Project Zero의 Ian Beer

커널

대상: macOS Sierra 10.12.2

영향: 응용 프로그램이 커널 권한을 사용하여 임의 코드를 실행할 수 있음

설명: Use-after-free 문제는 메모리 관리 개선을 통해 해결되었습니다.

CVE-2017-2360: Google Project Zero의 Ian Beer

libarchive

대상: macOS Sierra 10.12.2

영향: 악의적으로 제작된 아카이브의 압축을 해제하면 임의 코드가 실행될 수 있음

설명: 버퍼 오버플로우 문제는 메모리 처리 개선을 통해 해결되었습니다.

CVE-2016-8687: Gentoo의 Agostino Sarubbo

Vim

대상: macOS Sierra 10.12.2

영향: 악의적으로 제작된 파일을 열면 응용 프로그램이 예기치 않게 종료되거나 임의 코드가 실행될 수 있음

설명: modeline에서 입력 유효성 확인 문제가 발생합니다. 이 문제는 입력 유효성 확인 개선을 통해 해결되었습니다.

CVE-2016-1248: Florian Larysch

macOS Sierra 10.12.3에는 Safari 10.0.3의 보안 콘텐츠가 포함되어 있습니다.

Apple이 제조하지 않은 제품에 관한 정보 또는 Apple의 관리 또는 테스트 대상이 아닌 독립적인 웹 사이트는 권장 또는 보증 없이 제공되는 것입니다. Apple은 타사 웹 사이트 또는 제품에 대한 선택, 성능, 사용과 관련하여 발생하는 결과에 대해 책임을 지지 않습니다. Apple은 타사 웹 사이트의 정확성 또는 신뢰도에 대해 어떠한 언급도 하지 않습니다. 인터넷을 사용하는 데는 위험이 따르기 마련입니다. 자세한 내용은 공급업체에 문의하십시오. 기타 회사 및 제품 이름은 각 소유자의 상표일 수 있습니다.

게시일: 2017-04-06